Jump to content

Intel HDA Audio Codec STAC9227 for DQ965xx, DP965LT, DQ963FX, D946GZxx Intel Board sound working (Mic,Headphone).


  • Please log in to reply
52 replies to this topic

#1
AlainTox714

AlainTox714

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 208 posts
UPDATE: v3 release

I guess the Layout is not the best for this Codec so i swap to LayoutID 2 and PathMapID 1
for v3 release.

IMPORTANT:

REMOVE the old HDAEnabler.kext and use the new one.

the new one use a different Layout.

Attached File  STAC9227.v3.zip   288.19KB   2381 downloads

UPDATE: v2 release

v2 Will normaly display correct labels in Audio System Preferences and in Audio System Profiler.

Attached File  STAC9227.v2.zip   288.27KB   1593 downloads

STAC9227 codec is used by:

- DQ965GF
- DQ965CO
- DG965MS
- DG965SS
- DP965LT
- DQ963FX
- D946GZAB
- D946GZTS
- D946GZIS

Intel Motherboards and should works with its.

What i will try to get is a fully working codec:

- Selection between Outputs: Headphone (front) and Line Out (rear).
- Selection between Inputs: Microphone and Line In.
- Mute button.
- Complete report in Audio System Profiler.

Currently you will have erroneous label in Audio System Preferences, but selection is working*.
Only a very concise report* in Audio System Profiler (3 lines).
Normally you will have Microphone, Line In and Headphones working*.

* Tested by wayover, thanks to him.

Check if you are using another AUDIO injector like EFI strings or ALCinject and remove it otherwise it will not works.
If you are using HDAEnabler.kext REMOVE IT and use the new one (different LayoutID).
AppleHDA.kext version is 1.2.4a21 from 10.4.9 and MUST stay in S/L/E otherwise it won't works.

If someone like to try here is the first release for test:
Attached File  STAC9227.v1_toTest.zip   288.14KB   569 downloads

Please report as i didn't own any of these mobos,i can't obviously test it.

#2
krrr

krrr

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 421 posts
I wonder if this will work from my Custom Desktop 945GMX board (details in sig) and HP laptop For Internal MIC .

#3
AlainTox714

AlainTox714

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 208 posts

I wonder if this will work from my Custom Desktop 945GMX board (details in sig) and HP laptop For Internal MIC .



Sorry definitely not, 945GMX board use Realtek ALC888 audio codec.

#4
RogerSt

RogerSt

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
How to me to connect the headphones, what contacts need to be used for connection? thankful in advance

Attached Files



#5
AlainTox714

AlainTox714

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 208 posts

How to me to connect the headphones, what contacts need to be used for connection? thankful in advance


I am talking about the first pick (yellow one)

[5] = Headphone Right.
[7] = ground shield common left and right.
[9] = Headphone Left.

for the second pick don't know as i have never use it.

here is what the doc says:

Connecting to the HD Audio Link Header

See Figure 22, A for the location of the HD Audio Link header.
Table 9 shows the pin

assignments for the header.

Table 11. HD Audio Link Header Signal Names
Pin Signal Name Pin Signal Name
1 BLCK 2 Ground
3 RST 4 3.3V/1.5V I/O
5 SYNC 6 Ground
7 SDO 8 3.3V_CORE
9 SDI 10 +12V
11 No connection 12 Key (no pin)
13 No connection 14 3.3V/1.5V STBY
15 No connection 16 Ground


Hope this help.

#6
RogerSt

RogerSt

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts

I am talking about the first pick (yellow one)

[5] = Headphone Right.
[7] = ground shield common left and right.
[9] = Headphone Left.

for the second pick don't know as i have never use it.

here is what the doc says:

Connecting to the HD Audio Link Header

See Figure 22, A for the location of the HD Audio Link header.
Table 9 shows the pin

assignments for the header.

Table 11. HD Audio Link Header Signal Names
Pin Signal Name Pin Signal Name
1 BLCK 2 Ground
3 RST 4 3.3V/1.5V I/O
5 SYNC 6 Ground
7 SDO 8 3.3V_CORE
9 SDI 10 +12V
11 No connection 12 Key (no pin)
13 No connection 14 3.3V/1.5V STBY
15 No connection 16 Ground


Hope this help.

i will try later, quality of a sound will be different?

#7
wayover

wayover

    InsanelyMac Protégé

  • Members
  • Pip
  • 49 posts
i tested STAC9227.v1_toTest.zip in GarageBand, work fine! It is necessary to correct appearance in settings only. Thanks

#8
AlainTox714

AlainTox714

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 208 posts

i tested STAC9227.v1_toTest.zip in GarageBand, work fine! It is necessary to correct appearance in settings only. Thanks



Look at post#1 please v2 is out.

#9
wayover

wayover

    InsanelyMac Protégé

  • Members
  • Pip
  • 49 posts
There is a question on frequency. Whether really it works with frequency 96kHz 24 bit output?

#10
wayover

wayover

    InsanelyMac Protégé

  • Members
  • Pip
  • 49 posts
Subjectively, it became better sound, has varied positions of a toddler of loudness in the big side. Mute button, mic, line-in work! HDAEnabler work too, now shows in system profiler headphone, mic and linein connection.
In system options on Input tab when the cursor is on LineInput (InternalSpeakers?), it is visually visible that passes a signal from a microphone if to speak. On record it is not audible..

Attached Files



#11
AlainTox714

AlainTox714

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 208 posts

There is a question on frequency. Whether really it works with frequency 96kHz 24 bit output?


I guess so, but can test as i don't use and have any Midi device.

Here are the pic's of my BadAxe2:

Attached File  Picture_1.png   83.85KB   130 downloadsAttached File  Picture_2.png   85.12KB   112 downloads

On both pic's Input and Output 96Khz 24 bits are available.

#12
c0lt

c0lt

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
:blink: Thank you very much for your help... :D
:D Merci beaucoup :D
Now i have sound...

#13
wayover

wayover

    InsanelyMac Protégé

  • Members
  • Pip
  • 49 posts

UPDATE: v3 release

I guess the Layout is not the best for this Codec so i swap to LayoutID 2 and PathMapID 1
for v3 release.

IMPORTANT:

REMOVE the old HDAEnabler.kext and use the new one.

the new one use a different Layout.

Attached File STAC9227.v3.zip ( 288.19K ) Number of downloads: 9

v3 doesn't work for me

#14
AlainTox714

AlainTox714

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 208 posts

v3 doesn't work for me


Sorry, but what is not working?

Can you upload as usual some pics please.

#15
wayover

wayover

    InsanelyMac Protégé

  • Members
  • Pip
  • 49 posts
im try in leo and tiger, in system pref no input/output devices. System profiler also zero connections, but in logs:
localhost kernel[0]: HDAEnabler: Copyright (c) 2008 by Kabyl
 localhost kernel[0]: HDAEnabler: Added SPAudio support LayoutID:2
kexstat:
69	0 0x3f7d6000 0x4b000	0x4a000	com.apple.driver.AppleHDA (1.2.4a21) <67 63 5 4 3 2>


#16
AlainTox714

AlainTox714

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 208 posts

im try in leo and tiger, in system pref no input/output devices. System profiler also zero connections, but in logs:

localhost kernel[0]: HDAEnabler: Copyright (c) 2008 by Kabyl
 localhost kernel[0]: HDAEnabler: Added SPAudio support LayoutID:2
kexstat:
69	0 0x3f7d6000 0x4b000	0x4a000	com.apple.driver.AppleHDA (1.2.4a21) <67 63 5 4 3 2>


OK thanks, will try to figure out where i did a mistake!

#17
dnoyeb

dnoyeb

    InsanelyMac Protégé

  • Members
  • PipPip
  • 52 posts
Not sure what I'm doing wrong here so i figured I'd post... I'm building out a new quad core with a a DQ965GF motherboard... The only thing that I seem to be lacking is the sound..

So, I got v3, used Kext Helper B7, did both KEXT's at the same time in there, rebooted... now in "about this mac" under audio, it says Device ID 0x80862008 audio id: 4 and then Availible devices, it has nothing.

On my other hackintoshs, my normal sound test is to change the volume and listed for the beep... I am not getting any sound from any ports on this unit.

So, I also tried v2, installed both KEXT files with KEXT helper, still a no go after reboot.

am I missing something obvious? with all my other hackintoshes, the audio just happened to work, so this wasn't a big issue... Any help you guys can give is mucho appreciated.

btw, using a brand new install of itakos 4.1i 10.5.4.

#18
AlainTox714

AlainTox714

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 208 posts

Not sure what I'm doing wrong here so i figured I'd post... I'm building out a new quad core with a a DQ965GF motherboard... The only thing that I seem to be lacking is the sound..

So, I got v3, used Kext Helper B7, did both KEXT's at the same time in there, rebooted... now in "about this mac" under audio, it says Device ID 0x80862008 audio id: 4 and then Availible devices, it has nothing.

On my other hackintoshs, my normal sound test is to change the volume and listed for the beep... I am not getting any sound from any ports on this unit.

So, I also tried v2, installed both KEXT files with KEXT helper, still a no go after reboot.

am I missing something obvious? with all my other hackintoshes, the audio just happened to work, so this wasn't a big issue... Any help you guys can give is mucho appreciated.

btw, using a brand new install of itakos 4.1i 10.5.4.


Check if you are using another AUDIO injector like EFI strings or ALCinject and remove it otherwise it will not works.
Go with v2 forgot v3 it's not working.

#19
AlainTox714

AlainTox714

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 208 posts
Hi everyone,

I like to go further and have a working 10.5.x AppleHDA.kext working but i need some help.

I am looking for ioreg dump of MacBook pro 1st generation and 2sd generation with Sigmatel STAC9221 Codec.

I mean a full dump with in terminal:

ioreg -lw0 > ~/Desktop/MacbookXXX.txt

If someone can get this i will be very grateful to him.

#20
wayover

wayover

    InsanelyMac Protégé

  • Members
  • Pip
  • 49 posts
i'm find only STAC9220
http://forum.insanel...t...st&id=14407
http://forum.insanel...t...st&id=14404





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy