Jump to content

[GUIDA]Come installare iaktos 4i 10.5.4/ iaktos v5 10.5.5 su Acer aspire One


  • Please log in to reply
325 replies to this topic

#101
phoenix530

phoenix530

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 181 posts
per il discorso del reboot devi andare a disattivare la sospensione automatica del sistema e dei dischi rigidi nelle impostazioni di sistema...per il wifi, ora sto cercando di capire se e' un discorso di vendor id editando i driver se ci riesco....


EDIT: gli scoppiassero le corna a chi ha scritto sti driverr!!! sono riuscito a farli funzionare e vanno modificatiiii!!!!!!!!!!!!!!

ecco cosa dovete fare se nn detectate alcuna rete:

andate su: /system/library/extensions/io80211family.kext/contents/plugins/airportatheros.kext/contents/info.plist

cercate l'elenco con gli id delle schede, e inserite:

etc..................
<key>IONameMatch</key>
<array>
<string>pci106b,0086</string>
<string>pci168c,1c</string>
<string>pci168c,23</string>
<string>pci168c,24</string>
<string>pci168c,1d</string> <-------aggiungete questa stringa o una con il vostro id se nn va
</array>
<key>IOProviderClass</key>
etc............................


aggiorno la guida e buona notte ai sognatori :wallbash:
ho un aspire one perfettamente funzionante e viaggia alla grande con tutto tranne i lettori di card funzionanti :D

#102
ytuned

ytuned

    InsanelyMac Protégé

  • Members
  • Pip
  • 24 posts
E per la versione Iaktos 4 ci sono speranze per il wifi?
Riupperesti il file dei driver perch non lo fa piu scaricare!
Grazie 1000.

#103
phoenix530

phoenix530

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 181 posts
ragazzi io giuro che bestemmio....

ho spento e riacceso il pc e il wifi ha smesso di funzionare.... -_-
ora devo capire dove sta il problema...

il file del wifi cmq e' contenuto dentro lo zip che ho linkato all'inizio della guida...nn c'e' bisogno che lo scarichi dalla guida inglese :)

#104
GreenGoblin

GreenGoblin

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 145 posts
  • Gender:Male
  • Location:Livorno - Italy
Gi la stessa cosa che successa a me ogni tanto va al riavvio successivo non parte pi, avendo un disco poco performante rispetto ai vostri (parto da una versiona con SSD 8 giga modificata con hard disk da 1,8 pollici 4200 di rotazione) credo che abbandono leopard e se questo natale va bene vendo l'acer aspire one e mi comprer un samsung nc10. Comunque seguo sempre questo topic!

#105
phoenix530

phoenix530

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 181 posts
a me e' partito una volta sola e poi basta + :P
sto cercando di capire xke nn funziona niente, ma nn trovo soluzioni...mi sa che sto driver e' tutto da riscrivere perche' e' per la pressa :|

#106
thoroide

thoroide

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
Ok ho provato ma non ho ottenuto risultato aggiongendo:

<string>pci168c,1d</string>

Andando ad analizzare l'ID della mia scheda ho trovato per che era 168c,e008 quindi ho aggiunto le seguenti linee:

<string>pci168c,08</string>
<string>pci168c,e008</string>

Ho riavviato e POF, la wlan partita...

Poi ho provato a fare un reboot e PATAPOFF la wlan non ha pi funzionato, come sta accadendo a tutti.
E' una wlan-wo (Work Once). Ho preso su e-bay una DELL, vediamo se quella una wm (Work Many).

In ogni caso a differenza del solito adesso KisMac quando fa la scansione sembra decisamente intoppato, al posto di far scorrere i canali wlan puttosto spediti, li fa incrementeare molto lentamente, come facesse fatica ad accedere alla risorsa HW... Potrebbe aiutare...


Saluti

#107
phoenix530

phoenix530

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 181 posts
stessa cosa che e' successa a me praticamente....ho aggiunto quella stringa e andava, quando ho riavviato ha smesso di funzionare...nn so che pensare... :\

ma quelli di voi a cui funziona sempre il wifi, che bios avete installato?


EDIT: qualcuno su un altro forum sostiene che va installato AppleACPIPlatform.kext della iatkos v4 per far andare il wifi ....qualcuno che puo' estrarlo puo' provare e verificare se le cose migliorano? io ho richiuso il pc e dovrei fare un casino per riacollegare il lettore dvd all'aspire....

aspetto notizie


EDIT2: raga mi succede una cosa strana dopo aver fatto una pulizia del sistema con osx86tools....quando spengo il pc mi da una schermata di kernel panic quella con il riquadro centrale e dice di riavviare il sistema...nn capisco cosa possa essere...
se avvio con -v mi compare un errore in appleHDAController....qualcuno mi allega un backup del proprio kext? tnx

#108
thoroide

thoroide

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
Eccolo, appena estratto dalla iaktos4

Adesso provo pure io.

Saluti

EDIT:
Ho provato e per il momento l'unica cosa che ho ottenuto il non riconoscimento della tastiera. Il mouse lo riconosce poich bluethooth, ma la tastiera quella integrata e nisba... Non ne ho una USB e non riesco neppure a inserire la PW per poter vedere se va il wifi. E soprattutto non riesco a inserire il kext originale perch non riesco a digitare la PW in kext helper... Sono un pelo fermo. Non c' modo di incollare testo nel campo password !!!

EDIT2:
Ho strappato la tastiera dal PC di mia figlia e ce l'ho fatta (a digitare la PW) in ogni caso nulla da fare per la wlan. Ho rimesso il kext originale e la tastiera integrata ritornata a funzionare. Mentre la wlan continua a non andare.

Attached Files



#109
phoenix530

phoenix530

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 181 posts
a ke ci sei mi estrai appleHDAController.kext da iatkos v5 che a me si e' sputtanato il file?

tnx :)

grazie per il favore, spero di risolvere il mio problema con lo spegnimento.....riguardo l'altro kext se hai provato con quello della iatkos v4, nn so cosa pensare...ma tu quando hai installato il sistema hai selezionato la patch per le periferiche ps2? in tal caso prova a estrarla dal disco di iatkos v5 e installala xke mi sembra strana sta cosa che smette di funzionare la tastiera...


dunque resoconto finale:
grazie al kext che mi ha uppato thoroide (anora grazie per la cortesia ^^) ho risolto il mio problema di spegnimento nn riuscito...

riguardo al wifi, sembra che anche modificando il kext aggiungendo il vendor id della scheda, nn cambi nulla...nn resta che collaborare con gli inglesi e vedere se trovano una soluzione fornendo loro informazioni sul nostro testing...io oggi ho gia' lasciato un messaggio...speriamo bene...


--------NOTIZIA IMPORTANTE!!!!!!!!!!!!!--------

dunque ho scoperto una cosa interessante....
partendo da una situazione in cui nn ho installato nessun driver per il wifi, eseguo la seguente procedura:
-ripara permessi
-rimozione mkext
-installazione kext wifi
-apertura senza riavvio di kismac

facendo cosi funziona tutto...nn so ora pero' se al riavvio perdo le impostazioni attuali....

EDIT: come volevasi dimostrare le perdo XD



qualcuno sulla pagina inglese, sostiene che installando questa patch funzioni tutto: http://forum.insanel...howtopic=133683

se qualcuno prova mi faccia sapere xke se a me si sputtana il sistema devo fare un casino per formattare e ricominciare....

#110
maklore

maklore

    InsanelyMac Protégé

  • Members
  • Pip
  • 34 posts
io ho seguito passo passo la guida per installare iAtkos v5 ma il pc dopo l'installazione non parte, appena si vede la mela fa il reboot. Ho provato anche a "personalizzare" l'installazione ma senza risultato..possibile che la v5 non funziona solo a me???

#111
phoenix530

phoenix530

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 181 posts
fa il reboot xke nn hai installato il fix della cpu e quindi quando compare darwin devi premere invio e scrivere cpus=1

scrivendo cosi il pc nn ti si riavvia + e puoi accedere al sistema...per evitare di scrivere ogni volta cpus=1, installa poi il pacchetto della ideneb come scritto in guida :)


PS: in seguito ad alcuni smanettamenti, ho apportato delle modifiche alla guida dal momento che sono riuscito ad ottimizzare un po' il sistema :D
resta sempre il problema del wifi, se qualcuno prova quella patch che ho precedentemente linkato mi faccia sapere ^^

se installate il fix della cpu, eseguite da terminale sudo nano /Library/Preferences/SystemConfiguration/com.apple.boot.plist e dove leggete "cpus=1 -f". rimuovete il -f dal momento che a me e' parso che il sistema caricasse + velocemente.. :D
nn so pero' se questo -f aiuti il sistema nella gestione del wifi dal momento che molti dicono di lanciare il sistema con -f all'avvio (fatto sta che a me o con o senza nn funziona mai)....
c'e' da provare ripeto quella patch e capire se serve o no a far andare bene il wifi...

#112
maklore

maklore

    InsanelyMac Protégé

  • Members
  • Pip
  • 34 posts
:D grazie della dritta...provo subito!!

#113
phoenix530

phoenix530

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 181 posts
raga io invece ho sempre il problema del file appleHDAController.kext.... ma voi ve lo ritrovate installato sul sistema? se lo installo con kext helper mi smette di funzionare l'audio ma si spegne bene il pc, se lo levo, funziona l'audio, ma si spegne sempre con kernel panic il sistema... -.-


EDIT: ho scoperto che a dare il kernel panic allo spegnimento, e' il file HDAenabler.kext contenuto nella cartella del microfono....andrebbe patchato ma nn trovo lo script...nel frattempo ho trovato un file patchato ma senza supporto per il microfono...se qualcuno ha la versione patchata che nn da errore con supporto al mic, o la patch, se la posta mi fa un grande favore :)

EDIT2: dunque sono riuscito a patchare il driver audio con supporto al microfono semplicemente sostituendo un kext interno...risultato adesso funziona tutto alla perfezione senza errori strani allo spegnimento ^^
ho riuppato lo zip con i driver strettamente necessari all'installazione includendo anche quelli patchati dal sottoscritto per l'audio :D


attendo sempre info sul wifi se qualcuno prova quel metodo precedentemente segnalato :)

#114
ytuned

ytuned

    InsanelyMac Protégé

  • Members
  • Pip
  • 24 posts
Phoenix seguendo una guida che un ragazzo ha postato come commento sul blog di croccobiscotto, ho messo un programmino che ti riproduce un suono all'avvio e uno allo spegnimento e il pc si spegne/riavvia immediatamente, seguendo questo piccolo trucchetto senza l'ombra di kernel panic.
Prova un p e fammi sapere.
A me davvero quasi immediato lo spegnimento!

#115
phoenix530

phoenix530

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 181 posts
no vabbe' evito prove strane anche xke come ho gia' detto, ho risolto modificando il kext audio (l'ho riuppato fra i driver nella prima pagina) :blink:

vorrei sapere se qualcuno piuttosto ha provato la patch segnalata per far andare il wifi..
alcuni sostengono che fixando il DSDT il wifi inizi a funzionare correttamente...

#116
thoroide

thoroide

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
Riuppalo con megauploaad, che sti ceffi di rapidshare, se non sei premium uploader, permettono lo scaricamento per sole 10 volte.

Adesso provo la patch.

Ciao

#117
phoenix530

phoenix530

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 181 posts
ok thoroide allora aspetto tue notizie :(

nel frattempo ho riuppato su mediafire il pacchetto con tutti i driver(link sul primo post) ^^

#118
thoroide

thoroide

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
Dimenticavo....

Potresti tettagliare meglio questo passaggio nella guida che io non ho mai fatto in quanto non ho pito bene quali permessi e come fare per ripristinarli. A me obiettivamente andato tutto bene senza fare questo passaggio.


-ora aprire il disk utility e ripristinate i permessi...finita l'operazione riavviate e godetevi la vostra accellerazione quartz e la risoluzione a 1024x600


Infine ho provato il patcher ma mi da un errore e non mi compila il file. Ho provato a fare -f (Per forzare la compilazione) ma mi da lo stesso errore e non mi genera il file. A questo punto ho mollato il colpo e ora mi sono deciso a reinstallare tutto da capo facendomi una situazione PULITA della quale mi creer una immagine. pertanto al momento sono in fase di reinstall totale, tra un'oretta dovrei ritornare online.


Infine, aggiungi al pack dei driver il FIX per la tastiera dell'acer per far funzionare anche il tasto < e > che con questa installazione non funziona.

Concludo dicendo che ho provato anche il driver attualmente in BETA2 bel il controller jmicron per le SD card, ma funziona troppo male, il sistema crasha spesso ed molto instabile ed al momento supporta solo (quando va) le SD fino a 2GB e non le SDHC. Se infili una SDHC osX si congela e muore li. Sconsigliato !!!!.




A dopo

#119
phoenix530

phoenix530

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 181 posts
praticamente devi aprire l'utility disk (menu applicazioni -> cartella utility) e cliccare prima sulla tua unita' con su leopard nell'elenco a sinistra e poi cliccare sul tasto per riparare i permessi in basso di fianco :censored2:
+ preciso di cosi nn so che dirti XD

#120
thoroide

thoroide

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
Chiarissimo ora, devi sapere che io non sono un grande espertone di mac os x, anzi se proprio devo dirla tutta proprio sull'aspire one che sto provando per la prima volta in vita mia questo SO.

Sono uno sporco windowsaro, che per molto curioso e queste prove che sto facendo mi serviranno per prendere decisioni future...

Mac os x mi sta piacendo abbastanza e i problemi che sto vivendo ora sono solo dovuti all'hackintoshame ma immagini che su una macchina MAC reale i problemi siano quasi zero.

Al momento mi far le ossa un p poi vedo...

Ciao ^_^





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy