Jump to content

ATI / NVIDIA OnBoard (P) ATA Driver


  • Please log in to reply
58 replies to this topic

#41
blob4000

blob4000

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
Thanks to everyone who contributed to this kext!

Sorry I've been away from the scene for a while. I've just moved to another city, and I'm waiting for a decent version of 10.5 (for AMD) to come along before testing this driver.

#42
Shadow Root

Shadow Root

    InsanelyMac Protégé

  • Members
  • Pip
  • 19 posts
I am waiting for a Leopard version too :(

#43
zandera

zandera

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 179 posts
  • Gender:Male
  • Location:Prague

Will this work for my Nvidia nForce4 MCP51??


if sata, than sata not ide
its strightly different thing

look my specs

#44
ole2

ole2

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 180 posts
  • Gender:Male
  • Location:Grenoble, France
the file is gone?

Ok, here the rev. 2 of the driver, this one start with udma 6 on last 3 supported (supposed :( ) NVIDIA ATA controlers instead of udma5...
Cheers!
Z



#45
Magicum

Magicum

    InsanelyMac Protégé

  • Members
  • Pip
  • 39 posts
  • Gender:Male
  • Location:Russia
Tried this at my 10.5.2 (Leo4Allv2) and ATI SB450 IDE Controller, some better than before (booting takes 8-10 minutes instead of previous 30-40 minutes) but still slow.

== ADDED ==
Possibly (just suggestion) that now, being patched, the speed is ok, but HDD continuously going to sleep mode or just powered off after each operation. Not sure, but who knows.

== FINAL RESULT ==

The solution doesn't work on Asus A6Rp laptop (ATI SB450 South Bridge IDE Controller) with 10.4.10 mac.nub

#46
Magicum

Magicum

    InsanelyMac Protégé

  • Members
  • Pip
  • 39 posts
  • Gender:Male
  • Location:Russia
== SOME UPDATE regarding ATI S450 IDE Controller ==

Distro: Leo4all, Leo4allv2 (Leopard 10.5.2)

I've made some test. Below are results

1. Using AppleGenericPCATA.kext (I've taken this kext from some tiger threads whre guys improved ATA issues):
HDD works slowly, but continuously, without gaps, pauses, only slow. Similar to inactivated DMA mode.

2. Using AppleOnboardPCATA or AppleVIAATA:
Read\write operations are fast as should be, however there are a lot of long pauses between processing data portions. That's why using both 1. and 2. produces the same result: ~3 hours installation takes, 15-30 minutes for boot, 10-15 minutes for shutdown.

Still need any help. And new idea, possibly this caused not by IDE Controller, but some other device?

#47
Magicum

Magicum

    InsanelyMac Protégé

  • Members
  • Pip
  • 39 posts
  • Gender:Male
  • Location:Russia
nobody had sych trouble? or everybody don't care ? =)

#48
Bernymo

Bernymo

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts

Ok, here the rev. 2 of the driver, this one start with udma 6 on last 3 supported (supposed :( ) NVIDIA ATA controlers instead of udma5...
Cheers!
Z


Hello, thanks for this file,
Sorry but i don't understand how integrate the file on my ISO DVD
thanks .

#49
Shadow Root

Shadow Root

    InsanelyMac Protégé

  • Members
  • Pip
  • 19 posts
I am using AppleVIAATA, but I have a SB450. IDE disks works good. But SATA dont recognized. Any idea?

Thank you!

gaston

#50
KibosJ

KibosJ

    InsanelyMac Protégé

  • Members
  • PipPip
  • 50 posts
  • Gender:Male
  • Location:Darlington, UK
Does this work on the SB600? I tried following the instructions, but I cannot make Leopard see my DVD RW at all ;). Tiger used to see it and Leopard sees it if I install it over the top of tiger but I got a Kernel Panick after rebooting when doing that.

#51
djaxxo

djaxxo

    InsanelyMac Protégé

  • Members
  • Pip
  • 27 posts
Hey! looking for almost same kexts but for the Sata , ATi SB450
really cool if any knows a working kexts for this ^^,

#52
badkidforum

badkidforum

    InsanelyMac Protégé

  • Members
  • Pip
  • 46 posts
  • Interests:say video games, n say Pc's .. geek networking professional .. loves wasting time on PC :D...
Here is the solution my friend.

SB450 .... related SATA Drive problem. most easiest solution.

have the .kext file
http://forum.insanel...t...st&id=33801 . posted by me in other forum.

Solution is as easy as a PIE.

Get kexthelper from google -> a freeware utilty.

1. download the AppleOnBoardPCATA.kext ( within ZIP file )

2. Run 'kexthelper' drag AppleOnBoardPCATA.kext file ... provide your root password. n click Easy Install ...

3. All Done : Reboot : Plug in Your SATA cables. n enjoy. !!

Working on my two machines.

Hope that cud help out friends.

that works SB450 ATI chipsets.

This can improve the performance of your MAC upto 4 times.
on mine machine ... it is .......
the smooth n the best experience. boots in 45 seconds from BIOS. everything.

hope this 'll help

#53
RoyaRandom

RoyaRandom

    InsanelyMac Protégé

  • Members
  • PipPip
  • 87 posts
Do I have to remove AppleGenericATA and AppleOnBoardATA from IOATAFamily.kext/Contents/Plugins/, since I'm using Kalyway and it's workin well, except for IDE. My IDE/PATA drive isn't funtioning but it's recognized, SATA works fine.

#54
mxd7788

mxd7788

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Ok i've uploaded the ppf to silos.ru it's for the iso on the bay , if you want to test it pm me

#55
tsungchot

tsungchot

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
Hi i'm using AMD 64 Athlon X2 Dual Core Processor 4200+
supports SSE,SSE2,SSE3,x86-64
chipset = ATI Xpress 200 (RS480) Rev.10
Southbeidge = ATI SB400
LPCIO = SMSC LPC46M192
i have windows in C: <--(SATA) and D: <--(FAT32) recovery for Windows XP (which i'm using XP)
using Dual display
and i just bought Western Digital 320GB SATA drive with partitioned NTFS (total = 320GB)
i went through the main screen of installation.
and at the beginning where u erase your HDD to format for MAC OS X
i don't see No Hard Disk Drive except the DVD drive that Mac OS X in it.
from windows XP i see all the HDD. just from "DISK UTILITY" screen at the beginning of the installation OS X, i don't see NO HDD.
PLease HELP !!!!!!! i really need help !!!! H !!!!!! E !!!!!!!!!!! L !!!!!!!!!!! P !!!!!

I used iATKOS_1.0i and Leopard 10.5.1 all AMD patched.

#56
ole2

ole2

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 180 posts
  • Gender:Male
  • Location:Grenoble, France
somebody managed to get Leo version of this driver?

#57
Presko

Presko

    InsanelyMac Protégé

  • Members
  • Pip
  • 26 posts
this adds only paralel ata support if you are using sata dont think it will help you

#58
raicamortensen

raicamortensen

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
hi to all member , i check all drive and install it , it can successfully run and if you are not forced it it has no benefit if u force or not. thanks..

#59
sapibinca

sapibinca

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
hi i have a problem with a nforce controller in my laptop.
notebook acer 7520g chipset mpc 67 ,i can install leopard on a usb drive but not in my internal disk!
When trying it internal after installing os i've "still waiting for root device" error .
The strange thing is that i can boot on internal only when i've two hardisks installed!!! and no " still waiting for root device" error.
someone has any idea about it?
tnx and sorry for my english





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2015 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy