Jump to content

Modded ALC662 & Sigmatel 9223 with codec verbs


  • Please log in to reply
139 replies to this topic

#1
OcciJano

OcciJano

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 154 posts
  • Location:Mexico City
  • Interests:iPod, Pets, Dance latin music, Music, Macintosh, Hackintosh
Hi, just want to share my Modded ALC662 & Sigmatel 9223 with codec verbs.

Realtek ALC662Attached File  Modded_662_AppleHDA.zip   1.59MB   8630 downloads also try links: Post#6 LineOut-Headphone active in LineOut & MicBack-MicFront active in 2nd Mic, post#12 LineOut, Headphone, MicBack active and sepated, cleaner than the one in post#6 thanks to tmongkol. Legacy 662 in post#72 by tmongkol.
As godexsoft says in post #109, VoodooHDA is available from Voodoo Forums it works well.
If you upgraded to 10.5.7 with LegacyHDA you need VoodooHDA or use previous AppleHDA, otherwise Mac OS won't start with LegacyHDA installed.
I'm actualy using LegacyHDA for 10.5.8 & Snow Leopard by tmongkol http://www.insanelym...p...460&st=100#
VoodooHDA 32/64 for Snow Leopard compiled by tong http://www.insanelym...p...75372&st=0#
Chameleon 2 is a dream come true! Thanks Voodoo Labs team!!!

Attached File  Input662.png   53.4KB   2368 downloads Attached File  Output662.png   56.38KB   2003 downloads Attached File  SystemProfiler662.png   58.99KB   2426 downloads




Sigmatel 9223 Attached File  Modded_9223_AppleHDA.zip   1.59MB   1065 downloads
Attached File  Input9223.png   48.84KB   548 downloads Attached File  Output9223.png   52.06KB   428 downloads Attached File  SystemProfiler9223.png   61.95KB   651 downloads


Don't forget to Remove (Backup) your ALCInject.kext & HDAEnabler before installing, otherwise it won't work.
AppleHDA.kext posted here contains HDAEnabled edited to use ID 662 or ID 9223.
If System Profiler shows Audio ID: 662 or ID 9223 then it's ok.
Try to install the "With Verbs" version, if it doesn't work, try the "Without Verbs" version.

Thanks to: Taruga, THeKiNG, and MadTux for all your hard work and guides.

OcciJano

#2
Plucky81

Plucky81

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 149 posts
  • Gender:Male
  • Location:Palermo, Italy
Hi OcciJano!
Sorry... I escaped for a while!
Anyway... I tried the others drivers (in the other topic) and they didn't work... are these different????

At the moment I need to install the "original" kext (AppleHDA.kext) before turning off or restarting and I need to install the Dr. Hurts' kexts (AppleHDA.kext and HDAEnabler.kext) after the reboot...

Let me try... I will make you know :thumbsup_anim:

Thanks for the message!

Gianluca

#3
OcciJano

OcciJano

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 154 posts
  • Location:Mexico City
  • Interests:iPod, Pets, Dance latin music, Music, Macintosh, Hackintosh
Hi Gianluca81:

Yes, it's a more recent AppleHDA.kext. It contains two versions, the one without the codec verbs strings is almost identical to Taruga's 1.2 patcher, the one with codec strings, is made following the guides that THe King and MadTux are publishing. I tried those guides with the actual version of AppleHDA.kext, but, the Mic output isn't working plus some errors, so I decided no to publish by now the newer versions. Instead the older version works fine with codec verbs, with mic and no errors.

The case of ALC662 kext, 662 is very limited in the output and input ports, some may encounter that the versions I'm including won't work with their particular motherboard, I hope to be giving a better one in a near future, as many, many people in this and other forums are getting better results. As you can read I'm just implementing their findings for myself and sharing with you.

Well, you only need to remove ALCInject.kext & HDAEnabler from your Extensions folder, and try both versions of AppleHDAkext, one at a time, to see which one is better for you. Both versions include a HDAEnabler inside.

Only try the 662 if you have a 662.

Sorry for my bad English.

#4
Keeper75

Keeper75

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
TYVM OcciJano!

Your ALC662 kext works perfectly on a P5GC-MX motherboard !

Though, there's one small issue which i can't get to work - Front audio - is there a way to enable it ?


Regards,


Keeper

#5
Plucky81

Plucky81

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 149 posts
  • Gender:Male
  • Location:Palermo, Italy
Hi Man!
Nothing to do... :thanks_speechbubble:
The only working kext seems to be the Dr. Hurts' one.
I tried yours but there's no Out or In in System Preferences/Sound even if System Profiler recognize the device.

At the moment if I want to make it works I have to...
  • start the computer with the "original" AppleHDA.kext to make System Profiler doesn't see any audio device
  • install Dr. Hurts' AppleHDA.kext and HDAEnabler.kext
so I can see: 1 analogic out, 1 digital out, 1 mic in and 1 line in.

Then, if I want to make it works at the next reboot, I have to delete the AppleHDA.kext and HDAEnabler.kext installed before, re-install the "original" AppleHDA.kext, restart the computer and re-follow the previous steps!

Can you explain what does it mean?!

Thank you!

Gianluca

#6
OcciJano

OcciJano

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 154 posts
  • Location:Mexico City
  • Interests:iPod, Pets, Dance latin music, Music, Macintosh, Hackintosh
Keeper75: I'm on that right now, I hope to have a better ALC662 soon.

Gianluca81: Well, every ALC662 kext (mine & others) have problems with some mobos, I'm trying to figure out how to get a more general one.

Edit: 29/10/2008 No success with 10.5.5 version, will keep trying.

Keeper75: try this for 662 audio front Attached File  AppleHDA.kext.zip   809.31KB   1378 downloads

#7
Keeper75

Keeper75

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
OcciJano,

I can now hear through the front panel, but only if i select the "Line-Out" on System Preferences. If i select the new "Headphones" option, i cannot hear anything - neither on the front panel, nor on my back speakers.

Another thing that i've noticed is that, by selecting the "Line-Out option", the audio is being routed to my back speakers and also to the front panel simultaneously...and the volume slidebar is controlling both outputs simultaneously too.


I hope that this feedback helps you out.


Regards!

Keeper

#8
OcciJano

OcciJano

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 154 posts
  • Location:Mexico City
  • Interests:iPod, Pets, Dance latin music, Music, Macintosh, Hackintosh

OcciJano,

I can now hear through the front panel, but only if i select the "Line-Out" on System Preferences. If i select the new "Headphones" option, i cannot hear anything - neither on the front panel, nor on my back speakers.

Another thing that i've noticed is that, by selecting the "Line-Out option", the audio is being routed to my back speakers and also to the front panel simultaneously...and the volume slidebar is controlling both outputs simultaneously too.
I hope that this feedback helps you out.
Regards!

Keeper


Thanks for your feedback, I have not a front panel in my ALC662 system, but I have it in the Sigmatel 9223 one. Well I need to try there, the front output in the 9223 sounds strange, I need to research a lot to solve it.

#9
Dr. Hurt

Dr. Hurt

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 1,493 posts
  • Gender:Male
  • Location:Cairo, Egypt and NYC, USA
  • Interests:Wandering around on the internet!! Politics, Sci/Tech, Medicine.

Keeper75: I'm on that right now, I hope to have a better ALC662 soon.

Gianluca81: Well, every ALC662 kext (mine & others) have problems with some mobos, I'm trying to figure out how to get a more general one.

Edit: 29/10/2008 No success with 10.5.5 version, will keep trying.

Keeper75: try this for 662 audio front Attached File  AppleHDA.kext.zip   809.31KB   1378 downloads


OMG!!!
I can't beleive it. I finally got audio out of the front panel with your kext!! I've trying to do that for months. Thank you very much. You're a genius.

I did however notice that audio out of the font panel needs line-out selected in the system prefernces, but who cares?! Also, front panel mic is now working.

#10
OcciJano

OcciJano

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 154 posts
  • Location:Mexico City
  • Interests:iPod, Pets, Dance latin music, Music, Macintosh, Hackintosh

OMG!!!
I can't beleive it. I finally got audio out of the front panel with your kext!! I've trying to do that for months. Thank you very much. You're a genius.

I did however notice that audio out of the font panel needs line-out selected in the system prefernces, but who cares?! Also, front panel mic is now working.


Glad to hear that front mic is working, I have no way to try it in my 662 mobo, thank you for your feedback.

#11
VCH888

VCH888

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 585 posts
To OcciJano

Thank you for your work. I tested 662-audio-front AppleHDA.kext. I had heard sound from speakers and headphone at the same time. When I looked at Info.plist, both Line Out (nodeid 20) and Headphones (nodeid 27) had the same of audio output (nodeid 2) and audio mixer (nodeid 12). I tried to solve the problem. Finally I got nodeid 27, nodeid 4, and nodeid 14 for Headphones so that I can listen my songs from speakers or headphone. Also, I removed nodeid 25 (Mic at Ext Front), so I could use a mic (Mic at Ext Rear) correctly.

#12
OcciJano

OcciJano

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 154 posts
  • Location:Mexico City
  • Interests:iPod, Pets, Dance latin music, Music, Macintosh, Hackintosh

To OcciJano

Thank you for your work. I tested 662-audio-front AppleHDA.kext. I had heard sound from speakers and headphone at the same time. When I looked at Info.plist, both Line Out (nodeid 20) and Headphones (nodeid 27) had the same of audio output (nodeid 2) and audio mixer (nodeid 12). I tried to solve the problem. Finally I got nodeid 27, nodeid 4, and nodeid 14 for Headphones so that I can listen my songs from speakers or headphone. Also, I removed nodeid 25 (Mic at Ext Front), so I could use a mic (Mic at Ext Rear) correctly.


Thank you very much :blink: .
I will fix that the weekend, meanwhile, would you like to share your mod to everybody? Posted here.
If you use headphones (front), line-in (back) switches off? (mine don't)

Edit 1: I will move my 662mobo to the other case with front panel (need to test autonsense with mic-front & headphones), so we can share results.
Edit 2: Here's the version with tmongkol corrections Attached File  AppleHDA.kext.zip   809.93KB   966 downloads
Please, ALC662 users, post your results with this version
Here are my results:

Line (green back) Out working .
Line In (blue back) working.
Mic (pink back) working.
Headphones (green front) working.
Mic (pink front) removed in this version.
Speakers not working (pink/blue both at back but haven't found a way to enable them.
Digital Out (Orange)? (can't test it, I don't have it)

Thank you

#13
Dr. Hurt

Dr. Hurt

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 1,493 posts
  • Gender:Male
  • Location:Cairo, Egypt and NYC, USA
  • Interests:Wandering around on the internet!! Politics, Sci/Tech, Medicine.
Green speaker jack at the back is working when I select line out in system prefernces. (Correct)
Pink mic jack at the back is working when I select internal microphone in system preferences. (Should be line in because my system does not even have internal speakers or mic))
Blue jack at the back not working.
I don't have digital so I didn't test it.
Green jack at the front panel is working when I select Headphone in system preferneces. (Correct - fixed))
Pink mic jack at the front panel is not working at all.

Also auto detection of plugged devices is not working, but I actually like that because it's usually buggy even on windows. Also now sound does NOT play through the front and back speakers at the same time - which is good.

Thank you.

#14
IronFly

IronFly

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 241 posts
i tried on my system2 (Intel D945GCLF2) and i got verbs but not sound or mic; maybe i'm doing something wrong.

this is my dump from ubuntu.

Attached File  ALC662V1_dump.txt   8.15KB   238 downloads

#15
haroldc

haroldc

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 108 posts
  • Location:paris

i tried on my system2 (Intel D945GCLF2) and i got verbs but not sound or mic; maybe i'm doing something wrong.

this is my dump from ubuntu.

Attached File  ALC662V1_dump.txt   8.15KB   238 downloads


same mobo, same problem :)

#16
OcciJano

OcciJano

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 154 posts
  • Location:Mexico City
  • Interests:iPod, Pets, Dance latin music, Music, Macintosh, Hackintosh
haroldc & IronFly, will see your codec dump.

Dr. Hurt, blue jack is Line-in, the reason I removed Mic Front (pink) is that some programs like Sound Studio confuses the mic port, I hope to have a solution.

I hope, really, really hope to solve the most of the ALC662. Cross fingers.

Thank you all for your feedback :) .

Edit Nov/2/2008

Haven't found a solution yet, I'll keep trying.

#17
Pietruszka

Pietruszka

    InsanelyMac Protégé

  • Members
  • PipPip
  • 98 posts
  • Gender:Male
Same results as Dr. Hurt said

front mic doesn't work...

GREAT JOB!!!...

motherboard:
gigabyte g31m-s2l alc662

#18
Dr. Hurt

Dr. Hurt

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 1,493 posts
  • Gender:Male
  • Location:Cairo, Egypt and NYC, USA
  • Interests:Wandering around on the internet!! Politics, Sci/Tech, Medicine.
Thank you very much OcciJano. You have made me and a lot of other users very happy. Keep up the good work.

Dr. Hurt

#19
Pietruszka

Pietruszka

    InsanelyMac Protégé

  • Members
  • PipPip
  • 98 posts
  • Gender:Male
One more thing...

I need to boot with -f to have working sound...

if not i got message System/Library/Extensions/AppleHDA.kext/Contents/Plugins/HDAEnabler.kext not properly installed...

can you tell me what is wrong.....did chmod chown with AppleHDA.kext.....repaired permissions....

thanks for any help...

#20
OcciJano

OcciJano

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 154 posts
  • Location:Mexico City
  • Interests:iPod, Pets, Dance latin music, Music, Macintosh, Hackintosh

i tried on my system2 (Intel D945GCLF2) and i got verbs but not sound or mic; maybe i'm doing something wrong.

this is my dump from ubuntu.

Attached File  ALC662V1_dump.txt   8.15KB   238 downloads


IronFly try this, it contains almost the same thing, but, using your codec verbs edited Attached File  IronFly.zip   813.7KB   258 downloads





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy