Jump to content

[Guide] Boot from EFI partition, zero modification installs on Intel SSE2 or better...


  • Please log in to reply
1405 replies to this topic

#1381
TLS5972

TLS5972

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
good job.

#1382
munky

munky

    Agent of Evolution

  • Retired
  • 2,901 posts
  • Location:The Land of Hairy-Arsed Highlanders
Hello all. Haven't really been keeping up with this topic, slightly amazed at the number of replies :)

I 'deprecated' this method only because Chameleon 2 should be able to do everything this bootloader can do. If this one works better for some people, then of course keep using it. Software doesn't rot, after all ;)

#1383
mattrb4

mattrb4

    InsanelyMac Protégé

  • Members
  • PipPip
  • 55 posts

Hello all. Haven't really been keeping up with this topic, slightly amazed at the number of replies :(

I 'deprecated' this method only because Chameleon 2 should be able to do everything this bootloader can do. If this one works better for some people, then of course keep using it. Software doesn't rot, after all :(


munky is the greatest, his method is amazing.

#1384
BlackCorsair

BlackCorsair

    Insanely Metal Rocker

  • Members
  • PipPipPipPipPip
  • 309 posts
  • Gender:Male
  • Location:ITALIA - CAGLIARI - TRIESTE
I still stay on your way, munky! Great!

#1385
mansanas.org

mansanas.org

    InsanelyMac Protégé

  • Members
  • Pip
  • 22 posts

I still stay on your way, munky! Great!


Ditto that, tried other bootloader methods, and munky's method is the most stable and efficient.  Cheers!

#1386
mattrb4

mattrb4

    InsanelyMac Protégé

  • Members
  • PipPip
  • 55 posts

I still stay on your way, munky! Great!

Ditto that, tried other bootloader methods, and munky's method is the most stable and efficient. Cheers!


It looks to me like you guys did not do the $30 upgrade to Snow Leopard EFI boot edition. munky's EFI method works in Snow Leopard, you just need the new Chameleon!


Use this script to create a full munky EFI for Snow Leopard and old Leopard for any PC! AUTOMATICALLY! Link!

If you have a non-core-i7 chip then you need to use the script to edit your smbios.plist entry that has macpro;41 and change that to macpro;31 . You insert your kexts that you need in the folders and get others that you need from the repository.

Enter buildcache in -s single user mode after you restart when installing SL with old leopard.

#1387
wd1

wd1

    InsanelyMac Protégé

  • Newbies
  • Pip
  • 1 posts
Hi Guys...
Please help I'm new here...

I have Asus P6T SE + i 920
I try to install "Leopard 10.5.4 (9E25) Retail" in first time in my life))))
Installation has passed successfully, after install was updated to 10.5.7 with Combo Update...
Now it is time to start adjustment... But...After I have done "E" steps from MJ guide I have got stuck
When I try perform this command:

Phase 2: Installing the modified bootloader.

3) ./fdisk -f boot0 -u -y /dev/rdisk0 - I see "Permission Denied"

help please... I'm tired (((( three days thinkings and attempts

I don't know how to recieve full admin rights...

Forgive me my bad language knowledge

#1388
kizwan

kizwan

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 1,422 posts

Hi Guys...
Please help I'm new here...

I have Asus P6T SE + i 920
I try to install "Leopard 10.5.4 (9E25) Retail" in first time in my life))))
Installation has passed successfully, after install was updated to 10.5.7 with Combo Update...
Now it is time to start adjustment... But...After I have done "E" steps from MJ guide I have got stuck
When I try perform this command:

Phase 2: Installing the modified bootloader.

3) ./fdisk -f boot0 -u -y /dev/rdisk0 - I see "Permission Denied"

help please... I'm tired (((( three days thinkings and attempts

I don't know how to recieve full admin rights...

Forgive me my bad language knowledge

To gain admin rights, enter this command in the Terminal, followed by your password:-
sudo -s

kizwan

#1389
digital_dreamer

digital_dreamer

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,100 posts
  • Gender:Male
  • Location:Missouri USA

It looks to me like you guys did not do the $30 upgrade to Snow Leopard EFI boot edition. munky's EFI method works in Snow Leopard, you just need the new Chameleon!


Use this script to create a full munky EFI for Snow Leopard and old Leopard for any PC! AUTOMATICALLY! Link!

If you have a non-core-i7 chip then you need to use the script to edit your smbios.plist entry that has macpro;41 and change that to macpro;31 . You insert your kexts that you need in the folders and get others that you need from the repository.

Enter buildcache in -s single user mode after you restart when installing SL with old leopard.

You're absolutely right, mattrb4! Amazing stuff! :)

MAJ

#1390
munky

munky

    Agent of Evolution

  • Retired
  • 2,901 posts
  • Location:The Land of Hairy-Arsed Highlanders
thanks all for your kind words. ;)

#1391
Johanmartin

Johanmartin

    InsanelyMac Protégé

  • Members
  • Pip
  • 38 posts
I have an asus p6t6 ws revolution corei7 965 and have been following MJ:s guide for installing leopard using the 10.5.6 retail CD. Everything is fine and the system starts noramly when I use the boot 1-3-2 CD. When I follow munky´s guide using the kexts in the initrd.img file or in the EFI_pack-v3, however, the system boots very slowly and runs extremly slowly. Could someone please help me?

Logically, If it works when using the boot 1-3-2 CD, it should also work with any bootloader using the same kexts, or am I wrong here?

#1392
Eddie Turfboer

Eddie Turfboer

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 150 posts
  • Gender:Male
  • Location:The Netherlands

I have an asus p6t6 ws revolution corei7 965 and have been following MJ:s guide for installing leopard using the 10.5.6 retail CD. Everything is fine and the system starts noramly when I use the boot 1-3-2 CD. When I follow munky´s guide using the kexts in the initrd.img file or in the EFI_pack-v3, however, the system boots very slowly and runs extremly slowly. Could someone please help me?

Logically, If it works when using the boot 1-3-2 CD, it should also work with any bootloader using the same kexts, or am I wrong here?


Basically, same kext whether on boot-132 or bootloader functions the same. Are you sure that both options are exactly the same?

#1393
slade67

slade67

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
hey just a question, i did everything as said in the guide.
I am currently trying to get snowy work on vmware, and it does quite well with sound, networking etc.
but i am stuck on the graphicsEnabler which is possible (qe,ci).
I am stuck on the EFI installation in order to get the Boot.plist to work.
I put the kext from the darwin_snow.iso in the EFI partition but everytime I reboot the machine it ends up in VMWare telling me it is not Snow Leopard Server and Vmware will power off
any clues on what i did wrong ?
i used efi 5.1 and 6.1 no luck so far

#1394
munky

munky

    Agent of Evolution

  • Retired
  • 2,901 posts
  • Location:The Land of Hairy-Arsed Highlanders
wow, amazed that people are STILL finding a use for this guide :)

so I just wanted to post here that i'm basically no longer active in the community. its been a blast and i'd like to thank everyone who i've known or who has helped me out over the past five (FIVE!!) years - its been a blast :)

Warmest regards

- Rory

aka Munky

xx

PS In case anyone is interested in what i'm doing these days, i'm still playing around with various media centre apps and OS's, and i'm getting into iPhone development - with the possibility of employment in that realm in the near term. Exciting times! ;)

#1395
PJ_Mac

PJ_Mac

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
  • Gender:Male
  • Location:NY
Awesome, very helpful, thanks!

#1396
MaLd0n

MaLd0n

    ...filling veins with juice of chaos...

  • Moderators
  • 11,139 posts
  • Gender:Male
  • Location:Rio de Janeiro
Thanks munky

#1397
Guest: tt325325_*

Guest: tt325325_*
  • Guests
Castle Lineage II-Gracia Final

Castle Lineage II—Gracia Final Open-test will release on 5.27.2010

Home page:h t t p:// w w w .c a s t l e l 2 .c o m
Official forum:h t t p:// b b s. c a s t l e l 2 .c o m

Server Info
Game server:IBM System x3450
Network:Exclusive bandwidth 30M, share bandwidth 100M, Unlimited
Server load:1200 accounts online at the same time
Game rates: Exp:100x, Adena:300x, Drop:300x

GAME SPECIFICS:
*Release PVP attribute system
*Release Dual-dagger Compound system
*New S84 Vesper weapons, Vesper armors, Vesper jewelries etc
*Release two-in-one skills
*Release Vitality system, Element Attribute system
*All newbie weapons, armors, jewelries, entertainment props, consumables can be
achieved easily in Castle Convenience Store
*Release all accessories, Weapon Enchant system
*Release Wedding system, the IDs of couple are in special color, the couple can teleport to each other, know the condition and position of each other
*Newbie can level up easily, finish all occupational changes at Occupational Change Master more efficiently
*Release new BOSS, dropping weapons and armors of Vesper, Dynast, Infinity series
*Perfect races, all functions of Gracia Final available, skill enhancing, duel system
*All auto-learned skills
*Class and sub-class up to LV85, balanced classes.
*Release hundred kinds of Agathion bracelet
*Complete Demonic Sword Zariche & Blood Sword Akamanah system, Transfiguration system
*Auto resurrection state protection
*Multiple accounts support make your playing easy
*Two weeks a period of Seven Signs system, make special attribute to exchange for equal-grade weapon from Blacksmith of Mammon, selling rare props

#1398
sn8k

sn8k

    Personnal Devil

  • Members
  • PipPipPipPipPipPipPip
  • 889 posts
  • Gender:Male
  • Location:Paris, pas celui du texas.
hi all ,

I've followed the tuto but i got a weird problem ...

at boot up, i keep on getting that :
Boot0: GPT
Boot0: HFS+
Boot0: booting
Boot0: done
Non-system disk
Press any key to reboot

I've followed the instructions twice, but still no luck ... Any idea on how to resolve that ?

(ps : i'm on slow leo 10,6,4 build 10F564 and GUID partitionned)

thx for your answers

#1399
timbojill

timbojill

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 104 posts
can someone post this guide for GUID partitions ? E-mail uvidownloader@gmail.com with it.

#1400
bright_plastik

bright_plastik

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
Dear Munky, i admire a lot your domination of the mac partitions, and the conseguent ability to do what you want of them...

But, as an absolute noob, I started to study the differences between GPT, MBR, efi and stuff...I used to move discretely well in the win deployment, but here... gosh... everything seems to have conseguences I can't do anything about.

My problem (as obviously I have one ;-) )

installed 10.6.0 through this boot cd, which is the only on that worked with my laptop
http://www.insanelym...howtopic=207692

followed your guide dozens of times... had frequently problems with unmounting the partition...

I even tried the automatic version, the EPOS script...
http://news.metaparadigma.de/?p=1706

but it always stopped through crosschecking the partition, or, at the unmounting...

then, tried with the chameleon RC5. No dice.

then, tried with the PCEFI 10.5, and 10.6. No dice.

then, tried a combination of everything to create the .mkext file

I now manage to install all the kext I need, but I can't boot from my shiny EFI, containing everything I think to need for a brilliant 5.1 macbook, with graphics and everything...

BUT...


every bloody time I reboot, no matter what I struggle to do,
I receive this message:

boot0: GPT
boot0: error

I know everything in the EFI partition is in order, cause I've been studying for weeks,
but I can't manage to make boot0 to read the partition and load the boot manager.

Please, tell me where i'm wrong. I think it had to do with mounting and unmounting, which erases the data in EFi, but how can I work on it if I don't mount?
And, other BIG problem, upon reboot I ALWAYS see the EFI partition, again, no matter waht I do.

I read guides since weeks now, but I can't still complete this operation.


PLEASE, share the power to do what you want! It's weeks I'm sitting here without a clue!



My rig:

Packard Bell TJ65 (found all the kexts, apple.com.boot, smbios and graphic ID stings I need for it)

640gb HDD, 2 partitions: HFS+ and FAT32 (and stupidly mounted EFI), GPT, with the intention to install win 7 in the second partition, but for now just a stupid FAT32 partition laying there...





1 user(s) are reading this topic

1 members, 0 guests, 0 anonymous users


© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy