Jump to content

ATI HD3850/70 EFISTUDIO MOD for TRIAKIS + ATINDRV.KEXT Triakis


  • Please log in to reply
31 replies to this topic

#1
mitch_de

mitch_de

    InsanelyMacaholic

  • Retired
  • 2,885 posts
  • Gender:Male
  • Location:Stuttgart / Germany
I added to the orig. EFISTUDIO (great tool for gfxstring, also for NVs!!!) am entry (select it) ATI HD 3850_TRIAKIS.
EDIT: This may also work for ATI HD3870 ! (not 3870X2!)

HINT: new motherboard - same gpu with gfxstr - no screen?!
It seems to be that an working gfxstring may NOT work anymore if you use the same gpu in an new/other mainboard!
Also shared gfxstrings for an gpu may not work in YOUR enviroment! Can be that the new mainbaord has other ID for the PCIe Slot. Wrong PCIe ID in "used/shared" gfxstring may result also in no screen,
So this easy EFISTUDIO tool is great to get really your own gfxstring.

Very usfull for those 3850/3870 users which get scrambled / no screen at all with their try&error downloads of ATI3850 packages shared around.
Whats TRIAKIS ?
Its an modded Framebuffer (i dont know who made it) , which is used insted of the LAMNA.
TRIAKIS Framebuffer plugin is in the ATINDRV.KEXT which is included.
To use this Framebuffer, it must be called /linked by the gfxstring (or, not recommended by the injectors like NATIT.KEXT)
The orig. EFISTUDIO only has an 3850 entry with LAMNA link, not the TRIAKIS.
So i made this set of EFISTUDIO + fitting ATINDRV.KEXT with TRIAKIS framebuffer plugin inside.

!! Start EFISTUDIO, select the ATI 3850 TRIAKIS entry for 3850/3870 users - perhaps good to remove an extisting(not working) gfxstring before!!
!! If you made gfxstring (in boot.plist) you MUST remove all injectors (NATIT.KEXT, NVCRUSH.KEXT) !!
!! Before reboot, install the ATINDRV.KEXT with Kext Install Helper (or make by cli commands rights/owners are OK, all must be root:wheel) !!
!! Before reboot you should remove extensions.mkext or boot once with bootflag -x (safe mode - rebuilds extensions.kext) !!

DL below includes:
1. EFISTUDIO with ATI HD3850_TRIAKIS gfxstr with Triakis insted of Lamna strings
2. fitting ATINDRV.KEXT (TRIAKIS) for gfxstr above

LINK: NVINSTALLER has new 10.5.5 dev ATI drivers !!!
http://nvinstaller.com/

Attached Files



#2
mitch_de

mitch_de

    InsanelyMacaholic

  • Retired
  • 2,885 posts
  • Gender:Male
  • Location:Stuttgart / Germany
EDIT: This , using the 3850 Triakis EFISTUDIO + ATINDRV Triakis may also work with 3870 (NOT the X2!!) if it has also 512 MB VRAM.

#3
nattachai

nattachai

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
It works. Thanks.

Sapphire ATI HD 3780 DDR3 512MB
iDeneb 10.5.4

#4
Neew

Neew

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
  • Gender:Male
does anyone know what I should use to get my grafics work on 10.5.5???

#5
leonardoprc

leonardoprc

    InsanelyMac Protégé

  • Members
  • PipPip
  • 76 posts
  • Gender:Male
  • Location:Brasil/Salvador-BA
I installed Kalyway 10.5.5 updated on my PC
Intel Core2 Duo CPU E4600 @ 2.40GHz
GeForce 8600GT 512MB
Darwin v9.5.0

Everything works 100% except for the random freezing after I install my graphics card(using EFI Studio) :wacko:

Just move your mouse (even without it being visible) that the login screen appears. And everything more work, QE / CI, allowing even play Age Of Empires

Any body run across this before and find a way to fix it?

#6
markswell

markswell

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts
wow but this not work with my asus silent magic(ddr2) 3650 512MB

#7
cornishman

cornishman

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts
  • Gender:Male
  • Location:Kernow, Nr. England
  • Interests:F1, MotoGP, Rugby Union
Still getting the garbled screen with my Galaxy 3850 512mb card. ;)

#8
b:z

b:z

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 137 posts
I could not find the driver for Nvidia QuadPro FX 570m with hardware ID 0x040c

Please add it into your support video list.
Many thanks.

#9
lastExile

lastExile

    lastExile��

  • Members
  • PipPipPipPipPip
  • 333 posts
  • Gender:Male
  • Interests:netadmin of osx86.hu irc network for the past few years
first off WHY TRIAKIS WHEN IT HAS DISABLED POWERPLAY & POWERMANAGEMENt ???????????? use either Lamna or the new mega atleast there is some power management triakis has 100% running fans and core

#10
quis

quis

    InsanelyMac Protégé

  • Members
  • PipPip
  • 83 posts
Uh........How to use this exactly...I'm a newbie.

I successfully installed Jas 10.5.4 on my P43 machine today but only ethernet worked out-of-the-box. (So I'm downloading iDeneb now...)
Tried several 3870 drivers but after reboot the screen just got scrambled up...

Thx in advance.

#11
mitch_de

mitch_de

    InsanelyMacaholic

  • Retired
  • 2,885 posts
  • Gender:Male
  • Location:Stuttgart / Germany

first off WHY TRIAKIS WHEN IT HAS DISABLED POWERPLAY & POWERMANAGEMENt ???????????? use either Lamna or the new mega atleast there is some power management triakis has 100% running fans and core

Thanks for that info.
I tried all available .pgk, but i get with all blue screen or an scrambled screen. Until i switched to the triakis ATINDRV insted of the lamna.
I have no performance problems and no powermanagement problems, fans works as it should.
lastexile: If i tested YOUR ATI HD 10.5.5.pdk (19.9.08) i get an Kernel Panic using the included natit and an blue screen using gfxstring. So triakis is NEEDED for me und til YOU have an better solution!!!

To get closer to that problem (some of the ATI 3850 cards will make much, much problems- only work with triakis, some work with lamna)
i believe that the reason is in different atombios and/or different VRAM type (GDR3 vs GDR4)
if we could have some go/no go card info, lastexile can perhaps more help, or at least warn OSX86 users to buy some of the 3850 models which make problems.

Please post your 3850 card info and what works, what not
my:
MSI 3850, 512 MB GDDR3, OS X 10.5.5, orig. Apple drivers, needs gfxstring(link to triakis) + ATINDRV with triakis, no screen or scrambled screen with lamna ATINDRV (gfxstring link to lamna / Natit lamna)

#12
quis

quis

    InsanelyMac Protégé

  • Members
  • PipPip
  • 83 posts
I'm now using iDeneb 10.5.5.
Have tried all those packages and kexts floating around the web...All of them doesn't work or just give me a terribly scrambled screen.
Finally with this mod and a Triakis_2400_2600_2900_3800.zip file,
I succeeded in having a resolution of 1440X900 for my widescreen display, and Leopard can also recognize the name of my Viewsonic LCD.

However I just can't turn on QE....
My card is a DDR3 HD3870 512mb.
Any solutions?

#13
Karoly

Karoly

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
it works with ideneb 10.5.5 v1.3, 3850 but i had to install nvinstaller latest first
thx

#14
shockre

shockre

    InsanelyMac Protégé

  • Members
  • Pip
  • 26 posts
i cant get it working with sapphire hd3850 512mb ddr3..
any suggestions?

#15
bigfut08

bigfut08

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
I have HIS Radeon HD 3850 512MB 256Bit GDDR3 PCI Express X16 (H385F512ANP). I had exactly the same problem until i installed the Triakis framebuffer. I currently run Leopard 10.5.5 which i installed from the Retail DVD using Boot-132 method. I had to install 10.5.2 first, update the ATINDRV.kext and then update to 10.5.5. Using 10.5.4 Retail DVD would give me scrambled screen. And i didn't use gfxstring and didn't update boot.plist.

My Configuration:
GA-EP45-UD3P, Intel Core2 Duo E8400, 4Gb DDR2 (800MHz, Dual Channel)
HIS Radeon HD 3850 (512MB DDR3)
HighPoint RocketRAID 2300, 500Gb RAID1 (2 x 500Gb Seagate HDD)
Pioneer DVR-215


#16
Demone

Demone

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
@bigfut08
I have a HD2400XT and as a lot of ppl I was having the scrambled screen problem.
I then installed latest nvinstaller package (9f23 as of now) and using EFIStudio I selected ATI HD2400, changed the framebuffer value (inside the efi string) to Megalodon
Inserted the modified efi string inside boot.plist, changed ATIRadeon2000.kext to include hd2400XT Ven.ID and Prod.ID, rebooted WORKED !

#17
viktike

viktike

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
Got Sapphire HD3850 AGP. Not working with updated Kalyway release :( tomorrow I'll try with Jas 10.5.4. iDeneb just not works.

#18
b:z

b:z

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 137 posts
I could not get my 4870x2 work under 10.5.5 :(

Is there any news support this card?

Thank you

#19
mitch_de

mitch_de

    InsanelyMacaholic

  • Retired
  • 2,885 posts
  • Gender:Male
  • Location:Stuttgart / Germany

I could not get my 4870x2 work under 10.5.5 :D

Is there any news support this card?

Thank you

No. ALL! 4XXX cards are not possible for us, until ATI or Apple realease drivers for them.
Differences to 2XXX and 3XXX cards may be to much for an simple "use that with that" solution.
No WAY , i am sure !

#20
MacDoodle

MacDoodle

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts

I added to the orig. EFISTUDIO (great tool for gfxstring, also for NVs!!!) am entry (select it) ATI HD 3850_TRIAKIS.
EDIT: This may also work for ATI HD3870 ! (not 3870X2!)

HINT: new motherboard - same gpu with gfxstr - no screen?!
It seems to be that an working gfxstring may NOT work anymore if you use the same gpu in an new/other mainboard!
Also shared gfxstrings for an gpu may not work in YOUR enviroment! Can be that the new mainbaord has other ID for the PCIe Slot. Wrong PCIe ID in "used/shared" gfxstring may result also in no screen,
So this easy EFISTUDIO tool is great to get really your own gfxstring.

Very usfull for those 3850/3870 users which get scrambled / no screen at all with their try&error downloads of ATI3850 packages shared around.
Whats TRIAKIS ?
Its an modded Framebuffer (i dont know who made it) , which is used insted of the LAMNA.
TRIAKIS Framebuffer plugin is in the ATINDRV.KEXT which is included.
To use this Framebuffer, it must be called /linked by the gfxstring (or, not recommended by the injectors like NATIT.KEXT)
The orig. EFISTUDIO only has an 3850 entry with LAMNA link, not the TRIAKIS.
So i made this set of EFISTUDIO + fitting ATINDRV.KEXT with TRIAKIS framebuffer plugin inside.

!! Start EFISTUDIO, select the ATI 3850 TRIAKIS entry for 3850/3870 users - perhaps good to remove an extisting(not working) gfxstring before!!
!! If you made gfxstring (in boot.plist) you MUST remove all injectors (NATIT.KEXT, NVCRUSH.KEXT) !!
!! Before reboot, install the ATINDRV.KEXT with Kext Install Helper (or make by cli commands rights/owners are OK, all must be root:wheel) !!
!! Before reboot you should remove extensions.mkext or boot once with bootflag -x (safe mode - rebuilds extensions.kext) !!

DL below includes:
1. EFISTUDIO with ATI HD3850_TRIAKIS gfxstr with Triakis insted of Lamna strings
2. fitting ATINDRV.KEXT (TRIAKIS) for gfxstr above

LINK: NVINSTALLER has new 10.5.5 dev ATI drivers !!!
http://nvinstaller.com/



Sorry, but I am very new to this. I have the original Intel platform that the devs first used for developing osx86 - p4 on an intel 915 board. Unfortunately I could not get the intel gma900 graphics to work in Leopard so I bought an ati3850 but I can't get it too work either. Well, at least I can't get QE to work. I installed iAtkos 10.5.5 but got a scrambled screen. I then rebooted into single user mode and then renamed the atiradeonx2000.kext file and was able to boot after this. I can even choose different resolutions but I still can't get QE to work.

I would like to try this fix but I can't figure out how to use the efistudio_3850_triakis.sitx file. I've downloaded it but how do I import it into efistudio?

I hope this isn't a dumb question but I've been a winderz user for a long time and have a very limited experience with anything else.

Thanks in advance!





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy