Jump to content

Gigabyte GA-G31M-S2L installation guide


  • Please log in to reply
28 replies to this topic

#1
zolookas

zolookas

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
Hello, G31M-S2L users, since i've bought this mobo, i've wanted to share my experience.

Currently the best DVD for this mobo is iDeneb v1 10.5.4, so use it.

Choose these options when installing:
Chipset->ICHx Fixed
Chipset->JMicronATA
Kernel->Kernel 9.4.0 Vanilla
Network->Ethernet->Realtek8111
Fix->ApplePS2Controller (if you need PS/2 keyboard and mouse support)
If you are using integrated GMA, do not select any video card driver, otherwise do not forget to select appropriate ATi or nVidia driver.

Fixing audio:
1. Install OSX.
2. Download alc662 codec dump from here: Attached File  alc662_s2l.txt   8.14KB   1417 downloads and AppleHDA patcher from here: Attached File  AppleHDAPatcher_v1.20.zip   981.35KB   842 downloads
3. Unzip AppleHDA patcher by double clicking it and drop alc662_s2l.txt file on AppleHDA patcher application (green frog icon).
4. After patcher does it job, press "Quit" button and restart your computer.

Known issues:
Integrated GMA 3100 works only in 1024x768 and without QE/CI. So you will probably want to buy ATi or nVidia card.
You can not control audio volume using volume control on the top system bar.

#2
paulicat

paulicat

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 241 posts
Do shutdown and reboot hang on yours??

#3
King Leper

King Leper

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 3 posts
I also have a GA-G31M-S2L, currently I'm running 10.5.5 vanilla kernel (updated from kalyway 10.5.2) I have an 8600GTS working through EFI. I also had the restart and shutdown issue, I have found that with the vanilla kernel S3 sleep will work, however if I load the latest acpiplatform.kext (available in the PS2 fix package attached to this post) then I am able to successfully restart though I can only S1 sleep (the sleep state is configurable in the BIOS). I also found this package which will install a script to disable your second CPU on shutdown, this should fix your shutdown issues. I also attached the best version of the sound driver I have been able to find, it still lacks front audio but the volume is adjustable (though mute is broken) and it claims to work with digital out though I haven't tested it. If I could just have front audio I'd be in hackintosh heaven.

Attached Files



#4
AlpineRaven

AlpineRaven

    InsanelyMac Protégé

  • Members
  • PipPip
  • 51 posts
So this logic board works well specially with -

SATA/IDE
LAN
Video
Reboot
Sleep
&
Shutdown

does all above work 100%? Please be honest.
Cheers & Thanks
AP

#5
Bungo

Bungo

    InsanelyMac Sage

  • Coders
  • 296 posts
  • Gender:Male
Using this and this guides I have succesfully installed Mac OS X from retail disc and updated to 10.5.4 with combo updater.
Everything (onboard audio not tested - xmod works) seems to work but dvd drive, it hangs up and not respond after few minutes with disk in it.
Could help me resolve that problem?

EDIT: links are working now

#6
AlpineRaven

AlpineRaven

    InsanelyMac Protégé

  • Members
  • PipPip
  • 51 posts

Using this and this guides I have succesfully installed Mac OS X from retail disc and updated to 10.5.4 with combo updater.
Everythings seems to work but dvd drive, it hangs up and not respond after few minutes with disk in it.
Could help me resolve that problem?


Both Links above doesn't work.. can you please paste again one more time?
Cheers
AP

#7
yozloy

yozloy

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts
I just brought a G31M-S2L Mobo, and a E5200 CPU, I only tried ideneb 1.3 10.5.5 on my Hackintosh.I'll share a little experiences of my installation

1. The Bios Must be the F3 version, in order to recognize the 2.5GHZ E5200, don't forget to set the optimize selection in the bios after upgrade the bios
2. In the customize software section, I choose all the kernel (sleep step and the SEE3 last one), this fix the sleep and reset shutdown problem,but when
it comes to sleep only mouse disappear?
3, like Zolookas said to select choose IChx, and the in ideneb 1.3 there is the ALC622 available in the audio selection, works perfect except no audio
input and no problem in the front audio slider
4. the onboard 3100 sucks, only 1024*768 and the refresh frequency is low, no QE!! I can't use DVD player and can't install final cut either.
5. About the time zone you must change to match other OS'time, for me, I'm in China, I move from +8 to+4
Still some question:

1.My Kingston DDR 667 is recognize as as 800MHZ by default, Do I need to change?

2.what's the best choice for Video card can get more bang out of the Buck

3.there 's RT8111 Ethernet selection in ideneb 1.3, how can I set it manually

4. what's the different between Vanilla kernel and others, it's a Mobo feature or Cpu feature,

#8
flavius99

flavius99

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 1 posts
This is my first foray into the brave new hackintosh world, and I was able to get an older Kalyway to work. Now I'm about to try out iDeneb v1.1 - any recommendations what graphics adapter I should get?

Performance is much less important than complete support.

#9
YuriPav

YuriPav

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
Hi Guys! I need some help with this board!!! Im running version F7 bios but after I install from the Ideneb v1.3 disk via a sata (which is succesful) and select restart I cant boot from the HDD. I just get "Disk boot failure, insert system disk and press enter" I assume its a bios setting issue? Ive seen a lot of posts for various mobos that say "enable AHCI" But this mobo doesnt appear to have that option! Could anyone please post their successful Bios settings as I cant seen to make it work ;)

#10
hwarfnugen

hwarfnugen

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
Has anyone been able to get sleep (S3) to work with this motherboard? After I try to wake the machine up from sleep it boots the computer like it was a cold boot. S1 works, but that leaves all the fans on. Other than that it's working perfectly.

I've tried iDeneb v1.3 and v1.4 with the vanilla and the Voodoo kernel. I have even tried different BIOS versions.

#11
mattrb

mattrb

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 318 posts
  • Location:Chicago, IL

Has anyone been able to get sleep (S3) to work with this motherboard? After I try to wake the machine up from sleep it boots the computer like it was a cold boot. S1 works, but that leaves all the fans on. Other than that it's working perfectly.

I've tried iDeneb v1.3 and v1.4 with the vanilla and the Voodoo kernel. I have even tried different BIOS versions.

yes, it works s3 on my buddies ga-g33m-s2l, which is the same as yours.

You need retail install though. Use munky EFI Partition, its great.

Look at the tutorials and you will find the way! If you have questions then PM me after reading the tutorials. The sound kexts for retail are in the legacy applehda tutorial thread (for your alc662)

Its really easy and all you need to do is either go to the apple store and get the disk or you can go download it from the piratebay.

#12
hwarfnugen

hwarfnugen

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts

yes, it works s3 on my buddies ga-g33m-s2l, which is the same as yours.

You need retail install though. Use munky EFI Partition, its great.

Look at the tutorials and you will find the way! If you have questions then PM me after reading the tutorials. The sound kexts for retail are in the legacy applehda tutorial thread (for your alc662)

Its really easy and all you need to do is either go to the apple store and get the disk or you can go download it from the piratebay.


I cannot say thanks enough. I used my retail 10.5 disc and everything is working correctly. I used Boot-132 and Munky's EFI.

Now my hackintosh can sleep at night. :)

#13
mattrb

mattrb

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 318 posts
  • Location:Chicago, IL

I cannot say thanks enough. I used my retail 10.5 disc and everything is working correctly. I used Boot-132 and Munky's EFI.

Now my hackintosh can sleep at night. ;)


Awesome man!

#14
korotkov

korotkov

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
Hi there!
I got the same mobo and want to install Native Leopard by boot-132 method
I did all like says
1 Boot the Boot132 CD
2 When I get to the Boot prompt, hit enter once.
3 Ejected the Boot132 CD.
4 Inserted (Gold Master ISO) MacOSX Leopard DVD 10.5.0
5 Hited Enter.
6 But on step 6, when installer start to loading, after 2-3 minutes of loading it shutting down..., with -v command it shutting down after message "cpu crash" or something, I couldn`t see all the messages before shutting down. I also tryed different versions of bios F3, F6, F10 i disabled all processor tweaks in bios, disabled ide, I also removed videocard, but it all the same.
I don`t know what to do else...:((((
Why does this happen?

#15
mattrb

mattrb

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 318 posts
  • Location:Chicago, IL

Hi there!
I got the same mobo and want to install Native Leopard by boot-132 method
I did all like says
1 Boot the Boot132 CD
2 When I get to the Boot prompt, hit enter once.
3 Ejected the Boot132 CD.
4 Inserted (Gold Master ISO) MacOSX Leopard DVD 10.5.0
5 Hited Enter.
6 But on step 6, when installer start to loading, after 2-3 minutes of loading it shutting down..., with -v command it shutting down after message "cpu crash" or something, I couldn`t see all the messages before shutting down. I also tryed different versions of bios F3, F6, F10 i disabled all processor tweaks in bios, disabled ide, I also removed videocard, but it all the same.
I don`t know what to do else... :rolleyes: (((
Why does this happen?


that boot-132 iso cd baloney is {censored}. Just get ipc, iatkos and install on drive #1. Then install install chameleon 2 on drive # 2 and either choose efi boot partition method in the installer or just the normal method where you put the kexts on the osx partition ( and not the efi partition). I like the first method, efi boot partion, you need to look at munky's tutorial to figure out how to install kexts, and the kexts are in a different place then on munky's guide, they are in the extra-->extension folder. Then just do

opeen /Volumes/name_of_105_disk/System/Installation/Packages/OSInstall.mpkg


Then point installer to your new drive # 2 and then you are DONE!


P.S. dont use that ipc or iatkos {censored} perminently because it is inferior to what I am offering you. Also make sure you make a dsdt with dsdtpatcher gui. That i will fix restart/shutdown issues.Wait, you signed up 3 years ago and this is your first post, FUNNY!

#16
Robbie MacKinnon

Robbie MacKinnon

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
It should work with Boot132 CD. Maybe your have not built your system correctly.
Did you just build it of have you run another OS on it before? Maybe you CPU fan in not installed correctly or something. Maybe take it apart on put it together again.

I found a very easy wat to get everything working on this motherboard.
Boot with Boot132 CD
Install Leopard retail
Once installed boot up leopard, download and install this:
http://######.com/osx86tools/
Then everything works (sound, video, restart etc) and it boots without needing boot132 CD :)

Hope this helps, but you will have to find the problem with your hardware first.

#17
Higor Vaz

Higor Vaz

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
  • Gender:Male
  • Interests:Cogumelos Mgicos, Programao Web, Musica, Mulheres heheheh
Hi all, Im using this mobo and tried to install IPC and Kalyway and cant get it to install "Waiting for boot volume".
A friend told me to set the HD to AHCI but I didnt found this option on the Bios config.
Any help Please.

#18
Robbie MacKinnon

Robbie MacKinnon

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts

Hi all, Im using this mobo and tried to install IPC and Kalyway and cant get it to install "Waiting for boot volume".
A friend told me to set the HD to AHCI but I didnt found this option on the Bios config.
Any help Please.


When do you see "Waiting for boot volume"? Exacly what stage do you receive the message?
Have you considered using this retail install guide:
http://www.insanelym...showtopic=76404

#19
Ed Vstr

Ed Vstr

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts

...
I found a very easy wat to get everything working on this motherboard.
Boot with Boot132 CD
Install Leopard retail
Once installed boot up leopard, download and install this:
http://######.com/osx86tools/
Then everything works (sound, video, restart etc) and it boots without needing boot132 CD :(
...


Robbie , What is your Hackintosh specs ? I am intending to build one with this same motherboard, it could be helpfull to know your specs, please. ;)

Thanks.

#20
LatinMcG

LatinMcG

    Insanely digesting DSDT

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 2,509 posts
  • Gender:Male
  • Location:Tampa, Florida
i use grub-dfe.iso to load retail. and loved it.. but had to give it back to its owner.. updates no problems.

sux to fix computers and have time to install osx then wipe it back to plain xp for customer! :P
im buildnig me a cheapo soon like this. $209 at compusa shhhh :) core2 duo 279 add dvd and 2nd hd and Nvidia... good to go.
(psu is junky 300w)





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy