Jump to content

ATI Radeon 9550 working/funcionando on 10.4.3


  • Please log in to reply
61 replies to this topic

#1
cuastermos

cuastermos

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts
Hello!
I have been able to make work ATI Radeon 9550 on 10.4.3. Here are the step that I have follow:

1.- Delete Extensions.mkext and Extensions.kextcache from /System/Library
2.- Edit ATIRadeon9700.kext :

Select ATIRadeon9700.kext
In the menu (right button of the mouse or CTRL+first button) select Show Package Contents, go to Contents and open with texteditor the file info.plist

Go to the line like this:
<string>0x4E441002 0x41441002 0x4E481002 0x41481002 0x41501002 0x4E501002 0x41521002 0x4E541002 0x4A481002 0x4A491002 0x4A4A1002 0x4A4B1002 0x4A4C1002 0x4A4D1002 0x4A4E1002 0x5B601002 0x5B621002 0x3E501002 0x4E561002 0x5B641002 0x3E541002</string>

Add 0x41531002.

3.- Save and close the file. If you can't save the file, while you have the texteditor open with modificated info.plist move to trash the info.plist of Contens folder. Obtain the information of Contents folder and change the permisions from system to "user" (your account name). Save now the file. Optionally change again the permisions of Contents and info.plist but now from "user" to system.

4.- Go to Disk Utility and Repair Disk permisions (for precaution).

Reboot! And good luck :dev:

PD: I think that this would be work with other ATI compatible cards.
This are recopiled information of other posts.
--------------

Hola! Aquí pongo lo mismo pero para los hispano hablantes.

He conseguido hacer funcionar la ATI Radeon 9550 en el 10.4.3. Aquí están los pasos que yo he seguido:

1.- Borra Extensions.mkext y Extensions.kextcache de /System/Library
2.- Edita ATIRadeon9700.kext :

Selecciona ATIRadeon9700.kext
En el menu (botón derecho del ratón o CTRL+botón primario) selecciona Mostrar Contenidos del paquete, ve a Contents y abre con el texteditor el archivo info.plist

Ve a una linea como esta:
<string>0x4E441002 0x41441002 0x4E481002 0x41481002 0x41501002 0x4E501002 0x41521002 0x4E541002 0x4A481002 0x4A491002 0x4A4A1002 0x4A4B1002 0x4A4C1002 0x4A4D1002 0x4A4E1002 0x5B601002 0x5B621002 0x3E501002 0x4E561002 0x5B641002 0x3E541002</string>

Añade 0x41531002.

3.- Salva y cierra el archivo. Si tu no puedes salvar el archivo, mientras tienes el texteditor abierto con el info.plist modificado, mueve a la papelera el info.plist de la carpeta Contents. Obtiene la información de la carpeta Contents y cambia los permisos de sistema a "usuario" (tu nombre de cuenta). Salva ahora el archivo. Opcionalmente cambia los permisos de Contents e info.plist pero ahora de "usuario" a sistema.

4.-Ve a la Utilidad de Discos y repara los permisos (por precaución).

Reinicia! Y buena suerte :D

PD: Pienso que esto puede funcionar con otras tarjetas compatibles ATI.
Esto es información recopilada de otros posts.

#2
ssutton

ssutton

    InsanelyMac Protégé

  • Members
  • Pip
  • 22 posts
English version: Yes, it works but mouse doesn't seem to be hardware accelerated! I think this is due to the lack os specific 9550 drivers.

spanish version: Que pasa neeeeeng!!!! Funciona bien pero parece ser que no acelera el dibujado del cursor en pantalla. Si averiguas como conseguirlo me harias un favor porque todo lo demas me funciona d.p.m !!!


Thanks /gracias.

#3
cuastermos

cuastermos

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts
Engish version: Yes very well manuel. Yes i have the same problem, and I'am currently investigating in that.

En versión española: Si, yo tengo el mismo problema, y estoy investigando en ello.
Si saco lo que es avisaré pero veremos a ver porque aquí hay tomate :dev:

#4
Tek_No

Tek_No

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 316 posts
Does this card support Quartz Extreme and Core Image?

Are you able to switch resolutions?

#5
ssutton

ssutton

    InsanelyMac Protégé

  • Members
  • Pip
  • 22 posts
It supports QE and CI after patching (editing) 9700.kext. Resolution switching on the fly is not supported. It must be changed in boot.pls file. I got mine running quicktime 7 with a 720i resolution movie and no frame drops, also 1080i is possible but not recomended (gets a bit choppy and drops lots of frames)

#6
FullMetal

FullMetal

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 177 posts
  • Gender:Male
  • Location:レゼンブール
I'm running 10.4.4 and was able to get my ATI Radeon 9550 up and running

Thanks for the guide!

#7
JJJJJ

JJJJJ

    InsanelyMac Protégé

  • Members
  • PipPip
  • 87 posts
English: Don't work for Ati Radeon 9200

Spanish (aspañolus :D): No tira ni pa Dios en la Ati Radeon 9200

#8
bilditup1

bilditup1

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 104 posts
  • Gender:Male
  • Location:New York
It's important to note that the Radeon 9550/9600 series doesn't play nice with AMD nForce3 chipsets. On my computer, without using QuartzDebug to disable QE, the whole system is brought to an absolute crawl. Just putting the word out.

#9
cuastermos

cuastermos

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts
JJJJJ where I put 0x41531002 you must change for 0x(your device ID)1002
You can see the device ID in system profile.
4153 is only for 9550

--------------

JJJJJ donde yo pongo 0x41531002 tu debes cambiarlo por 0x(tu ID de dispositivo)1002
Tu puedes ver el ID de dispositivo en perfil de sistema.
4153 es sólo para la 9550

#10
JJJJJ

JJJJJ

    InsanelyMac Protégé

  • Members
  • PipPip
  • 87 posts
ok, i'll try it

------------------------

tiene su logica :D lo probare :angry:

#11
ZildjianKX

ZildjianKX

    InsanelyMac Protégé

  • Members
  • PipPip
  • 53 posts
I wonder if this would work for the X300, since I've heard it is just the PCIe version of the 9550, which is in the iBook. I'll play with it now.

No go on the X300 mobile.

#12
miliuco

miliuco

    InsanelyMac Sage

  • Donators
  • 400 posts
  • Gender:Male
  • Location:Spain
Saludos, cuastermos, y gracias por la versión ES :)

Sitio de MILIUCO

#13
asapreta

asapreta

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 756 posts
Do you ment to have CI and QE when said it was working?

#14
Louis

Louis

    InsanelyMac Protégé

  • Members
  • Pip
  • 36 posts

English: Don't work for Ati Radeon 9200

Spanish (aspañolus :angel:): No tira ni pa Dios en la Ati Radeon 9200


Hi fellow ATI 9200 owners....(I have a Compaq X1000 laptop using 9200 mobility)
Using the information posted here, I checked a few .kext and the device ID for my ATI card is not listed in the 9700.kext of course (I tried adding it first, but no go) then I saw it (0x4c66) listed in the ATI8500.kext!!!....
So I guess that the 9200 is in the 8500 family line.... or something like that....
I didn't see this info anywhere else so I thought I'd share it....
You never know....

#15
Bearcat

Bearcat

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 431 posts
Just to make sure people don't confuse one card with another such as a PCIe version of another, there is a GPU data base over at techPowerUp which lists the chipsets in most of the video cards

It's at http://www.techpowerup.com/gpudb/

cheers

#16
cuastermos

cuastermos

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts
asapreta CI and QE is working too. The only bug is a mouse tearing.

#17
Louis

Louis

    InsanelyMac Protégé

  • Members
  • Pip
  • 36 posts
Buenos dias Cuastermos,

Check this out.....
http://forum.osx86pr...showtopic=10415
This guy got his X700 fully recognized and working, no tearing, etc, etc by adding device ID's in the binary part of the ATI 9700 driver.....
Looks like your in luck.....

#18
JJJJJ

JJJJJ

    InsanelyMac Protégé

  • Members
  • PipPip
  • 87 posts
English: From other forum:

Hey guys,

I discovered another tweak for MACOSX, very interesting stuff, especially
if you own an ATI card, and running on AGP. This is interesting, because
this hack enables Quartz for PCI, too. And most of our Cards are by now
detected as PCI Cards due lack of drivers. afaik. cmiiw.



Hack to Enable Quartz Extreme on Radeon "PCI" Cards


1. Open the terminal

2. type sudo -s to become root

3. type nano /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/CoreGraphics.framework/Versions/A/Resources/Configuration.plist

Here you'll find a section that needs changing for PCI card users (again still requires a Radeon card)

<key>GLCompositorRequiredClasses </key>
<array>
<string>IOAGPDevice </string>
</array>

Change IOAGPDevice to IOPCIDevice

OR (thats what I did)

Add a line that it looks like this

<key>GLCompositorRequiredClasses </key>
<array>
<string>IOAGPDevice </string>
<string>IOPCIDevice </string> </array>

4. Save the file.

5. Tell me the results

*lol* No don't worry, i checked it out for myself, I also added both lines
(IOAGPDevice and next line the same with IOPCIDevice) System rockstabile here.



Español: Lo he sacado de otro foro... da soporte parcial al quarzt al menos a mi ya no se me cuelgan el screensaver, aunque tampoco los muestra, algo es algo :whistle:

1.- Editar /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/CoreGraphics.framework/Versions/A/Resources/Configuration.plist

2.- Buscar:
<key>GLCompositorRequiredClasses </key>
<array>
<string>IOAGPDevice </string>
</array>

3.- Añadir:

<string>IOPCIDevice </string> </array>

4.- Guardar y reiniciar.

5.- Probar el salvapantallas, al menos, ahora no deberia daros error, aunque tampoco funcionaran.

#19
cuastermos

cuastermos

    InsanelyMac Protégé

  • Members
  • Pip
  • 25 posts
I have all working (like the guy that you have mentionated) except the mouse tearing. All following the steps that I've post here. For others cards it is necessary to look for a compatible device for apply the patch. It's simple, it's to make belive osx that your device is another of the same series that it supports.

#20
regularg0nz0

regularg0nz0

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts
  • Location:Minneapolis, MN, USA
  • Interests:Stuff.<br /><br /><br />Oh! And things!
I used to use a little freeware program called PCI Extreme to do the hack that JJJJJ posted when I was running a Radeon 7000 PCI on a G4-upgraded B&W.

The link is here:
http://www.versiontr...fo/macosx/16006

I'm not sure, but this might work on OSX86...

Heh... I'm surprised I didn't think of this before.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2017 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy