Jump to content

P5k bios 406 (ahci) Q6600 - unknown CPU ?


11 posts in this topic

Recommended Posts

Hi everybody !

I upgraded my MB to Asus P5K and discovered that i had no AHCI on the latest bioses, therefore i downgraded to the last bios i found out that had AHCI selection on - v 0406. But ofcourse there is a catch... at boot, it says : unknown cpu detected ( i have a Q6600), must update to latest bios in order to unleash its power.. Anyway both leo/win work flawlessly, so my question is, how bad is it if i don't update (in order to keep the ich9 ahci), is there any danger to the hardware ? ( i don't plan on overclocking anyway). Second question, if anybody knows, is there any other way to enable the ahci other than downgrading to 406/less ? I don't care much about the jmicron controller onboard as it slows down my pc alot.

Thanks in advance for you response.

Link to comment
Share on other sites

Two solutions : upgrade to latest bios and use IDE Enhanced and not AHCI.


If you really wanna use AHCI for whatever reason, just upgrade your P5K with the P5KR bios (yep, it works :D).

Thanks for your swift answers, cyclonefr, could you tell me if there is a custom p5kr bios version i need to find, or latest stable 403/beta 605 should do?(i see the hardware difference with this board is p5kr also has raid on ich9 and a gigabit lan controller)

Also is this stable ( i know you have quite some experience with this board), any problems that might occur. I wanna keep AHCI not because some abstract description of this function but because i actuallly noticed some emprooved responsiveness of winxp and leo programs.

Link to comment
Share on other sites

Used afudos ver 2.11 and renamed bios to p5kr0605.rom (edit:btw 703 works too). Booted with a msdos formated usb(by the way from all the files you need to delete to make space don't delete command.sys) then did a
afudos /n /ip5kr0605.rom
(the i is not a typing mistake, forces the rewrite, without /n confirms bios does not match mb). Anyway i just wanna tell you it worked for me too. I sweated a bit when it wouldn't restart on ctrl alt del in dos, but forced restart, set up ahci in enhanced config, and that was it! (don't be scared if it does not detect drives at first, enter setup and change the sata config either to enhanced-ahci or compatible-ide). Thanks for the help !

Results - rock stable at the time of the edit (5 months difference)
-sata config - enhanced - IDE - does not detect any drives; AHCI - fully working (speeds up the loading process, general gui response improoved) on win/leo; Raid - never bothered to check (shouldn't work as the chipset is actually ich9 not the ich9r on p5kr); IDE works if sata config is set to Compatible - IDE (useful for win install, then update to ahci);
-need to install drivers for the p5kr now, some of the p5k drivers are needed ( realtek ), but utils don't. In Windoze AI Suite needs to be p5kr, reports temps lower (i might be wrong) than the bios(35 - vss 43 on bios); AI nap has some errors (mostly works). Also it is my impression that the coolers run at slightly higher speed (can't check that, seems to be a little louder).
-boot is way more beautiful, if you disable jmicron on bios, steps directly from asus picture to os bootloader, no msgs whatsoever;
-stable config, no problems of any kind.
-EDIT 9.08.2009: pain in the ass to install Windows 7 RTM - installs very slowly, then loops in a error reboot

Edit 2013: This wonderful fellow edited the bios, so you just have to reboot with a fat32 flash containing the rom and use the onboard ez flash to update


And here is a install guide for ML, again from our friends http://hackintosh-forum.de/index.php?page=Thread&threadID=5054

Link to comment
Share on other sites

  • 1 year later...
  • 9 months later...

Windows 7 Enterprise Edition 11 posts

Cannot install Windows 7 I just completed my first computer build, using a ASUS P5N-D motherboard. There is one SATA hard drive and a SATA DVD. When I booted from the Windows 7 Enterprise DVD, it loaded the got the background screen. It didn't load the first installation step. I ran the DVD in another machine, and it got to the screen, so the DVD should be tiffany



Don't know where to go from here. In looking over other threads, I thought the problem may be that the AHCI for the SATA components was not set correctly. I couldn't find that in the BIOS.


As noted, this is my first build, and am wondering if I need to something before the motherboard tiffanys came with a Chipset Support DVD. It is not a bootable DVD, and the BIOS goes to the various RAID setup options.

Link to comment
Share on other sites


  • Create New...