Jump to content

Forced to use CPUS=1 OR Hacked Kernal to Boot WHY?


11 posts in this topic

Recommended Posts

Install method: IAtkos 1.0r3 EqUaTe disc with PC_EFI

Drivers selected: Intel x3100 graphics driver, Netkas patched SMBIos



Forced to use CPUS=1 to boot, even with reg bootloader (none PC_EFI). I'm not sure why this keeps happening? May be related to x3100 graphics BUT HOW? Can someone help me figure out what I need to do to get this to work? Please see below for details on my setup.



System specs are:


Lenovo 3000 N200 Notebook

Product Model 0769AVU

Processor Intel Core Duo T2330 1.6GHz on Intel 965 Express

Bus Speed 533MHz

Cache 1MB L2

Memory: 1GB DDR2-667/PC2-5300

Maximum Memory 4GB

5-1 Card Reader Richo

Hard Drive 120GB Serial ATA 5400 rpm

Optical Drive DVD-Writer - DVD-RAM/-R/-RW (Matsumi)

Display Screen 15.4" WXGA Widescreen Active Matrix TFT Color LCD with VibrantView

Graphics Controller Intel GMA X3100 128MB DDR2 SDRAM Shared PCI Express

Display Resolution 1280 x 800 (Internal) / 2048 x 1536 (External)

Network & Communication:

Network Broadcom 10/100/1000Mbps Gigabit Ethernet IEEE 802.3ab Integrated

Lenovo 54Mbps Wi-Fi IEEE 802.11b/g Mini PCI Express **AKA broadcom I looked it up**

Modem 56Kbps V.92 Data/Fax Modem Integrated

Expansion Slots 1 x ExpressCard/54

Pointing Device TouchPad synamtics


Ports 4 x 4-pin Type A USB 2.0 - USB

1 x mini-DIN S-Video Out

1 x RJ-11 Modem

1 x RJ-45 Network

1 x 4-pin IEEE 1394 - FireWire

1 x Mini-phone Microphone/Audio In

1 x Mini-phone Stereo Audio Out

1 x VGA

Operating System Windows Vista Home Premium


Built-in Devices:


Security Features:

Security Slot

Hard disk drive password

Fingerprint reader



Link to comment
Share on other sites

  • 2 weeks later...

It appears I have to use a hacked kernal to get both cores. At least that solves my issue though. Almost got the whole system figured out. If anyone has an idea of how I could use the vanilla kernal with my system I'm open to experimenting.



Also Having trouble with getting this system to boot from a USB HD. Flagging the USB HD active with fdisk has not worked. I also know the the Darwin boot loader is setup correctly. I believe the USB to IDE adaptor I'm using is not compatible at least to boot from. I plan to try another one on my next install.

Link to comment
Share on other sites

CCG Thanks for the replie. Still no luck with that bootefi fix. Its doing everything that I_am me's script does but writtin a lil better I think. It also marks the partitions active which I have always done manually. So that is good to see also. Something is strange here I am going to try none efi now with bootefi and see what that does.


If anyone has a clue what else I can try PLEASE post. This system is very simular to the Compaq c700 except it does not respond like a c700 at all. So I'm running out of ideas FAST.





Link to comment
Share on other sites

Which version of EFI are you using? Had the same blinking cursor with EFI v8 for weeks. Nothing fixed the boot problem. The blinking cursor boot problem was fixed by using EFI v7.3. Boots everytime without the DVD in the drive. Something with my Dell Optiplex 755 and EFI v8.


Strange but tested

1) Boot the DVD installer, open terminal and install EFI 7.3, reboot and boot to the desktop

2) Boot the DVD installer, open terminal and install EFI v8, reboot and blinking cursor

3) Boot the DVD installer, open terminal and install EFI 7.3, reboot and boot to the desktop


Steps that I used to install Leopard

1) Boot the DVD (iatkos or Kalway)

2) Open Disk Utility and create (I used GUID) and name the partition (Leopard)

3) Open Terminal and install EFI v7.3. Use the EFI steps below (gathered from numerous others on this forum)

3a) Type in "diskutil list" and locate your Leopard drive (my setup was disk0 and disk0s2)

3b) diskutil unmountDisk /dev/disk0

3c) cd Volumes/PATCHER/efi/pc_efi_v73. PATCHER was my USB drive

3d) ./startupfiletool /dev/rdisk0s2 ./boot_v7_guid_only

3e) dd if=./guid/boot1h of=/dev/rdisk0s2 bs=512 count=1

3f) diskutil unmountDisk disk0

3g) dd if=./guid/boot0 of=/dev/disk0 bs=400 count=1

3h) ./bless -mount "/Volumes/Leopard" -setBoot -verbose

4) Install Leopard

5) Remove the DVD and you should see the OSX bootloader. Press F8 and enter -v so you can watch for errors


If you still get the blinking cursor

6) Boot the DVD (iatkos or Kalway)

7) Open Terminal and reinstall EFI v7.3

7a) Type in "diskutil list" and locate your Leopard drive (my setup was disk0 and disk0s2)

7b) diskutil unmountDisk /dev/disk0

7c) cd Volumes/PATCHER/efi/pc_efi_v73. PATCHER was my USB drive

7d) ./startupfiletool /dev/rdisk0s2 ./boot_v7_guid_only

7e) dd if=./guid/boot1h of=/dev/rdisk0s2 bs=512 count=1

7f) diskutil unmountDisk disk0

7g) dd if=./guid/boot0 of=/dev/disk0 bs=400 count=1

7h) ./bless -mount "/Volumes/Leopard" -setBoot -verbose

8) Type in "reboot"

9) Remove the DVD and you should see the OSX bootloader. Press F8 and enter -v so you can watch for errors


My first post but I want to thank all who have been down the road before me and shared their headaches and for those who will follow in our footsteps.

Link to comment
Share on other sites

Simple Simon WELCOME to insanelymac. Thanks for the help. Although it was not what helped me I appreciate it.


Here is what worked.


1st I was installing on a USB HD which it turns out OSX has issues with the USB to IDE controller I was using. But I have 3 so no biggie I switched to another one. I finally got a Darwin bootloader and then everything started but then BAM right back to the bios and no boot. So I tried -v -x with no luck. Then I started searching for other darwin commands and all I could find was cpus=1 so I tried it and BAM into OSX I got.


Working Items are these: Broadcom WIFI detected as third part works, Broadcom Bluetooth Works, Firewire Works, USB Works, x3100 Graphics FULL CI/QE, DVD+RW DL works, Keyboard & PS2 Mouse work, Special Sound buttons Work for sound, Video out not tested, battery icon shows.


None working parts are Realtek ALC262 Sound, and Richo 5-1 card reader, finger print reader (although it shows in about this mac AMAZING), express card slot, 10/100 Broadcom Ethernet not working.


Partially working things are these. Also what I hope someone here can help me with.


1. CPU is a Core Duo 1.6 T2330 but I have to type CPUS=1 which is SOOO strange. Can anyone suggest a fix for this? I have installed Vanilla kernal because I have a Dual Core CPU so why the CPUS=1 does not make sense. Will I have to use a different kernal. What if I get a real Core 2 Duo will that change anything? This laptop will support a real core 2 Duo and I may get one.


2. Sonix SN9C201 camera. Partially working because photobooth turns it on but will not show a picture. All I get is a black screen. However the WebCam Monitor that you get with the SN9C201 driver uses the camera just fine but just displays what it sees no picture taking ability.


3. Sound is strange its a Intel High Def Audio (AKA Realtek High Def ALC262 ID# 17AA384E) and seems to load up but I hear NOTHING. I can turn it up and down and mute it and plug in headphones but I hear NOTHING.


The most important thing to me is getting both cores. I hope someone has an answer or suggestion for me.



Link to comment
Share on other sites

Turns out this problem is directly related to the vanilla kernal. Without it I can boot normally. Otherwise I must use CPUS=1, unlike our Dell Friends I believe.



Is there an possibility for getting both cores with the vanilla kernal? I get an instant reboot so there must be something I can do. How can I see the error I'm getting if I get the instant reboot?





Link to comment
Share on other sites

Ok I have come to the conclusion that my BIOS sucks and I will never be able to run vanilla kernal without cpus=1. But at least it does boot that way so i dont have to fear updates.


I am about to add my laptop to the HCL 10.5.2 as I am almost 100%.


Install procedure is as follows for this model.


IAtkos 1.0r3 EqUaTe disc.


Selecting the following items:


EFI bootloader install but no vanilla kernal and no ACPI vanilla. This will install uphucks kernals and patched ACPI kext


Intel x3100 graphics kext


Netkas patched SMBIOS kext


Speedstep addon by uphuck


Extra Items selected: menu meters




Once installed boot up and install 10.5.2 combo update by kalyway


Then install newest power mgmt bundle 137 by jaro12345 Here: http://forum.insanelymac.com/index.php?showtopic=80425


Then install netkas 9.2.0 speedstep kernal found here packaged by macaroo VERY NICE: http://www.mediafire.com/?bmcos0yqdyl


You could also install netkas newest SMBIOS for better detection under "about this mac" but I had no real problems there.


Once you reboot system is almost 100% working. Except for sound. I will update this later when I figure that out.

Link to comment
Share on other sites

i am installing on a friend pc, leopard terminal doesn't recognised my usb stick, but shows up in disk utilities. strange i couldn't install efi and that is the only thing left for it work.

Link to comment
Share on other sites

ricki do you have the same model 0769AVU?


Some USB to IDE/SATA have issues with booting. Not sure why? Controller clash/conflict I call it. I have had the same issues on various laptops/desktops on windows and makes sense it would affect OSX also since it is a hardware issue.

Link to comment
Share on other sites


  • Create New...