Jump to content

Keyboard and Trackpad fix "AFTER" 5.2 update?


67 posts in this topic

Recommended Posts

Aldos - what version of Leopard are you using? iAtkos or Kalyway?

I am using iAtkos and I cannot seem to get my PS2 keyboard working in any way.


If I delete and replace AppleACPIPlatform.kext I get a kernel panic and if I replace the other kexts with yours my keyboard still doesn't work.



I'm a little bit angry with this 'cause it keeps messing my brains.


My mouse is on USB and they keyboard on PS2.


Any ideeas???

Link to comment
Share on other sites

I wasnt installing the power management bundle right but I've done that now, though I have hit a new problem my trackpad has become unusable the mouse jumps all over the place clicking on random things, the keyboards fine. I have to connect a usb mouse to use it, any idea's what might cause this?

Link to comment
Share on other sites

I'm just replace ApplePS2Nub.kext and nothing else. And it works. With some warnings... *About this Mac* working too. SystemProfiler seems to be buggy.


bash-3.2# kextstat |grep ACPI |awk '{print $6,$7}'

com.apple.iokit.IOACPIFamily (1.2.0)

com.apple.driver.AppleACPIPlatform (1.2.1)

com.apple.driver.AppleACPIButtons (1.2.1)

com.apple.driver.AppleACPIPCI (1.2.1)

com.apple.driver.AppleACPIEC (1.2.1)

org.tgwbd.driver.ACPIPS2Nub (1.0.0d1)

com.apple.driver.ACPI_SMC_PlatformPlugin (3.1.2d1)

com.apple.driver.AppleACPIPowerSource (1.0.5)

Link to comment
Share on other sites

Aldos's package worked for me too, thx so much! And replaced the ACPIPS2.kext with the 80kb one from meisterk's link, also modified the Info.plist as Aldos suggestted. Now PS2 keyboard, Battery meter and bluetooth all works.

Link to comment
Share on other sites

I fixed it! I had to use my old Tiger install's ApplePS2Controller.kext (that kext was grabbed from this forum), and my PS/2 keyboard worked!For those still having problems, feel free to try my fix:http://rapidshare.com/files/91256196/Apple...r.kext.zip.html
Thanks for the link :wacko: Will give it a try when I go to reinstall!
finaly !keyboard - OKBattery metter - OKIt seems that until now all is workingI've made a pack with all files i usedhttp://rapidshare.com/files/91282272/PS2_Batt_Working.zip
Also will try this one, and hope one of them work for me, Big Thanks :)
Link to comment
Share on other sites

  • 3 weeks later...

Hello All;


I havent tried Aldos Kext files yet but im using a laptop PS2 ports are Ok when updating the original upgrade im using iATKOS v1.0i but my laptop Keyboard and Touch pad is dead.


I have done replacing the ACPI.kext from my 10.5.1 but will encounter KP


When upgrading using Kallyways Upgrade Keybaord and Touchpad is Ok but it i think might have mess up my video using NVinject Go it will take about 3min just to boot up the system not like on the original upgrade but no keyboard and touchpad as i said.


Any idea if what are the kext for keyboard and touchpad so may may just transfer the on from Kallyways.



Link to comment
Share on other sites

  • 3 weeks later...



Thanks to the guy who uploaded the ZIP with the .kext files!


I tried to replace it in the folder but that didn't work...


The only way to get this fixed (for me) was using KalyWay's KEXT helper B7 and install the 5 kext from the zip that way...


Thanx thanx thanx!!


If anyone know's how to get an Nvidia 8400M GT worked.., plz let me know;)


Grtz, Junior

Link to comment
Share on other sites

I wanted to add my results.


When I upgraded from 10.5.1 (Kally vanilla kernel) to 10.5.2 my PS2 keyboard and mouse stopped working. Since I am on a desktop, I was able to use a USB keyboard and mouse to get working BUT when I did, USB external disk drives were not recognized and everything seemed really slow and choppy.


I used the kexts provided by Aldos and was able to get the PS2 keyboard and mouse working again. The USB drive and choppyness is not present when PS2 is used.


Thanks a lot Aldos

Link to comment
Share on other sites

rebootF8 during restart and type : -v -f for forcing all kext to be loaded and for verbose mode


Hey, Aldos first I would like to thank you for creating this great package which solved my problems perfectly! However I have a question: do I always have to boot with an -f option from now on, because if I don't keyboard and trackpad stop working once again. Or is there any other solution to the problem? I am running Leo4All 10.5.2 Vanilla on a dell xps m1530. Thanks in advance! :)

Link to comment
Share on other sites

Maybe this is still of interest:


if somebody just installed the update

pls make the following test:


keep the existing AppleACPIPlatform.kext (10.5.2 update not change that file, so is the old one that worked in 10.5.1)

but delete in it the ACPIPS2Nub.kext and use the one from my archive.

the PS2 should work


i did just that on my HP Compaq nx7400 and now the Keyboard and the Trackpad are working again.

Link to comment
Share on other sites

Yeah I have the same problem. Where I always have to use -F to boot or I will lose keyboard/mouse


I am running Leo4All 10.5.2 also. Maybe that is the problem?


I am not sure but I guess so, since we're the only ones. ;) In the official site of Leo there is a fix that is supposed to fix this is issue, but it never worked for me. A am tired of booting with -f. Here is the link: http://osx86leo4all.wikidot.com/known-issues scroll to the end of the page an you'll see it. Please tell me if it has worked for you, when you try it. Did you install Leo with Vanilla kernel too?

Link to comment
Share on other sites

Yeah sure did, vanilla 9.2.2


Got it to work without the -F.


Try this go to Leo4All wiki and under known issues there is a PS2Fix.zip patch. I first tried installing the patch for "Unmodified" Kernal and that killed my trackpad/keyboard even with the -F. So I tried it again and installed it for Modified Kernal and presto worked like a charm.


Ok another update. I did a format/reinstall (was just messing with way to much stuff and wanted to start over). You also need to delete the ApplePS2APCI (or however it is organized).

Link to comment
Share on other sites

  • 4 weeks later...
  • 1 month later...

// Edit:

When I boot with -f, Leopard works normally, but without support for my keyboard. It said: "cant't load driver ApplePs2[...]" etc.


It doesn't works. I used Aldos PS2_Batt_Working-Pack. I have replaced all files in this pack in /System/Library/Extensions and the PowerManagement.bundle copied to the /System/Library/SystemConfiguration folder. Then I have repaired permissions. After reboot, all I got is kernel panic. :(


Here's the Message:




hi mem tramps at 0xffe00000

PAE enabled

Darwin Kernel Version 9.2.0: [...]

Local APIC version not 0x14 as expected

panic(cpu 0 caller 0x00430CE1): "Unable to find driver for this plattofrm: \"ACPI\".\n"@/SourceCache/xnu/xnu-1228.3.13/iokit/Kernel/IOPlatformExpert.cpp:1407

Debugger called: <panic>

Backtrace, Format - Frame : Return Adress (4 potential args on stack)


Backtrace terminated-invalid frame pointer 0


BSD process name corresponding to current thread: Unknown


Mac OS version:

Not yet set


Kernel version:

Darwin Kernel Version 9.2.0"



How can i fix that, and how can I get my PS/2 Keyboard working without destroing my system (again)? Do I have to reinstall Leopard?

Link to comment
Share on other sites


  • Create New...