Jump to content

Anyone got Leopard working on Dell D620?


5 posts in this topic

Recommended Posts

I'm having troubles with Leopard on this Dell D620. Have tried formatting the whole disk, and using Acronis. 10.4.x is fine, 10.5 goes thru the installation fine but then doesnt boot.


If anyone has it working on a D620 could you let me know - and what Distro you've used please?


And if you're dual booting.


I really want Leopards installed and am happy to dedicate the drive. Just not 100% sure about EFI stuff and, well, it just doesnt seem to like this laptop. Saying that, I could only get it to work on my PC briefly - but that's got an old P4 Northwood processor...


The D620 has an Intel core Duo. On board Intel Graphics. (GMA945 I think.)


Thanks in advance.

Link to comment
Share on other sites

  • 5 weeks later...

Since then i have successfully upgraded with the Kalyway combo update to 10.5.2 and have also been able to get my sound to work thanks to Taruga's applehdapatcher. I will attach my modified codec dump to the bottom of this. I have the Stac9200 it works except for mute button and the speakers do not mute when you plug in headphones. Still no luck on the ethernet (Netextreme BCM5752) or the wireless (Intel Pro/wireless 3945 ABG). I have tried using a PCMCIA wireless card as well and have found out that the PCMCIA slot does not work as well. If anyone has any solutions for this assistance would be greatly appreciated.



Link to comment
Share on other sites

Running 10.5.2 on D620. Initially installed 10.5.0 through Brazilmac method

MBR Partitoin table

Dual boot with XP


Intel GMA950 with QE+CI

HDA Audio working with AppleHDA Patcher and Sigmatel9200 codec dump (no mute or headphone detection)

No Driver for Built in Gigabit ethernet yet :D

Luckily have Dell Wireless (Broadcom based) which works fine without any modifications. Intel Centrino wireless does not work

No Sleep (Vanilla Kernel)

AppleSMBios from mac.nub, so shows up as a real mac in system profiler

One core disabled with cpus=1 in com.apple.Boot.plist

Link to comment
Share on other sites

  • 3 months later...

got 10.5.1 running on my Dell D620 no sounds, no wireless, no ethernet, when it goes to sleep doesnt wake up


Intel® PRO/Wireless 3945<--- no luck finding the kext :P(




upgraded to 10.5.2


no luck on 10.5.3 any guide on this one??

Link to comment
Share on other sites


  • Create New...