Jump to content

[Guide] Dell Precision m4300


28 posts in this topic

Recommended Posts

My first try to make a small guide about the business notebook: Precision m4300 become a hackintosh.


My Configuration

W12M42 - M4300 ADVANCED December

CPU: Core 2 Duo T7500 (2.2GHz,4MB)

Graphics Card: Quadro FX 360M (based on 8400M GS ?)

15.4" WUXGA (1920x1200) LCD Screen

Lan Broadcom 5752

Audio Card: Sigmatel 9205

PalmRest with Fingerprint Reader

2048 MB 667 MHz DDR2 SDRAM

160GB (7,200rpm) SATA Hard Drive


Wireless Dell 1505 (Broadcom BCM4328)



Onboard Devices



- Multicore -> enabled

- Dynamic Acceleration -> enabled

- Speed Step -> enabled


- CPU XD Support -> enabled

- Fingerprint -> activate



POST Behavier

- Virtualization -> enabled




I used the iAtkos 1.0i DVD to install Leopard 10.5.1.

Format the HDD with MBR and select only the main 10.5.1 Bundle, not the EFI stuff.

After reboot I download the Nvidia 10.5.2 Beta + NVinject Bundle and remove NVinject from Extensions Folder

Download the NVinjectGO 0.2 and move it to Extensions Folder and repair Permissions.

After that I download the AppleHDAPatcher 1.2.0 and the Sigmatel 9205 Codec from this board

After reboot replace the AppleHDA.kext from Sigmatel 9205 thread to the AppleHDA.kext in my Extensions Folder and reboot again.

Than start the AppleHDApatcher again with the same codec and reboot the last time.

Now I have sound working with internal speakers and headphones also an unknown mic device is detected.

With NVinjectGO i have now WUXGA resolution on a 15,4" LCD with QE/CI support and Dual Monitor Mode (not testet)

Battery Meter is working with iAtkos installation. (about 3-4 hours with 9 Cell Accu)

Fingerprint working with upek protector suite for leopard.


Xbench gives me a very low result: ~ 40 149.65 Points 176.48

without graphictest and hdd: ~ 93 Points


Something is not working very well, so the graphic performance is very low and also I think the CPU is not working with his full performance.

The performance is now much better after I found out how the internal powermanagement is working. You can use the full power of this notebook if you do the followed things: Plug the power supply in, boot your system, go to energy settings and set your display hibernate to 1 minute.. wait 1 minute or so long as the display goes off. after this you can make xbench test and paste your results in this thread.


Sleep is not working and shutdown also.

ExpressCard is working but nor the PC-Card (error in console, but not test, cause i have no card)

Also i think bonjour is not working, cause i can see only smb shares, not the apple file shares. but i can connect directly to afp shares


Hope I could help somebody.


please post your experience with this notebook


ps.: can somebody helps me find the right kernel for dell's speed stepping?





Link to comment
Share on other sites

Hello cyonix!


I got the same hardware and I finally found your thread!! I am very happy because I was trying to install iAtkos for 10 days, and everytime I installed it, I just boot on the partition I saw the Apple screen and then a kernel panic.... :P

Thanks for your guide a lot.


Can you just explain better for the customization of graphics, sounds drivers such as where to find theses ones?? It would be very very kind and helpful.



French hackintoshman ;)

Link to comment
Share on other sites

Great guide Cyonix! Glad to see you have your system going, I have a Dell Latitude D820 with similar specs. I've been trying to enable both cores with no success, I have heard some dell laptop users have success doing this by going to sleep and waking up but not by simply turning the the display off. Sleep does not work over here as it goes to sleep fine but returns with a blinking cursor on a black screen. Thanks for the tip to get both cores going, will definitely have to try it!

Link to comment
Share on other sites

hi cyonix,


Yes, my dell m4300 is working under iatkos properly, I managed to have display in 1920*1200 high resolution and sounds is working only output and not mute buttons.

I did not manage to make the wireless working. So the only thing that I need to work is the ethernet card (Lan Broadcom 5752). I installed some kext file with my ID the the plist file. The card appears to work, but whenever I plug a cable there is no network. I also forced to put the correct MAC address but it is always saying that the network is down. Can you help?



Link to comment
Share on other sites

Question about this because I'm thinking of getting an M4300. You say that the internal microphone doesn't work.

What about the line in jack? I'd like to be able to record in GarageBand. Is the soundcard likely to recognize a USB MIDI keyboard when plugged in? Also, this guide mentions IATKOS 1i, what about r2? Has anyone tried Kalyway, or the 10.5 distributions (ToH, BrasilMac, etc.)?

Link to comment
Share on other sites

  • 2 weeks later...
  • 4 weeks later...

Hello cyonix,


since I have also a M4300 I would like to use your post to add hopefully valueable information regarding that laptop.


I installed iAtkos_v1r2.iso on it. During the installation I did format the drive as MBR and I did not select any drivers.

The installation went fine and I installed Kalyway 10.5.2 update afterwards. After that I upgraded the kernel to "universal kernel 9.2.0" so performance is back :D

CPU shows a lot of features. Speed step is working, at least what I get told from the monitoring tool. xBench test not yet done, but will come.



Usind HDA patcher 1.20 for STAC9205 sound as described in the forum (patch, reload system, copy HDA again back into Extensions worked for me)

Mic does not work, speakers are fine, headset not yet tested.



Broadcom 57XX 14e4/1673 is working after a huge effort. I installed the AppleBCM57XXEthernetEH.kext into Extensions.

Patching the driver and disabling the NVRAM check with HEX editor. Editing 1673 into the info.plist.

Only restriction: Manually set IP, MAC always 000000000 but it works. In case card doesnt start up I use "ifconfig en0 up".



Installing NVidiav33.pkg with no kext selected. After that I installed manually the NVInjectGO.kext (nvinject.free.fr). Now the props of the card are correct.

Full resolution @ 32bit.


Bootloader installation:

I used the startuptool to create a bootloader on the leo partition. It was the only way to get it right. All other hints didnt work for me.

Boot from iAtkos DVD, run commands a.s.o.. Thread is somewhere in here :(


Almost forgot: Bootup time from "beep" till desktop shows up --> 18sec




Link to comment
Share on other sites

  • 2 weeks later...

houli: nice that u have managed the broadcom lan adapter working... can u explain the steps?


my xbench score is 146 but i must have power supply pluged.. i'm on 10.5.1.. i'll try kalyways updater in the next days and post my experience.. have u tried guid format and efi?

Link to comment
Share on other sites

good news for all m4300 user!!!


after installing kalyways 10.5.2 installer and downloading the shutdownfixed kernel from #10.5.2 channel from irc, I managed to use speedstep with ACPICPUThrottle.kext and Speedstep.app. Now I can run full power on battery with xbenchresult of: 146 points



the better news is, that after the leopard graphiccard update I get 176!!! points, so I'm now faster than a macbookpro :P



sleep and lanadapter dont work as before

Link to comment
Share on other sites

  • 1 month later...

Hi guys, I am new to the osx86 seen so bare with me here, i set my hdd up to 1 partition named untitled, and set it as a mbr.

I only selected the main package to install and the install went fine. However when i reboot i just get a blinking cursor, i have tried flagging the partition and still no luck


Just wondered if you could let me know what you guys did to get it to work





p.s if i leave cd in i can boot into osx.

Link to comment
Share on other sites

  • 1 month later...

Dear friends,


Thanks to cyonix's guide, I'm writing this from my new hackintosh Dell M4300 T8300, 2RAM, Nvidia fx360m, without fingerprint.


I installed the new iAtkos 2.0 BS release, downloaded by a famouse torrent site and followed the install instructions: at the custumizing, I tryied to add many stuff like ntfs-3G (tool for read/write ntfs partition), nvidia drivers, broadcom...


After installation the system just started like original!!! (without removing anything, with the default kernel)


The shut down and the reboot were working!!!! (now i did something and it's not working)


The wireless Dell 1505 i working properly and its recognized as "Third Party Wireless Card".


The Sigmatel also started after following your instructions, but with less reboots: patching>reboot>replace kext>reboot and done.


The ntfs-3g is working fine by default after this installation.


For now, I don't know how to start the nVidia to work all the time properly, without all the time switching power to 1 minute... I wonder what will happen if I try Kalyway Update on this iAtkos2.0 release... Actually I didn't understood how to do all this steps with the update ("downloading the shutdownfixed kernel from #10.5.2 channel from irc, I managed to use speedstep with ACPICPUThrottle.kext and Speedstep.app.") If it's possible could you be so kind to explain a little bit more like for a newbees...


The Broadcom tweak also sounds interesting... It sounds too hard for me...


Tonight I'll try to install a PCI Realtec Lan card switched in my Dell D/Docking station (with a PCI port).


Thank you so much for the guides and advices!

Link to comment
Share on other sites

  • 1 month later...

Hey cyonix,


Thanks for the guide. I'm new to osx86 and this forum, but when I finally forced myself not to devaite from the steps you set out, I got everything (pretty much) going on my m4300.


I selected Speedstep under Customize when installing, and it works fine for me. I also have to select the CPUPowerManagement option for it to load OS X properly without the install disk.


I'm downloading the kalyway_10.5.3_ComboUpdate right now. Have you given this update a try yet?


Also, have you had any luck getting the mic and speaker jacks to work - or to have the lan picked up properly on startup?


Anyway - spent alot of time going over this guide in the last couple of days and wanted to thank you for putting it out there.

Link to comment
Share on other sites



I am writing this to inform all Dell PRECISION M4300 owners


I have installed The IATKOS v.2 and updated with kalyway_combo_update_10.5.3 and everything works fine i mean the update works very well but you have to fallow the instruction.


Then i just update again with real apple update to 10.5.4 it seams real stable no problem just let you all know about it :)


but i still have problem with wireless sound and the c.d.-dvd driver

Link to comment
Share on other sites

  • 3 months later...

OK, finally i got almost everything working, here's my story:


Installed iAtkos 2.0 cleanly (no customization), this was the only distribution that booted at all (tried many many).

Updated to 10.5.5 with a combination of Mysticus C's Combo Patches 1.1.5 and the safe update option in sonotone's Dell Laptops Post-installer 1.3.1. Either one works by it self but not all drivers in the Post-installer worked for me however the Combo Patches drivers did.


Before updating i had to fix the graphics and the keyboard/trackpad as they will be non functional afterwards. The NVIDIA Quadro FX360M works well with Nvinject latest drivers (also included in both Combo Patches and the Post-installer), and to get around the common keyboard/trackpad problems on laptops i used AppleACPIPS2Nub.kext that i found over at uphuck forums.


Afterwards i used the Lid sleep driver and Speedstep enabler from the Post-installer.

And ICHx-AHCI, MacBook, PS2-Battery-Power management drivers from Combo Patches (these can be used prior to rebooting, after updating).


Next step where to get the ethernet card working (BCM 5755, id:1673) and thanks to noahbody99's AppleBCM5751Ethernet.kext i got everything working (mac, dhcp).


The inbuilt wifi card (Intel 3945) dosent work (there are some experimental drivers but they are'nt ready). Instead i used a Netgear WG511T PC Card that i had laying around. Although first the PCMCIA slot had to be fixed using Eureka's PCCard.10.5.2.beta3 driver. Next i followed this guide (Leopard-The new kext method) to activate my WG511T (Atheros AR5212 168C:0013), however i only did the first step as the Intel 3945 already showed up as an airport card and adding another one dident make sense. Strangely i only got the WG511T working if i first installed the BCM 5755 driver, secondly the PCMCIA driver and finally the WG511T driver, no other order worked !?!


The final step where to fix the audio, Sigmatel 9205 (8384:76A0). There are dozens of Sigmatel drivers floating around the forum, most will give you speakers and line-in. I ended up with a AppleHDA.kext from theStevo that seems to be working well. However the internal mic isent working with this kext, a driver enabling the mic is found here, but i never got it working satisfyingly.


Thats about it, almost everything works. Reboot and Shut Down isent working, but Sleep and Bluetooth seems to be working out of the box. The graphics performance are much better after sleep so a applied the startup-sleep trick found in roneil4's D630 guide.


Hope this will help some...


Link to comment
Share on other sites

  • 2 weeks later...

i managed to get the mic working on mine. Somewhat followed mauritsius' guide but for sound i used the sigmatel 9205 drivers from the dell post installer. That worked fine but there was no mic. To get the mic working i used the post by theSlug here


I also used the trackpad scrolling driver for the Lattitude D630 from the dell post install. Tapping works, but finger scroll not too good. I'm gonna have to mess around with a little more

Link to comment
Share on other sites

i followed mauritsius' guide and got great experience.. all features working except touchpad finger scrolling/tabbing and vga output.

the dual display support is very important for me, maybe anybody can helps me.. i try to find out the nvcap codes, but no luck.. i havent a docking station, so i cant test the dvi output in the dock.

Link to comment
Share on other sites

  • 2 weeks later...

Hey i got everything working except the video. I have the high resolution screen as the original poster allowing me to have 1920 x 1200 resolutions, but no matter what nvidia injector i use or efi string, when osx loads, all i see is a blue background, that blinks from time to time. Thats it, i can nevery actually see my desktop. I have tried iatkos 10.5.4, and 10.5.5 and have the same results with both. The funny thing is i have a m4300 with just a regular screen, for 1280 x 800 resolution, and ihave no problem with any injector that i use!


can anyone help with this???? thanks!

Link to comment
Share on other sites


  • Create New...