Jump to content

Still waiting for root device, dammit


21 posts in this topic

Recommended Posts

I have successfully installed Kalyway Leopard on my PC (using boot flags -v and cpus=1), but I had no success in booting it so far...


Here are my specs:

Intel Core2Duo @ 2.2GHz

MSI P35Neo (MacOS won't accept 2 cores on this board for some reason)

2GB DDR2-800 RAM

1 Western Digital SATA2 HDD 250GB (1st partition - Primary - Windows - NTFS, 2nd partition - Primary - MacOS - HFS+)

1 Maxtor 200GB PATA HDD (storage purposes) - not recognized (not a big deal)

1 Samsung DVD-RW SATA Drive

XFX nVidia 8600GT gfx card


I am currently dualbooting Vista and MacOS. Both boot properly, but MacOS stops after a while and prints out "Still waiting for root device".

First, MacOS stopped booting after right "Using 10485 buffer headers and 4096 cluster IO buffer headers", but I used MacDrive in Windows to replace some Kexts that I found in a tutorial here on InsanelyMac, and apparently, that fixed the problem... Until I ran into the next one:


OSX can't boot from the HDD using -F, -X, -S, cpus=1, -legacy, rd=/dev/disk0s2 or any combination of these parameters. I have confirmed that my MacOS disk is at Disk0 and Partition No. 2. If I don't specify the "rd" parameter, the same thing happens, except OSX states that it is booting from a disk with an "UUID" (or something like that) followed by a number that actually corresponds to /dev/disk0s2 (confirmed it from the MacOS setup Disk Manager).


Take a look at these two screenshots... The second one displays Kalyway successfully booting from a DVD (notice the AppleViaATA driver in action), and the first one displays the installed OSX booting from the HDD without success. Sorry about the blurry shots.


Help? <_<



Link to comment
Share on other sites

Make sure your DVD drive is set to master not Cable Select, use only one HDD on the SATA connection and disable your nic card in the bios. See if you can get past this point.

Link to comment
Share on other sites

My DVD drive is on a SATA connection, so how can I set it to slave/master/cable select? I'll try to disable the NIC, but I don't know if that will do any good...


Also, how the hell can I enable AHCI on my MSI P35 board? I can't find the option anywhere!

The manual doesn't provide any help about AHCI at all - http://global.msi.com.tw/index.php?func=do...amp;type=manual

Link to comment
Share on other sites

Actually, the drive itself works, I INSTALLED Leo on my PC without any glitches! I am dualbooting it with Vista as well. A week ago, I tried a PATA DVD drive, and it didn't work for some reason, but that doesn't actually matter now.


Now, I tried booting from the CD using rd=/dev/disk0s2 (the parititon that MacOS is installed on), and I still get the "Still waiting for root device" error.

Tried disabling the NIC, and nothing changed. Tried the mach_kernel, toh and vanilla that comes with kalyway, nothing special - everything looks the same.


People say that AHCI needs to be enabled, but I can't find that option in my BIOS anywhere! But I don't really know if that is necessary, because if the DVD can boot properly and recognize all my SATA drives and install without any problems, why can't the installed Leo simply boot? I mean... It reads all the file it needs from the HDD (the red light on my case is going nuts when Darwin is loading), but later on, it can't recognize it? What's the deal? Am I missing any KExsts?


My board is using the ICH9 + P35 chipset. 3 KExts contain my chipset ID, which is 0x29218086 and 0x29268086:





Is it OK if all 3 contain these IDs, or should I use only one KExt? Which one should I use?

Link to comment
Share on other sites

Just found out that my motherboard does not support AHCI or RAID... But, I still fail to see the problem since the installation DVD recongnized my sata DVD drive and sata HDD drive just fine. What's the deal?


Help, please? :wacko:

Link to comment
Share on other sites

First you cannot boot OSX, you can load the boot loader, but that is less then half the way.


Your OSX Partition isnt flaged bootable. The boot loader is loaded from your partition, but that doesnt mean that it recognizes the partition for its ongoing proceedere.


a lot of people stuck here, the easy way to do this is Kalyway`s DVD.

Link to comment
Share on other sites

There is a big difference between a bootloader and the kernel... But never mind that, how do I flag my OS X Partition as bootable? It's already marked as primary though.

What should I do with Kalyway's DVD, what's the easy way out?

Link to comment
Share on other sites

Well, for some reason, only Kalyway Leopard gets past the "Using 10485 buffer headers and 4096 cluster IO buffer headers" line...

I tried JaS Tiger, iATKOS Leopard, ToH Leopard, and all stopped on the line above.


Still, I can't get Kalyway to boot! I can't enable AHCI, since my motherboard doesn't support it, :D

What am I supposed to do to get Leo to recognize my SATA root drive? Any kexts you may suggest, please?

I tried flagging the OS X Partition as "boot" using the gparted liveCD, but no dice...


Again... Please? :P

Anybody had any problems like this at all, or am I the only one?

Link to comment
Share on other sites

Guess I'm the only one then... This is the last bump I'll try on this topic, because it looks like I always get stuck with unique problems ;)


...Bumpety bump...

You aren't unique, you're just on the bleeding edge.


The problem is you are trying to get ICH9 to work.


This is a thread about how I got ICH8R to work by copying the Leopard install DVD to a partition on a USB drive, then modifying files to make it work.



It is reasonably likely you could figure out how to make yours work the same way. You would have different device ids to patch into AppleAHCIport.kext. The second post on the thread gives the details. You might have to use another machine which at least boots Tiger to copy the disk image and modify the files.


BTW steve-o uses AHCI mode. So if your BIOS doesn't support that, it won't work for you. I could have done it that way, but I didn't want to because reinstalling XP and Vista is too much work.

Link to comment
Share on other sites

Thanks for the reply! I will try your suggestions.

However, I have Windows Vista installed as my second os next to the currently non-working OS X, so I'm fine. I have access to my extensions folder using MacDrive on Windows Vista, and I have already made some adjustments to the Extensions folder... Maybe that will do the trick here as well.


Will keep you posted!

Link to comment
Share on other sites

"Still waiting for root device"


System specs:

  • Intel Core 2 Duo E6300 1.86Ghz
  • Intel DG965WH desktop board
  • 2x 1GB Kingston PC4400 ram
  • Maxtor 200GB IDE (internal, primary [Vista x64])
  • WD 160GB Mybook (external via USB, for media)
  • WD 80GB (enclosure via USB, for Leopard)
  • Nvidia 7900 GS KO


  • D/L torrent, extracted through WinRAR, burn ISO, Reboot -> Boot DVD
  • Tried enter, then F8 -v, -v -x, -v -r, "vanilla"
  • Disabled onboard firewire and ethernet via BIOS (due to -v error messages)
  • Will not go further than error message below (picture)

PLEASE HELP! I've read through all 68 pages of the Kalyway thread. :(



Link to comment
Share on other sites

  • 7 months later...

My HDD (Seagate 80G) using SATA and DVD Rom(Lite On) using PATA. When i try to install Leopard ToH It show error"Still waiting root " too and never show install sreen


BUT when I tried to change HDD cable to Sata1 and Set my DVD ROM to master and disable Lan Card in Bios It work with a bit problem - PS/2 Mouse can't use while installing Leopard ToH but when i changed to Mouse USB It came workkkk THANKYOUUUUU finally it seem work.

Link to comment
Share on other sites

  • 4 months later...

  • Create New...