Jump to content

Help with setting partition as active...


willowhaven
 Share

9 posts in this topic

Recommended Posts

I have fought, kicked, screamed, threatened...etc...trying to use GParted LiveCD, all with no success. My computer will not boot from it. Does anyone have a different program to set my Leopard install as active so I can use the Darwin Bootloader as my loader? I would greatly appreciate it!

 

Jennifer

Link to comment
Share on other sites

I'm having a heck of a time too. There seems to be something jamming up the boot sector, and I don't know how to fix it. It seems I just try over and over and eventually it just works. This latest iATKOS patch, I am redoing my install, and I'm up to about nine installs now with blinking cursor every time. fdisk in Darwin says the partition is set bootable. fdisk in gparted says the partition is set bootable. I use these tools to re-reset the flag. I reboot. Blinking cursor. I've tried one partition, I've tried Darwin's recommended autofs with an 8MB boot area.. no change.

 

I just threw Windows on the drive real fast and it boots fine, so I am going to see if there's anything I can figure out with this and then do it again. No sleep tonight I think!

Link to comment
Share on other sites

I got it working, and I kinda know what is happening, but I don't have a solid or reliable fix.

 

What seems to happen is the boot sector gets jammed up with something and can't get the right info. The way I figured this out is by installing Windows XP. Windows happily fixed the MBR and Windows booted fine. Then I re-nuked the drive, installed OS X, and on reboot I got a Windows-specific error about it not being able to find the OS. So the iATKOS bootloader didn't actually overwrite the MBR, cuz the Windows one was still there.

 

I fixed this by using the first iATKOS DVD, and using the Darwin_bootloader script. This flushed the MBR and got the right info on there. If I had to do it again, I cannot guarantee it would actually work. ; ;

Link to comment
Share on other sites

Okay...I finally figured out why I couldn't use GParted. Apparently my Dell didn't like the disks my HP created. We have a lot of "snobby" computers in this house and all of them think they are too good to talk to the others. <sigh> Sibling rivalry, I swear! Anyway...now that I am into GParted, what do I do? Can someone do a FAQ as to how to use GParted to set up Leopard?

 

Thanks!

 

Jennifer

Link to comment
Share on other sites

All you're going to do in GParted is set the boot flag. Just right click on the partition/volume that your OS is going to go on and in the set flag window, check boot. When you're done, the gui should show that volume as active.

Link to comment
Share on other sites

 Share

×
×
  • Create New...