Jump to content

NForce SATA Controller


757 posts in this topic

Recommended Posts

I have an MCP55 and this also isn't working for me.


I am using 1.0.3 version of your(McDevil's) NForce SATA placed in IOATA/Contents/Plugins.


My PATA is working with this, but SATA won't initialize still. Fails with I/O error still.


http://pixabug.com/ioreg-12-21-07 is my ioreg -l -w0


I added 0x037f10de for my SATA and 0x36e10de for my PATA




Link to comment
Share on other sites

Getting the "Still Waiting for root device" on 10.4.10....I'm on an MCP55


I did delete the previous AppleNForceATA.kext from the IOTATAFamily.kext...didn't have it in root extensions folder.


Putting the new kext in IOATAFamily.kext/Contents/PlugIns didn't change anything.

Me too. Same with Leopard as well.


Leopard seems to only work if the IDE drive is set to master. 10.4.10 doesn't seem to work with it at all though...

Link to comment
Share on other sites

Ok, let's try to resolve those nasty issues. Before we begin, I want you to know that this kext driver WAS NOT TESTED UNDER LEOPARD (by me), so you'll get NO SUPPORT until i test it personally (which should occurr in the next few days).


Now, for the unlucky people that were having troubles, follow those steps:

1. delete all the apple nforce kext from the extension directory (/System/Library/Extensions/).

2. delete all the apple nforce kext from the IOATAFamily.kext Plugins directory (/System/Library/Extensions/IOATAFamily.kext/Contents/PlugIns/)

3. download the zipped file in a new, clean directory and double click it to extract the kext.

4. place the extracted kext:

4a. if you are creating/modify a dvd: place it into extensions.mkext (also delete previous kext)

4b. if you are booting from hd: place it into /System/Library/Extensions, chmod and chown the kext, then remove extensions.mkext and extensions.kextcache from parent directory (/System/Library/)

5. shutdown the pc

6. disconnect all pata hard disk (cdrom can remain connected)

7. boot up the pc and take a look at the console output.


If after this procedure the system is still reporting problems, please send me an email in the following format:

HW ID: 0xXXXXXXXX (this is the dev/ven id example: 0x03f610de)
Method: YYY  ("HD" if you are booting from hd or "DVD" if you are using a bootable dvd)

Also attach a copy of the system.log and the output of "ioreg -l -w0" (post them as an attachment!)


if system.log isn't available, please try to post a picture of the boot progress or (try to) describe it exactly.

if output of ioreg isn't available, specify "ioreg: not available" in the email.


email subject MUST BE "NFORCE ATA ERROR". All other emails will get trashed (or flagged as spam).

You can find my email address in the signature.


Be prepared to be a kext tester. This mean: you'll try a (just compiled) debug version of the kext on your machine sent directly from me. (if irc access is available, it will really speed the resolution of the problem!)


Regards, Domenico.

Link to comment
Share on other sites

Hey MeDevil, you rock everything this x86 world ever wanted :P Now lets port Mac to the PS3 j/k not worth the effort...yet ;-) I will be testing this momentarily and donating after I pay off my CC for this month. (BTW, if you are honestly looking for some new challenge to conquer my buddies and I could use some good help. I'm sure you could help us decipher the PS3's HDD FS.)

Link to comment
Share on other sites

Thanks a ton MeDevil. Your driver has got my Compaq F730US laptop with nforce MCP 51 working off the SATA drive, ;-)


A few observations :

The driver takes some time to detect the drive. I get a message 'Waiting for boot Volume with UUID....."

"Waiting on <dict ID="0"><key>IOProviderClass</key><string ID="1">IOResources</string><key>IOResourceMatch</key><string ID="2">boot-uuid-media</string></dict>"


Then I keep waiting for as many as 10 secs.....

On the other hand pressing the power on button and releasing it causes the "ApplNForceATA: NVIDIA nForce MCP51 Serial ATA by MeDevil (...)" to appear almost immediately.

Is that normal?


:P But the disk is detected the boot process completes and I get the Leopard Desktop,


Now to get my keyboard and mouse working before I move any further.!!!!



Thanks again. Great Work. You're a life saver.

Link to comment
Share on other sites

Hi all,

I am on MCP 55 as well,

Tried placing the new AppleNForceATA.kext in both /extensions as well as IOATAFamily.kext/contents/plugins/ getting the waiting for root device on both occasions :wacko:

Even My PATA Speed are terribly slow.. if i get that working tat will be great!!

Link to comment
Share on other sites

I got everything working allright, with the kexts on the install dvd. But when it boots it says something about a read/write error from the SAM Multimedia, and in between the "Still waiting on root device" error. I'm also an a MCP55. This was with Leopard, so I'm going to try now with tiger (10.4.8), and see if it works.

I'll let you know....

Link to comment
Share on other sites

Haha... The temptation to dig out my 650i, buy another 8800GTS 512 and enjoy playing Crysis a lot more now NVidia chipsets have a working OS X SATA driver...


But. Nah. I hate NVidia chipsets. I think it would only {censored} me off again. Plus, I'd have to back off some way on my overclock.

Link to comment
Share on other sites



I have a compaq F730US laptop with nforce MCP51 chipset. I was able to get a preistalled copy of Leopard (by attaching the laptop hdd to a intel PC and patching it for AMD) working with this kext.


Well, after getting my keyboard and touchpad working somewhat (mostly not) I have the following problems:-


1. The ide DVD drive is not accessible

2. After about 20 reboots or so - I seem to have developed some problems with loginwindow, securityd, mdnsresponder and mdworker crashing with EXC_CRASH (except securityd which crashes with EXC_BAD_ACCESS).

3. The initial 20 bootups or so were fine but sometimes the OS ran really slow, sometimes it was remarkably faster. The keyboard and touchpad worked only once - but that is another issue.

4. I did a lot of fsck'ing in single user mode and the partition was repaired almost every time.


I'm likely to be totally out of line here - but is there any possibility of data corruption? I haven't changed much except the ApplePS2Controller kexts and these crashes seem out of place at that.


I'll re-install if I can't find a reason - but am willing to test the driver further ;-)


Thanks, though, for everything - there's light at the end of this tunnel yet!

Link to comment
Share on other sites

tried injecting into ToH-leopard dvd, and tubgirl Tiger. both hang at waiting for root device. Leopard probably wouldn't have worked anyway because my system is AMD, but the tiger dvd should have at least made it to the GUI install screen. (I've gotten to the GUI without the new kext, but couldn't see my drive.) The tiger dvd gives a SAM error trying to read the dvd. Maybe I'm not properly injecting the kext or something like that.


any suggestions?


hp dv6119us notebook pc


I too had this issue on the same notebook, it seems the KEXT does not like the controller for the DVD-Rom, I installed OSX onto an external HDD which worked (No Video acceleration, No Keyboard or Mouse (Had to use USB KB/Mouse), No wireless, even though it is detected as a Airport Card, No ethernet) So once I had a desktop I was able to access the DVD, as soon as I copied over the new kext, fixed permissions and rebooted, I have a full working SATA drive (Great work Medevil) I lost the ability to access the DVD-Rom which is why I think we are getting the waiting for root device error. (I also got the SAM error, (I was thinking this might be the Card reader maybe??)


So At this point as I was not smart enough to get everything working, so I am hoping when/if we get the kext 100% compatible with this laptop we can work on the other things....but with all the issues, I think the HP DV6119Us is a dead duck when it comes to Macos osx ;)

Link to comment
Share on other sites

Same is the problem with my laptop hp tx1000 i cannot access dvd rom drive.....

hope we get a soln soon..

it worked before with the appleviaata.kext ...posted in the huge forum of the darwin nforce sata/ata cotroller thread by ghakazian..

Link to comment
Share on other sites

Hi can someone tell me how to install this 2 my osx86 dvd? i have no idea do i use nero?? what file do i replace on the dvd? do i just replace this file then reburn anything else involved?

Also my motherboard on my laptop is a Nforce 560 will this chipset work with this driver i really wanna get osx up and runing on this laptop ;) will it work on pata and sata? thanks let me know mate

keep up the good work will make a donation ;)

Link to comment
Share on other sites

i think that all of us are waiting for a ppf patch or something else for inject this kext in our iso...like the last kalyway iso, uphuck or similar...

that thing is a good xmas gift for us...

you are the best for us unlucky people with nforce sh*t...

Link to comment
Share on other sites

Every one that is geting that error "still wating for root device," i know noticed that "IOATACONTROLLER Device blocking bus" comes up right before the root device error. from past experience, if u have more than one nvidia device in ur system &0xffff0000 needs to be specified in the info.plist or more than one device may be trying to use that driver. i currently do not have osx running, so i cannot correct the issue.



MeDevil --

If u could Add &0xffff0000 After the device id's i think it might fix some of the probs

Link to comment
Share on other sites

But. Nah. I hate NVidia chipsets.
You and me both...
me three, even trying to put linux on the DV6119 requires extra boot commands...but it does windows pretty well :D


You poor people, hate Nvidia chipsets is not the way, choose a better Nvidia chipset is (even an old one).

Link to comment
Share on other sites


  • Create New...