Jump to content

Can Fusion/Parallel boot a physical install of WinXP

14 posts in this topic

Recommended Posts

My case is like this:


I have a desktop PC installed a WinXP first (as of most of us :D ).

Then I added another harddisk to install OSx86. By now I use BIOS boot priority to select which OS to boot only. That means each OS don't know the existing of each other at all.


Yesterday I tried to install VMware Fusion on OSx86 and then select "File -> Open". At that point, I can select some existing VMware virtual machine *.vmx. But instead I selected the partition of the WinXP, not a .vmx file. Then the virtual machine menu has one more entry called "Boot Camp Partition" and it allow me to boot! However.... :wacko:


After the WinXP loading screen show up just for a while, I got blue scan and said something like:


c0000221 error



The next attempt give me safe mode selection screen but also no good can't boot in no matter what I selected...


So my questions are:


1) Actually I was wondering... This time the OSx86 and WinXP are guarantee running on the same piece of hardware. Should it be able to run the copy of OS resides on the partition next to it also? That physical copy of WinXP has all optimized drivers that match the machine already. Anyone tried before? (Fusion allow me to add the partition to the VM menu and named it as "Boot Camp Partition".... So it must has some plan for doing this, right?)


2) Or may be if I am using native Mac hardware and using Boot Camp drive to install the WinXP, will I have better result?


3) Or I can install something on the WinXP to let it better communicate with Fusion when running VMware simulation mode?


4) Also, how about if I am using Althon64 X2 CPU? Will this affect the result?


5) How about Parallels? Can it do it? (Seems Transporter only import an existing copy of OS into virtual machine, not boot it. Right?)


Many thanks!!

Link to comment
Share on other sites

Both VMWare fusion and Parallels can do what you say, but only on real macs. I haven't gotten it to work on my PC, although some other people have. I gave up...


Boot camp won't work, it only works on a real mac. The AMD Cpu thing doesn't matter.

Link to comment
Share on other sites

i have found that, and intending to try it as soon as parallels finish downloading...but i boot with darwin...u think it wont work this way?



Parallels - Boot your physical Windows partition from MacOS X86

[ Tutorials ] [ OSx86 ] by macgeek @ 10.02.2007 15:38 CEST

Sherry Haibara has found a way to boot physical Windows partitions in Parallels,

running inside a MacOS X86 install! Congrats! Here is the tutorial:


Get the latest Parallels beta here

Open Parallels and choose to create a new virtual machine.

It'll ask you what HD do you want to use. Choose Boot Camp.


Continue the setup, but do not run the Virtual Machine.

When finished, close Parallels.


Use a Text Editor to edit your virtual machine configuration file (*.pvs).

Find the line that says:


<b>"Disk 0:0 image = Boot Camp" and replace it with this

"Disk 0:0 image = Boot Camp;diskxsy"</b>


where diskxsy is your Windows/Linux/Other OS "Boot Camp" disk.

disk0s1 is valid for instance.


Save and exit.


Start up Parallels and launch the Virtual Machine. Enjoy!


source: InsanelyMac

Link to comment
Share on other sites

ok, here's what i did:


installed parallels, made the new virtual machine, chose bootcamp in options, did the change according to my previous post, but took in consideration the XP drive name which is disk0s2 here.


then got chain0 on c:\ and edited boot.ini




i can still see darwin bootloader, press f8, get windows options of XP boot or OS X boot....chose OS X and i could still see darwin boot loader takin charge of loading OS X....


and on parallels, nothing from what i did changed anything from what it was doing earlier before chain0.....like i only get in parallels a black screen looking just like any pc boot of BIOS, with the memory amount, and under it: Boot from hard drive... and it stays like that and nothing happens...


any success by anyone?

Link to comment
Share on other sites

Yesterday I retry with Fusion. I found that I haven't further amend anything but this time I can load the physical winxp! :( But it is not very stable as I installed some hacked display driver (ATI1950GT modded to be FireGL7350 + ATI CCC which, cause an error everything boot in winxp within Fusion).


So I use a clean ghost image to reload a winxp that without much hardware driver. After ghost, get in winxp natively at least once (seems necessary to get the winxp config properly). Then go back to OSX and Fusion. This time no more error about ATI CCC. The winxp will detect a lot of new hardware like EISA, PCI bridge.... blah blah.... Input the winxp CD for the system to complete the hardware profile setting for the Fusion's hardware env.. Then reboot (at this point, I always get hang and need to force shutdown the virtual machine). Restart the Fusion => this time the winxp will run faster => but not enough. Install the VMware Tools then reboot the winxp again. Now I got a full speed, dual core supported winxp running in OSX.... :help:


But I must add. During the above process, I got my OSX hang few times. I don't know why. May be my kernel is too old? (10.4.9)


I will do some more then tonight. If ok, I will ghost this copy of winxp again as my future "clean ghost image". Then later I don't need to re-do the above painful hardware detection process anymore....


The Unity function is damn good to use! I never tried Parallels before but what I heard is:


Parallels has more features; VMware has more speed


Let see if you guys can get it work or not! :)

Link to comment
Share on other sites

Sorry to contradicte Synaesthesia and cyclonefr,


VMware at first Run detected my Vista partition (with the trick of activating that partition before ran VMware) on my Dell XPS, I'm using Darwin bootloader.


After VMware made the boot camp entry you can set back active the Mac partition to boot with the Darwin bootloader.


I also made manualy the boot camp entry on my AMD rig, since in that installation Mac OS is in another disk I set up a third disk with GUID scheme and VMware created a boot camp entry, then edited the vmx and the vmkd files.

Link to comment
Share on other sites

  • 4 weeks later...

A similar option is included with Parallels Desktop 3.0 (which *does* work on Hackintoshes; I'm running it now); however, as opposed to running the same version of Vista from inside Leopard (separate HD), I did a completely separate install of Vista from Parallels.


One reason I did it this way is due to resolution differences between Leopard and Vista; I can't run Leopard at any resolution greater than 1024x768 (while Vista scales to 1280x1024). While Leopard *does* support CI/QE, I have no resolution-switching capability. Unless/until this is fixable, there's no reason to change.

Link to comment
Share on other sites


  • Create New...