Jump to content

intel GMA950 + 10.4.10 anyone done it?


10 posts in this topic

Recommended Posts

I've tried a couple distro's, so far no luck


has anyone with an intel GMA950 been able to upgrade from 10.4.9 to 10.4.10?


If so what steps did you use?


I've got uphuck 1.3 universal working great, but the 10.4.10 upgrade so my iphone works has not gone so well, I've reloaded the laptop 5 times so far, each one will boot up, showing a grey screen with apple logo, and then flash blue and crash



pretty sure at this point it's a driver issue with the gma950

Link to comment
Share on other sites

Mobo Intel D945GNTLKR + D945

(3536 MHz, 4 giga / 3.3 giga memory works, boots direct from 1. sata(0)

which has OsX. I have no windows anymore. Choise is not ideological...

I only do not need it.)


Start: Upchuck_10.4.9_v1.4i.iso. = First 1.4 version with rosetta.

Update: MacOSXUpd10.4.10Intel.mpkg from PascalW


= 8.10.1 " Sochi2014:Vote for us " kernel. (I hate that kind like kernel info!)


iLife 08 & iWork 08 works excellent. - And all other programs too.

Only one bug... wake from sleep not works. I wait, that PascalW

or Koolcal will make easy 8.10.3 kernel update.


Ok. Then: This is what You ask:

Fix: gma950.pgk (1.0) date 24.05.2007 by upchuck - some early distro. - 1.3 ?

Fix: Finnish.pkg 10.4.7 distro. - Everyone understand that from my english? :-)

Fix: ich7r.pkg (1.0) My Great Company

Fix: azalia.audio.pkg (1.0) My Great Company


I have all early distros, can not say where all .pkg are exactly from.

I have made system building folder with necessary update like:






quicktime.codecs.pkg (uphuck)


Flip4Mac WMV.mpkg


rr231x_0x-Mac-v21-042507(2).dmg for HighPoint RocketRaid 2300

pci-e sata-II card. (flash bios unbootable, and it works well after that.

It is almost equal fast than motherboard sata, about 90%. Card is 1x version

of pci-e, because motherboar has only 1x place. Driver is from 4x version



Gma950.pkg 1.0 upchuck has all different res and refresh choises.

This time I am not sure from azalia... I use C-media's Usb Sound... ehh...

"card"? stick? box? ...what ever. Cheap & works well. It has microphone in.

= Skype.


Hmm... what else... OsX likes memory. It is cheap now. I recommended it.

And because You ask gma950... look at that:




I allready have that dual dvi model card (actually two) , but i am not tested them yet.

I am buying two lcd to myself and two to my wife. - Extremely Difficult Things to choise.

Yeah... I know, sips and pva and tn ... four equal or 2 pivot + 2 normal, Or big 26"

full hd and smaller side monitor (pivot?)... well...


If I understand right, gma950 with driver shows every mode, what monitor can presents,

WHEN monitor is connected. That is the reason, why pivot mode is not showing by driver



Hope this help. And after fixing use Yasu to clean Your system.

Link to comment
Share on other sites

I managed to get it work on my dell inspiron 6400.

Here's what i did: first,do clean install using Kalyway 10.4.10 installer DVD ( of cuz it wont boot w/o patching)

second, use Jas 10.4.8 installer DVD to restore IntelGMA950 kexts and reboot

Now u should have managed to boot into GUI instead of hanging at the blue screen

hopefully it helps those with GMA950.

Link to comment
Share on other sites

I have it working fine with CI&QE. Installed JaS 10.4.8 then installed PascalW's 10.4.10 update, skipping the video drivers. For some reason, it seems that it still tries to modify the video drivers, giving the solid blue screen anyway. Reboot into single user mode and delete the AppleIntelGMA950* kexts and AppleIntelIntegratedFramebuffer kext. When you reboot, you will make it to the desktop, but the video will be stuck in 1024x768 without CI&QE. Then reinstall the GMA950 package from the JaS 10.4.8 DVD, reboot, and you will be working fine.

Link to comment
Share on other sites

  • 6 months later...

This worked also for me,

After updating to 10.4.10 with Patch you have to go to singleusermode, delete AppleIntelIntegratedFramebuffer.kext and AppleIntelGMA950.kext

Then u have to reboot in OS X with resolution 1024x768

Now u have to install the GMA950.pkg

For the ones who search it and dont find the right one, i have attached the file.



ILife and IWorks 08 are fully supported.

QE/CI is also supported.


Have Fun


Link to comment
Share on other sites


  • Create New...