Jump to content

Quad Boot Help


Nevadabob
 Share

33 posts in this topic

Recommended Posts

Hi, i'm trying to get a quad boot rig up and running on my 80gb ide drive. My pc is compatible with osx86 as i've installed it before. I want to have vista,xp,osx86 and ubuntu all running on the system. I currently have vista,xp and ubuntu. After reading guides I have seen that I need to make a fat32 partiton (less than 32gb) and then erase that into a mac osx partition via the installer cd. My problem is that whenever I try to format the fat32 partiton to mac using the disk utility, the moment i click erase the name greys out and it is left like that sometimes with the hdd led constantly on. Is there somethng i'm doing wrong?? Do I need to reinstall EVERY os but in a different order for it to work?

 

Any help would be greatly apreciated.

Link to comment
Share on other sites

My problem is that whenever I try to format the fat32 partiton to mac using the disk utility, the moment i click erase the name greys out and it is left like that sometimes with the hdd led constantly on.
What else happens? Does disk utility freeze, ...? As a side note, is the OS X partition a primary partition? I have XP, Vista and OS X each on their own primary partition, Ubuntu and all my other partitions are on an extended partition.

All that happened in my case when i formatted to HFS+ in disk utility was that the partition i was formatting got deselected in disk utility [don't know about the HDD led's since mine aren't working], but it was formatted nonetheless. Have you tried continuing the installation after this? Does the partition for OS X show up?

On my new rig i had to format the OS X partition several times in disk utility [to HFS+] before it got recognized by the installer.

I don't think you'll need to reinstall all OS'es. I don't know if GRUB will 'survive' the OSX installation [tho IIRC, it does], in which case you'll have to reinstall it through the live/install CD, which is easy enough, really.

 

Hope things work out. If you need any more help, just let me know, i'll do my best to help, hehe :P

Link to comment
Share on other sites

Tanks for the reply. When I attempt to format, the Disk Utility doesn't freze. It just gets deselected. I tried leaving it on once after I had clicked erase and the hdd leds were on for ages so thats why I thought it was not working. Perhaps it has been formatting but taking a long time. Everytime I boot into linux to format the parttion back into fat32 it says that it is an hfs partition. The Mac installer doesnt recognise this. Perhaps i'll just leave it on formatting and see what happens.

Link to comment
Share on other sites

Tanks for the reply. When I attempt to format, the Disk Utility doesn't freze. It just gets deselected. I tried leaving it on once after I had clicked erase and the hdd leds were on for ages so thats why I thought it was not working. Perhaps it has been formatting but taking a long time. Everytime I boot into linux to format the parttion back into fat32 it says that it is an hfs partition. The Mac installer doesnt recognise this. Perhaps i'll just leave it on formatting and see what happens.
Converting the partition from fat32 to HFS+ in disk utility was very fast for me, less than a minute i think for a 20GB partition. Then if i clicked on the HFS+ partition, it would show as HFS+ in disk utility. As i mentioned above, i had to format the partition to HFS+ several times before it would become available as a disk on which i could install OS X. So what i did was: format in disk utility, quit disk utility, resume installation. If the installer could not see my partition, i went back to disk utility and repeated the process. Last time i had to do this a few times; on my old rig once sufficed.

I don't know what else you could try... When i formatted the partition on which i'd install OS X i first formatted to fat32, then added type 'AF' using cfdisk in Ubuntu. I don't know if you've done this, if not, it may be worth a shot as well...

 

Oh and about the partition needing to be less than 32GB, i think it's bollocks. I don't know if you read that this is the limit for fat32 partitions, but i've got a partition that's 100GB... I don't see why 32GB would be a limit... I may be wrong ;)

Link to comment
Share on other sites

Ok, i'm back in the installer. Just booted out of linux, Gparted claims that it is an hfs partition. The disk ultility still reads it as a fat32 partition. Everytime I attempt to format the fat32 to hfs it does something for a few secs (10-20) where everything greys out and I can't click close, and then I can click close and everything is still greyed out. When I click back on the partition it is the same as before.

Link to comment
Share on other sites

The fat32 format limitation is on Windows, I've tried to format a 80GB partition on XP Disk Management it doesnt work. But you can force format it from command line. Start -> Run -> cmd -> format d: /fs:fat32
Ah, i see. I've formatted fat32 partitions under Windows as well, but using the command line, as you mentioned, so i wasn't really aware of the 32GB limitations of XP's disk management...
Ok, i'm back in the installer. Just booted out of linux, Gparted claims that it is an hfs partition. The disk ultility still reads it as a fat32 partition. Everytime I attempt to format the fat32 to hfs it does something for a few secs (10-20) where everything greys out and I can't click close, and then I can click close and everything is still greyed out. When I click back on the partition it is the same as before.
Try formatting the partition to FAT32 again [with Gparted, or whichever program you may prefer], and then setting the type to 'AF' with cfdisk under Ubuntu. I think to do this you had to:

 

open terminal

type: sudo cfdisk, enter password

select the partition with the up/down arrows, then use the left/right arrows to select the 'type' option, then hit enter twice [iIRC] and type 'AF' for type [it's not listed, you have to type it yourself].

Then exit, and try the installer again, going through the disk utility procedure again. Strange that it's not working as you've succeeded installing OS X before. I can't verify these instructions now, should they not work give me a shout, but i won't be able to check before tomorrow evening [as in, 24+ hours from now].

Also, i just read in a thread that OS X must be on a primary partition, just in case.

 

Also, if you do get OS X working, what filesystem are you thinking of working with? I have all but one of my data partitions as HFS [not HFS+], as these can be read/written from Ubuntu [7.04+ i think] as well as under Windows, using MacDrive. The ext3 kext/program thingy for OS X didn't work for me, so i gave up on that. I think the other solution would be using NTFS and macfuse for OS X read/write support, as NTFS read/write is also supported under Ubuntu 7.04. Just my :whistle:

Link to comment
Share on other sites

Thanskf or the help. I'm just finalising the install on my PC. Adding the AF was what did it! My computer is set up like this:1 ide drive (with the OS's and software on)2 x sata drives (1 full of games, the other full of videos and music etc)The satas are shared between all OS and are in NTFS. I was hoping that OSX would read the ntfs partitons and so I gues I would install macfuse.Let me know what you think!thanks for the help!Got a problem now! Which bootloader do you use in order to select which os to boot?? currently when I turn on the computer I can see it quickly cycle past grub and darwin and into vista bootloader. I tried configuring the vista bootloader with easybcd but I am getting an error when trying to boot into osx "Chain booting error".

Link to comment
Share on other sites

Thanskf or the help. I'm just finalising the install on my PC. Adding the AF was what did it! My computer is set up like this:

 

1 ide drive (with the OS's and software on)

2 x sata drives (1 full of games, the other full of videos and music etc)

 

The satas are shared between all OS and are in NTFS. I was hoping that OSX would read the ntfs partitons and so I gues I would install macfuse.

 

Let me know what you think!

thanks for the help!

:( glad to hear that solved it. Were the instructions for the cfdisk stuff about right? That was just off the top of my head ^^

OS X has default NTFS read i believe, no write. MacFuse solves that, but i haven't used it extensively. MacFuse was an option when i was installing koolkal's 10.4.10 combo update, so i decided to give it a try, and it seems to work alright, but since i only have small partitions assigned for XP and Vista i haven't written much onto them through OS X. I think macfuse is pretty stable, but the forum could shed more light onto this matter.

So yea, give it a shot to. Believe me, you want more than read for your drives: without it you can't even change metadata for music, rename files, ... Been there before, soooo annoying :P

Link to comment
Share on other sites

Yeah your intructions were great. Worked a charm. I'm having trouble getting the grub boot loader to load up. Would the easy option be to reinstall linux??
That would be the lazy solution :unsure: Lazy in the sense it doesn't really teach you... Have a search at ubuntuforums.org for instructions on how to reinstall grub. Or try this, copied from here:

"OK, here we go

 

1. Boot from the LiveCD

 

2. Open a terminal

 

3. sudo grub

 

4. root (<tab> (Where <tab> is the TAB key) It will then list your HDD's ie hd0

 

5. You will get back something like "grub> root (hd0,5) "

 

6. setup (hd0) or whatever your HDD is.

 

7. quit

 

Hope this helps

 

Regrds,

Roger"

 

I think i've used this method before and it worked. If it doesn't, search around a bit... I do not recommend using SuperGRUB which will be repeatedly mentioned at the Ubuntu forums, it's failed numerous times for me, causing more problems than it's solved... Good luck :)

Link to comment
Share on other sites

Ok, I got grub to load up now, also added OSX to the loader. However when I try to load osx up it comes up with "HFS+ Partition Error". Have you everr eceived this error message, if so how did you fix it??
Hmm... i think i did once but don't remember how to fix it. Search for it here in the forum, but make sure you search titles only, i'm pretty sure you'll get a solution quickly...

Edit Try this?

Also, what dyou have in your Grub menu.lst for OSX? I think i just copied the stuff from Windows, and changed the partition [and name, of course :unsure:]

Link to comment
Share on other sites

Thanks for the link, just found it myself. I tried and sadly to no avail. I still get the same error. Do you think it could be fixed by just re-installing osx?
Hmm... i don't know... Could be worth a shot tho, particularly since it's a clean install [no configs/programs/etc... lost under OSX] and it doesn't take that long to reinstall OSX [it does on my old machine :D]. You're sure OSX is on a primary partition right?

It may also just be a setting in grub's menu.lst, or ...

I won't be back before tomorrow evening, i hope you're able to sort things out... If not, i'll try helping you further then.

Good luck :D

Link to comment
Share on other sites

Thanks for your help. finished re-installing it. It's a no-go.I'll check out the grub settings tomorrow. Thanks for everything.
Just to let you know, on my new system my grub entry is as follows [all OS'es on one physical disk]:

title Mac OS X

root (hd0,2) note: 3rd partition [on my only drive]

savedfault

makeactive

chainloader +1

 

the entry in my old rig, which has 2 disks: ubuntu + grub on one, OS X on the other:

title Mac OS X

root (hd1,1) note: 2nd partition on the second drive

makeactive

chainloader --force +1

 

I'd certainly try adding the 'chainloader --force +1' option to see if that makes a difference... I'm not sure why i added it, whether it was for the abovementioned HFS+ error or because of something else. It boots, that's all that matters :P

Link to comment
Share on other sites

*sigh* I just uninstalled Grub loader and have been using the Vista loader, still not working. I'l reinstall grub with those settings and let you know how I do. Thanks for the advice.Ok, just tried to boot os x with second entry you had for os.x and I get "Error 17: cannot mount selected partition". Is this because I used the wrong number partition?Also, when trying to boot into vista from the grub loader I get the error "bootmgr is missing" i've just tried repairing it with the vista installation cd but the error persists. HELP!

Link to comment
Share on other sites

*sigh* I just uninstalled Grub loader and have been using the Vista loader, still not working. I'l reinstall grub with those settings and let you know how I do. Thanks for the advice.Ok, just tried to boot os x with second entry you had for os.x and I get "Error 17: cannot mount selected partition". Is this because I used the wrong number partition?Also, when trying to boot into vista from the grub loader I get the error "bootmgr is missing" i've just tried repairing it with the vista installation cd but the error persists. HELP!
I've never used the Vista loader, so i don't know about that...

As for the partition number: remember Ubuntu counts the first partition on your drive as partition 0... You can use this information together with Gparted to see what partition number you should be using in grub. I think it would give you a different error if the correct partition were selected, unless something's really wrong with it...

Also, a read of the quad booting guide at osx86project.org could be useful to provide further insights and details for succesful quad booting :happymac:

Otherwise, i'm kinda running out of ideas :/ Hope things get sorted tho...

Link to comment
Share on other sites

Well, I finnally managed to get Vista booting fro GRub. Turns out that vista installed the bootmgr file and boot folder onto my C:/ partition which was XP. So I copy and pasted it across and it worked!! Shame I still cant get my mac to work....

Link to comment
Share on other sites

I am not sure but ..... shouldn't Darwin be able to load all other OSes if you are installing it last?
i don't think it boots Ubuntu... I'll give that a shot tho, it might just work... But Grub is very nice, very easy to repair in case something breaks/you need to reinstall any of the OSes, or if you add another OS, ... Also, I don't know how you'd reinstall Darwin, tho i'm sure there's a way :(
Link to comment
Share on other sites

Try this with GRUB:

 

I found it somewhere on the net, let me know if this help. This is for Suse but i guess this might help for Ubuntu

 

To add OSx86 to the GRUB menu do this:

 

1) Copy the folder "i386" from the OSx cd (which is located at /usr/standalone/i386)and put it in /boot/grub/ The i386 folder is hidden normally so ensureyou can see all hidden files in whatever operating system you are currently in. What I did is copied the files over in windows to a flash drive and then copied them from the flash drive to my home space and then used the following command in the terminal: cp -r /home/i386 /boot/grub/i386

 

2) Go To Applications > System > YaST

 

3) Go To "System" and select "Boot Loader"

 

4) Click "Add"

 

5) Select "Other System (Chainloader)"

 

6) Type in OSx86 for your Section Name and for Device select browse.

 

7) Browse to where you saved your i386 folder and select the chain0 file. This means you should have /boot/grub/i386/chain0 in the field where it says device

 

8) Click OK and you're done.

 

NOTE: If you try editing the menu.list file straight, it will not show OSx as a choice. You must initially use Yast in order to get the option to show in GRUB then if you desire you can edit it manually.

Link to comment
Share on other sites

Try this with GRUB:

 

I found it somewhere on the net, let me know if this help. This is for Suse but i guess this might help for Ubuntu

...

Yea that comes from the quad boot guide i mentioned previously in the thread... The problem is Ubuntu doesn't have YaST, so as far as i'm aware you have to edit grub's bootlist manually to get OSX/any additional OS that's not natively recognized by Grub running [without third party programs, that is].

I tried booting Ubuntu from the darwin bootloader and it did not work... Adding 'rd=disk0s5' as a boot flag didn't help, and since my linux partition is not shown by the it i can't just highlight it and hit enter :thumbsup_anim: I found an interesting post here tho which tells you how to escape the clutches of both Grub and Lilo so you end up using the Darwin bootloader for all OSes, including Ubuntu, but i find it to be a very work-around method...

 

Edit: I think i remember how i got around the "error 17: ...", at least in my computer - I changed the access mode for my hard drive from 'Auto' to 'Large', in the bios. But, i'd recommend you to check what setting yours in on, if it's anything but 'Auto', try setting it to 'Auto', if it is currently 'Auto', try changing it to 'Large'. This is, of course, a reversible procedure, so should one of your other OSes choose to no longer boot, you can undo it. Not that this should happen...

rest of original post:

nevadabob: Would you mind making a screenshot of your disk's partition layout [say, a screenshot from Gparted] and a copy of the menu.lst you're using for grub? I'm hoping this could help...

Also - in what order did you install all your operating systems? May be remotely relevant...

Link to comment
Share on other sites

Adding 'rd=disk0s5' as a boot flag didn't help

in linux it would not help cause disk0s5 is BSD style, linux style is [hs]d[abc...], in example - you have your HDD connected as PATA(regular IDE drive) to the first channel as master and you need to point 5th partition, the name will be hda5(h - regular IDE drive, a first channel master drive, 5 - 5th partition)

Link to comment
Share on other sites

 Share

×
×
  • Create New...