Jump to content

HP A6120N Installation Notes

time ed

15 posts in this topic

Recommended Posts

[Mods: I'm not sure if this belongs in "Hardware/Drivers" or the FAQ wiki. Please move if necessary.]


This is an off-the-shelf box I picked up at Circuit City. I chose it because the hardware seemed compatible with the HCL, and it was on sale.




Socket 775 Core 2 Duo E4400 (2Ghz)

800 MHz FSB

Northbridge: Intel 945G

Southbridge: ICH7DH (RAID 0,1,5,10)

2Gb 667 MHz PC2-5300 (max 4Gb)

Onboard graphics: Intel GMA 950

Four SATA connectors

Onboard audio: Realtek ALC888S

Onboard NIC: Intel 82562V (Ekron-N 10/100 Mbps) recognized as Intel Pro/100 VE


First things: this machine comes with v5.17 Award BIOS customized for HP. There is no way to configure power management in the BIOS other than either on or off. I left it on. Also, you must set the SATA controller mode to ACHI (it ships configured RAID 0).


Next thing: I couldn't get the JaS distro to load. Booting from the DVD, the box kernel paniced with AppleACPI.kext having no dependencies, then crash. Not knowing how to work around it I moved on to Uphuck.


Last thing: as this was going to be a Vista dual-boot box, I decided to do things backwards and configure the Windows boot loader in advance using bcdedit and chain0 from the Uphuck distro. Doing it this way saved a lot of time in my opinon.


Uphuck v1.4i(r2) with 8.9.1 kernel fully installs in about 15 minutes on this machine. I included SpeedStep in the installation but SpeedStep crashes on start up [devs: email me for the dump logs if you're interested]. Here's the relevant snip from the system logs:

Jul 29 05:06:40 rockford-box kernel[0]: ACPI CPU Throttle loaded

Jul 29 05:06:40 rockford-box kernel[0]: ACPICPUThrottle: Adding CPU0

Jul 29 05:06:40 rockford-box kernel[0]: ACPICPUThrottle: Failed with code -536870212

Jul 29 05:06:40 rockford-box kernel[0]: ACPICPUThrottle: Adding CPU1

Jul 29 05:06:40 rockford-box kernel[0]: ACPICPUThrottle: Failed with code -536870212

Jul 29 05:06:40 rockford-box kernel[0]: ACPICPUThrottle: Adding CPU2

Jul 29 05:06:40 rockford-box kernel[0]: ACPICPUThrottle: Failed with code -536870212

Jul 29 05:06:40 rockford-box kernel[0]: ACPICPUThrottle: Adding CPU3

Jul 29 05:06:40 rockford-box kernel[0]: ACPICPUThrottle: Failed with code -536870212

Jul 29 05:06:40 rockford-box kernel[0]: ACPICPUThrottle: No valid CPUs returned by ACPI! It's possible your BIOS does not think your system should be

throttled and therefore did not return any available power states, or maybe your CPU only supports one other power state than maximum which is below 1Ghz!


Jul 29 05:06:55 rockford-box crashdump[482]: SpeedStep crashed


Along with the core Uphuck 10.4.9 install, 8.9.1 kernel, and SpeedStep, I loaded GMA950 drivers, Intel Pro/100 drivers, MacFUSE, the extra applications and nothing else. Everything but audio and network worked at start up. I got audio working with the ALC88x kernel extensions linked from the HCL (the release notes said it would only work with the 8.8.1 kernel, though). The box did not recognize my display (Samsung 226BW) but I had a full complement of resolution selections.


The NIC does not work. I've scoured the forums and posted here about it, but I think I'm SOL.


I decided to update to 10.4.10/8.10.1 kernel using the latest updater from Koolkal. After the update, the only display resolution is 1280x780 and audio no longer works. Network still does not work. The box, however, screams!

Thanks and best regards,



[EDIT 8.9.07]:

- The Speedstep problem is a BIOS problem. The BIOS is stripped down by HP and doesn't allow access to power management features.

- The resolution problem was caused by me forgetting to restore the AppleIntelIntegratedFramebuffer kext after running the Koolkal update.

- There simply is *no* driver for the Intel NIC.

- Toruga posted some ALC888 drivers - they work! http://forum.insanelymac.com/index.php?showtopic=36520


[EDIT 8.27.07]

- Reinstalled 10.4.9 with Uphuck 1.4i(r3). Uphuck 1.4i(r2) will not run Rosetta applications if Quicktime is updated to v7.3.

- I did not install Speedstep this time.


[EDIT 9.15.07]

Updated the OS to 10.4.10 following Koos tutorial: http://kaspers.freeflux.net/blog/archive/2...10410guide.html

During the update, I changed the kernel to Netkas 8.9.1.


[EDIT 11.13.07]

I've had several folks PM me, asking how I installed the GA311 (see Post #2, below). After the physical card installation, I booted the Uphuck DVD, ran the Installer and installed the R1000 drivers found under Drivers >Network >Realtek. Reboot. When the desktop loaded, I opened System Preferences >Network and added some DNS entries. That's it.


[EDIT 11.25.07]

- Updated to 10.4.11. First, I downloaded the Intel-only update from Apple, then I backed up the usual kext's and kernel. During the update I tried upgrading the kernel to 10411.hacked.nopc_efi from IRC#10.4.11. The kernel panic'd at AppleACPIPlatform.kext. I could not boot into single-user mode. I booted the Uphuck DVD and restored the 8.9.1 kernel and system.kext through the terminal. The system booted but I lost sound. I reinstalled the Toruga drivers.

- I have not installed EFI. I kept the vanilla 10.4.11 kernel and system.kext in the event I do.

Link to comment
Share on other sites

I have an HP A6113W with I believe to me the exact same specs as you listed. I also have the problem of SpeedStep crashing plus the remaining issues you have. To get sound working I installed azalia which is located on uphuck's install. One question did you get sleep working? I "almost" got close, but the monitor would only return to a solid blue screen. Also delete and reinstall/fix permissions on your graphics kexts and you "should" be able to gain your resolutions back.

Link to comment
Share on other sites

Wow, it is the same box:



Did you get to 10.4.10? If so, any details or gotchas?


Thanks for the Azalia tip. I did get audio working wit some ALC kexts I found in the forums, but its flaky. I'll try that tonight.


Did you replace your NIC?


I figured out the graphs problems with 10.4.10 the hard way as well. There are two threads covering .10 installation - one in this forum and one in Post-Installation. Between the two I found out there is a framebuffer kext that needs to be backed up, plus the other graphics drivers. I got it working last night and installed Parallels. Everytime I tried to start it, it crashed the OS. I didn't trust the uninstall, and so reinstalled 10.4.9.


Tried VMWare Fusion after that. I don't know whats up with it. It was slooooow, unresponsive, and kept both cores at 50%. VMWare tools didn't install properly and locked up the VM. I finally backed the application out to give the processor a rest. I guess I have much more reading to do on both Fusion and Parallels. But I need one or the other to work.


No, I still have the same problems with sleep. I would rather get audio, SpeedStep and virtualization working first....

Link to comment
Share on other sites

I installed a cheap Network Everywhere NIC that I found at Wal-Mart (model no. NC100U-WM). It works like a champ with tulip.kext installed. I did update to 10.4.10, but only after reinstalling 10.4.9 and waiting to update the graphics, audio, etc extensions. Only after I installed 10.4.10 did I install Azalia, GMA 950 support, ICH7, etc. I used the 10.4.10 update for hackintosh found on the bay.


I am currently using the onboard Intel GMA 950 for graphics. It's working like a champ as well with maximum resolution 1680x1050 on my monitor with core image and quartz extreme supported. I tried an ATI Radeon x1300 but I could never get the DVI port to work, only VGA. I also recently purchased a GeForce 5200 PCI card that had working DVI, but the resolutions given were {censored} after using Titan.kext and Natit. So I am sticking with the good 'ol GMA 950 for the time being. What card are you using?


Don't think I can help much for virtualization. I have Windows Vista running on a seperate 168.55 GB partition and OSX running on a 204.5 GB partition. I boot using Darwin's bootloader and it works perfectly! (much to my surprise)


Lastly, I managed to get sleep working beautfully last night. The problem was that console was spitting out some sort of problem with the USB root hub? Therefore the computer was actually sleeping and waking, but my USB keyboard and mouse were not functioning due to the hub problem. Oddly enough, my USB external drive and flash drive were still operating properly when I checked using my PS/2 mouse. So, to solve the problem I stuck a cheap 5 USB port PCI card in and plugged the non-functioning peripherals into it and they now work nicely when the computer wakes. There is about a 20-30 second delay before my monitor wakes though, which is sufficient for me.


I haven't really looked into the SpeedStep problem yet, but please let me know if you find anything! One more thing, if you haven't all ready installed 4 GB of memory in your machine do, OSX practically flies!

Link to comment
Share on other sites

I've been trying to use the KoolKal 10.4.10 updater. My core distro (Uphuck) includes ICH7R. Is that the driver you used? I have ICH7-DW on my board, and I'm not clear on the difference so I didn't install it. Does it make a difference?


Did you install the 8.10.1 kernel?


I'm sticking with the onboard GMA950. It works very well and I have max resolution, too. How can you tell about QE/CI?


I have the same partition set up, except I stuck with the Windows bootloader. It was easy to configure the bootloader in advance of installing OSX, and it worked well after the install. I only had to edit Boot.plist after the initial install. I guess I can install XP in a local VM, but it would be ashame to waste the Vista install.


Maybe sleep is working on mine. Once I wiggle the mouse or tap the keyboard I have the 20-30 sec delay, then the blue screen for 20-30 secs, then the desktop renders - sometimes. The whole thing has locked up on me before.


I've saved the crash logs from SpeedStep in the hope I can get one of the devs interested. I found a CPU throttling thread in The Genius Bar, but I'm having a hard time following it.

Link to comment
Share on other sites

I am not quite sure what 10.4.10 distro I am using. I just used the first one I found on the bay and prayed for the best. I think it is Pascal or something if memory serves me correctly. I did install the ICH7 driver from uphuck's install. I am also not sure if it makes a difference...to be honest I am not quite sure what ICH7 is? Forgot to mention previously that sleep works on mine by momentarily pressing the power button (or waiting for the machine to sleep) and then pressing it again when you wish to wake the machine. Mouse clicking or keyboard tapping doesn't work on mine in regards to sleep/wake.


To check for QE and CI just click the displays option under system profiler. If either is supported it will simply say QE: Supported or CI: Supported.

Link to comment
Share on other sites

  • 5 weeks later...

time ed. Do you really have to set the ACHI to install Uphuck? If so this means you had to reinstall Vista right, start from scratch? Did you delete your recovery partition? If so did you back it up. Did you re-install Vista from the recvery CD's you made or did you have anopther copy. I just got my computer and I'm wondering what decisions you made because I have to make some tough ones. Thanks for any response.



Link to comment
Share on other sites

  • 4 weeks later...
time ed. Do you really have to set the ACHI to install Uphuck? If so this means you had to reinstall Vista right, start from scratch? Did you delete your recovery partition? If so did you back it up. Did you re-install Vista from the recvery CD's you made or did you have anopther copy. I just got my computer and I'm wondering what decisions you made because I have to make some tough ones. Thanks for any response.




Yes, I did have to set ACHI to install Uphuck as there is no RAID support in osx86; and no, I didn't have to reinstall Vista.


Here is how I installed:

1. carve out an osx install partition from existing drive.

2. boot into the BIOS and set drive controllers to ACHI.

3. reboot into Vista. When the desktop loads, Vista will warn you about loss of RAID support. Continue on. Vista will recognize the drive controllers, load the appropriate drivers and update (as far as I know) the recovery partition. Reboot again.

4. extract chain0 from your osx distro and set up the Vista bootloader to dual boot. Follow any of the dual-boot tutorials.

5. install osx. After the install, and before you reboot, modify boot.plist timeout to something like 30 seconds.


After a week of dual booting I got sick of it. I only keep Windows around for that *one* app that isn't supported on linux or osx, and I really didn't like Vista anyway. But before I blew the whole thing away, I bought a copy of VMWare Fusion and downloaded VMConverter from the VMWare site. I ran Converter over Vista and turned that install into a virtual machine (takes a few hours). Afterwards I backed up, deleted all partitions (including recovery), and reloaded osx. With osx running, I installed Fusion and copied in my Vista VM. Perfect (for me). Now I have Vista on my desktop in Unity mode and I never have to reboot.

Best regards,


Link to comment
Share on other sites

Thanks for your reply time ed. I should install it soon I'll let you know how it goes. One more question how do I modify boot.plist. I am completely new to os x. I may try using it on vmware on vista first just to see. I'm sure I'll like it but am unsure if it'll work though your giving me a bit more confidence.

Link to comment
Share on other sites

Editing the timeout:

Go to Applications/Utilities and open Terminal.

In the terminal, type sudo -s and enter your password.

At the next prompt, type: textedit /Library/Preferences/SystemConfiguration/com.apple.Boot.plist

scroll down to <key>timeout<key>, and next line down (<string>5<string>), change 5 to some value like 30.

Save and close.

In the terminal, type diskutility repairPermissions /

When Disk Utility is finished, exit Terminal.

Next time you reboot, you'll have a 30 second time-out before Darwin loads.


It is possible with VMWare to boot an existing physical Windows installation. I would go this route if you are testing, or do not want to fool with VMConverter or reload your box or care about recouping disk space. Surf to VMWare, register, and download the evaluation copy of Fusion. Install the app and follow the instructions for booting a phyiscal installation.


Mind you, VMWare will not work for high-end gaming (well it might, but I've never seen it sucessfully done). For anything else, its the shizzle.


One more thing: if you *must* have Windows, and you're worried about preserving your Windows installation, and you have an extra $100, I would do this: surf out and download a Vista key extractor and back up your original product activation key. Then, buy yourself a copy of Vista Home Basic Upgrade. You can do a full, clean reinstall of any Vista installation with that and the right product key. Follow these instructions: http://blogs.zdnet.com/Bott/?=196



Link to comment
Share on other sites

time ed,


I chose IDE then Enhanced instead of combined. Its seems to be installing fine.


Why ACHI over IDE? Its still Sata? Can I change it back to ACHI after the MAC OS X install? I am installing using JAs 10.4.8 then using the Apple sites 10.4.9 updater then followed a tutorial in the tutorial section on what to back up in extensions and put back into extentions before you reboot.


Anyhow I did not take a chance and set it to ACHI instead. WIll IDE work to? Its sais its still SATA and then you have an additional choice of Combined and Enhanced and like I said on the first line of the paragraph I chose Enhanced.


Anyhow I have the P5LP-LE Asus board to. I forgot to choose GM950 and chose GM900. I was reading that the 900 seemed to work better over the 950 , but you have full support with 950?


I went out and bought a Linksys Wireless-N WMP300N. It has the broadcom chipset but not the 440x but 43xx chipset. Hope I can get that to work and if not I iwll take the above post and look at the netgear one. But I want wireless to.


I will be inserting a Nvidia 7300 GT shortly. THat is 100% compatible.


Not sure why the Built in Pro 100 does not work. THeoretically it should?


Anything else I need to look out for? I also chose the Az... Audio in additional drivers. Also chose Enhanced and X11 and Intel only Login WIndow 10.4.4.





Wow changed it to ACHI, and this time during the jas 10.4.8 install I chose the GM 950. The 900 did not work. Got half blue screen chopped up with the 900 kext.


THe Wireless I mentioned works 100%.


Question even though I see it list the Processor as 1.87GHZ core 2 then it sais two but does not list them seperately. How do I know if both are working? If I press F8 during the boot then -v for verbose I see it say enabling both processors but then I see something where it sais 1 CPU. BUt thats during the console boot so who knows.


My AUdio still does not work. What do you recommend?


Do you get the Onboard Ethernet to work? Nto sure if its the same as mine but it shoudl be since we both have the 945GV chipset.

Link to comment
Share on other sites

Will a Quad Core Q6600 work in on this motherboard or it will it need a bios revision?



Also which memory will work in here? I have 2 gigs of PC2 5300, 667MGZ. I was told that this new german comapny makes good memory not sure? Aeneon? I can get two more 1 gig stick for $75 US is that a good deal.


Sorry about the last post its large but please read them and when you get a chance reply to that one and this one together if you want?



Link to comment
Share on other sites

time ed wrote :

Toruga posted some ALC888 drivers - they work!


Could you point me to them?


If I install a netgear NIC down the line will OS X take care of the installation or is their some procedure I need to follow?


Thanks in advance.

Link to comment
Share on other sites


Toruga's audio drivers:


The GA311 is just a PCI NIC. It has a Realtek chip. There's nothing special you need to do to use it.



- I can't see where you noted your audio chipset so I don't know. Unless its something out of the ordinary, Azalia works with just about everything. See above.

- Can't tell you anything about your processor, either. The Uphuck distro I run recognizes and reports both cores of the processor on my board. I've read in other threads that some processor/distro combos won't work, or don't recognize correctly. It seems common. Don't know what to tell you about a quad core.

- The type of memory seems correct. I don't put too much thought into buying memory apart from what's required by the MB. The HP box I have came with 2G. I was browsing in Best Buy one afternoon and noticed 1G sticks of Kingston on sale for $40 so I bought two.

- I think I mentioned there is no driver for the ethernet chip on my MB, hence the GA311.

Link to comment
Share on other sites

  • 4 months later...

  • Create New...