Jump to content

Vista Dual Boot Issues


12 posts in this topic

Recommended Posts

So i'm trying to dual boot Vista and osx86 but with little success. The system is a Dell XPS210 with SATA HD and SATA optical.


To simplify things i deleted the 2 utility and restore partitions on the HD.


I'm cutting down all the processes a little here but this is the lowdown


Vista installs and works fine on it's own

OSX86 "jas 10.4.8 intel only" works fine on it's own


I partitioned the disk in half

Installed vista on part1

Installed OSX86 on part2


osx86 reports HFS+ disk error on boot

i set part2 to active and OSX86 boots

but now Vista won't boot

I repair the vista install and vista now boots but osx86 won't


I install chain0 into vista root, run bcdedit to create a dual boot

On restart the boot screen appears i select osx86 but the screen just reverts back to the boot screen. The keyboard is locked out at this point and the boot screen eventually times out and boots vista


I double check my osx86 install by setting part2 to active and it runs fine but vista won't load etc etc...


So i'm kind of going round in circles.


i swear i am missing a simple trick. i need some out of the box thinking because i'm stuck in a rut

Link to comment
Share on other sites

Easy BCD hasn't changed my situation unfortunately.


I deleted the old OSX boot entry and replaced it with a new one from BCD. I save, i restart and select OSX. the boot loader reappears, my keyboard doesn't respond and it eventually boots into vista.


I'm thinking that maybe the MBR settings are wrong but i'm still unsure. Is it just a case of marking part1 as active and part2 as normal or is there more to it?

Link to comment
Share on other sites

Sorry i didn't explain it properly. The keyboard works fine as i can select OSX from the boot menu. But when i select osx the screen goes blank for a few seconds then the boot menu reappears again. This is where my input devices don't work. But this ins't the real problem this seems to be more of a symptom from a bigger problem and that is that OSX won't boot from the Vista Boot Loader

Link to comment
Share on other sites



I'm having this same problem too! It's really annoying. I've tried to use both dawrin's bootloader, chain0, AND easyBCD with no success. Basically this is what happens to me:


- Installed Vista

- Installed OS X

- Both work fine on their own

- However, when i set the Vista partition as active again, Windows won't boot because of winload.exe

- Then i boot into Vista's DVD and repair

- Vista is fixed

- Then OSX won't boot anymore (Vista's boot loader will go black when i pick OS X, and then go back to the boot loader after a second)

- So, I set OS X's partition back as active and reboot.

- HFS Partition Error.

- Booted into OS X's single user DVD, update MBR and restart

- OS X works.

- Go back to the fourth one.


Any ideas?




Link to comment
Share on other sites

I too am having this problem. I had the dual boot working perfect with easybcd and neogrub last week then i made a mistak eof letting my 10.4.8 try upgrading to 10.4.10 a total disaster. Well anyways this led to a total reformat. PS vista -- osx dual boot. Well i have osx on first part and vista on second partition i can get both to work by disk part exactly as you guys have emntioned. Easy bcd wont work.. neogruband the stag1 and stage 2 files wont work and the chain0 gives me the same result black screen where the cursor moves down on the left side 2 inches then back to the vista boot loader. I really cant remeber what i dod last time but it worked perfectly. I almost remeber using neogrub but i remeber putting the stage files on the mac partition . Can anyone help us. I have been working on this for the last 4 hours. I will post when i get it!!!


P.S. there was a tutorial on what i did the first time and that worked perfectly, but i cant rememeber what i did.

Link to comment
Share on other sites


when you select osx in your vista boot menu, quickly also press F8; hopefully you'll then get the menu of the darwin bootloader, from which you'll be able to select osx.


the darwin bootloader tries to boot the active partition by default, which would be vista's in your method.


to avoid having to always press F8, once you're in osx follow these instructions from the osx86 wiki: Messing with the boot options.


i hope this'll work for you.


alternatively, and to avoid the redundancy of the boot menus (ie having to select osx in both bootloader menus), read devilhood's tutorial, where he has some advice for dualbooting vista and osx.

Link to comment
Share on other sites


  • Create New...