Jump to content

Geforce Go Series (Internal Laptopdisplay)


7 posts in this topic

Recommended Posts



I'm using Jas 10.4.8 with Semthex Kernel 8.8.1 on my Laptop "Toshiba Qosmio G20"

Intel Pentium M 1,8 GHz / 1GB RAM / NVidia Geforce 6600 Go (128MB)


Everything works fine ... Video works fine too with MacVidia Drivers but no QE/CI Support


But i wanted to have the full experience with QE and CI so i tested...


Got it working on an external screen with qe/ci... but the internal screen is still offline/black...


That is what i tried ...


-Different Combinations of QE/CI enabler:


TITAN (only) different Versions

NATIT (only) different Versions: dual, mobile, etc..

NVidiaEFI (only)


TITAN with NVidiaEFI

TITAN with NVidiaEFI and LaptopDisplay



-I tried different Versions

-get my EDID via MonitorInfo.exe (Windows XP)

-Entered EDID in DisplayUtil

-moved Folder to Display/Overrides/


-IOGraphicsFamily (PowerSaving issue?)


-Changed the IOGraphicsFamily.kext with the one from "_np"


-Titan & Natit


-Switched EDID Informations from 0->1 and 1->0


-The 6-12 Trick with VGA D-SUB



-doesnt work for me...




Starting the System with -v (Verbose Mode) shows me...


NVDANV40HAL loaded and registered.

IOPanelDevice: Machine is Laptop!

IOPanelDevice: Registered OK!

LaptopPanelA: Started OK!


Titan: By omni, built November 4, 2006

Titan: Testing fpr NVidia card...

Titan: Found NVIDIA GeForce Go 6600

Titan: All Set, cross your fingers!

NV: NVidiaEFI Support Version 1.0.2, build 1002071310

NV: Internal LCD Panel Detected on Output: A, Head N:0

NV: Internal LCD Panel Max Resolution: 1440x900

NVDA::start(VGA) <1>

NVDA::start(VGA) <1> failed


Now i have no idea what i can do to bring the Internal Display to work...

I've read in some forum posts that user have bring these issue to work...


Any feedback is welcome...

Link to comment
Share on other sites

I think its an Laptop issue ... The Graphics Adapter is not the problem...


Looks like the behaviour of "External Monitor Output" and "Internal LCD" Management isnt supported with the qe/ci enablers like titan etc.


But its strange that the MacVidia Drivers work...

Link to comment
Share on other sites

  • 5 months later...

I think I can line up in this thread with similar hardware and same problem... I just posted in _np's Laptop Display thread, but I'll check out this thread aswell. Also james2mart seems to have a Qosmio... I also nearly tried all driver combinations together with the LaptopDisplay, IOGrapicsFamily and the Display Overrides fed with my EDID of internal Display...


check out my full description here:



Link to comment
Share on other sites

  • 8 months later...
  • 1 month later...

  • Create New...