Jump to content

convert FAT32 to Mac OS Journaled


10 posts in this topic

Recommended Posts

Actually when i try to install osx in x86 "disk utility" is not convertin my 20gb fat32 partition into "Mac Os Extended Journaled" format


so is there any utility for windows which can convert a fat32 partition into "Mac Os Extended Journaled" partition


pls help me out guys

Link to comment
Share on other sites

Let me help out, asking for help at the same time.


People, I am in a pre-nervous wreck. please help me preserve my sanity.

I was totally new at this, but managed to install a dual boot - check my sig !!


Then I :( up the OSx trying to help wireless development (Jalavoui ROCKS! :thumbsup_anim: )


No problem, I thought. I´ll just wipe the whole thing, start fresh... 2 hours TOPS I will

be up and running...


ITS BEEN 4 DAYS NOW !! Please please someone help!


The problem Coolquaser is having is the same as mine. The partition will not mount, hence


OSx will not format to extended journaling. The first time I tried (and got it right!!!), I must confess that I was so excited, so little sleeped and caffeine driven, that I cannot recall exactly what mistakes/corrections I made. But many were done, I even got all excited and wrote up this thread to help others with install problems !! (ebios, mounting, etc)





I wrote in there to beware of the 1024 cylinder boundry (partition boundry to be bootable drive) -

What is this boundary ?! How to go around it ? What size in MB is this boundary? Surely I did it

before so I could do it again, I dont want a (for example) a 8 GB OS system !!


when I had to start over... i dont understand how upon first install I had


XP - 50gb ntfs

OSx -50gb fat32 (mac os extended journaled)

Storage - 50 gb fat32 common storage place


I used the darwin bootloader, tweaked to 30 sec timeout with the apple.Boot.plist - everything was perfect !!


So the question is - does the OSx partition HAVE to be below the 1024 boundary WITHOUT using bootloaders like acronis etc... I tried then, they are ugly, very little reliability... and heck I GOT IT BEFORE WITHOUT THEM !!


These last days I managed to format, partition, install xp, check errors, trying OS... I killed a ONE WEEK OLD HITACHI DRIVE !! I sent it back and got a brand new seagate 100GB I would love NOT to assasin.


what am I (we) doing wrong?




Ps: Is it possible, maybe it was what I did by accident... to partition before this boundary, the partition again the rest of the drive in 50% ntfs/fat32, and then append these to the under-1024-partition, thus creating two "virtual" partitions that can boot?

Link to comment
Share on other sites




Hi again. Found a possible answer! And pardon my lack of tecnicallity !


I managed to install a new dowloaded Jas 10.4.8 and intel sse2 sse3 ppf1 ppf2.

My first success is im my sig! But this install, on reboot to customize personal settings, before the 1000 hello's in all languages... My screen is shrinked to a small center bar on the screen, no mouse support!



SO now, at least, I managed to format extended journalled plus mount and install. Right now trying my sig's ISO.


How I got here? after 2 days with NO sleep, one assasined Hitachi drive due to so many reformats, partitioning and installs (about 17 tries, 2x7 times zero out) - yey for refunds! :thumbsup_anim: - New seagate 100 GB 72,000 rpm :gun:


So, blanck drive, Xp install NTFS format WHOLE drive.


1 - Install XP, install Part. Magic 8.

2 - Partition drive (I did 50Gb/50Gb) for OSx, after XP




here is where I got my problems, and I have no tecnical knowledge, so pardon me if I say something "wrong". There seems to be problems with OSx and extended drives. In partition magic, many times 2 small 8mb partitions are created in the beggining and end of drive, sometimes just one of the ends. Please mind I have been up 2 nights straight blown in caffeine!

I've made them unallocated, hidden, fat16, 32, ntsf.... poor poor hitachi... I respect thy efforts, pardon me... anyway, nothing worked. Followed every singles step by step guide, wiki, etc. Never was able to simply get rid of them, or merge them. People made reference to them as being normal, and they ARE, bup depending on bootloading, maybe it's just the other way round - you CANT have them.


This is because this time round, steps 1 and 2, and then I have


Part 1 - XP

Part 2 - unallocatted

part 3 - unallocated 8mb (extended I think)


Step 4 - Format partition 2 -> Fat32 Primary (not active)


This made my partition 2 merge with the last 8mb on extended, or unallocated partition. Was left with 2 simple halves.

Had to reboot, Xp loaded nice.


step 5 - Reboot with Tiger installer DVD

step 6 - Disk Utilities should now find the drive, after I MacOS Extended Journalled it, mounted and installed. (as I speak, just finished installing my sig's ISO, no video problems !!) :tomato: - rebooted !! dandy... going on to edit boot selection timout.


Hope it helps !!



Link to comment
Share on other sites

hey which disc are you using. I had a problem with the Jas 10.4.8 SSE3 only install DVD. DO NOT USE THIS DVD To format your hard drive.


I have a 160GB partition. 30 GB dedicated to OSX, 100 dedicated to windows, and another 30 for a shared volume that OSX and Windows can both access just in case I need to transfer files to each of the parititions. I used the Jas 10.4.8 SSE3 DVD to install to my computer and to format the drive as I was using an older version of OSX. It formated the drive and installed as normal. But when I restarted I got a boot error. I used my utility cd to check to see which partition was made active sometimes the OSX partition is marked Active. So to my horror. I had Unallocated space of 160GB. All the partitions were gone!


I had to recover them one by one. Do now use this CD to install format your drive.


Also the way I understand it, is that OSX has to be first. it has to be installed first. That is what I did.


I formatted my drive clean, installed OSX first. and then installed windows.

OSX cannot be on a Logical drive or Logical Drive with in a extended partition. It must be primary. If its not primary it wont boot.

I hope this helps everyone.

Link to comment
Share on other sites

My experience with this is, that the partition table is corrupt.

I'm having the same problem right now, but i'm leaving it this way, since OS X is up and running.

To fix the partition table, you can use Partition Table Doctor.

Do not try this if you have Mac OS partition, since that partition will be recognized as empty space, and will be saved as that. And that means, the data will be lost.


If you only have fat32, ntfs and linux partitions, it's 99% save.

After restoring it, you should be able to format partitions through disk utillity.


Another option

Use Acronis Disk Director Suit, it can format a partition to almost every format (also mac os formats), with this utill you can format even if the partition table is corrupted.

It can be found on Hiren's Boot CD.


Best would be to try Acronis first!


Hope this helps ;)

Link to comment
Share on other sites

  • 5 months later...



Any idea how you managed to convert Windows Fat32 to MacOS Extended (Journaled) on DiskPart Utility.


I know its a command line but I don't know what to do.


Please advise as I am having the same problems you were having with formatting FAT32 to MacOS Extended (Journaled) on Disk Utility.




Link to comment
Share on other sites


  • Create New...