Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
lu0s3r322

chain0 chain boot error

12 posts in this topic

Recommended Posts

i've searched the forums but i really havent found any formal solutions to fix the chain boot error message tha comes up in some of the tutorials like the profit42.com and andrewescobar.com tutorials

 

i've seen people talk about how they use ubuntu live cd to change the partition type,but i have no idea what that is.

 

is there any way to fix the problem without having to download anything? if there isnt, whats the easiest way to fix it?? cause ive been stuck on this for hours.

Share this post


Link to post
Share on other sites

You forgot to set the partition type to AF

Now you must change it

u can use a linux distro on CD like Knoppix or LimuxCare and with fdisk change the partition type to af

do it carefully withot mistakes on the partition (if u have a multiboot)

Share this post


Link to post
Share on other sites

hey ive had a similar problem

i cant boot from grub or using the chain booter

in grub i get like an unsupported executable format error, chain boot error from winxp chain0

i used the vmware image dd'ed to a partition. i didnt make the partition with diskpart but i used paragon hd manager to set the type to AF and it still wont boot! what should i do next?

Share this post


Link to post
Share on other sites

well i partially fixed my problem. i had changed my partition type to AF after dding the image but i dont think that affected it. however installing darwin on the AF partition worked! so i decided to restore macosx to my darwin partition using vmware. this works well, however i get a file missing error at the end of the restore and when i boot, i get the you need to restart your computer error. safe mode fails as well but silently, mouse moves but nothing happens. using verbose regular mode i found it crashes right after it says displaying vram[c000-00000] or whatever right before you would normally see the mouse and blue background pop up.

 

any ideas on what's gone wrong in the restoration process (NOTE I moved TPCMACPI.kext to trash for boot but then put it back for restore so thats not whats missing)

Share this post


Link to post
Share on other sites

well i still have no idea what went wrong with restore! however i did delete some extensions in single user mode to fix my graphics problem.

Safe mode remains the same blue screen and mouse.

regular mode gets past gray startup screen but does nothing after showing the mouse and the macosx progressbar.

it never says starting macosx and the bar always stays empty and nothing happens. In both safe and regular mode you can move the mouse around but besides that its pretty useless.

 

edit -- booted into single user mode and started system with sh /etc/rc and i get netinfod errors:

1) file_init failed 2) ni_init failed 3) start_service error 4) then it exits for a sec and tries and fails again.....

also memberd cant find the root user.

these errors dont make sense to me because the filesystem is already mounted and you are logged in as root at this point. anyways i suppose that this might be happening behind the scenes at the frozen startup dialog with the apple logo

Share this post


Link to post
Share on other sites

well, I have an sse3 processor so I used maxxus's 0.5c patch to repatch my system for sse3 suppport because Im using deadmoo's image. However I dont know how to replace mach_kernel or whatever to the old version.

BTW- fixing it using the patch allows me to get past the loading dialog to the login dialog, but i can't login and Ive tried everything (and yes i know deadmoo's password is bovinity!) so im worried that this is related to the netinfod errors

any thoughts???

 

edit - found mach_kernel.old and replaced mach_kernel with that and now I can't even start osx fully! using verbose mode i get apple acpi errors and platform=x86pc fails as well.

Share this post


Link to post
Share on other sites

ok well I have fixed the kernel problem by using the old sse2 one however i think that now when i boot the unpatched one it reverts to the see2 kernel becuase it is saved as /mach_kernel

in any case i cant login from the gui or in single user mode when i run login.

typing passwd by itself yields su: who are you? and trying to change root's or curtis's password always yields sorry (cant change them).

 

edit - dled original kernel, replaced it and it works but I still cant log in

 

edit edit - ya i fixed it, had to remove /var/db/netinfo/local.nidb

Share this post


Link to post
Share on other sites

hi.

i have that chain loader error too. I've tried everything....easyBCD, acronis OS selector...i even messed with that bcdedit and did every successful...my osx partition is indeed primary and it is type AF! I have the boot menu set but when I choose OSX...i get that Chain loader error!

 

please help, I'm trying to solve this problem 3 days now!

 

:wacko::wacko::wacko::wacko:

Share this post


Link to post
Share on other sites

i tried to dual boot with hack attack guide and when all seem to be fine, i choose mac os x in the boot and i get a message that say "chain boot error" :blink::wacko: :wacko: :wacko: :wacko: :wacko:

 

what did i do wrong?

Share this post


Link to post
Share on other sites

chainboot error = no mac partition found, you can fix that from windows commandline with

diskpart:

 

DISKPART> detail part

 

Partition 3

Typ : 07

Versteckt: Nein

Aktiv : Nein

Offset in Byte: 32256

 

Volume ### Bst Bezeichnung DS Typ Größe Status Info

---------- --- ----------- ----- ---------- ------- --------- --------

* Volume 1 Snow Leopar HFS P Partition 100 GB Fehlerfre

 

DISKPART> set id=AF

 

Die Partitions-ID wurde erfolgreich festgelegt.

 

ID=07 means the partition is flagged as NFTS.

select the mac volume and set the ID to AF (AppleFileSystem). problem fixed.

The chainboot error applies typical for restored backups.

 

 

i tried to dual boot with hack attack guide and when all seem to be fine, i choose mac os x in the boot and i get a message that say "chain boot error" :(:):):):P:wacko:

 

what did i do wrong?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Posts

    • You can try this one here 2.9.0 let me know if its better for you ?   VoodooHDA.kext.zip
    •   Boot option name retrieval 1) Locate the booter image as explained blow. 2) Locate ".contentDetails" in the parent folder 2.1) if unsuccessful, locate ".disk_label.contentDetails" in the parent folder 2.2) if unsuccessful, retrieve the volume's name   HFS Boot 1) Retrieve blessed file via https://github.com/CupertinoNet/EfiPkg/blob/development/Include/Guid/AppleBless.h#L41 1.1) if unsuccessful, retrieve blessed folder via https://github.com/CupertinoNet/EfiPkg/blob/development/Include/Guid/AppleBless.h#L45, append "\\boot.efi". NOTE: This is broken in the latest binary I checked. 1.2) if unsuccessful, use the following hard-coded paths: "\System\Library\CoreServices\boot.efi", "\EFI\APPLE\{ARCH}\BOOT.EFI", <StandardEfiPath>, "\\boot.efi" in this order 2) FV2 Recovery does not follow the usual practice because it is not shown by BootPicker anyway. Determine it via https://github.com/CupertinoNet/EfiPkg/blob/development/Include/Guid/AppleBless.h#L49, verify it does not match 1).   APFS Boot 1) Determine the APFS Volume Info (and hencefor detect whether it is APFS in the first place) via https://github.com/CupertinoNet/EfiPkg/blob/development/Include/Guid/AppleApfsInfo.h#L54 1.1) Determine the APFS Container Info via https://github.com/CupertinoNet/EfiPkg/blob/development/Include/Guid/AppleApfsInfo.h#L36 1.2) Verify the Volume Role via https://github.com/CupertinoNet/EfiPkg/blob/development/Include/Guid/AppleApfsInfo.h#L51 1.3) Retrieve blessed file analoguous to HFS 1). NOTE: This step and 1.3.1) are broken in the binary I checked, hencefor it does not happen, but is probably supposed to. 1.3.1) if unsuccessful, retrieve blessed folder and append the booter name the same way as in HFS 1.2) 1.4) (if unsuccessful,) locate all Volumes that are part of the same container, check whether the current Preboot partition has folders named by the just located Volumes' GUIDs and append the hard-coded paths from HFS 1.2) if existant 2) Recovery detection works the same way as 1.4), just for a Recovery instead of a Preboot volume
    • Got garbled sound in earphone    Notebook Asus X550VX i7 - 7700hq with ALC255 not working with applealc  layout id  3, 13, 17, 18, 27, 28, 99 its is working with VoodooHDA but the new one 2.9.1 it much has low volume, but bad sound in earphone     codec dump linux https://drive.google.com/file/d/1pg2y76WvFYsO8vFY-2B_2OLyKMmkQ8Tg/view     latest debug http://www.mediafire.com/file/2pjny4eq5r64ed8/debug_1383 (1).zip  
    • For F6 Bios, which DSDT is the one i should use? I´m a little confused in the Mass of DSDT here ;-).   Great Thread by the Way.   Another Question: I have 2 960Pro inside my Rig (one with OS X, one with Windows 10). When i try to mount my EFI on OS X NVMe the system freezes... :-(   DWhen i unplug the Windows NVMe everything is fine an it mounts the EFI.   Anybody an idea?   Tried the upper Port on the Board (OS X) & the middle / lower Port, in the Middle it mounts the EFI in the lower it freezes.   But i need the middle Port for an SATA M.2 SSD :-D... Even when i plug the Windows NVMe into an PCIe Adapter Card it freezes at the point i mount the EFI.   I´m mounting with Clover Configurator.     Thank You guys.
    •   Just add "ngfxsubmit=0" to config.plist to disable the fix within nvidiafixup


×