Jump to content

[Help] Upgrade Monterey to Ventura or Sonoma?


27 posts in this topic

Recommended Posts

Posted (edited)

Greetings,

 

I currently use MacOS 12.4, is it better to upgrade to Ventura or Sonoma? and what should I do to update?

 

I'm using OpenCore version 0.8.7 and my hackintosh setup is:

 

i7-8700K     Asus Rog Strix z370-E      Coolermaster Seidon 120mm c3 plus     Asus rog rx 560 O4G Gaming     Hd Western Digital Black 1TB     M.2 Nvme Samsung 960 Evo 250GB     DVD-Rw LG-GH24NSD1     Evga g3 Super Nova 750W 80+ Gold     G-Skill F4-3200C16D-16GTZ     Zalman Z9 Neo White Case

for wifi I use ASUS USB-N13 and for bluetooth asus bt400

 

I look forward to your kind reply, thank you :) 

 

Edited by Montelli
Link to comment
Share on other sites

--Full EFI folder EFI Montelli.zip 

-Delete old EFI folder and paste new. Don't use merge files
-Don't use Drag and Drop into EFI partition. Use Copy/Paste instead
-Reset NVRAM one time - with OpenCore use entry "Reset Nvram" / with Clover use F11 key on boot screen

 

or

 

--Update things https://www.olarila.com/topic/38117-how-to-update-opencore-and-kexts-easy-way-with-ocat/

  • Like 2
  • Thanks 1
Link to comment
Share on other sites

On 6/1/2024 at 12:44 PM, MaLd0n said:

--Full EFI folder EFI Montelli.zip 

-Delete old EFI folder and paste new. Don't use merge files
-Don't use Drag and Drop into EFI partition. Use Copy/Paste instead
-Reset NVRAM one time - with OpenCore use entry "Reset Nvram" / with Clover use F11 key on boot screen

 

or

 

--Update things https://www.olarila.com/topic/38117-how-to-update-opencore-and-kexts-easy-way-with-ocat/

 

Thank you for your reply, I followed the guide in your olarila link everything except OpenCore DEV... I'm not sure, should I follow this part about OC DEV?

I'll show you in screenshoots OC Validate tells me:

image.thumb.png.1ad1ceb1b0d739bfb4d6ac9551abe2c5.png

image.png.0979810a5b4d33a580367c343c91ebbf.png

 

 

Thank you :) 

 

 

Link to comment
Share on other sites

1 hour ago, Montelli said:

Now how can I proceed to install Sonoma?

Via system preferences. Just go!

Enjoy!

Link to comment
Share on other sites

Posted (edited)
17 hours ago, MaLd0n said:

Via system preferences. Just go!

Enjoy!

 

via system preferences I tried to update but but it doesn't work...I get this message:
"Failed to prepare the software update. Please try again."

 

how can I fix?

 

Thank you

Edited by Montelli
Link to comment
Share on other sites

On 6/3/2024 at 12:15 AM, MaLd0n said:

Via system preferences. Just go!

Enjoy!

 

I solved it by updating and downloading from the Appstore... strangely it didn't work from system preferences... So now I have Ventura

 

Why doesn't work Ethernet? in network setting I read Ethernet IP Self-assigned with the yellow dot

Link to comment
Share on other sites

1 hour ago, Anto65 said:

https://rog.asus.com/motherboards/rog-strix/rog-strix-z370-e-gaming-model/spec/

LAN

Intel® I219V

 

Maybe you would need intelmausi.kext ?! 

 

ok excuse my ignorance I was convinced I had already uploaded it in the past.

 

now internet works and if I try to search for the Sonoma update it tells me Update not found the macos version is not compatible... Do I just need to change the SystemProductName in the config.plist? The one present now is: iMac 18.3 Intel Core i5-7600K @ 3.80 GHz

Which one do you recommend I change to?

 

Link to comment
Share on other sites

Posted (edited)
26 minutes ago, Anto65 said:

Bene 😃

 

But you are not using Maldon EFI with macPro7,1 ?

 

Ok I changed it now to MacPro7,1 ... after rebooting notification appeared on desktop:

 Screenshot2024-06-04alle18_22_31.png.33847b1e50351a20f934039170a56987.png

 

Should I be concerned ? This has never happened to me before...

 

in meantime I'm downloading Sonoma :)

Edited by Montelli
Link to comment
Share on other sites

Posted (edited)
44 minutes ago, Anto65 said:

Add this kext 

https://github.com/Lorys89/RestrictEvents/releases/tag/1.1.4 

 

Also useful for updates, does not require boot-arg

 

Should also resolve the memory warning if not , try following here

https://dortania.github.io/OpenCore-Post-Install/universal/memory.html#mapping-our-memory

 

ok I only inserted the kext and notification no longer appears. But exactly, what is the issue notification was referring to? RAM?

 

Edited by Montelli
Link to comment
Share on other sites

Posted (edited)

It's a common problem with that smbios...( Yes , RAM )

don't think about it 🤣 ... try updating now 

( Probably that the wifi-usb needs to be updated with Sonoma )

Edited by Anto65
  • Like 1
Link to comment
Share on other sites

Posted (edited)
On 6/4/2024 at 7:33 PM, Anto65 said:

It's a common problem with that smbios...( Yes , RAM )

don't think about it 🤣 ... try updating now 

( Probably that the wifi-usb needs to be updated with Sonoma )

@Anto65 @MaLd0n

I formatted and reinstalled Sonoma directly, now:

1) unfortunately bluetooth doesn't work, I use kext BlueToolFixup V2.6.4 with asus bt400... There is a way to fix it?

2) I would like to test and understand if I fully use all capabilities of my CPU and GPU and powermanagement... There is a way to check? 

3)There is a problem with my version of OCAT... the version I have now is 0.8.8 and if I try to check update: you are currently using the latest version! ... how it's possible ? before updating to Sonoma I updated Ocat and kexts to open core 1.0.0

4) Wifi work :) 

 

 

 

Edited by Montelli
Link to comment
Share on other sites

Posted (edited)
2 hours ago, MaLd0n said:

Asus BT-400 is native.

Post ur efi folder here. Remove ur serials.

 

thank you for your reply MaLd0n,

 

😅 lol... solved... I don't know why.. but BlueToolFixup kext (https://github.com/acidanthera/BrcmPatchRAM) in last folder there seems to be version 2.6.8... but actually there is version 2.6.4 of BlueToolFixup so I updated it directly from OCAT to version 2.6.8... 🫠

 

and for this?

Quote

2) I would like to test and understand if I fully use all capabilities of my CPU and GPU and powermanagement... There is a way to check? 

3)There is a problem with my version of OCAT... the version I have now is 0.8.8 and if I try to check update: you are currently using the latest version! ... how it's possible ? before updating to Sonoma I updated Ocat and kexts to open core 1.0.0

 

 

Edited by Montelli
  • Like 1
Link to comment
Share on other sites

1

Update BlueToolFixup.kext

https://dortania.github.io/builds/?product=BrcmPatchRAM&viewall=true&version=2.6.9&sha=d7e3f23c374c7048bc31a207da3d1804f593f47b

 

2

You can use  Geekbench , Cinebench 

or similar to check the performance...Maldon will certainly be able to advise you better

 

3

The version of the app is one thing (you probably have the latest one)
You need the version of OpenCore that manages OCAT
update yourself
(By Dev's choice)
Formatting the Volume deletes the hidden .OCAT folder in the library, containing the database with OC version 1.0.0

Select " Latest Version " and update OC & Kexts

https://drive.google.com/file/d/1wOQQC73c6UKkJe_CdFDdCvTX4Ix7baIK/view?usp=drivesdk

 

4

👍

Link to comment
Share on other sites

Posted (edited)
19 hours ago, Anto65 said:

1

Update BlueToolFixup.kext

https://dortania.github.io/builds/?product=BrcmPatchRAM&viewall=true&version=2.6.9&sha=d7e3f23c374c7048bc31a207da3d1804f593f47b

 

2

You can use  Geekbench , Cinebench 

or similar to check the performance...Maldon will certainly be able to advise you better

 

3

The version of the app is one thing (you probably have the latest one)
You need the version of OpenCore that manages OCAT
update yourself
(By Dev's choice)
Formatting the Volume deletes the hidden .OCAT folder in the library, containing the database with OC version 1.0.0

Select " Latest Version " and update OC & Kexts

https://drive.google.com/file/d/1wOQQC73c6UKkJe_CdFDdCvTX4Ix7baIK/view?usp=drivesdk

 

4

👍

 

1) Bluetooth works fine, after installing kext I had to run this command in terminal to reset bt: sudo pkill bluetoothd

Ps. I notice that in folder of link you sent me there is blueToolFixup version 2.6.4 and not 2.6.8 version... So had to update the kext directly from OCAT

 

2) Ok I'll try to do some bench now,...

 

3) OCAT is now updated

Edited by Montelli
Link to comment
Share on other sites

Posted (edited)
On 6/7/2024 at 1:24 PM, Montelli said:

 

1) Bluetooth works fine, after installing kext I had to run this command in terminal to reset bt: sudo pkill bluetoothd

Ps. I notice that in folder of link you sent me there is blueToolFixup version 2.6.4 and not 2.6.8 version... So had to update the kext directly from OCAT

 

2) Ok I'll try to do some bench now,...

 

3) OCAT is now updated

 

I did some benching on both Mac and Windows 10 (I use dualbot on two separate, mac on ssd nvme m.2 and win on sata ssd)

I notice that there is a lower score in Mac, by any chance can I fix it?

 

MAC
Cpu
https://browser.geekbench.com/v6/cpu/6422280

Gpu
https://browser.geekbench.com/v6/compute/2298370

 

Windows 10
Cpu
https://browser.geekbench.com/v6/cpu/6435569

Gpu
https://browser.geekbench.com/v6/compute/2302733

 

 

then I also used Cinebench but with this the values seem different so I don't know if it makes sense to make a comparison...

 

MACmulticore.thumb.png.62b0db801f32c7712dd8d992b703bb77.pngMACsinglecore.thumb.png.984b3176a1de6585866a2c5768c9695b.pngWINMulticore.thumb.png.19195291caa8ee01f94be57e8c53da5a.pngWINSingleCore.thumb.jpg.905316af659da9706f0fd47f279a33b2.jpg

 

 

 

@MaLd0n and there is a better way to check performance? 

Edited by Montelli
Link to comment
Share on other sites

Excuse me, but I made this observation just to understand if it can be resolved but if difference is minimal it is not important... thanks

 

However I have a question @Anto65 @MaLd0n, I have always used the Asus rog AMD rx 560 GPU with two display HDMI and DP. The internal gpu is UHD Graphics 630 and I have activated iGPU-Multimonitor from Bios and now I can use internal one... but when I connect the HDMI to external GPU nothing appears, my question is:

 

There is possibility of using four display? do I have to activate something in open core?

 

Thank You so much I wait your response

Link to comment
Share on other sites

20 minutes ago, Montelli said:

it's possible to use internal GPU and external GPU at the same time on Sonoma?

Yes. U need change smbios to iMac19,2 in ur case and enable Internal Graphics on bios/uefi. IGPU stay only for harwdare accel.

Link to comment
Share on other sites

 Share

×
×
  • Create New...