Jump to content

Ventura Black Screen, 5700 XT


6 posts in this topic

Recommended Posts

Hello, I have been running Monterey on my 3770K + AMD sapphire 5700xt with the smbios MacPro6,1 for a while perfectly fine, avoiding the black screen using Lilu + weg + pikera boot argument on 


I successfully installed Ventura with the addition of acidanthera’s Cryptex fixup.kext, and changed the smbios to iMacPro1,1 current behavior is boots past verbose, and then goes to a black screen as it behave before the WEG pikera argument in Monterey.


I have tried the following…. 


1. Booting with the arguments:





2. Booting with iGPU was successful, applied root patch with latest OCLP. When i switch iGPU, to back to 5700xt same behavior tho… only way to boot iGPU is removing the card completely regardless of bios settings


3. Tried multiple methods of device properties renaming, and acpi dsdt patching, as mentioned by a post by  @miliuco.,with no luck.


I believe my problem is the fact my PCI path has a “pci-bridge” before the GFX. When I look at it in iHacktools.


My apologies in advance, if any rules were broken in my post as I am a new member, and thank you in advance.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...