Jump to content

AppleALC 1.6.1 causing boot loop. OpenCore 0.7.0 - 0.7.2


dmcnaugh15
 Share

38 posts in this topic

Recommended Posts

First thing first:  If I'm posting in the wrong forum, my apologies up front; please point me in the right direction.  This is my first post here, and I'm not familiar with the site.

 

The Problem:  I'm looking for help with a boot loop problem I've noticed with OpenCore since version 0.7.0.  It only happens when using AppleALC 1.6.1 and newer.  If I use 1.6.0 and older, the problem resolves.  Here is a video demonstration of the problem: https://youtu.be/FIPJQRPFBPM.

 

My computer specs:

  • OS: Big Sur 11.5.2
  • Bootloader: OpenCore 0.7.2
  • Board: ASUS ROG MAXIMUS XI HERO (WI-FI) - chipset Z390
  • CPU: Intel(R) Core(TM) i9-9900K
  • Graphics: Radeon RX 580 Series
  • AppleALC codec: Realtek ALC1220
  • Config file attached (removed SN, UUID, board number, ROM info)

 

Measures taken to try to fix the problem (none have worked):

  • Confirmed all other kexts (other than AppleALC) are updated (as of 8/15/2021)
  • Created new/fresh ACPI/SSDT tables - downloaded Coffee Lake files from Dortania
  • Created a new config.plist file starting from the Coffee Lake pre-built file on Dortania
  • Confirmed my ALC codec is Realtek ALC1220 using linux
  • Tried every layout id for the Realtek ALC1220 codec.

 

I would be immensely grateful if anyone can provide a solution!

config.plist

Edited by dmcnaugh15
Attached the config file

Hi Allan,

 

Thank you for responding!  I tried the EFI folder and the updated config file you sent; also I remembered to reset NVRAM. Unfortunately, the problem persisted.  Any other ideas?!?!

 

 


I think the kext are not loaded in the right order, take a snapshot if you use ProperTree or if you use OCC delete them and re-add them will put them in the right order
in Kernel -> Quirks try disabling DisableRtcChecksum

  • Thanks 1

I played around with a few of the UEFI BIOS settings, but none of those changes worked, so I put them back where they were.  I tried all the layout-ids suggested by Dortania for the ALC1220 codec (1, 2, 3, 5, 7, 11, 13, 15, 16, 21, 27, 28, 29, 34), which I got at the following link: https://dortania.github.io/OpenCore-Post-Install/universal/audio.html#finding-your-layout-id

 


Antuneddu,

 

Interesting... I was not aware kext order mattered.  Attached are snapshots using ProperTree.  The first is "Kext_Snap_01".  The last is "Kext_Snap_03".

Kext_Snap_01.jpg

Kext_snap_02.jpg

Kext_snap_03.jpg


I followed Antuneddu's suggestions:

  • Changed DisableRtcChecksum to false in config
  • Used OpenCoreConfigurator to delete existing kexts, re-add them, and update.  OCC reordered them, as expected (see screenshots).
  • Same problem after reboot.

Kext_Snap_01_v2.jpg

Kext_snap_02_v2.jpg

Kext_snap_03_v2.jpg


The problem reliably goes away when using AppleALC 1.6.0 and returns when using 1.6.1 - 1.6.3.

 

That fact indicates there's something in the kext itself that contributes to the problem.  But, I see no one else with the same problem online, so that makes me think there is something unique with my configuration that's also contributing.  It's just driving me crazy!


Trying to set the UEFI BIOS to the default settings, and clear the NVRam and boot again.

EDIT: Just to check, are you not using the Debug version of AppleALC right?

  • Thanks 1

13 hours ago, dmcnaugh15 said:

Are you saying to reset the UEFI BIOS settings to factory default?

Yes, only keep the settings necessary to Hackintosh, such as:

 

CSM = disable

iGPU Video = disable

 

 

 

  • Thanks 1

Hi Allan,

 

Thanks for the continued suggestions.  With the EFI folder and config file you sent, I reset the UEFI BIOS settings to factory and disabled legacy compatibility support (CSM) and iGPU, and reset NVRAM.  Still same problem.

 

Any other thoughts?

 

Alex


Hmmm it's a pity.


Can you send me your entire EFI content? Zip and upload it here.


Also, you haven't installed kexts elsewhere like L/E or S/L/E right? Are you only using the EFI/kexts injection?

 

  • Thanks 1

Allan,

 

I just figured out what your last question was about... the one where you asked about kexts in S/L/E or L/E.  I didn't know what it meant at first.  But, now I've navigated to the folder location: "Hackintosh HD/Library/Extensions".  I believe that would be what you've referred to as S/L/E.  In that folder location, I see the following kexts (see screenshot).  Should I remove any of them? In particular, I'm looking at FakeSMC, IntelMausiEthernet, and VoodooHDA.  Those look like old versions of kexts I've used in the past.  I don't recognize the other kexts, so I'm wondering if they should stay there.

 

 

 

8_21_21__9_32_AM.thumb.jpg.fce17c5bb6516e45d71bef94acddc05a.jpg


And those G13, Logi…?

 

Now you need to repair the permissions, and reboot. 😃

  • Thanks 1

I will try deleting the logi files.  I think those may be for my Logitech gaming mouse.  


Question: When you say to “repair permissions”, do you mean to reset NVRAM?


Just now, dmcnaugh15 said:

Question: When you say to “repair permissions”, do you mean to reset NVRAM?

No, is totally different.

 

In macOS we can't just delete/add kexts on S/L/E or L/E.

You can use the Hackintool to do it:

Screen Shot 2021-08-21 at 13.16.09.png

  • Thanks 1

Downloaded Hackintool 3.6.2.  Clicked the icon to rebuild KextCache.  Received a message saying "Disable Gatekeeper and mount the disk in read/write mode?" (see screenshot 1).  So, I disabled SIP, thinking that might make the message go away.  But the message persists with SIP disabled.  Hackintool does go ahead and makes the changes it can, but there are many changes it doesn't have access to (see screenshot 2).  Do I need to pay attention to this message, and mount the disk in read/write mode?  If so, should I follow instructions on this url: https://apple.stackexchange.com/questions/395508/can-i-mount-the-root-system-filesystem-as-writable-in-big-sur

 Or, is there a better way to do it?

 

1469062821_1-Message.jpg.362bf90d1d790cf3d359f0ff55f324d7.jpg1296834982_2-RWaccess_sjpg.thumb.jpg.511d7d1e681ce44fcba8a48da2526939.jpg


Posted (edited)

Follow up: after repairing the [accessible] permissions (excluding the read only permissions - as per last comment) using Hackintool, the problem persists, but is slightly different.  Instead of immediately rebooting at the apple boot screen, it hangs up (i.e. freezes) there.

Edited by dmcnaugh15

Might be unrelated, but your config is not up to par with feature-set of OC 0.7.2. Here are the results of OC Validate:

 

OCS: Missing key Base, context <Patch>!
OCS: Missing key BaseSkip, context <Patch>!
OCS: Missing key Base, context <Patch>!
OCS: Missing key BaseSkip, context <Patch>!
OCS: Missing key Patch, context <Booter>!
OCS: Missing key Flavour, context <Entries>!
OCS: Missing key TextMode, context <Entries>!
OCS: Missing key Flavour, context <Tools>!
Serialisation returns 8 errors!

 

Misc->BlessOverride: \EFI\Microsoft\Boot\bootmgfw.efi is redundant!
CheckMisc returns 1 error!

 

Completed validating /onfig.plist in 2 ms. Found 9 issues requiring attention.

 

I'd compare the sections mentioned above with the sample.plist, fix these issues and validate the config again, before continuing.

 

  • Thanks 1

 Share

×
×
  • Create New...