Jump to content

ALC887-VD is not working


3 posts in this topic

Recommended Posts

First of all my specs:

  • Motherboard: MSI A78M-E35 (Realtek ALC887)

  • RAM: 16GB Corsair Vengeance LP (1600Mhz DDR3)

  • CPU: AMD A10-5800K (overclocked @ 4,20Ghz)

  • GPU: NVIDIA GeForce GT 640

  • SMBIOS: MacPro7,1 (Already fixed iServices)

  • EFI: Link to Google Drive

  • Monitors: 2x Dell P2214H (One connected over VGA, the other over a HDMI->DVI cable)

I successfully installed macOS 11.2.3 on my PC. I currently have two issues:

  • First stage of the boot logo happens on my left screen, but when the OS loads it switches to the right

  • No sound because AppleALC is not detecting (or patching) on-board audio.

The first issue is something I honestly don't care too much about, but if anyone knows how to fix its let me know. The latter is the real issue as sound is pretty important. I've tried the following:

  1. Every single layout ID. First time I tried this I didn't realise it was prioritising GPU audio to be patched.

  2. VoodooHDA. This worked great, it detected both audio devices and all input and output lines! But Safari kept crashing tabs on me.

  3. Every single layout ID. I realised that the wrong audio device was being patched, so I just blacklisted that. Now it properly renames my onboard audio to HDEF, but still none of the layout ID's work.

  4. Every single layout ID for a third time. This time I put them in DeviceProperties instead of using alcid=xx. This made it output "failed to find IOHDACodecVendorID" with every codec I tried.

Here's some screenshots of Hackintool and IORegistryExplorer. Things I've noticed wrong with these screenshots myself (These were made at point 3 above):

  • IORegistryExplorer: HDEF doesn't have any child object. Normally it should have an AppleHDAController child.

  • Hackintool -> System -> Peripherals only shows the NVIDIA (0x10DE) card.

I was hoping someone could help me debug this with the info I've given.

enter arg alcid = your id at boot
however always at boot arg npci = xxx and he who does not let you have audio with AppleALc, so try to remove it, hoping it will start without
×
×
  • Create New...