Jump to content

Asus U36SD Sandy bridge cant Shutdown Sleep - Clover - HM65 6-series chipset Nvidia 520M HD3000 FL1000 USB3 AR9002WB-1NG wifi AR8151 Gigalan


13 posts in this topic

Recommended Posts

Its been a long way 10 years ago i bought this notebook. Last time i use myhack mbr method and chameleon and Mountain Lion with aicpm

Last week the hdd was dead and i tried to install win10 plus the last possible way for sandy bridge: High Sierra 10.13.1 iwith Clover and GPU SSD uefi.

I was install with Clover 4831 with UEFI method. Finish. the some polished for post install.

 

System - HighSierra 10.13.1

Clover 5040 something with legacy and uefi boot.

Asus U36SD - RX Bios 206, hybrid DSDT + some SSDT patches: (still trying doing battery hot patch and may other patch like GPRW)

Sandy bridge i5 - 2410m with ssdt from ssdtPRGen.sh

SSD ADATA 650SU - GPT UEFI sharing with win10. 3 partition i think. EFI fat32, Win10 NTFS, HighSierra apfs

12 GB RAM DDR3

AR9002WB-1NG Wireless Network Adapter patched to 9285 via DSDT patch

AR8151 via L1c kext

520M  Nvidia web driver 

HD3000 intel 

 

Asking solution for :

1. I cant got to uefi shell with  aptiomemoryfix.efi  aptiomemoryfixdrv3.efi . Sometimes it cant pass uefi boot with "Error allocating 0x800 pages at ... Error loading kernel cache(0x9).

   The latest clover 5130 showing unsupported uefi _SMC...when booting.

   It can go to uefi shell after i installed legacy too and uefi with mbr bootaf early february 2021 clover version 50xx , from legacy i can go to uefi, type memmap > memmap.txt, less problematic error allocating.  

   UEFI booting still got trouble sometimes even with slide=0, and clover custom slide.

 

2. Cant sleep , it just blank the screen, not coming back, The shutdown also the screen just blank, the power still turned on. 

    I though usb problem but if i patch EHC1 to EH01, problem persist plus USB cant use.

   The patching shutdown and 0x0d ACPI DSDT already done, but still cant sleep, shutdown,

   Any clue for shutdown and sleep?

 

3. I heard in high sierra somehow 520M supported. I still trying on 13.1. I checked Coredisplay installed, but  the 520m recognized just nvidia card. how to switch to it? inject? i use whatevergreen kext.

 

4. memmap attached,  cant you help the slide number. Does it fix the problem number 1 eufi?

 

Could you helped me?

 

 

 

 

   

 

 

 

Send me alikas-MacBook-Pro.zip

Edited by Babiloe

GeForce 520M is Fermi and, as such, is very buggy and poorly supported in Sierra/High Sierra. Disable your dGPU and run solely on HD3000 iGPU, knowing that it is also a little buggy over time in High Sierra (small artefacts, horizontal lines across the screen).

Hi herve.

Ok i think I have to let it go stay at hd3000 disable it via ssdt or wegnogpu boot switch. The last 520m work is on elcapitan ?

 

The bothering one is can't sleep can't shutdown. Any clue about this. Do I need to sierra instead ?

 

Edited by Babiloe

You could check the assertions after failed attempt to put computer to sleep with Terminal command:

pmset -g assertions

 

I'd also recommend you disable hibernation:

sudo pmset -a hibernate mode 0
sudo pmset -a hibernatefile /dev/null
sudo rm -f /var/vm/sleepimage

 

here is my assertions after pmset hibernate mode 0 after tried sleep

because usb? or because ssd?

no usb attached.

 


2021-02-23 02:05:20 +0700 
Assertion status system-wide:
   BackgroundTask                 0
   ApplePushServiceTask           0
   UserIsActive                   1
   PreventUserIdleDisplaySleep    0
   PreventSystemSleep             0
   ExternalMedia                  0
   PreventUserIdleSystemSleep     0
   NetworkClientActive            0
Listed by owning process:
   pid 60(mds): [0x00000009000b8007] 00:01:07 BackgroundTask named: "com.apple.metadata.mds.power" 
   pid 76(apsd): [0x00000030000b808d] 00:00:28 ApplePushServiceTask named: "com.apple.apsd-connectionestablish-push.apple.com" 
   pid 76(apsd): [0x00000011000b8032] 00:00:59 ApplePushServiceTask named: "com.apple.apsd-login" 
   pid 95(hidd): [0x0000000f00098031] 00:00:00 UserIsActive named: "com.apple.iohideventsystem.queue.tickle.4294968002.3" 
    Timeout will fire in 120 secs Action=TimeoutActionRelease
Kernel Assertions: 0x4=USB
   id=502  level=255 0x4=USB mod=01/01/70 07.00 description=com.apple.usb.externaldevice.1a120000 owner=ASUS USB2.0 WebCam
   id=504  level=255 0x4=USB mod=01/01/70 07.00 description=com.apple.usb.externaldevice.1a110000 owner=IOUSBHostDevice
Idle sleep preventers: IODisplayWrangler

Edited by Babiloe

Before I dig deeper into your setup, a few quick comments that could cause sleep/wake issues:

  1. you run High Sierra, so no need for that SSDT-EC table which also inject USB power properties that may clash with your system (though probably not)
  2. you inject USBPorts kext (which I presume you generated with Hackintool) so get rid of SSDT-UIAC table which you also inject; it's either USBPorts kext on its own or USBInjectall kext + SSDT-UIAC table
  3. I don't understand why you have tables SSDT-0-Cpu0Ist and SSDT-1-CpuPm in your Clover ACPI/patched folder when you have the generated CPU power management table called SSDT-10-CpuPm already there. If you use the latter, I would not expect the former 2 and I would expect you to drop SSDT tables CpuPm + Cpu0Ist in your Cover config

OK.

 

1. and 2. The SSDT-EC-USBX.aml SSDT-UIACL.aml and USBports.kext are parts of hackintool product.

   so i just use USBports.kext only. 

    So SSDR-EC this also not needed in Sierra also? I switch back and forth with Sierra and High Sierra to check the difference. still cant shutdown also in Sierra.   

  

 

3. i have ssdt.aml created by ssdtPRGen.sh on ACPI/patched. SSDT-0-Cpu0Ist and SSDT-1-CpuPm are at ACPI/origin and ACPI folder product by debug mald0n Runme.app  for this zip debug.

    ok  if i use this ssdt.aml so the clover need SSDT-0-Cpu0Ist and SSDT-1-CpuPm dropped?  like this

 

 


        <key>DropTables</key>
        <array>
            <dict>
                <key>Signature</key>
                <string>DMAR</string>
            </dict>
            <dict>
                <key>TableId</key>
                <string>CpuPm</string>
                <key>DropForAllOS</key>
                <false/>
                <key>Signature</key>
                <string>SSDT</string>
            </dict>
            <dict>
                <key>TableId</key>
                <string>Cpu0Ist</string>
                <key>DropForAllOS</key>
                <false/>
                <key>Signature</key>
                <string>SSDT</string>
            </dict>
        </array>
 

 

    

    I am quite not understand with this Sandy ACPICPUPM. So if i use ssdt.aml generated the SSDT-0-Cpu0Ist and SSDT-1-CpuPm need dropped  or not?

    I thought it need to be dropped first. create ssdtprgen for ssdt, then it not dropped and use ssdt.aml on acpi/patched. so i am wrong. ok i dropped as config copy.plist

 

 

    I am guessing this not shutdown due ssd sata or usb problems. still not shutdown after those trial.

 

 

 

 

 

Ace!

 

Re: CPU power management for Sandy Bridge and Ivy Bridge:

  1. you drop SSDT tables CpuPm and Cpu0Ist in your boot loader config (therefore you should have no such files in ACPI folder)
  2. you inject your generated CPU-specific power management SSDT table
  3. you apply the AICPUPM patch to avoid MSR-related KP/reset

 

Speak to soon

shutdown solved

 

sleep not done

 


alikas-MacBook-Pro:~ alika$ pmset -g assertions
2021-02-24 19:23:05 +0700 
Assertion status system-wide:
   BackgroundTask                 0
   ApplePushServiceTask           0
   UserIsActive                   1
   PreventUserIdleDisplaySleep    0
   PreventSystemSleep             0
   ExternalMedia                  0
   PreventUserIdleSystemSleep     1
   NetworkClientActive            0
Listed by owning process:
   pid 378(SubmitDiagInfo): [0x0000002b0001808a] 00:00:07 PreventUserIdleSystemSleep named: "com.apple.SubmitDiagInfo" 
    Details: Submitting diagnostic and usage information, cleaning up.
    Timeout will fire in 112 secs Action=<unknown action>
   pid 161(mds_stores): [0x00000007000b8006] 00:00:43 BackgroundTask named: "com.apple.metadata.mds_stores.power" 
   pid 97(hidd): [0x0000002000098041] 00:00:18 UserIsActive named: "com.apple.iohideventsystem.queue.tickle.4294967909.3" 
    Timeout will fire in 119 secs Action=TimeoutActionRelease
   pid 59(mds): [0x00000007000b8005] 00:00:43 BackgroundTask named: "com.apple.metadata.mds.power" 
   pid 393(AddressBookSourceSync): [0x0000003000018093] 00:00:02 PreventUserIdleSystemSleep named: "Address Book Source Sync" 
    Timeout will fire in 1797 secs Action=TimeoutActionTurnOff
   pid 78(apsd): [0x00000022000b8043] 00:00:16 ApplePushServiceTask named: "com.apple.apsd-login" 
   pid 78(apsd): [0x00000022000b8042] 00:00:16 ApplePushServiceTask named: "com.apple.apsd-recreatecourierstate-push.apple.com" 
Kernel Assertions: 0x4=USB
   id=500  level=255 0x4=USB mod=1/1/70, 7:00 AM description=com.apple.usb.externaldevice.1a100000 owner=IOUSBHostDevice
   id=501  level=255 0x4=USB mod=1/1/70, 7:00 AM description=com.apple.usb.externaldevice.1d100000 owner=IOUSBHostDevice
   id=504  level=255 0x4=USB mod=1/1/70, 7:00 AM description=com.apple.usb.externaldevice.1a110000 owner=IOUSBHostDevice
   id=505  level=255 0x4=USB mod=1/1/70, 7:00 AM description=com.apple.usb.externaldevice.1a120000 owner=ASUS USB2.0 WebCam
Idle sleep preventers: IODisplayWrangler

 

Idle sleep preventers: IODisplayWrangler whats that maybe plugged ac power?

  • 4 weeks later...

Hi Babi

 

On my Asus K53E, in El Capitan had sleep and shutdown working normally.

In Sierra no shutdown and sleep.

Work around for shutdown had to edit DSDT.aml.  

Two statements which I used explained in my Guide for shutdown to work.

 

For Shutdown to work:  Need to Use MaciASL and edit your DSDT.dsl.

 

Under General Folder --MaciASL Patching option Use the Intel Shutdown Fix.

 

  there's a 2nd SLPE change it to SLPB 
  and there should be 4, 1

 

When you open the patch option you'll see the SLPE go to the second one and edit it right there not afterwards
because it saves you time while patching other ones.

 

USB prevents and so does the Display these two issues create "no wake"  issue.

Mine dead sleep deep sleep I would say,  but doesn't wake up. Have to reboot.
The wake issue is in DSDT.  It's older style DSDT and new style DSDT has different language.

Unless you have newer DSDT language, you have to gut out most of the mess in there.
Then you have to understand and know the new and old language to make the changes.

I knew where the problem is but it's a lot language to change. I was looking for a wake script

that was a hack but could not find one.

 

USB ports creates the problem and disturbs the Display.  I am not savvy enough to find the issue.  Not enough tools that I know of to stat the direct 

connection.  

 

I know that if your USB ports are not set right it chatters constantly disturbing the system from sleeping.

Then when you sleep it manually it doesn't wake up. So what happens is the sleep is like a shutdown where there are no low idle signals

to trigger a wake up.  It is complete silence and no activity to even send a wake up.  Dead.

 

So the sleep actually needs to be in an idle mode to where the system is idling at low levels enough to keep the system from shutting down

and from waking up.  Total still mode but power is there just enough to send a spark to wake. 

 

 Hope this gives you some clues to your endeavor.

 

Have  a great weekend!

I don't recall all that I did for the USB to work right.


I used USBX from Rehabman. He has the tools to do it.

 

This solved my USB ports issue.  This stopped the chattering on boot and while running.

 

Had to create SSDT USBX.aml and a kext

 

I'm on my windows right now so I don't have access to this.

Plus my HP is out of commission until I install mac os.

 

If you're interested just pm me or write back here

×
×
  • Create New...