Jump to content
3 posts in this topic

Recommended Posts

Hey there!  As I have not yet reached Newbie/Member status, I am unable to post anywhere but here.  I hope it's okay to post inquiries here.

I'm running Catalina 10.15.7 on my laptop, and I had it running perfectly.  Wifi from itlwm, and battery status from Rehabman's guide for hot patching ACPI.  However, after a couple of stupid attempts to get itlwm working (moving FakeSMC from L/E to C/K/O and vice versa), my battery status seemed to disappear.  I'm not quite sure what exactly happened, but if anyone could give any insight, I'd be grateful.  I've tried hot patching about 3 times over, and it doesn't help at all, and when I try to manually patch my DSDT, it throws multiple "UNEXPECTED" errors.

 

Thanks in advance for any help!

 

-Techsoul

48 minutes ago, dkjacks said:

Have you tried VirtualSMC and its plugins?

 

Which boot manager are you using?

 

https://dortania.github.io/OpenCore-Install-Guide/config-laptop.plist/haswell.html#starting-point

I'm using Clover 5119, it seems to be the most stable for my machine.  I've tried OpenCore, but it's too intricate for my taste.  I actually fixed the problem by reverting to an older Clover folder I had on a USB Stick, and the battery status started working again.  Now I have a different problem.  I'll make a separate topic for that though.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...