Jump to content

Big Sur 11.1 in Pentium dual core g3240 with Nvidia gt 710


13 posts in this topic

Recommended Posts

I am facing kernel panic while clean installing Big Sur 11.1 on Intel Pentium dual core g3240 with NVidia gt 710.(I know it is not supported, Catalina works well!)
clover latest/oc latest

AMFI: SIP is off, allowing core dump for pid 1 (launchid)
pid 1 exited -- exit reason namespace 2 subcode 0x4, description none

IOPlatformPanicAction -> AppleAHCIDiskDriver
IOPlatformPanicAction -> AppleAHCIDiskDriver
IOPlatformPanicAction -> AppleSMC

panic(cpu 1 caller 0xffffff8006cbf016):initproc exited -- exit reason namespace 2 subcode 0x4

EFI-clover.zip EFI-oc.zip

Pentium G3240 is Haswell and I see no reason why it would not support Big Sur given that you can run Catalina on it. You may just have to fake the CPU id of mainstream Core I models. It's the GT1 Intel HD iGPU of those Pentium CPUs that's not supported.

GeForce GT710 remains supported in Big Sur provided it's a Kepler model; it seems to be the case since you stated it worked in Catalina too.

 

Regarding your OC config, I see a several potential errors and/or issues:

  1. ACPI tables: SSDT-EC-USBX-Desktop and SSDT-EC. You should only be injecting one of those and the former is for Skylake and later platforms. As such, get rid of it.
  2. Device properties: you're injecting a property for your iGPU. Not required since it's unsupported.
  3. Kernel: I'm surprised you use NullCPUPowerManagement. I would have expected native CPU power management to be fully supported on your Haswell Pentium with the usual SSDT-PLUG table. Are you sure you need those 2 x AHCI injector kexts?
  4. NVRAM: adgpmod boot arg is for iGPUs and is therefore useless. -lilubetaall is also not required if you use latest version of Lilu and PlugIns, they all support Big Sur 11.1
  5. SMBIOS; pretty sure iMacPro1.1 is not the right profile to use on a Haswell platform with Nvidia graphics. Use iMac14,2 or iMac14,3 (Nvidia graphics card usually require the SMBIOS of a Mac with Nvidia graphics) which may require to add -no_compat-check boot arg (I believe those Macs were officially dropped by Big Sur).

 

Regarding your Clover setup, again several errors and/or issues:

  1. Kexts: same remark regarding NullCPUManagement. I don't understand why you'd inject that kext when you've installed ACPI table SSDT-PLUG for native CPU PM.
  2. Config, ACPI: Ouch!
    • You've enabled nearly all of the fixes; that can't be right and you should only enable those you need, granted you may need to experiment with them only by one which can be painful.
    • You've enabled Generate P States and Generate C States, something for Core2Duo/Arrandale platforms. Not applicable to your Haswell platform, disable them
    • Remove those tables you actually don't drop
    • Unless you did not already use ACPI table SSDT-PLUG, all you would need for native CPU PM is enable PluginType
  3. Config, Boot: again, no need for boot arg agdpmod=pikera
  4. Config, Graphics: you may need to enable Inject Nvidia here
  5. Config, Patches: AppleIntelCPUPM patch if for Sandy Bridge + Ivy Bridge, not for your Haswell platform which requires KernelPm patch (OS X/macOS handle CPU PM through the kernel for Haswell and later , no longer from AICPUPM kext). Remove EightApple, it's for the 2nd stage boot glitch experienced with iGPUs.
  6. Config, SMBIOS: here again, iMacPro1.1 is not adequate; change to iMac14,2/iMac14,3 as suggested above. You already have -no_compat_check in your Clover config...
  • 2 weeks later...
  • 3 weeks later...
On 2/6/2021 at 1:54 PM, vinukn335 said:

Aggressive LPM support".  disabled. same error. Any error in dsdt.aml?

Looking at your photos your using a very modern mother board, you will not need to use a DSDT file, and as pointed out above you will have to fake (spoof) your CPU i.d. I have a G3240 on a Gigabyte GA-Z97-HD3 running Big Sur 11.2.1 very well so it is all possible. I see from an earlier post you say you had it running Catalina perfectly. If so I suggest you change your smbios to allow BS to upgrade and maybe try that route. That is the way I went from Mojave to BS on the Z97 and the upgrade went without issues.

 

You will have to change your smbios to something like Mac Pro6,1/iMac15,1 or the likes as also pointed out above, and from memory my Z97 also has -xcpm. I'm not on that machine ATM so can't quote further as I'm on a Dell T5400 (also resurrected by open core).

 

Take a look here,  http:// https://github.com/acidanthera/bugtracker/issues/365   this will show you what changes you will need for your Haswell cpu.

 

I made the jump from clover to open core a few weeks ago and at the age of 69 for me it was a massive, massive learning curve but I can say its all worth it in the end and I'm still learning. If you still can't get anywhere I can post my Z97 config details etc which may help you get it off the ground.

 

 

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...