Jump to content

Z490 Aorus Ultra, i7 10700, iGPU (HDMI) - no video output


4 posts in this topic

Recommended Posts

Z490 Aorus Ultra, i7 10700, iGPU only (for now) -> The mobo does not have a DisplayPort, so stuck on HDMI.

OpenCore 0.6.5, trying to install Catalina 10.15.7

 

The USB boots successfully, but just before I expect it to go to the Apple logo - I lose all video output. Here's a screenshot of the Device Properties.

I tried using 00009B3E as well (as per the OpenCore guide for Comet Lake) but no joy there either.

DVMT in BIOS is set to 64MB, so I removed the framebuffer properties, but there is Lilu and WG in the Kexts folder.

 

Some other screenshots along the way : https://imgur.com/a/Q6BSfc0

 

Any recommendations?

1.png

Link to comment
Share on other sites

  • 5 months later...
On 1/21/2021 at 1:36 AM, apoorv said:

Z490 Aorus Ultra, i7 10700, iGPU only (for now) -> The mobo does not have a DisplayPort, so stuck on HDMI.

OpenCore 0.6.5, trying to install Catalina 10.15.7

 

The USB boots successfully, but just before I expect it to go to the Apple logo - I lose all video output. Here's a screenshot of the Device Properties.

I tried using 00009B3E as well (as per the OpenCore guide for Comet Lake) but no joy there either.

DVMT in BIOS is set to 64MB, so I removed the framebuffer properties, but there is Lilu and WG in the Kexts folder.

 

Some other screenshots along the way : https://imgur.com/a/Q6BSfc0

 

Any recommendations?

1.png

Okay, to boot Catalina with the 10700 you will first need to remove any CPUID references in the Kernel section because Catalina natively supports Comet Lake.
Second you need to upgrade to OC 0.6.9. which has the full CML CPU identification support within OC, making it easier to run.
Third, your device properties for the IGPU needs to change to 00009BC5 for AAPL,ig-platform-id and 9BC50000 for the device-id (this is the real device ID of the 10700 IGPU). You should also add the framebuffer-patch-enable, framebuffer-stolenmem,framebuffer- unifiedmem and framebuffer-fbmem values of 01000000, 00003001, 00000080 and 00009000 respectively for the full VRAM memory fix.
Lastly you'll need to add -igfxmetal=1 in the NVRAM boot-args to enable the IGPU acceleration.

Link to comment
Share on other sites

  • 3 weeks later...
 Share

×
×
  • Create New...