Jump to content
d620osx

[Solved] Unable to complete 10.15.7 Supplemental Update installation

10 posts in this topic

Recommended Posts

Hi

 

Sorry had posted this in the wrong section and had omitted the necessary information. 

 

@Hervé - Apologise and thank you for the head up.

 

I seem to be having issues updating my machine from the system menu, or the combo update. I am currently running 10.15.7 but when I try and instal the latest supplementary update, the machine reboot and when I log in it still states that an update is outstanding.

 

I think the issue may be with my clover install, as when the update is installed, and the system boots up I do not see the additional update option (not sure what it is called sorry).

 

I have attached my clover folder and the machine I am using is a Dell Optiplex 790 i5 with a GT210 GPU.

 

I would be very grateful if someone can check my clover folder for me and confirm what I have setup wrong to stop the system updating.

 

Thank you

CLOVER.zip

Edited by d620osx
Share this post

It's highly unlikely to be a Clover issue.


Given that you're using an old and unsupported Tesla card on that Optiplex running Catalina 10.15.7, I can only guess that you've used Dosdude1's patcher at installation. If so, that's no small detail but one you omitted to state... I'm not sure if Dosdude1's patcher supports 10.15.7's supplemental update but, like after any Catalina update on this kind of setup, you must re-apply the patcher. If the patcher does not support that supplemental update, stay away from it.

 

The alternative (and I'd recommend this) would be that you replace your old graphics card by a model natively supported by Catalina and run a full vanilla system's, not a patched one.

 

Of course, I assume that, by now, you also know that you must boot the temp "install maOS from..." temp partition to complete the update and that this may be required several times (usually no more than a couple of times until it disappears, unless you have a disk blessing issue in which case it sticks and you have to manually delete the associated folder in /System/Volumes/Data).

 

Oh, and you should also know that, to date, Intel has released 10 x generations of i3/i5/i7/etc. CPUs, so saying that your Hack is fitted with an "i5" is pretty meaningless unless you actually specify the exact model and generation. Time to update your signature...

Share this post

Thank you @Hervé for always helping.

 

I have updated my profile after checking the build on my machine. I have :

 

Optiplex 790 Core i5 2400 3.1 GHz  - Intel® 2nd Gen - 16GB DDR3 - MSI GT710 2GB

 

I had updated the GPU to GT710 :| when I moved to 10.15 but completely forgot.

 

When I select on update the machine reboot but at the clover stage I do not get the "install macOS from ..." so not sure where the issue is.

 

Thank you

Share this post

Well, if you have a Sandy Bridge CPU and a MSI GT710 2GB graphics card, all should work OOB as long as this GT710 is a Kepler model as expected (there are Fermi GF119-based models which are of course unsupported in 10.15). Strange that you do not see the temp partition at reboot. Try and press F3 when you reach the Clover main menu, that unhides all hidden partitions (though none hidden in the config file you posted above).

 

10.15.7 is build 19H2, 10.15.7 Supplemental Update is build 19H15. Check which shows after reboot.

 

Note that you should revise your Clover config given that, in the Graphics section, you've got Inject Intel + Inject ATI + Load VBIOS + a Cedar ATI/AMD framebuffer in place. Looks like a config carried over from your Vostro 200... All you would require for a GT710 is Inject nVidia if anything at all.

Share this post

When I click on F3 at the clover menu, I can see:

  • Boot max OS X from xxx via pre boot
  • Boot macOS from xxx
  • Boot Mac OS X recovery for xxx via Recovery


I do not see the option for install macOS from...

I will update the clover for the GPU once I have fix the update issue.

Thank you

Edited by Hervé
Removed duplicated contents
Share this post

Thank you @Hervé for all the pointers today. I think the issue may have been the nvram.

 

Found another thread on the forum which suggested booting into clover and clicking on F11. Then log in to Mac OS and select the upgrade. On the system re-booting I could see install mac os from xxx - data. After two re-boots I the system has updated.

Share this post

  • Hervé changed the title to [Solved] Unable to complete 10.15.7 Supplemental Update installation
×