Jump to content
Welcome to InsanelyMac.com - No more ads! And some exciting news... Read more... ×
ThatHackintoshNoob

OpenCore MacOS BigSur on Dell Inspiron 3670

4 posts in this topic

Recommended Posts

Hi Guys,

I have have an old dell insprion 3670 laying around.I recently tried to hackintosh it with bigsur.I get to the apple logo and no progress bar. When in verbose mode it gave me this error when it had a kernal panic:.com.apple.AppleIntelGFLgraphicsFramebuffer. I am guessing this has got to do with my graphics but I am a noob at hackintoshing therefore struggling to figure it out. If anyone can help I would be very greatful as I have been trying to do this for weeks.Here is my Config.plist for anyone that can help:

config.plist

Share this post


Link to post
Share on other sites

Hii! I might be able to help you. You seemed to have either skipped over or forgot the framebuffer patching guide. I recommend following this and hopefully you will have your kernel panic fixed. Here's the fix for clover, you're gonna have to translate it for OpenCore since I haven't yet switched to using OpenCore. Hopefully it works!

		<key>Properties</key>
		<dict>
			<key>PciRoot(0x0)/Pci(0x2,0x0)</key>
			<dict>
				<key>AAPL,ig-platform-id</key>
				<data>
				BwCbPg==
				</data>
				<key>device-id</key>
				<data>
				mz4AAA==
				</data>
				<key>framebuffer-con0-busid</key>
				<data>
				AgAAAA==
				</data>
				<key>framebuffer-con0-enable</key>
				<data>
				AQAAAA==
				</data>
				<key>framebuffer-con0-flags</key>
				<data>
				xwMAAA==
				</data>
				<key>framebuffer-con0-index</key>
				<data>
				AgAAAA==
				</data>
				<key>framebuffer-con0-pipe</key>
				<data>
				CgAAAA==
				</data>
				<key>framebuffer-con0-type</key>
				<data>
				AAgAAA==
				</data>
				<key>framebuffer-con1-busid</key>
				<data>
				BAAAAA==
				</data>
				<key>framebuffer-con1-enable</key>
				<data>
				AQAAAA==
				</data>
				<key>framebuffer-con1-flags</key>
				<data>
				xwMAAA==
				</data>
				<key>framebuffer-con1-index</key>
				<data>
				AwAAAA==
				</data>
				<key>framebuffer-con1-pipe</key>
				<data>
				CAAAAA==
				</data>
				<key>framebuffer-con1-type</key>
				<data>
				AAgAAA==
				</data>
				<key>framebuffer-con2-busid</key>
				<data>
				AQAAAA==
				</data>
				<key>framebuffer-con2-enable</key>
				<data>
				AQAAAA==
				</data>
				<key>framebuffer-con2-flags</key>
				<data>
				xwMAAA==
				</data>
				<key>framebuffer-con2-index</key>
				<data>
				AQAAAA==
				</data>
				<key>framebuffer-con2-pipe</key>
				<data>
				CQAAAA==
				</data>
				<key>framebuffer-con2-type</key>
				<data>
				AAgAAA==
				</data>
				<key>framebuffer-patch-enable</key>
				<data>
				AQAAAA==
				</data>
				<key>framebuffer-stolenmem</key>
				<data>
				AAAwAQ==
				</data>
			</dict>

 

Share this post


Link to post
Share on other sites

Hi! I'm back after a few days, decided to try on my own Inspiron 3670! So I got it to boot with your config, made some changes and ran trough sanity checks. Applied patches for the graphics, and here it is!

 

Patches:

	</dict>
	<key>DeviceProperties</key>
	<dict>
		<key>Add</key>
		<dict>
			<key>PciRoot(0x0)/Pci(0x2,0x0)</key>
			<dict>
				<key>AAPL,ig-platform-id</key>
				<data>BwCbPg==</data>
				<key>framebuffer-patch-enable</key>
				<data>AQAAAA==</data>
				<key>framebuffer-stolenmem</key>
				<data>AAAwAQ==</data>
				<key>device-id</key>
				<data>mz4AAA==</data>
				<key>framebuffer-con0-busid</key>
				<data>AgAAAA==</data>
				<key>framebuffer-con0-enable</key>
				<data>AQAAAA==</data>
				<key>framebuffer-con0-flags</key>
				<data>xwMAAA==</data>
				<key>framebuffer-con0-index</key>
				<data>AgAAAA==</data>
				<key>framebuffer-con0-pipe</key>
				<data>CgAAAA==</data>
				<key>framebuffer-con0-type</key>
				<data>AAgAAA==</data>
				<key>framebuffer-con1-busid</key>
				<data>BAAAAA==</data>
				<key>framebuffer-con1-enable</key>
				<data>AQAAAA==</data>
				<key>framebuffer-con1-flags</key>
				<data>xwMAAA==</data>
				<key>framebuffer-con1-index</key>
				<data>AwAAAA==</data>
				<key>framebuffer-con1-pipe</key>
				<data>CAAAAA==</data>
				<key>framebuffer-con1-type</key>
				<data>AAgAAA==</data>
				<key>framebuffer-con2-busid</key>
				<data>AQAAAA==</data>
				<key>framebuffer-con2-enable</key>
				<data>AQAAAA==</data>
				<key>framebuffer-con2-flags</key>
				<data>xwMAAA==</data>
				<key>framebuffer-con2-index</key>
				<data>AQAAAA==</data>
				<key>framebuffer-con2-pipe</key>
				<data>CQAAAA==</data>
				<key>framebuffer-con2-type</key>
				<data>AAgAAA==</data>
			</dict>
			<key>PciRoot(0x0)/Pci(0x1b,0x0)</key>
			<dict>
				<key>layout-id</key>
				<data>DQAAAA==</data>
			</dict>
		</dict>

 

Screen Shot 2020-11-02 at 12.00.58 AM.png

config.plist

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By MacNutty
      Apple has always fascinated me with their outstanding hardware and software. Always wished of having a piece of Apple at my hand, but due to its high cost, at-least in India, never I had a chance of buying a Mac, have a iPhone though. Years ago I had made a desktop hackintosh when Apple had released MAC OSX Leopard, which actually worked quite well. But after switching over to laptop and donating my old desktop, my days of MacOS were completely lost. Busy work schedules also made me cut-off from the hackintosh zone.
       
      Being a software developer, I recently received a project for developing cross platform mobile app using Xamarin. As I was not having a Mac, building a hackintosh became a necessity for building iOS version of the app. But after so many years of gap, didn't knew where to start from.
      After searching the web and various forums, came to know about OpenCore vanilla installation. So, followed the Dortania guide for installation on my Dell Inspiron 7572 (India edition) laptop.
      Things didn't work perfectly at the beginning but after trail and error, search and patching, now I have almost a perfect hackintosh laptop. Here are the details:
      Dell Inspiron 7572 Laptop:
      Processor: Intel Core i5-8250U (8th Gen) | 8 GB DDR4 RAM | Graphics: Intel UHD 620 + Nvidia MX150 | Audio: Realtek ALC3246 | Realtek RTL8168H Ethernet | Qualcomm Atheros QCA6174 Wifi & Bluetooth.
      WORKING / NOT WORKING:
      Graphics: Full HD with HDMI detection working using Lilu.kext & Whatevergreen.kext. Sound: Speaker, headphone jack and mic working using AppleALC.kext (Layout ID: 21) Bluetooth: working out of the box. Ethernet: RealtekRTL8111.kext Sleep: working with patched SSDTs using Dortania's ACPI guide. Camera: working out of the box. SSD / HDD (Raid 0): working using CtlnaAHCIPort.kext. USB 3.0: working out of the box. Battery Status: working with patched SSDTs. Trackpad with all gestures & Keyboard: working using VoodooI2C.kext & VoodooI2CHID.kext iMesssage, App Store, FaceTime & Updates: working as real Mac. Wifi: Qualcomm adapter not working. Got a cheap USB adapter from Amazon TPLink TL-WN725N for INR. 439 (US $6). Card Reader: Not working. Didn't bother as am not using it at all.  
      ScreenShots:


       
       

    • By tonyx86
      **********************************************************************************
      In this thread, I have fully documented the installation of macOS Catalina on my HP EliteDesk 800 G4 Mini. It is a PERFECT HackMini8,1 and is running very well for me without any issues. I hope this documentation helps you to install macOS on your hack. Please leave feedback if you think there is anything I can improve and let me know if you have any questions.
      **********************************************************************************
       
      Background
      This is my first "modern" hack supporting UEFI and my first hack using Clover "on-the-fly" patches.  My previous hacks
      Laptop: Thinkpad T61 / Nvidia NVS 140m Laptop: Dell Latitude E6410 / Nvidia G3100m Desktop: Gigabyte G31 / GeForce 9600 Desktop: Biostar TH55HD / Sapphire Pulse RX580 (Google "Catalina Biostar TH55HD" and look for user name deeveedee)  
      are all perfectly running Catalina and I patched them all "manually" - all DSDT patches applied with MaciSL with virtually no Clover on-the-fly patching and all booted Legacy Clover.  This UEFI hack was MUCH easier and took about 20 hours vs. a combined hundreds of hours for the old hacks.  I wanted a hack that was a little more future proof and I think this is it.  I hope you enjoy this as much as I am enjoying it.  It is a perfect MacMini8,1.
       

       
      My system specs
      HP EliteDesk 800 G4 Mini (I7-8700T / UHD 630 / Q370 Chipset / 32GB DDR4 RAM) 3 x DP Ports (connected to monitors using DP -> DVI adapters) 6 x USB 3.1 1 x USB Type-C 3.1 2 x NVMe SSD (M.2 PCIe x4 2280/2230 combo ports) 1 x SATA6 SSD 1 x Intel Ethernet RJ-45 Conexant CX20632 Audio Codec Unsupported M.2 PCIe x1 2230 Intel Wi-Fi.  A possible solution is here, but I am NOT offering any support for this.  
      macOS Installation 
      Important: You MUST BE LOGGED-IN to download attachments from this forum
      See macOS installation steps here See Known Issues here for additional installation steps that may not yet be included in my attached config files See CLOVER (UEFI) installation later in this first post
      See OC (UEFI) draft EFI here
      See BIOS configuration in attached BIOS configuration PDF document
      See EFI and /L/E kexts in attached EliteDesk.zip archive See how I developed my installation methodology here See references here See instructions here for installing two M.2 2280 NVMe SSDs and one SATA HD / SSD  
      What is not working
      Microphone port  
      What is not tested
      USB c 3.1 port (I have partially tested the USB 3 functionality of the port and it seems to be working fine with the USBPorts.kext in the attached EliteDesk800.zip archive) Wi-Fi / Bluetooth (intentional since I have not yet replaced my Intel card). A possible solution is here, but I am not offering any support for this.
       
      What is working
      Everything not mentioned above Sleep / Wake Multiple displays with IGPU graphics acceleration, hot pluggable display ports and DP->DVI adapters USB 3.1 ports Audio (internal speaker and headphone jack) Ethernet  
      Known Issues and their solutions - see here
       
      BIOS Version / Configuration
      Version: 02.11.01 Rev.A or 02.12.00 Rev.A or 02.14.01 Rev.A See attached BIOS configuration in PDF document "HP EliteDesk 800 G4 Mini BIOS Configuration.pdf" Intel ME must be enabled for proper sleep / wake of UHD 630
       
      Clover Configuration
      Clover for UEFI booting only Install Clover in the ESP UEFI Drivers Recommended drivers DataHubDxe FSInject SMCHelper File System drivers ApfsDriverLoader VBoxHfs Memory fix drivers OcQuirks (replaces AptioMemoryFix) Additional drivers NvmExpressDxe Install RC scripts on target volume Themes Choose your desired theme Install Clover Preference Pane (option not available when installing on USB thumb drive)  
      UHD 630 Framebuffer Patching
      See here and here to understand my graphics properties for use with WhateverGreen.kext Read this to see my attempt at graphics patching without WhateverGreen.kext (WEG) to get a better understanding of what WEG is doing
       
      Current Versions
      Catalina 10.15.7 Clover (UEFI) r5122 Lilu.kext 1.4.9 WhateverGreen.kext 1.4.4 AppleALC.kext 1.5.4 IntelMausi.kext 1.0.4 (acidanthera version) EFIChecikDisabler.kext 0.5  
      ScreenShots
       
       
      HP EliteDesk 800 G4 Mini BIOS Configuration.pdf
      EliteDesk 800 G4 Mini - CLOVER Rev 1.4.zip
    • By MaLd0n
      iMac20,1 Hackintosh 
      A good build for professional audio and video processing.
      We love silence and Cooler SCYTHE Ninja 5 is mandatory in this case!
      A very custom DSDT for best experience under macOS. Removed all unused devices, injected all Apple devices, essentials, cosmetics, real improvements.
       
       

       
       
      -OpenCore Vanilla TUTORIAL-
       
       
      -USB Port Mapping TUTORIAL-
       
       
      -Bios/UEFI Settings-
      CSM Support - Disabled
      Internal Graphics - Enable
      -Thunderbolt Configuration-
      Security Level - No Security
      GPIO3 Force Pwr - Enabled
       
      -Hardware-
      Mobo - Ga Z490 Vision D
      https://tinyurl.com/y4gajha4

      Processor - i7 or i9 10th Intel
      https://tinyurl.com/y6jlskwz

      GPU - RX 580, 590, VEGA 56, VEGA64, 5700XT or RADEON VII
      https://tinyurl.com/y4mxc7t6

      Cooler - SCYTHE Ninja 5 
      https://tinyurl.com/yyrbx5lf

      NVME - WD Black SN750 NVMe SSD
      https://tinyurl.com/vnq46yr
       
      -EFI folders- 
      Clover - https://tinyurl.com/yxzftuyr
      OpenCore - https://tinyurl.com/y3lt8t9l
      Just paste EFI folder into EFI partition, reboot and extract one SendMe. Post this dump here for full ACPI solution!
      Download RunMe.app dumper
       
      -If you want to buy me a beer - Donations with PayPal
      https://tinyurl.com/r2bvzm7
       
      -DSDT- Complete Solution
      DSDT.Z490 VISION D MaLd0n.zip
       
      -SSDT- Not complete solution
      SSDT-OLARILA.aml.zip
       
      -DSDT Patches-
       
       
       
      -USB Solution-
      USB SOLUTION.zip
       
       
       
       
      -Boot Time with Clover or Opencore is same-
       
      -Screenshots-































       
      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
      Thx to KGP for SSDT Thunderbolt
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!

      We're all here to have fun and learn from each other!
    • By goldrag423
      Hey everybody, I decided to try to make a Hackintosh because I had some mac programs from when I switched to Windows. I'm trying to do it vanilla but this is my first time. After some trial and error and Google I've gotten to where the Apple logo and the progress bar shows but then it freezes and all power is cut to all of the usb ports. I've attached what it looks like with the verbose flag and here's the link to my CLOVER folder:
      https://drive.google.com/drive/folders/1FDc_qLOVET64OWi9YzwDopsM1i-7nGS2?usp=sharing
       
      And here are my specs:
      Motherboard: Gigabyte b75m-d3h
      CPU: Intel i5 3570 (Ivy Bridge)
      GPU: Nvidia GTX 1660 (I've disabled it in my config.plist)

    • By AudioGod
      I have put together this simple little guide for anybody wanting to use a Patched DSDT EFI with the same configuration as me.
      This is also a thread to discuss everything Z390 Pro and try and help where we can and maybe make things a little better for you. 
       
      A huge massive thank you to @glasgood @MaLd0n @larabee These three guys have helped me and talked me so much and are as helpful as you could ever get, Without them I wouldn't have a perfect working build like I do or be putting up this Guide & Discussion Thread sharing the hard work and countless hours that we have all put in to this.   
       
       
      This EFI and Patched DSDT have been created to work with a Gigabyte Aorus Z390 Pro, 9900k with a Vega 56 but has also been tested and verified fully working with the following Hardware using Catalina 10.15.7
       
      CPU's
      8600K, 8700, 8700K, 9400K, 9600K, 9700K, 9900K, 9900KS (All KF Models work but use SMBios iMacPro1,1 instead)
       
      GPU's
      RX 560, 570, 580, 590, Vega 56, Vega 64, Radion VII, RX 5500, 5500 XT, 5600, 5600 XT, 5700, 5700 XT
      (If you have success with any different CPU or GPU's then please do let me know)
       
       
       @glasgood Has kindly put together a new simple Catalina install guide so Just Follow He's Guide For a Perfect Install.
       
       
      HARDWARE USED
      • Intel I9 9900k 
      • Gigabyte AORUS Z390 PRO
      • Sapphire Nitro+ SE Vega56 (connected to monitor with DisplayPort)
      • Corsair Vengeance Pro RGB 16GB @3200mhz (2 x 8GB)
      • Corsair RM850x 80 Plus Gold Power Supply Unit. 
      • CoolerMaster MASTERLIQUID ML360R RGB CPU Cooler
      • Samsung 970 EVO 1TB NVMe SSD macOS Catalina 10.15.3
      • Samsung 860 EVO 1TB SSD (2.5) Windows 10 Pro
      • ABWB BCM94360CS2 802.11AC WI-FI With Bluetooth 4.0 PCI-Express (PCI-E)   
      • Lian Li PC-O11DW Dynamic ATX Case
       

       

       

       

       
       
      WORKING
      • Sound 
      • Ethernet Port
      • WiFi
      • SSD Trim
      • USB 3.0 & 2.0 (All ports Open Natively)
      • AirDrop
      • iCloud
      • Hardware Acceleration
      • iMessages
      • Facetime
      • Sleep & Wake
      • Sleep and Shutdown via the Power Button
      • Handoff
      • Netflix on Safari browser
      • Continuity
      • Sidecar
       
       
      CLOVER & OPENCORE EFIs 
      Current EFI Change-Log Updated 02/11/2020
       
       
      Clover EFI Update - 04/08/2020 - Use with Bios revision F12K (F12J Pro Wifi) Only or Replace with the older F11 DSDT if you don't want to update the bios
       
      Clover Z390 Pro Navi Vega EFI 040820.zip - Vega, Navi (5700, 5700XT etc), Radeon VII DSDT EFI
      Clover Z390 Pro Polaris EFI 040820.zip - RX500 Polaris Series (RX590, 580, 570 etc) DSDT EFI
       
      Note - If your not using a 5700 XT or any other Navi GPU then remove agdpmod=pikera from the boot arguments.
       
      Please Note - I have now set KernelPM to No as standard so if you don’t have a unlocked MSR or not using my MSR Unlocked Bios Profile then go into the Clover Config.plist and set KernelPM to Yes or you won’t be able to boot up. An even better fix would be to unlock your MSR using my profile method.
       
      OpenCore v0.6.3 EFI Major Update - 02/11/2020 (Big Sur 11.0.1 Ready)
      I have now created a OpenCore EFI done the way the OpenCore Devs intended it to be made, There is no DSDT in use so you can use this EFI on any supported GPU and the SSDTs have been made so they will not be used in any other Operating System apart from MacOS.
       

      OC 063 Z390 Pro 19,1 EFI 021120.zip - OpenCore v0.6.3, SMBios iMac19,1
      OC 063 Z390 Pro 1,1 EFI 021120.zip - OpenCore v0.6.3, SMBios iMacPro1,1 (IGPU Disabled)
       
      Note - If your not using a 5700 XT or any other Navi GPU then remove agdpmod=pikera from the boot arguments.
      Note 2 - Do not try to carry across your old OpenCore Config.plist to the new EFI as to many changes have occurred in 0.6.0. Use the new Config.plist instead.
       
      PlistEdit Pro.zip - PlistEdit Pro (use to edit OpenCore)
       
      For OpenCore Using PlistEdit Pro add your details by modifying the following 

       
      PLEASE NOTE - These EFIs are setup to be used with your msr Unlocked but if for any reason you can not unlock MSR then just modify following in the OpenCore config.plist :
      
       
       
       
      PLEASE NOTE - Please flash your motherboard bios to revision F12K (F12J Pro Wifi) to use my current Clover EFI. It’s a major rework of the bios and vital changes have been made to the layout and power tables. New DSDTs have been created and installed into the new EFI’s but will not work correctly with any other bios revision.
       
      Latest Gigabyte Z390 PRO/Pro Wifi BIOS Firmwares
       
      mb_bios_z390-aorus-pro_f12k.zip - Aorus Z390 Pro Bios Firmware F112K
      mb_bios_z390-aorus-pro-wifi_f12j.zip - Aorus Z390 Pro Wifi Bios Firmware F112J
       
       
      CFG Unlock (MSR) F12K (F12J Pro WIFI) BIOS Profile - The Easy Way 
      Highly recommended if your using a Vega 56/64, Radeon VII or Navi GPU
       
       
      DSDT's FOR CLOVER ONLY (A big thanks to @MaLd0n for compiling these DSDT's)
       
       
      To Create Your Own Patched DSDT Message @MaLd0n using the link bellow
      https://www.olarila.com/forum/17-dsdt-patch-requests/
      (If you want a perfect setup then getting your own patched DSDT made would be the best thing to do, Mine will work perfectly fine but different hardware no matter how small a change it is can tend to have some sort of effect on the DSDT and your setup)
       
       
      If Your Not Using File Vault Then Please Disable Hibernate
      disablehibernate.command
       
       
      ADDITONAL DOWNLOADS
      Clover
      Clover Configurator
      Kext Updater
       
       
      OPTIONAL DOWNLOADS
      BroadcomFix.zip   (Use these kexts if your Broadcom bluetooth/Wifi isn't working properly)
      FakeSMC    (Can be used instead of VirtualSMC)
      Hackintool
      IORegistryExplorer
      Native Display Brightness with MonitorControl
       
       
       
      BIOS SETTINGS (Bios Revision F12k & F12j Pro Wifi)
       
      • Enter BIOS -> Press Delete -> Enter Setup
      • Save & Exit -> Load Optimized Defaults
      • Boot -> CFG Lock -> Disabled
      • Boot -> Windows 8/10 Features -> Win 8/10 WHQL
      • Boot -> CSM Support -> Disabled (Can be set to Enabled if need be but try to have it set to Disabled first)
      • Favourites -> Extreme Memory Profile (X.M.P.) -> Profile1
      • Favourites -> VT-d -> Disabled (Can be set to Enabled or Disabled, Your choice)
      • Settings -> IO Ports -> Internal Display Output -> PCIe 1 Slot
      • Settings -> IO Ports -> Internal Graphics -> Enabled (Disabled If Using SMBios 1,1)
      • Settings -> IO Ports -> DVMT Pre-Allocated -> 64M
      • Settings -> IO Ports -> DVMT Total GFX0-Allocated -> 256M
      • Settings -> IO Ports -> Aperture Size -> 256MB
      • Settings -> IO Ports -> Wifi -> Disabled (Z390 Pro Wifi Only)
      • Settings -> IO Ports -> Audio Controller -> Enabled
      • Settings -> IO Ports -> Above 4G Decoding -> Enabled
      • Settings -> IO Ports -> USB Configuration -> Legacy USB Support -> Auto
      • Settings -> IO Ports -> USB Configuration -> XHCI Hands-off -> Enabled
      • Settings -> Miscellaneous -> Software Guard Extensions (SGX) -> Disabled
      • Settings -> Platform Power -> Platform Power Management -> Enabled
      • Settings -> Platform Power -> ErP -> Enabled
      • Settings -> Platform Power -> RC6(Render Standby) -> Enabled
      • Save & Exit → Save & Exit Setup
       
       
      SCREENSHOTS

       

       

       

       

       

       

       

       

       

       

×