Jump to content

OpenCore Inject Nvidia


10 posts in this topic

Recommended Posts

Hello

 

I am trying to convert from Clover to Opencore but unfortunately OpenCore doesn't have an equivalent to the Inject Nvidia and I get a black screen after the boot process. My gpu is a MSI GT 210 and I am running Catalina 10.15.5 (using the legacy video patch from dosdude and chris111). I've been told that I need DSDT to set up my GFX0 device properly. Using clover I can boot without problems and with full acceleration. I can boot with OpenCore but only with nv_disable=1. 

 

OC FolderOC.zip

My IOREG: Antonios’s iMac.zip

 

 

 

Edited by NBABASKETBALL

You're using iMac15,1 SMBIOS on what seems to be an old pre-USB3 platform. Before anything else, please post your system's hardware specs.

 

If this is an old Core2/Clarkdale/SandyBridge platform, consider using iMac13,x/iMac14,x SMBIOS instead. These were the last iMac model ranges fitted with nVidia graphics. iMac15,1 is a Haswell-based model fitted with AMD Radeon R9 graphics.

Try the attached SSDT to enable Nvidia GPU on OC.

Copy the attached file SSDT-GFX0-210.aml to EFI/OC/ACPI

Copy the attached file config.plist to EFI/OC

config.plist

SSDT-GFX0-210.aml

 

Also, why are you using VooDooHDA kext ? Have you tried AppleALC.kext instead ?

 

@Hervé He started a thread here but apparently the Forums prevents him from replying because he is "new" ?? Seems crazy that the Forums let him start a thread there but not allow him to reply. So, he created a new post here. He has mentioned his system specs.

@Hervé My specs are old but with iMac 15,1 they work fine. I used to have iMac 14,2 but I tried a Big Sur install on my second hard drive and then I didn't bother changing it. do you suggest any reasons why I should? 

CPU: xeon e3120 

Dell optiplex 330 motherboard

GPU: GT 210

4GB DDR2 RAM

500GB WD SSD

 

@MacNB Thank you so much. I booted with full acceleration and everything. I know can get rid of clover. 

One of the side effects I expect you'll encounter by using iMac15,1 SMBIOS is lack of proper/limited CPU power management. Given that your platform is running on an old Wolfdale Xeon CPU (same generation/family as E8x00 or Xeon X52xx), you'll probably only notice LFM (@2.0GHz ?) and HFM (@3.16GHz) with nothing in between.

 

I have a similar setup in my old Vostro desktop fitted with a Wolfdale Xeon X5270 and only SMBIOS profiles such as MacPro3,1 or iMac10,1 allow CPU to run at intermediate speeds, MacPro3,1 providing better CPU power management than iMac10,1. Such unsupported models SMBIOS force me to use the -no_compat_check boot arg of course.

 

I keep a dedicated config on the side, set with iMac13,2 SMBIOS, that I use when I want to install a macOS update (using the SMBIOS of an unsupported model preventing update offers and installations).

Hiy MacNB,
I have a NVIDIA Quadro FX 880M with Processor: Intel Core i5 Speed: 2.39 GHz and all work fine with Clover but I would like to switch to Opencore due to better stability and some premium features so I created an EFI folder that follows Dortania's guides and I'm stuck close to IOConsole users: gIOScreenLock so I know this is a GPU related issue.
In Clover, I only use the InjectNvidia tag but I don't know how to duplicate that in the Opencore configuration
  Thank you for your help

config.plist

KH’s MacBook Pro.ioreg

Your config.plist file does NOT match the IOREG output.

That is, the IOREG file shows that your Mac is a MacBook Pro 16,3 but your config.plist file shows that you are using iMacPro1,1.

It appears that you have taken someone's desktop config file for your laptop.

E.g. in the ACPI section, you are adding SSDT-PMC.aml but that is usually for a desktop system with Z370 chipset :unsure:

 

Model ID has a large impact on Graphics and CPU power management.

MacBookPro16,3 is a strange choice for such an old i5 520M CPU - especially for power management and battery life.

For your laptop you should be using MacBookPro6,2 - but that does not support Catalina so you could try -no_compat_check boot-args.

If MacBookPro16,3 works for you then good luck.

 

I am surprised that you have working system with Quadra FX880M since that GPU is based on GT216M chip and only supported up to High Sierra I think. But then I do not have experience of Nvidia on laptops.

 

Any way, based on the IOREG you posted, I have added Device properties for your FX880M and changed the SystemProductName to MacBookPro16,3. You need to Fill In the missing platformInfo fields and try it.

 

kmsn-config.plist

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...