Jump to content
Followers 0
Jaeger798

Panic diags file unavailable, panic occurred prior to initialization

6 posts in this topic

Recommended Posts

Hello everyone! I just bought a PC with the only purpose of turning it into a hackintosh and, guess what, it's my first time. I decided to jump straight into Opencore as that seems waay more stable and reliable than Clover, but every post i found while googling proposed solutions only for the latter...

 

Well, let's begin. First of all, my build:
CPU: i7-6700K
GPU: i plan to use the integrated one, so it would be Intel HD 530 
RAM: GSkill TridentZ 3200MHz 16x2 located in the 2 slots next to the CPU
Motherboard/Laptop model: Z170X Designare by Gigabyte
Audio Codec: Realtek 1150
Ethernet Card: I don't think i have one? If it's part of the mobo i don't know it, but i plan to use a wireless card 
Wifi/BT Card: (if available) I got a compatible card (one of the chipsets that the buyer's guide indicates as working with Big Sur) I still did not install it but it should work out of the box

 

What guide/tool followed: I followed Dortania's guide with the plist config for Skylake processors
What part I got an issue with: Well I'd like to know that, here's a picture: https://imgur.com/DJnpUwv & https://imgur.com/jPY4RUF
What files/config I am using: https://drive.google.com/file/d/1M4TfyJkSUJtq1OyjSvchVHzdXoLcfwQu/view?usp=sharing

 

Ok so the story so far: I started following the guide and all went well during the preparation of the USB drive, I just want to note that I dowloaded everything in DEBUG version because i kinda knew i would have needed it; the first problem occurred when i tried to boot from it: after about 30sec the screen would lose signal and i was not able to see anything. So back in Windows I see that in my drive there's a .txt file, which at the end reports a common [EB|#LOG:EXITBS:START] error. Following the troubleshooting section I see that it's just about this:
 If your firmware supports MATs:
- Enable both RebuildAppleMemoryMap
 and SyncRuntimePermissions
 then disable EnableWriteUnprotector.  
Actually it says that MAT is supported only in newer firmwares, and occasionally back to skylake. In my log.txt i could not find any "OCABC: MAT support is 1/0" so i just went with trial and error and tried both configurations, and the one that changes something is the one that assumes I do have MAT. 
So what has changed now is the new log screen I have attached, which at the end reports:
 "Panic diags file unavailable,  panic occurred prior to initialization"
and
"Memory panic stackshot succeded"
While the log file in the drive still reports [EB|#LOG:EXITBS:START]

 

All the googling that i did would suggest that I have a problem with CPU power management, so I tried to go back and see if I did something wrong with my ACPIs, but they look ok... I made them via SDTTime. The only thing I can say is that the EC and USBX are two separate files, but they say it doesn't matter...

 

Another thing I found talks about that damned CFG lock, for which I don't have an option in my BIOS. I do have the two quirks enabled to get around that though, so I don't thik that is the case.

 

At last, somebody says it could be a problem with the iGPU (which would explain why it lost signal before). I do have it enabled in my bios and 64mb allocated... I think that's it, the only thing I tried was removing the "framebuffer-fbmem" line that allocates 9MB, but nothing changed....

 

So I don't know what to try next, maybe there's something in the log that I can't read or maybe I did something wrong while setting everything up... I don't know, please help, I've been stuck for 2 days!

 

(The log file in the drive is here: https://drive.google.com/file/d/1gmE-fe3PXTtMuQAY6GXi9O-B91XM0wXo/view?usp=sharing )
 

Share this post

 

1 hour ago, RagK said:

Reset NVRAM then try. If it does't work then go here .

Thank you so much! I tried it but did not solve it...

I followed that guy's guide and first added -igfxvesa under NVRAM in propertree, so now my boot-arg looks like this: 

-v keepsyms=1 debug=0x100 alcid=1 -igfxvesa 

 

Then he said I needed a video patch, for which he provided the code

Now, I use proper tree, and I did not find a way to edit the code of my config.plist directly, so I added each voice manually, I think I did it right but there might be an error here. The code he provided looks like this:

Quote

<key>PciRoot(0)/Pci(0x02,0)</key>
            <dict>
                <key>AAPL,GfxYTile</key>
                <data>AQAAAA==</data>
                <key>AAPL,ig-platform-id</key>
                <data>AAAbGQ==</data>
                <key>framebuffer-fbmem</key>
                <data>AACQAA==</data>
                <key>framebuffer-patch-enable</key>
                <integer>1</integer>
                <key>framebuffer-stolenmem</key>
                <data>AAAwAQ==</data>
                <key>hda-gfx</key>
                <string>onboard-1</string>
            </dict>

and what I added in propertree looks like this:

Immagine.thumb.png.9ecc8bd159f58b5e2b392258955c280b.png

 

The data is translated from Base64 to Hex

Share this post

Just for information!
why is the google drive access disabled, and next which MacOS version do you intend to install and where is your EFI folder? Otherwise nobody can really help you

Share this post

7 minutes ago, spakk said:

Just for information!
why is the google drive access disabled, and next which MacOS version do you intend to install and where is your EFI folder? Otherwise nobody can really help you

You are totaly right! The reason is I'm a noob ahahah

https://drive.google.com/file/d/1DXCG9NIwgnyBrmbeG3fzPmfjMhuPEPcf/view?usp=sharing Here's the link to my EFI folder which includes the config.plist 

I'm trying to install MacOS Catalina 10.15.6 using OpenCore 0.6.1

Share this post

×