Jump to content
Sign in to follow this  
Followers 0
wowood

My hackintosh desktop think it has a battery

1 post in this topic

Recommended Posts

I build a HackMini with GB-BRi5H-8250, follow the https://dortania.github.io guide, everything work fine, except 2 tiny problems.

hope someone can help me,thanks very much.

 

system info

- macOS 10.14.6

- OpenCore 0.5.9

- SMBios iMac19,1

 

problems

- my device is a desktop, but get a battery tab in Energy Saver.

- hdmi audio not work after startup. It work fine after I plug and unplug the hdmi cable or toggle the display power button.

 

 

iShot2020-07-25AM10_06_30.thumb.png.cd1f2d2fd2c5cdeddc58c6d409324376.png

 

 

OC.zip

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

Announcements

  • Similar Content

    • By aerokevv
      Hey everyone,

      I'm having some trouble with connecting my new 3rd monitor to my machine.
      First off, here is some info about my build:

      macOS High Sierra 10.13.5
      CPU: Intel i7 Coffee Lake 8700k
      GPU: NVIDIA GeForce GTX 1070
      Motherboard: Asus ROG STRIX Z370-F GAMING
      Running on Clover. (config.plist attachment below)

      Monitors:
      DELL U2718Q 4K
      iiyama ProLite XUB2792UHSU 4K
      Phillips HD Monitor

      So the problem is:
      I bought the iiyama to use as a 3rd monitor. Previously I was using the DELL through a DisplayPort, and the Phillips through HDMI which worked fine.
      When I first got the iiyama monitor and I plugged it in everything was working great. The next day I boot up my machine and it will freeze on a black screen after I boot macOS through the clover bootscreen. I unplugged the new monitor, restarted the machine and it would boot normally again.

      I started trying some different inputs and nothing seemed to solve the problem. All that I know is that the machine freezes as soon as I plug in a 3rd cable, doesnt matter if its HDMI or DP. I even bought a HDMI to DP cable for the Phillips, to see if it was an HDMi problem, but even then it doesn't work. I've also tried powering the monitors off and turning them on once the machine has booted. Also no luck.

      Any help from one of you Hackintosh guru's would be highly appreciated. I bought the 3rd screen to make working from home even more efficient, but sadly enough my build won't allow me...

      Thanks in advance!

      Greets,

      Kevin
      config.plist
    • By Tristana
      Hello, and thank you for your help!
       
      Ever since installing my new Sapphire Radeon Pulse RX580, I've been having issues with audio freezing up for the whole system- seemingly the coreaudiod process crashing / my USB audio interface not working. It feels random but seems to correlate with playing youtube videos, streaming audio in Finder, playing sound files from chat clients like Telegram/Discord and such. The system otherwise works as normal, with only audio related functions breaking. Sometimes instead of a full freeze / crash, the sample rate of audio will just drop significantly, causing a lot of aliasing.
      I followed this guide here, though it is outdated and some KEXTs have been merged with WhateverGreen. The shikigva=4 & -rad4200 boot arguments weren't available in WhateverGreen so I didn't add any boot arguments.
      https://hackintosher.com/guides/fix-rendering-issues-fcpx-high-sierra/
       
      My issue was not fixed by this. I also learned that USBInjectAll hadn't been given a custom SSDT and so I made one, which I have included at the end of this post. I also disabled the 15 port patch which had been left on. My USB ports now show up properly (though I've excluded my mobo's type-c port to meet the 15 port limit). My audio issues still have not been fixed, though.

      On High Sierra, the crash was irrecoverable- opening sound in system prefs just froze up, and I have to reset the system to get audio back. In Catalina, I seem to be able to choose a different audio device then go back to my external interface to reset the driver and get sound back.

      Thank you for any help / ideas you can offer!

      UPDATE: Issue still persists. I'm now using a USBPorts.kext created by Hackintool and have updated my list of current kexts below.

      System:

      Kexts:


       
       
    • By wegosi
      Hello.
      Could, please, anybody with knowledge help me?
      Problem: on internal monitor all colors are perfect. on External - I have banding gradients and colors.

       
      My system: 
      ASUST N56VB
      Catalina 10.15.3
      Intel HD4000
      Intel® HM76 Chipset
      External monitor 21:9 2560x1080 via HDMI.
      Clover 5115
       
      What I tried:
      1. Different versions of Lilu and WhateverGreen
      2. Different combinations in config.plist in devices

      In mac Graphics/Displays I see only 24bit of color depth. Is it OK?
       

      Installed kexts:

       
      I don't update WhateverGreen, because then my external monitor stops working at all
       
      My config.plist:

       
       
      Graphics info:

       
      What other info should I provide?
      How to fix it? Thank you in advance
       
      config.plist
       
      EFI zip (not other options to upload here? max 7.85mb on forum, right?):
      https://drive.google.com/open?id=1bUFt_ouKNmdKJH1451AbPGQmh-K9OsHU
       
    • By e285ne
      Hello,
       
      could you help me with Intel UHD 620 HDMI port?
       
      HP ProBook G6 440
      Intel Core i5-8265u
      Catalina 10.15.4

      I've installed Catalina 10.15.4
      But I can't get HDMI working
      When I connect HDMI cable I got freezes and errors as in file freezes.png (attached)

      [IGFB][INFO ] Setting DP power failed (0xe00002bc), ignoring empty dongle handling (likely HDMI/TMDS case)

      I also looked into IOregistryExplorer and see that the connect type is 00400000 there for FB@1
      I tried to patch it via setup.plist but it seems that there is no change in IOregistryExplorer.
      Though the Hackintool sees the change (image attached)
      e285ne.zip
    • By Kailash
      I successfully managed to install Hackintosh on my Lenovo Ideapad 520 but now I don't have audio, brightness control feature or battery indicator. My audio driver is an ALC230. I am new to all this. What do I do to solve this? I have attached my EFI files below.
      EFI.zip
×