Jump to content
sapnupuas69

Intel HD 530 shows as Display 7MB - Catalina

3 posts in this topic

Recommended Posts

Posted (edited)

hello everyone, so my Intel HD 530 is not getting recognised by macOS. In the about my mac section, it shows as 'Display 7mb'
Im using HDMI connected to motherboard. I can only boot into os with 0x12345678 or 0x193b0005 as Fake Id and 0x19120000 as platform id with Mac17,1 as smbios. I do have the latest version of Lilu and WhateverGreen installed in boot loader and in L/E too. 

I have looked through many forum posts, and have not found a solution yet. 

 

732346967_Screenshot2020-07-21at3_48_32AM.png.2d151bb79b38c2f46199b1bf2327f0e7.png651656002_Screenshot2020-07-22at7_37_50PM.thumb.png.44b6e3f5d6fb1e9517d41bd77212fd99.png

edit: i forgot to change the smbios in the picture, I tried changing to 17,1 and restart, still no luck

EFI.zip

Edited by sapnupuas69
smbios showing 14,2

Share this post


Link to post
Share on other sites
Advertisement
4 hours ago, sapnupuas69 said:

hello everyone, so my Intel HD 530 is not getting recognised by macOS. In the about my mac section, it shows as 'Display 7mb'
Im using HDMI connected to motherboard. I can only boot into os with 0x12345678 or 0x193b0005 as Fake Id and 0x19120000 as platform id with Mac17,1 as smbios. I do have the latest version of Lilu and WhateverGreen installed in boot loader and in L/E too. 

I have looked through many forum posts, and have not found a solution yet. 

 

732346967_Screenshot2020-07-21at3_48_32AM.png.2d151bb79b38c2f46199b1bf2327f0e7.png651656002_Screenshot2020-07-22at7_37_50PM.thumb.png.44b6e3f5d6fb1e9517d41bd77212fd99.png

edit: i forgot to change the smbios in the picture, I tried changing to 17,1 and restart, still no luck

EFI.zip

 

download and start the RunMe.app from "MaLd0n", the app generates the missing information from your hardware and creates a folder with all important files (Ioreg files, DSDT etc.) on your desktop. At the end upload this folder so that someone can help you.

 

 

RunMe.app.zip

Share this post


Link to post
Share on other sites
Posted (edited)
10 hours ago, spakk said:

 

download and start the RunMe.app from "MaLd0n", the app generates the missing information from your hardware and creates a folder with all important files (Ioreg files, DSDT etc.) on your desktop. At the end upload this folder so that someone can help you.

 

 

RunMe.app.zip

 

I have uploaded the file, it would be nice if anyone could check what am I doing wrong. Thanks.

Send me iMac.zip

Edited by sapnupuas69

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

Announcements

  • Similar Content

    • By Del
      I installed Mojave on Lenovo G570 i5 Sandy HD3000 with resolution 1366x768 on LVDS display with series 6 chipset and getting stuck with gfx issue
      I was able to boot (without qeci) before using hd3000 patch 
       
      
       
      So I went back to High Sierra (HD3000 natively supported) and older os
      And the setup works on Mountain Lion but not Mavericks or newer.
       
      AppleIntelSNBGraphics doesnt load. Ive tried snbplatform id 0x00 0x00 0x01 0x00 
      Also edid injection.
        
      Nothing seems to work Stuck on it for almost 3 weeks
      This is very frustrating
      Any help is appreciated 

      Any suggestions?@Hervé
    • By mridhulofficial
      Hi team,
      Please advice me for the issue. Already gone through other posts.
      My spec Ryzen 9 3900x and Gigabyte B550 Aorus Pro AC motherboard.
      I installed Cataliana on my system .. everything looking perfect exept ethernet. Installed LucyRTL8125Ethernet.kext and ethernet is showing on network window but no internet connection. Adjusted hardware settings in network as Manually/100baseTX/full-duplex, flow-control but issue not fixed.
      Please help me.
       
      Thanks is advance.
    • By autantpourmoi
      I'm an happy user of a x99 built hackintosch since 6/7 years using it mainly for photoshop and fcpx ... Using new camera with better resolution and video in ProResRaw , my built start to struggle a bit 
      I'm thinking of making a new built and seeking for advices for this new built that I want evolutive and last at least as long as my previous built 
      I'll use a SSD M2 forth Generation so I need at least 2 to 3 SSD M2 PCI x4 slots
      then which proc to use , I was thinking about the AMD Ryzen 9 3900xt or the Intel I9 10900k ( don't have the money for AMD threadripper ) if you have better idea I'm really open to it as long as you explain it to me 
      then which chipset should I use:
      for Intel  , should I go to Z490 or X299 or W480
      For AMD , I think I have only the choice of X570
      I always used Gigabyte motherboard so it will be naturally my first choice but again I'm open to any suggestion
      I need at least usb 3,1 Gen 2 and TB3 is not necessary but an option and can be add later on with a PCI Card I think
      So I'll be pleased o read your opinion and the choices that you'll do for the purpose of this built 
      thanks in advance 
       
       
    • By MaLd0n
      -OpenCore Vanilla TUTORIAL-
       
       
      -USB Port Mapping TUTORIAL-
       
        1 -Create a USB bootable
       
      Create your usb installer, use this tool and download Catalina or Big Sur from Apple servers
       
      Catalina
      installScript_allfullapp.zip
       
      Big Sur
      installScript_1016fullapp.zip
       
      Credits: crazybirdy
       
      Copy Catalina / Big Sur installer to Applications folder, open terminal and run
       
      Catalina
       
       
      Big Sur
       
       
      If you want check one step by step, check here
       
      -Opencore Vanilla Tutorial
      https://tinyurl.com/ycvcnp8h
       
      2- EFI folder USB installation
       
      -EFI OpenCore Folder Desktop 10th Intel Processors
      Paste this EFI folder in EFI partition in your USB STICK
      https://tinyurl.com/ybwr9kq3
       
      -EFI Clover Folder Desktop 10th Intel Processors
      Paste this EFI folder in EFI partition in your USB STICK
      https://tinyurl.com/yxsw7d3t
       
      3- EFI folder SSD
       
      -EFI OpenCore Folder Desktop 10th Intel Processors
      Paste this EFI folder in EFI partition SSD 
      https://tinyurl.com/ybwr9kq3
       
      -EFI Clover Folder Desktop 10th Intel Processors
      Paste this EFI folder in EFI partition SSD
      https://tinyurl.com/yxsw7d3t
       
      4- Start Fine Tune
       
      Run this app and post full dump here for full ACPI solution
       
      RunMe.app
      https://tinyurl.com/y9562hz7
       
       
      If you like a SSDT way, here we go
      SSDT-OLARILA.aml.zip
       
      5- USB Solution
       
      Use these kexts, enable XHCI port limit patch
       
      USB INTEL SERIE 400.zip
       
      and follow this tutorial for remap USB ports
       
       
      --DSDT PATCHES--
       
      -FIX ERRORS AND WARNINGS -FIX ACPI ERRORS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA SERIE ID -DMAC -REMOVE LINES, PROBLEMATIC and UNUSED -FIX K.P in REBOOT -NVRAM -REAL TIME CLOCK -SLPB -DARWIN / WINDOWS -XHCI -PLUGIN TYPE -HDEF -ARTC -IPIC -TIMR -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -UAR1 -LAN -FWHD -USBX -PMCR -PPMC -XSPI -kUSBCompanionIndex -io-device-location -IMEI -EC -PNLF -ARPT -GFX0 -NVME -ACPI-WAKE-GPE -DTGP -HDMI / HDAU  
      --SCREENSHOTS--































      -If you want to buy me a beer - Donations with PayPal
      https://tinyurl.com/r2bvzm7
       
      Big Thanks to XLR and your Badass Motherboard, Ultrafast CPU, Coolest Heatsink, Huge Graphics Card, Tonnes of RAM,
      Gigantic Hard Drive, Lightspeed Disk Burner, Professional Sound Card, Massive LCD Display.
       
       
      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!

      We're all here to have fun and learn from each other!
    • By Bikash
      I have installed catalina and bootloader is opencore.

      But the AppleAlc is not working for alc282 codec. I have tried evey layout id provided in documentation for alc282 but not working.
      But the voodohda is working.

      I have attached ioreg file, codec dump, applealc debug log and Efi folder.

      Please help me to make this work.
      Thank you
      applealc.zip
×