Jump to content

AptioMemoryFix.efi name changed?


20 posts in this topic

Recommended Posts

  • 4 weeks later...

I tried the 'new' clover 5045 and the new aptio fixes on my dx58so



its really not performing as well as my old el capitan on the older clover from a couple years ago


can someone suggest a good aptio fix version for the DX58so board with clover in the high 4900 as that seems to be working better on this board




Link to comment
Share on other sites



thanks for weighing in .. I appreciate it


have you had a chance to see a post to you on your public feed...


I had installed I believe OSXaptiofix3drv if that is the new one that instals in the new location and something very strange happened to the bios / board of my dx58so


I used the tonymac method to install a fresh 10.14.5, installer usb legacy boot to a fresh format GPT disk in UEFI mode with APFS


in [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] I kept it simple installing for a Mac Pro 5,1 (which I was using before on my 10.11 config.plist) 


after installing I believe I upgraded clove to 5045, adding all the recommended drivers, as well as replacing all of the -64 versions I have used in the past... there were a couple new ones.


At this point I don't believe I had installed NVRAM rc scripts


I then used my original config.plist that has been working great from el capitan


I believe while upgrading OS X with the 10.14.6, something very strange happened..


I assume the update completed but


I was left with an additional preboot in clover selector.. something like install preboot from preboot or something to that effect


I now have preboot, install preboot from preboot, movaje and recovery as options


but here is the really strange part.. somehow there has been a preeminent change to my motherboard


when booting, if I don't go into the boot one time disk selection menu, it boots to a blinking then steady cursor  - that has never happened


when I go to the disk boot menu in bios (F10) instead of seeing a list of drives like this





I now have 


Mac OS X




if I manually select the UEFI disk it will boot to clover 


I have tried:


going into shell and removing all entries

reverting firmware back multiple generations and reinstalling latest re-setting optimal defaults

jumper boot into NVRAM reset mode and resetting passwords

even booting with NO DRIVES it shows Mac OS X in the Boot menu


I can't get rid of it and the board will no longer auto boot any volume while in UEFI boot mode


so somehow, that update managed to write something to the firmware of my motherboard



I have since used migration assistant to move data from my el capitan disk to the mojave install for testing to see if my needed apps will work and what conflicts I have


using my previous DSDT edits and clover config.plist the system


goes to sleep on its own

power management, CPU recognition, GPU recognition, all seem to be working

I had to upgrade from my gtx660 to a vega 56 for graphics



now what I can't seem to fix


wake is still hit or miss, when it does not wake properly all lights and fans come on, but displays stay black and the GPU while the lighted logo lights, the the built in load meter does not, and its not a GPU issue, I think that it is immediately panicking or something because you can't ping the machine or log in via ssh


the logs show nothing after the system when to sleep, normally if my system panicss it reboots.. but in this case it just sits there and I must reset


sometimes on reboot, boot, I will get the 'do not enter' sign and it takes several reboot attempts to clear whatever is screwed up before it boots again


ANY HELP taking a look at my DSDT, ioreg, and chosen drivers etc would be GREATLY appreciated as I have been banging at this now for 2 weeks and its just not stable enough to use as my daily driver again..


I can't go back to el capitan easily as 

1 the graphics card has to be swapped back

2 the system still wont get past this new Mac OS X entry in the UEFI boot menu that I can't clear






Link to comment
Share on other sites



I bring it up as I have read a couple threads where the new osxaptio fixes are possibly opening up native nvram.. perhaps its providing additional access to the motherboard


I see no other way that the DX58so could have been permanently effected other than drivers in the latest clover doing perhaps something it was not designed to do



Link to comment
Share on other sites



OK but I have been running hackintosh since 10.5 and never had a OS X update write permanent code to my motherboard


I also noticed that during this mojave install / experiment is that during the original 10.14.5 install that went onto a virgin disk with tonys version of clover installer... it likely used an updated Mac Pro 5,1 smbios definition but at some point and at this point I can't remember, I started using my clover config.plist from my el cap installation as that has been working rock steady since its install.... but that has an older smbios definition for Mac Pro 5,1  IE not the required firmware versions that apple requires  for mojave


thus during the install of the 10.14.6 update, does the apple update itself contain or attempt to do the firmware updates ?   I always thought that firmware updates were separate and had to be done stand alone?


But again I have read a couple threads where something similar has happened with recent clovers were a motherboard becomes unbootiable but I can't find it again... 


a couple weeks so far of 3-4am nights trying different combinations and I am getting lost in my work not remembering what was doing what


so the differences in the mechanics of the different versions of memory fix relate to how slide is calculated etc? 


what is the best way to test to see if the chosen memoryfix is working correctly


from what I have read I think that I am experiencing some symptoms of not having the right version


occasionally not waking from sleep, using a natively supported GPU vega 56, black screen with a frozen system behind it


occasionally on startup, getting the stop sign


nvram using rc.scripts and clover driver is holding my testvar but occasionally asking me to reactivate iCloud services even though nvram does not appear to be changing 




its really pissing me off that I can't find a way to un-brick the UEFI boot menu of my board and clear this 'MAC OS X'  entry/header that my OS X UEFI volumes fall under....


because the board wont auto boot anything at this point .. I have to go into the one time boot menu and select the volume under that header otherwise the motherboard boots to a intel splash screen then a black screen with a momentary blinking cursor then solid cursor


even with no disks installed I get the Mac OS X entry in the disk list so its not something the UEFI is getting from an EFI partition .. its burned into the board at this point





  • Like 1
Link to comment
Share on other sites

Is it useful to submit debug logs regarding OsXAptioFix3Drv ? How can this be done ?


I would be eager to switch to OsXAptioFix3Drv, but AptioMemoryFix works significantly better on my hardware.


Initial macOS boot is correct with either driver, but only AptioMemoryFix is able to wake my system from hibernation.
With OsXAptioFix3Drv, when I try to wake from hibernation, macOS displays the screen to log back in, then reboots.


As this is perfectly reproductible on my config, I think someone having knowledge of these drivers might be interested into investigating this.

Edited by barijaona
syntax clarification
Link to comment
Share on other sites

  • 1 month later...
On 8/30/2019 at 7:19 AM, dragonmel said:


I can't get rid of it and the board will no longer auto boot any volume while in UEFI boot mode

so somehow, that update managed to write something to the firmware of my motherboard



I think MacOS has simply added its own entry in the nvram. I don't think this is any issue. 


You can try removing the entry using this program https://www.softpedia.com/get/System/Boot-Manager-Disk/Bootice.shtml


This is a windows based program.

Edited by nijhawank
Link to comment
Share on other sites


  • Create New...