Jump to content
About Just Joined group Read more... ×
Sign in to follow this  
Followers 0
bluenote56

10.14.5 no sound on HP laptop

7 posts in this topic

Recommended Posts

Hi, just updated my HP laptop (in signature) and everything' s fine but sound. I tried to reinstall VoodooHDA 2.9.1 without any success.

Could someone give me some advice to fix it?

 

Thanks

 

 

Share this post


Link to post
Share on other sites
Advertisement

You need to figure out what audio device you have and its codec.  Mine is the Realtek ALC295.  Your's is probably very similar.  I used to use VoodooHDA but have switched to AppleHDA by using Lilu+AppleALC.kext.  I also needed FakePCIID.kext+FakePCIID_Intel_HDMI_Audio.kext in order to get HDMI audio to work.  My layout ID is 3.  That is set in the config.plist for Clover.  All of these kexts go in the Clover/kexts/Other folder.  Give it a try and see if it works for you.  If not, it's because you have a different codec/audio device.

Share this post


Link to post
Share on other sites

HP in signature:

HP 15bs059nl - 8 MB RAM - Intel Core i5 2700U @ 2.50 Ghz Kaby Lake - Intel Graphics HD 620 - Radeon 520 - 1TB HD

 

You probably meant i5 7200U, right?

 

With regards to audio, information you had posted here last year clearly showed that your HP laptop is fitted with Realtek ALC282 audio (layout 3 apparently). Since that could not have possibly changed, why don't you run with vanilla AppleHDA and latest Lilu + AppleALC ?

https://github.com/acidanthera/AppleALC

https://github.com/acidanthera/AppleALC/releases

https://github.com/acidanthera/AppleALC/wiki/Supported-codecs

 

And get rid of patched AppleHDA / VoodooHDA+AppleHDADisabler kexts of course.

Edited by Hervé

Share this post


Link to post
Share on other sites
7 hours ago, Hervé said:

HP in signature:

HP 15bs059nl - 8 MB RAM - Intel Core i5 2700U @ 2.50 Ghz Kaby Lake - Intel Graphics HD 620 - Radeon 520 - 1TB HD

 

You probably meant i5 7200U, right?

 

With regards to audio, information you had posted here last year clearly showed that your HP laptop is fitted with Realtek ALC282 audio (layout 3 apparently). Since that could not have possibly changed, why don't you run with vanilla AppleHDA and latest Lilu + AppleALC ?

https://github.com/acidanthera/AppleALC

https://github.com/acidanthera/AppleALC/releases

https://github.com/acidanthera/AppleALC/wiki/Supported-codecs

 

And get rid of patched AppleHDA / VoodooHDA+AppleHDADisabler kexts of course.

Thank you very much. I will try this solution as soon as possible and give you feedback.

 

Share this post


Link to post
Share on other sites
On 5/26/2019 at 1:50 PM, Hervé said:

HP in signature:

HP 15bs059nl - 8 MB RAM - Intel Core i5 2700U @ 2.50 Ghz Kaby Lake - Intel Graphics HD 620 - Radeon 520 - 1TB HD

 

You probably meant i5 7200U, right?

 

With regards to audio, information you had posted here last year clearly showed that your HP laptop is fitted with Realtek ALC282 audio (layout 3 apparently). Since that could not have possibly changed, why don't you run with vanilla AppleHDA and latest Lilu + AppleALC ?

https://github.com/acidanthera/AppleALC

https://github.com/acidanthera/AppleALC/releases

https://github.com/acidanthera/AppleALC/wiki/Supported-codecs

 

And get rid of patched AppleHDA / VoodooHDA+AppleHDADisabler kexts of course.

 

I tried but I had no success. I put AppleALC latest release and the other kexts in Clover/Kexts /Other all of them. No sound. I tried to install Voodoo again. No sound. Maybe I' m doing something wrong but after all it's not this hard to do. I don't know what's wrong. Thanks anyway.

 

Share this post


Link to post
Share on other sites

I am using VoodooHDA on my HP laptop.. works without issues.

Share this post


Link to post
Share on other sites
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

Announcements

×