Jump to content
Legomann

(Partial) success: MSI Z390 + i5 9600K

4 posts in this topic

Recommended Posts

Hello all,

 

I'm about to build a hackintosh and want to share my findings in that process. Also maybe get some help. 

 

The goal is to have a fast Mac with large disk capacity for image processing and a Windows gaming machine at the same time. The components I chose:

  • MSI Z390 Gaming plus
  • i5 9600K 6cores with HD630 graphics
  • 2x8GB Crucial DDR4-2666
  • nVidia GTX650 Ti (will be replaced later by Vega or Navi card)
  • 1TB Samsung 970 Evo plus NVMe + 4TB WD blue Disk as fusion drive

 

What is working:

Windows boots and games run. Installation was a bit tricky:

  • the GTX650 has no UEFI
  • Disk partition has to be GPT since it should be shared between Windows and OSX
  • Windows only installs on a GPT drive if the setup is purely UEFI.

I ended up with a 2 screen setup with the secondary monitor on the HD630 being the boot display. The Windows driver uses the GTX650 without problems. 

Disabling CSM is important, on MSI this is hidden under the odd entrance "Windows 8.1/10 WHQL Support" that has to be enabled(!). 

 

Booting and Installing OSX from USB stick. I found this post most useful as a starting point. After some trial and error I managed to boot with the HD630 into the installer

  • The board has bios version 7B51v14, the most recent is not working (will check again when the system runs without error)
  • Clean up EFI folder, update clover, apfs.efi (from osx installation). Clover folder is attached.
  • Onboard ethernet is working with IntelMausiEthernet V2.4.0

 

 

Not working (TODO list): 

Fusion drive: Mojave does not support fusion drives. Instead, the installer tries to convert a fusion drive to apfs which, since Mojave, has a similar feature. From command line, I can create a apfs "fusion drive" with some modified commands:

(will supply later)

However: I seems that afp is buggy when it has to share the disks with other partitions. The plan was to have Windows too on the SSD and a common transfer partition on the spinning disk. Setup of the "fusion drive" was fine, but the installer always crashes without message, presumably in the moment it tries to access the disk. At the moment OSX is installed on a separate disk, will continue to investigate.

 

HD630: No acceleration, 6MB video memory

GTX650: No output at all, but card is shown in profiler. Thought it would be supported ootb.

Speedstep: CPU power usage around 8W in idle.

Audio

USB3

turn off crappy board illumination

 

CLOVER.zip

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By alexbohariuc
      Hey guys, I'm new here, so hello world!
       
      Here we go. 
      I have the following configuration:
      Gigabyte Aorus Master Z390 i9 9900K Sapphire Vega 64 Nitro+ Corsair Vengeance 64GB 3000Mhz Corsair H150i PRO (disconnected from the internal USB) Samsung Evo 970 1 TB - Catalina Install Intel 660p 1tb - simple storage drive  
      I have the latest Catalina version installed with OpenCore 0.5.8 Bootloader.
      I have followed the guide, and also relied on this EFI, since I have the same hardware: https://github.com/cmer/gigabyte-z390-aorus-master-hackintosh

      When idle the pc freezes - becomes unresponsive and my router disconnects from the internet (Archer C9, connected via PPPOE user/pass).
      Besides the freezing issue, which I’m not sure where it comes from, the internet disconnection just puzzles me. Any ideas?
       
      Things I tried so far:
       
      Reset NVRAM Disabled cfg lock Removed the BT BCM94360CS2 from the internal USB port (solved the sleep issue) Removed IntelMausiEthernet.kext and disabled the NIC in BIOS - saw some similar problems related to this Used Vgtab to generate the power table for the video card (Sapphire Vega 64 Nitro+)  
      Also, before OC bootloader is loaded I get this message, but otherwise boots normally:
      OC: Setting NVRAM 4D1FDA02-38C7-4A6A-9CC6-4BCCA8B30102:rtc-blacklist - Not Found
       
      I'll try replacing IntelMausiEthernet.kext with IntelMausi from Acidanthera, but I don't think it will make any difference since disabling the NIC and removing IntelMausiEthernet didn't do anything.
      Delete the entries from Add and Block in config.plist to remove the NVRAM error above - although since it boots I don't think it's related to my freezing issue.
       
      Any ideas?
       
      Thanks in advance!
    • By char543
      Hey all, hope you’re well :-)
       
      Writing this from a phone so apologies in advance for formatting errors etc.
       
      I’d like to build / am in the process of building a new machine. I started, then my mobo died and had to be rma’d and that put things on hold for a while..
       
      Now things are are back on track here’s what I’m looking at. 
       
      I would like the system to boot Mac OS for music etc and as main / general os, Windows for gaming and Linux for development etc.
       
      Heres the hardware I’m looking at - when I was looking at this previously I had set it up with clover but am definitely looking to go opencore this time around.
       
      Gigabyte Aorus Pro / Aorus Pro WiFi 
      Intel 9700k
      Corsair 650w PSU
      CoolerMaster ML240L
      MSI Air Boost Vega 64
      970 evo 1TB (Mac)
      Intel 660p 512GB (Windows)
      Crucial BX500 120GB (Linux)
      2TB Barracuda or WD Blue (Storage)
      Fenvi FV HB-1200 WiFi / Bluetooth 
      Aerocool Cylon Case
       
      I wanted to rival next generation games consoles and get a newer GPU but I will not be using Catalina due to the removal of 32 bit support. Therefore I think the vega is about as good as I can get with Mojave, and it will still work fine in windows for gaming etc. 
       
      What are your thoughts on the above hardware ? 
       
      Hack/Mac-able? / With opencore ?
       
      Any Issues I may encounter ?
       
      I think I have most of the drivers / kexts for opencore together already but I’m obviously unable to progress with the ssdt files without the hardware. Wanted some advice on whether or not it’s doable before I splash the cash 
       
      I’ll also add to this thread / move it appropriately as the build progresses, hopefully smoothly
       
      peace & thanks in advance :-)
    • By bread.io
      Hey everyone!
      Got my first build up and running a few days ago, and while almost everything works perfectly, I'm experiencing some odd sound quality issues. I'm currently listening to my audio through the 3.5mm jack on the front of my case. The sound quality sporadically jumps from being muffled to clear and is also a bit staticky.
      I've dug into a number of different scenarios that sound similar to mine, but I hoped that someone here might be able to give me more clarity.
      Here's a sample of the issue: https://clyp.it/xyfxysf2
      Config.plist: https://pastebin.com/BStEGbpe
      My hardware:
      CPU: Intel i9 9900k
      GPU: Radeon 5700 XT OC
      RAM: Corsair ddr4 32GB (2x16)
      Motherboard: Z390 Designare LGA1151
       
      Any help is really appreciated!

    • By Eradian
      Hello,
       
      this is my 5th Hackintosh build, but the first one using OC 0.5.7 on Asus Prime Z390-P with Samsung M.2 EVO 970 1TB, and no, not the EVO 970 PLUS.
       
      I followed https://dortania.github.io/OpenCore-Desktop-Guide/ to the letter, first attempting 10.15.4, and was rewarded with a nicely booting USB install medium. Trouble started at the beginning of the actual installation process, with the program "macOS Utilities" crashing and triggering display of "Installer Log". From there I could invoke "Disk Utility" to initialize the M.2 with APFS and launch "startosinstall" from "Terminal" but that only resulted in a reboot. Then I tried 10.15.3 and also 10.14.4, always using gibMacOS and createinstallmedia as per the guide, but again, "macOS Utilities" invocation would be followed by a reboot or the selection buttons of this program not doing anything. These failures were reproducible with both iGPU and Radeon RX580 driving my monitor via DP. I also briefly tried another USB install medium I had prepared with Clover for my previous build on another ASUS Z390 board which also got to "mac OS Utilities" only to freeze exactly there. 
       
      When I was really at wit's end, I dismounted the EVO 970 M.2 and hooked up an SATA EVO 860, and much to my surprise, the 10.15.4 install completed without any further hiccups.
       
      Now I could just shrug and keep the SATA SSD, but I'd like to learn/understand what could possibly go wrong with the M.2 SSD and how to properly investigate this. Should I try to switch to the DEBUG version of OC 0.5.7 and enable a lot of logging? Not sure, as the failure seems to happen after the installer boot is finished and the "macOS Utilities" failures appear to happen in user space, at least in 10.15.4 there is the installer log indicating an array bounds violation.
       
      Any help would be greatly appreciated,
       
      Eradian
       
      PS: I could attach my EFI here, but its built following the vanilla guide Coffee Lake secition, plist.conf passes the on-line config checker and exactly that EFI works fine with the SATA SSD. So I'm rather looking for advice on how to investigate/provide useful input here.
       
    • By haoyouandme
      Hello:
      I install hackintosh Catalina 10.15.4, I need some help: 
      If I shut down my Hackintosh, it will reboot.
      If I sleep my Hackintosh, it never wakes up until I force to reboot it or shutdown it.
      Can you help me to solve this problem?
       
      CPU: I9-9900ES (QQZ5)
      Motherboard: Asrock Z390 Pro4
      GPU: Sapphiretech AMD 5700xt
      Memory: Samsung DDR4 16GB
      SSD: Intel 545s 128G SATA
      Power: Cooler master MWE Bronze 650
      EFI.zip
×