Jump to content

Mojave 10.14.4 installs with 1x32GB module, hangs End RandomSeed with 2x32GB


4 posts in this topic

Recommended Posts

Hi, first post here and pretty new to Hackintoshing.

 

Specs:

  • Lenovo ThinkPad X1 Extreme (laptop)
  • i7-8850H (Coffee Lake)
  • Intel UHD630
  • GTX 1050 Ti with Max-q
  • 4K Touchscreen
  • 2x 2TB EVO 970 SSD (one for Windows and one for macOS)
  • 2x 32GB DATARAM 2666Mhz DDR4 RAM (max for laptop, works in Windows and Ubuntu)
  • Haven't replaced the Wifi card yet for macOS compatible, just using Ethernet for now
  • Everything else is stock
  • macOS Mojave 10.14.4

 

Was stuck several days just trying to get passed End RandomSeed. What finally worked was the following:

  • Clover 4910 (instead of using RehabMan's versions)
  • The attached EFI zip
  • Leaving only one RAM module (1x 32GB) in the first slot on the mobo (the right slot if the laptop is upside down and the back is facing you)

 

Was able to install macOS to the SSD. Well, I am at the phase where I need to get macOS to boot from the SSD  without the USB. Struggling with that, but will make a different thread regarding it.

 

Thought I'd give it a go again with both RAM modules installed since I read somewhere once macOS is installed, you can change the RAM freely. Again, with both modules installed it just hangs at End RandomSeed.

 

What I have tried:

  • AptioMemoryFix-64 or OsxAptioFix3Drv-64 or OsxAptioFixDrv-64 or OsxAptioFix2Drv-free2000

  • AptioMemoryFix-64 plus OsxAptioFix3Drv-64 or OsxAptioFixDrv-64 or OsxAptioFix2Drv-free2000 (read somewhere that having a combination of AptioMemoryFix plus one of the others worked for some people)

  • Adding RAM entries in SMBIOS (see attached)

 

Unfortunately, none have seem to have had an effect. 

 

Any suggestions?

 

Thank you in advance for the help!

 

Capture.PNG

EFI.zip

Edited by ishraqiyun77
  • 7 months later...
  • 3 weeks later...
×
×
  • Create New...