Jump to content

Mojave laptop can't sleep / wifi issue


vhviveiros
 Share

4 posts in this topic

Recommended Posts

Hello guys!

 

I'm using a Samsung ativ book 2 np270e5g-xd1br, with i5-3230m/HM75, and everything is working fine, except by sleeping and wifi connection (the Hackintosh internet speed is about 10% of the windows/Linux, and sometimes It downs randomly).

 

I've tried a lot of tutorials but nothing solved my problem.

 

Hope you guys could help me :D

 

obs: I also figured that if I left the laptop for some minutes, It sometimes reboot.

Send me MacBook-Pro.zip

Edited by vhviveiros
Link to comment
Share on other sites

12 hours ago, Hervé said:

Your Clover config is incorrect and you probably do not have proper CPU power management. That has a direct impact on Sleep/Wake. Please use this config instead.

config.plist.zip

 

Then you may consider disabling hibernation and use plain old Sleep instead. This is achieved through the following Terminal commands:


sudo pmset -a hibernatemode 0
sudp pmset -a hibernatefile /dev/null
sudo rm -f /va/vm/sleepimage

 

Your kext set is out of date. Please use those instead.

FakeSMC.kext.zip

Lilu.kext.zip

WhateverGreen.kext.zip

 

It would appear that you have an Atheros AR9565 card. Those are quite poorly supported in OS X/macOS and limited to 11Mbps. Replace that card by a fully supported model or USB dongle.

 

Ideally, you should also use one of those add-on SSDT that disables the Nvidia dGPU. It's a GF117M Fermi model, unsupported under Mojave (10de:1140 = GeForce 610/710M or GT 620M/630M/720M). Keeping it enabled will simply contribute to draining your battery.

 

Is this a HackintoshZone distro? If so, don't be surprised to experience problems as you never know what this actually contains (stuff added, stuff removed). Full vanilla installation is highly recommended.

 

Thank you very much for trying to solve my problem. But, unfortunately, It doesn't work. I've already done these commands before, and did again, but, the problem keeps.

 

I changed the kexts and the config.plist, but, after that, the mac stucked at boot screen, and then, I restarted with -v flag and get that (sorry by the image quality :():

IMG_20190410_155006.thumb.jpg.a34c52df78d94737f81615afd463a980.jpg

 

After that, I booted with -x flag and older config.plist, and restored the old kexts, and kept only the ney config.plist. I rebooted and got that:

 

 

After that, the system rebooted, on the 3 times I've tried.

 

Now, I'm using the same files I used before.

 

About the distro, yes, I'm using the HackintoshZone one. I've used the Sierra vanilla, who were working fine, and tried to update, but the mojave's installer didn't even booted, so, I've gone with this one.

 

About the wifi board, I'll see what I can do...

 

And, about everything, again, thank you! :D

 

But... Hope that I get my problem solved

Link to comment
Share on other sites

I have this Laptop do you want my Clover Config. I got Mojave working at 90% it's just brightness missing.

The Only difference is my i7 other than that it'sd the same laptop.

Screen Shot 2019-04-16 at 12.12.08 PM.png

Edited by dbx103
Link to comment
Share on other sites

Le 09/04/2019 à 23h44, vhviveiros a déclaré:

Bonjour les gars!

 

J'utilise un Samsung ativ book 2 np270e5g-xd1br, avec i5-3230m / HM75, et tout fonctionne bien, sauf en veille et avec une connexion wifi (le débit Internet de 10% de celui de Windows / Linux , et parfois de bas au hasard).

 

J'ai essayé beaucoup de tutoriels mais rien n'a résolu mon problème.

 

J'espère que vous pourrez m'aider :RÉ

 

obs: J'ai aussi pensé que je laissais l'ordinateur portable pendant pendant quelques minutes, il s'est parfois éteint.

Envoyez-moi MacBook-Pro.zip

teste 

CLOVER.zip

Link to comment
Share on other sites

 Share

×
×
  • Create New...