Jump to content
Sign in to follow this  
Followers 0
karthiksh1989

Mojave AMD Ryzen 7 and Vega 64 Gigabyte installation step by step guide

3 posts in this topic

Recommended Posts

can somebody walkthrough with the mojave installation guide?

i have a mac high sierra 13.6 version on my macbook pro and want to install mojave on my desktop

Exact config is Gigabyte gaming wifi 7 motherboard amy ryzen 7 2nd gen 2700X processor Gigabyte G1 8GB grapgic card VEGA 64

running 2 nvme Samsung 256gb cards and 1 intel 180gb ssd internal and 1tb WD HDD, with 64 GB 3200Mhz Ram

 

https://wa.me/919611736534 (whatsapp)

Share this post


Link to post
Share on other sites
Advertisement
7 hours ago, karthiksh1989 said:

can somebody walkthrough with the mojave installation guide?

i have a mac high sierra 13.6 version on my macbook pro and want to install mojave on my desktop

Exact config is Gigabyte gaming wifi 7 motherboard amy ryzen 7 2nd gen 2700X processor Gigabyte G1 8GB grapgic card VEGA 64

running 2 nvme Samsung 256gb cards and 1 intel 180gb ssd internal and 1tb WD HDD, with 64 GB 3200Mhz Ram

 

https://wa.me/919611736534 (whatsapp)

 

A couple of things the WiFi is intel and won’t work, you can change the module and get it working with added Kexts.    The Intel drive is that a Optane?  Those won’t work and will crash the setup.   

Everything else can be made to work using the AMD kernel.   

 

Its easiest to to use a USB to Sata adapter, name the disk (Sata SSD) Mojave andbload it from the MacBook.   It will cycle through (if the MacBook is compatible for Mojave) for about 3 reboots.  Then the final boot will panic.   That’s ok just remove the drive and start the MacBook normally and then attach the drive to edit it.   

Go to the AMD kernel development thread for Mojave kernel and prelinkedkernel kernel as well as System kext etc... 

after swapping those out run a kext tool like kext wizard then load clover into the Mojave disk (make sure to check the target you don’t want to load clover onto your MacBook EFI partition.   

 

You should look at the AMD Sierra or High Sierra guides on the forum and read up before you try Mojave, it’s still experimental.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By t3s8r8
      Hi, anyone here got those problems like me ? When I click play, the film load nothing, just show blackscreen like this (attached) or when I download an episode to the computer, it shows error (err = -11800)

      Anyone here knows a fix ? Maybe a bug or problem from Hackintosh ?


    • By mrwlkr
      Hello everyone, I've an Acer Aspire E5-574 running Mojave at last update, everything is fine, except by the laggy mouse, as the attached, when the system needs the graphic card (Intel HD 520) it's generates a lag.
       
      Thanks

      final_5e2761c58c6b910015da7cf6_967905.mp4 Send me MacBook-Pro-de-Murilo.zip
    • By _ivan_palmisano_
      Ho provato tutti i modi ma sono arrivato alla conclusione che ha bisogno di una patch DSDT.
      Ciao, ho recentemente un hackintosh nel mio laptop e devo risolvere l'attacco video HDMI che non ha eseguito quando collego il mio laptop alla TV.
      le foto con queste informazioni sono state fatte con un programma quando che avrei vinto 10 nell'altra foto l'informazione di hackintosh.
      Acer Aspire 5741g Modello High Sierra System!
      Caratteristiche:
      CPU: Intel Core I3 350M 2.27Ghz Arrandale 32nm Tecnologia
      Ram: 6: 00GB
      Grafica: Monitor Pnp generico (1366x768 Ghz) 1024mb Nvidia GeForce GT 320M (Acer Incorporated)
      Archiviazione: 465 GB Sata
      Driver Optiocal: Optiarc DVD RW- AS-7585H
      Audio: dispositivo audio ad alta degradazione
      Qualcuno può aiutarmi!?! E 'la terza volta che faccio questo post in questo gruppo visto che sono nuovo nel mondo hackintosh preferisco se qualcuno è capace a risolvere il mio problema che lo faccia in remoto così non faccio sbagli.
    • By lizdav
      Hello People,
       
      I have a dual-boot system with both Win10 and MacOS on separate drives. MacOS on an SSD while Windows is on a standard laptop HD. At first it was working fine and I haven't thought much of it but recently MacOS started acting weird. The first thing I noticed was that Clover somehow "forgot" my primary boot drive. This wasn't a huge issue though, as it was booting just fine once I hit enter on the drive selected. I updated Windows 10 to a newer build, however, I did all of this with the SSD drive unplugged just to be sure. Now Windows is working properly while MacOS is having some quite frustrating errors which make it impossible for me to work...
       
      Anyway, the problems are the following:
       
      - random reboots
      - apps freeze or won't start just "bounce"
      - internet not working(eventhough every other device connects just fine)
      - system is laggy overall
       
      I have tried emptying NVRAM int Terminal but I only got a message saying 'Error clearing firmware variables'. I've been searching for solutions on the web for the issue at hand but struggled to find one... I would really appreciate some help.
       
      I attached my config.plist down below. If more information is required, please let me know.
       
      Thank you!!
       
       
       
      config.plist
    • By MaLd0n
      ---INSTALLATION TUTORIAL---
       
      ---Original Post---
      https://olarila.com/forum/viewtopic.php?f=45&t=9172
       
      ---USB---
      https://pikeralpha.wordpress.com/2016/07/13/simple-skylake-usb-fix-no-kexts-required/
       
      ---CLOVER FOLDER---
       
      CLOVER.zip
       
       
      --MOBO
      GigaByte Z390 M Gaming



      --PROCESSOR
      Intel Core i9-9900K


      --COOLER
      CoolerMaster MasterLiquid ML120R RGB


      --MEMORY
      Corsair Dominator Platinum 16GB (2 x 8GB)


      --GPU
      Sapphiretech Radeon RX 590 8 GB GDDR5


       
      --SSD
      Samsung 970 EVO NVMe M2 Flash Drive


      --POWER SUPPLY
      EVGA 750 N1, 750W


      --WIRELESS
      TP-Link Archer T9E


      --BLUETOOTH
      Orico BTA-403


      --CASE
      Thermaltake View 21 Tempered Glass Edition


      --DSDT Patches--
      -FIX ERRORS AND WARNINGS -FIX ACPI ERRORS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA SERIE 10 ID -DMAC -REMOVE 22K LINES, PROBLEMATIC and UNUSED -FIX K.P in REBOOT -NVRAM -REAL TIME CLOCK -SLPB -DARWIN / WINDOWS 2015 -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -REAL TIME CLOCK -ARTC -IRQs -SBUS -MIKEY -BUS1 -MCHC -ALS0 -SHUTDOWN -UAR1 -LAN -FWHD -USBX -PMCR -PPMC -XSPI -GMM -IMEI -EC -PNLF -ARPT -GFX0 -NVME -DTGP -ACQUIRE MUT0 0XFFFF -OPERATION REGION GPIO -MUTEX MUT0 0x00 -EXTERNAL REFERENCES -UNKNOWNOBJ -HDMI / HDAU -FULL RENAMED DEVICES  
      --SCREENSHOTS--





























      --BruceX--
       
      --USB-C-- test with SanDisk Ultra USB-STICK 128gb


       
      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, Sampath007, onemanosx, erroruser, Jenny David, Olarila Facebook Community, Hackintosh Facebook Community and many others!
      We're all here to have fun and learn from each other!
×