Jump to content

Netflix su hackintosh?


18 posts in this topic

Recommended Posts

Ciao e buon anno nuovo a tutti!
Mi trovo davanti ad un problema forse comune ma inaspettato: su safari non riesco a vedere netflix, mi riporta sempre alla schermata dei "requisiti di sistema di Netflix per lettori HTML5 e Silverlight" - silverlight è anche installato. Su chrome invece funziona con la tipica limitazione dei 720p massimo di streaming di cui soffre questo browser.
L'unica cosa che ho provato leggendo un po' in giro è provare a forzare il decoder video con questo comando 

defaults write com.apple.AppleGVA forceNV -boolean yes
e a ripristinare la configurazione DRM
defaults delete com.apple.coremedia
defaults delete com.apple.AppleGVA
sudo rm -rf /Users/Shared/SC\ Info
sudo defaults delete com.apple.coremedia
sudo defaults delete com.apple.AppleGVA

Ho aggiunto il flag -shikioff al file config senza nessun risultato positivo

Altre soluzioni?

A me pare tutto ben fatto, config (intravedo la mano di gengik) kext etc... se devo proprio trovare per forza qualcosa, a mio parere, visto che usi la iGPU senza nessuna definizione nel config, trovo strano l'uso di LULI+WEG+FakePCIID+Fake_intel+FakePCIID_Intel_HD_Graphics tutti e 4 in contemporanea; a livello teorico le 2 coppie sono mutuative o una o l'altra

BIOS setting:

 

Advanced \ System Agent(SA) Configuration IGPU Multi-Monitor : Enabled

Advanced \ System Agent(SA) Configuration DVMT pre-Allocated : 128Mb

 

dai kext in EFI rimuovi FakePCIID+Fake_intel+FakePCIID_Intel_HD_Graphics

 

salva il tuo config, USB di emergenza pronta, sostituisci e testa

 

config.plist.zip

Edited by iCanaro

Abbiamo fatto qualche passo in avanti, ora i codec video sono abilitati, quando avvio uno streaming su netflix sembra partire (cosa che prima non succedeva) ma poi nel player video ho questo errore S7363-1260-FFFFD089. Google mi dice che è un errore relativo a shiki, possibile?

Schermata 2019-01-02 alle 11.24.32.png


EDIT
Anche flaggando nuovamente "shiki=off" (non lo avevi messo nel tuo config, ho provato anche quest'altra strada) l'errore permane

:(

Edited by thecliffhanger
  • Like 1

shiki è stato incluso in WEG e il flag su shikioff nel config non so' se lavora con il solo shiki o anche con WEG; ma di norma deve lavorare e non disabilitarlo

 

per il resto direi che con le mie indicazioni e config sei passato dal nulla cosmico a full codifica hardware.

Per netflix prova altri browser o inserisci i link in VLC o video player alternativi tipo questo

https://iina.io

Edited by iCanaro

In realtà il senso del post era proprio poter vedere netflix con l’unico browser che vorrei usare, safari, perchè ho già testato che con chrome funziona e sicuramente lo farà anche con firefox, come sicuramente sarà valido l’altro metodo che hai indicato

Puó rientrare in questa problematica il fatto che imessage e facetime non mi funzionano? Quindi c’è ancora qualcosa di non perfetto nell’hackintosh

Guida interessante, sembrerebbe che abbia già configurato tutto bene ma comunque non imessage e facetime non funzionano: proverò più approfonditamente

Intanto sto facendo anche altre prove, mettendo nei custom flag "shikigva=12" e provando tramite safari i vari useragent di firefox e chrome (dal menù sviluppo), ma ottengo solo codici diversi (a causa del "browser diverso" che è solo simulato) dello stesso errore
 

Schermata 2019-01-02 alle 18.43.41.png

  • 1 year later...
On 1/2/2019 at 1:30 AM, iCanaro said:

BIOS setting:

 

Advanced \ System Agent(SA) Configuration IGPU Multi-Monitor : Enabled

Advanced \ System Agent(SA) Configuration DVMT pre-Allocated : 128Mb

 

dai kext in EFI rimuovi FakePCIID+Fake_intel+FakePCIID_Intel_HD_Graphics

 

salva il tuo config, USB di emergenza pronta, sostituisci e testa

 

config.plist.zip

Ciao, sto avendo anche io questo problema. Posso chiedere a cosa ti riferisci con Bios settings? Devo entrare nel bios della scheda madre. Ho una gigabyte 370, dove posso trovare queste impostazioni? Grazie in anticipo!

Grazie infinite. Potrebbe essere anche per quello che la qualità dei video in generale (mettendo da parte Netflix) non sia così eccelsa nonostante abbia RX Vega 56 8 GB. Ci provo nel fine settimana...

×
×
  • Create New...