Jump to content

How to install 10.4.8 on T60?


20 posts in this topic

Recommended Posts

My notebook is T60.


T2500(2GHz), 1GB RAM, 100GB 5400rpm HD, 14.1in 1400x1050 LCD, 128MB ATI Radeon X1400, CDRW/DVDRW, Intel 802.11abg wireless, Bluetooth/Modem, 1Gb Ethernet


Last time I try to install 10.4.8,after installtion then reboot I just see this,






So this time I want to install successfully, who can tell me how to do it?

which patches should be choose?


Link to comment
Share on other sites

Then you could boot up the osx86 boot cd, go into terminal. (on the topside with utilities)

Go to /Volumes/insertdrivename/System/Library/Extensions

Then you can delete extensions from your harddrive.


I know go into terminal, But how to go to /Volumes/insertdrivename/System/Library/Extensions and delete the kext file?

please post a detail one ! Thanks a lot !

Link to comment
Share on other sites

I know go into terminal, But how to go to /Volumes/insertdrivename/System/Library/Extensions and delete the kext file?

please post a detail one ! Thanks a lot !


with the change dir command lol :pyth:


cd /Volumes/insertdrivename/System/Library/Extensions

rm -R IOPCCard.kext

(then remove any kext cache if there)

cd ..

rm Extensions.mkext

rm Extensions.kextcache

(reboot and cross your fingers)



just my :stretcher:

Link to comment
Share on other sites

insertdrivename miss what ? for example...


It's the drive you named when you installed osx86.

For example, I have called my drive "Hackintosh HD"

The osx86 boots into her own cd root, not into your harddrive.

But it does mount your harddrives, they always be mounted in /Volumes.

You can do "cd /Volumes" then "ls -l" to see what drives are mounted. Then choose your correct one where osx86 is installed :)

Link to comment
Share on other sites

  • 2 weeks later...
if you have ati x1400. you won't be able to get your internal lcd to work...you'll need to plug into an external monitor.

I have a T60 1952 A97 that I have everything but audio and wireless working, I know the wireless (Intel) won't work, but the soundcard (SoundMAX) I am looking for a solution for.


BTW- I have JaS 10.4.7 loaded.. I could not install on 10.4.8 screen stayed black.. I have Intel GMA950..

Link to comment
Share on other sites

I have the same T60p with the ATI Mobility x1400. Model is 2006-66M.


Install with ONLY the JaS Combo and Updates. Do not install any ATI drivers.


Then, reboot to the installation DVD and go into Terminal. Delete the following:







That worked for me but only with basic 1024x768 video. I finally was able to get the video to work at native 1400x1050 resolution with QE/CI enabled. I experience the minor image corruption but it is not too big a deal. The problem is that I tried so many steps that I do not know exactly what finally solved it. In brief, I did the following. 1) manually set the resolution in the boot.plist (search the forums for how to do it). 2) replaced ATI*.kext files with the ones from 10.4.5. 3) manually set the PCI vendor and hardware ID in the Info.plist file for the ATIX1000.kext, 4) installed Callisto and Natit but then removed them both. They might have set something.


One funny thing I notice is that the video chipset is an X1400 (according to the specs) but I had to make the kext think it is an X1300.


There are available workarounds to get sound also working with the AppleAzalia.kext so just search the forums for that info.


I replaced the power management kext as per another thread in the forum and get battery status now.


My latest goal is the Intel 3945 wifi. I am playing with the new Intel 3945 wifi driver that is being ported from Linux. It is not working yet but it sees the adapter. There is a dedicated thread on that topic too.

Edited by Focher
Link to comment
Share on other sites


  • Create New...