Jump to content
FZSX

[SOLVED] Nvidia GT 710 Black Screen or Grey Screen Issue in Mojave 10.14.1

5 posts in this topic

Recommended Posts

Hello, im FZ, been in hackintosh community since mac os X lion years. Please consider me noob. i have helped hackintoshed pc of my friends and family. i ran el capitan, sierra, high sierra on below spec.

I lost some interest in hackintoshing from past 1 year now im back again cuz of mojave.

Lets start.

 

I posted this issue in Nvidia Topic for discussion but decided not to post until i could get some bug log out of it... but. eh.

 

Well ive Kepler based gt 710 card.

Issues:

Black Screen when booting with default drivers or nvda_drv=1 mode

OR

White/Grey Screen with 1 sec mouse movement then freezed keyboard and mouse with nv_disable=1.

  

Tested:

tried numerous ways to boot Mojave but does not works such as >

High Sierra/Sierra default Apple geforce nvda kexts, High Sierra Web Drivers, various clover configs, display edids, HDMI dvi port tests... so on.

 

Specs:

Tri Boot Setup:

Windows 10, Sierra(gt 710 works OOB, or with Web Drivers too), Mojave.

ASUS P5G41TM LX

Core2Duo E8500

Gigabyte Nvidia Geforce GT 710 2GB

 

 

I couldn't managed to get logs as half part of installation is still incomplete i.e Mojave installed from USB to HDD after but cant get into login/setup screen due to above mentioned black screen issue.

 

I will try to be as detailed as possible.

 

i had no mac device or any macos dmg/iso to install mojave so performed some steps in windows.

 

Steps i performed:

1. I downloaded Mojave 10.14.1 tar file from Olarila.com which is a complete raw image of Mojave USB stick as the post title says **The image is clean, without any mod with Clover bootloader, essentials kexts and patches inside Clover folder**. Which comes with this OLIRALA_MOJAVE_USB_EFI.zip which i backed up(see attachment OLIRALA_MOJAVE_USB_EFI.zip)

2. made usb in windows with win32diskimager

3. booted from usb and got kernel panic(i dont know which panic it is, see pic:|

4. swapped usb EFI folder with Olarila Clover EFI for LGA 775 (see attachment CLOVER.LGA775.OLARILA.zip)

5. booted from usb susccesfully till install screen but throws macOs Mojave could not be installed on this computer

6. i was fed up trying workarounds :wallbash:, i knew i need newer mac ids in clover config.plist to make it install :angel:

7. i downloaded Olarila Sierra from same site flashed in another usb stick and it worked out of box without messing any kext or kind.

8. added SMBIOS iMac13,1 in config.plist with clover configurator. 

9. booted from usb and succesfully installed Mojave with HFS+ partition on MBR partitioned HDD(dual booting with windows 10) :yes:

10. booted from usb to complete partial installation of Mojave but got black screen:ninja:

 

For getting all kernel, bug, kext logs i tried Problem Reporting script of black-dragon74 https://github.com/black-dragon74/OSX-Debug which requires active internet connection which is not possible, I tried to mod the script to run local but im not good at bash and it went in errors. I will do provide mojave logs manually from single user -x mode if i can. 

Ok I managed to run the script locally in single go and it went well problem_reporting_mojave10_14_1_debug_27676.zip

if any wants to have a look at script i modded gen_debug_local.sh

 

___

some other files

Patched DSDT.aml.zip

currentCloverEFI.zip

/CLOVER/misc.zip

EFI/CLOVER/ACPI/origin.zip

problem_reporting_mojave10_14_1_debug_27676.zip

 

___

UPDATE: Mojave 10.14.1 running successfully with some graphic glitches.

Here's what i did in short.

1. Patched official app store mojave with dosdude1 mojave patcher tool.

2. Only used its Post Install app with iMac 10,1 config(see pic) to patch already installed Olarila's Mojave(above 1 - 10 steps) with same currentCloverEFI.zip

3. Restarted and it all went well.

 

Detailed(it will confuse u, ignore/skim it.):

1. Downloaded official app store mojave

2. used crazybirdy's mojave mbr patcher tool (MBR-Manual-Method-20181108.dmg) with manual install.

3. when installing it went in errors related to "OSInstall.mpkg".

4. i had few options such as

  • use automatic mbr patcher tool(MBR-Auto-Method14-20181108.dmg)
  • upgrade from high sierra
  • try dosdude1 patcher on official app store mojave

5. i did the above short steps(step no2) at first try. enough tats it.

 

 

(attaching working mojave files...)

Attached log files

see post#3 mojave-working.zip

Edited by FZSX
typos and updates

Share this post


Link to post
Share on other sites
Advertisement

Looks like Core2Duo E8500 can be the issue here, not sure if it's still supported, maybe requires some kernel patching

 

Share this post


Link to post
Share on other sites
On 12/5/2018 at 8:10 AM, salut0714 said:

Hello, FZ !

 Is your Gigabyte Nvidia Geforce GT 710 2GB is 2GB DDR3 or 2GB DDR5 ?

 

Its DDR3

---

Data Extracted from GPUZ (Windows OS) >

---

General
Version    xxxxxx
Build Date    2016-06-07
Message    GV-N710D3-2GL/FV1/03FD
Board Id    xxxxxxx

Memory Support
Entry 1    DDR3
    Samsung
    4 Gbit x16
Entry 2    DDR3
    Micron
    4 Gbit x16
Entry 3    DDR3
    Hynix
    4 Gbit x16
Entry 4    DDR3
    Samsung
    4 Gbit x16
Entry 5    DDR3
    Unknown
    4 Gbit x16

Connectors
Connector 1    DVI-D
Connector 2    HDMI
Connector 3    VGA
 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By hungdv
      Hello guys,
      I was try to install MacOS Mojave on my new machine but no luck. Can anyone show me which guide to fit my system, please?please?please?
      + Mobo: GIGABYTE Z390 AORUS ELITE LGA1151v2
      + CPU: Intel Core i5-9600K 3.7GHz
      + iGPU: Sapphire RX 580 Pulse 8GB
      + Drives: SSD Samsung 970 Pro PCIe NVMe V-NAND M.2 2280 512GB
      + Ram: Crucial Ballistix Sport LT 2x8GB Bus 2666 DDR4
      + PSU: Corsair RM650 80 Plus GOLD
      + Case: Corsair 220T White RGB Airflow Tempered Glass
      + Cooler: Cooler Master HYPER 212 BLACK EDTION
      + Dual Band Network Card Broadcom Bcm94360 867Mbps.
    • By Rajan Pandit
      Hai, I have,
      i5 2500k
      GA-z68 AP D3 Rev.1
      Corsair 8 GM Ram
      Gigabyte Radeon RX 560 OC 4G Graphic Card
      500 GB Samsung SSD EVOf
       
      with this configuration I tried to install Mojave but After Apple Logo there was a black screen
      then nothing... please help
      I have create USB with terminal and Install Clover_v2.4k_r4961-Legacy.pkg to activate boot
      then I have recessary kext to EFI/KEXT/OTHER 
      but I am struck at Black Screen after apple logo
    • By Rajan Pandit
      Hai, I have,
      i5 2500k
      GA-z68 AP D3 Rev.1
      Corsair 8 GM Ram
      Gigabyte Radeon RX 560 OC 4G Graphic Card
      500 GB Samsung SSD EVO
      .. I want to install Mojave on this configuration...
      please help. what I need to do... 
      I have downloaded the Installer from APP Store...
      please help
×