Jump to content
Welcome to InsanelyMac.com - No more ads! And some exciting news... Read more... ×
FZSX

[SOLVED] Nvidia GT 710 Black Screen or Grey Screen Issue in Mojave 10.14.1

5 posts in this topic

Recommended Posts

Hello, im FZ, been in hackintosh community since mac os X lion years. Please consider me noob. i have helped hackintoshed pc of my friends and family. i ran el capitan, sierra, high sierra on below spec.

I lost some interest in hackintoshing from past 1 year now im back again cuz of mojave.

Lets start.

 

I posted this issue in Nvidia Topic for discussion but decided not to post until i could get some bug log out of it... but. eh.

 

Well ive Kepler based gt 710 card.

Issues:

Black Screen when booting with default drivers or nvda_drv=1 mode

OR

White/Grey Screen with 1 sec mouse movement then freezed keyboard and mouse with nv_disable=1.

  

Tested:

tried numerous ways to boot Mojave but does not works such as >

High Sierra/Sierra default Apple geforce nvda kexts, High Sierra Web Drivers, various clover configs, display edids, HDMI dvi port tests... so on.

 

Specs:

Tri Boot Setup:

Windows 10, Sierra(gt 710 works OOB, or with Web Drivers too), Mojave.

ASUS P5G41TM LX

Core2Duo E8500

Gigabyte Nvidia Geforce GT 710 2GB

 

 

I couldn't managed to get logs as half part of installation is still incomplete i.e Mojave installed from USB to HDD after but cant get into login/setup screen due to above mentioned black screen issue.

 

I will try to be as detailed as possible.

 

i had no mac device or any macos dmg/iso to install mojave so performed some steps in windows.

 

Steps i performed:

1. I downloaded Mojave 10.14.1 tar file from Olarila.com which is a complete raw image of Mojave USB stick as the post title says **The image is clean, without any mod with Clover bootloader, essentials kexts and patches inside Clover folder**. Which comes with this OLIRALA_MOJAVE_USB_EFI.zip which i backed up(see attachment OLIRALA_MOJAVE_USB_EFI.zip)

2. made usb in windows with win32diskimager

3. booted from usb and got kernel panic(i dont know which panic it is, see pic:|

4. swapped usb EFI folder with Olarila Clover EFI for LGA 775 (see attachment CLOVER.LGA775.OLARILA.zip)

5. booted from usb susccesfully till install screen but throws macOs Mojave could not be installed on this computer

6. i was fed up trying workarounds :wallbash:, i knew i need newer mac ids in clover config.plist to make it install :angel:

7. i downloaded Olarila Sierra from same site flashed in another usb stick and it worked out of box without messing any kext or kind.

8. added SMBIOS iMac13,1 in config.plist with clover configurator. 

9. booted from usb and succesfully installed Mojave with HFS+ partition on MBR partitioned HDD(dual booting with windows 10) :yes:

10. booted from usb to complete partial installation of Mojave but got black screen:ninja:

 

For getting all kernel, bug, kext logs i tried Problem Reporting script of black-dragon74 https://github.com/black-dragon74/OSX-Debug which requires active internet connection which is not possible, I tried to mod the script to run local but im not good at bash and it went in errors. I will do provide mojave logs manually from single user -x mode if i can. 

Ok I managed to run the script locally in single go and it went well problem_reporting_mojave10_14_1_debug_27676.zip

if any wants to have a look at script i modded gen_debug_local.sh

 

___

some other files

Patched DSDT.aml.zip

currentCloverEFI.zip

/CLOVER/misc.zip

EFI/CLOVER/ACPI/origin.zip

problem_reporting_mojave10_14_1_debug_27676.zip

 

___

UPDATE: Mojave 10.14.1 running successfully with some graphic glitches.

Here's what i did in short.

1. Patched official app store mojave with dosdude1 mojave patcher tool.

2. Only used its Post Install app with iMac 10,1 config(see pic) to patch already installed Olarila's Mojave(above 1 - 10 steps) with same currentCloverEFI.zip

3. Restarted and it all went well.

 

Detailed(it will confuse u, ignore/skim it.):

1. Downloaded official app store mojave

2. used crazybirdy's mojave mbr patcher tool (MBR-Manual-Method-20181108.dmg) with manual install.

3. when installing it went in errors related to "OSInstall.mpkg".

4. i had few options such as

  • use automatic mbr patcher tool(MBR-Auto-Method14-20181108.dmg)
  • upgrade from high sierra
  • try dosdude1 patcher on official app store mojave

5. i did the above short steps(step no2) at first try. enough tats it.

 

 

(attaching working mojave files...)

Attached log files

see post#3 mojave-working.zip

Edited by FZSX
typos and updates

Share this post


Link to post
Share on other sites

Looks like Core2Duo E8500 can be the issue here, not sure if it's still supported, maybe requires some kernel patching

 

Share this post


Link to post
Share on other sites
On 12/5/2018 at 8:10 AM, salut0714 said:

Hello, FZ !

 Is your Gigabyte Nvidia Geforce GT 710 2GB is 2GB DDR3 or 2GB DDR5 ?

 

Its DDR3

---

Data Extracted from GPUZ (Windows OS) >

---

General
Version    xxxxxx
Build Date    2016-06-07
Message    GV-N710D3-2GL/FV1/03FD
Board Id    xxxxxxx

Memory Support
Entry 1    DDR3
    Samsung
    4 Gbit x16
Entry 2    DDR3
    Micron
    4 Gbit x16
Entry 3    DDR3
    Hynix
    4 Gbit x16
Entry 4    DDR3
    Samsung
    4 Gbit x16
Entry 5    DDR3
    Unknown
    4 Gbit x16

Connectors
Connector 1    DVI-D
Connector 2    HDMI
Connector 3    VGA
 

Share this post


Link to post
Share on other sites

  • Similar Content

    • By iguannnaq
      Hi so iam using mac os mojave
      and this my pc spec
      Asus k84l
      intel core i3 2350m sandy bridge
      intel hd 3000
      ssd wd green 250 gb
      ram 4gb
       
      i dont know after i use for a minute and freezing please help me
      this my clover i dont know what the problems
       
      https://drive.google.com/file/d/1aP_s0LVZPAtZf_Z4rpN0Puj_dqLlfcuk/view
    • By iammask
      I am on OpenCore 0.6.3 with AirportBrcmFixup.kext, BrcmBluetoothInjector.kext, BrcmFirmwareData.kext, BrcmPatchRAM2.kext in my EFI/OC/Kexts.
      For USB mapping, USBMap.kext is being used.
      Bluetooth is loaded but there's no option to turn it on.
      please check screenshot attached, tried to include everything 



    • By kushwavez
      A really good motherboard with macOS compatible bult-in Wifi & Bluetooth

      ASUS Z170-Deluxe (with Wifi)
      BIOS: v3801
      CPU: i7-6700K 4.0 to 4.2 GHz (w/o OC)
      RAM: 1x 16 GB Corsair DDR4 2400 MHz
      GPU: Intel HD 530 (Headless) & ASUS Radeon RX 5700 OC 8 GB
      Audio: ALC 1150
      Ethernet: I219V2, I211-AT
      WiFi & Bluetooth: Broadcom BCM94360HMB Half-Mini-PCI-E
      More Specs: https://www.asus.com/Motherboards/Z170-DELUXE/specifications/
       
      El Capitan 10.11.6 -> Big Sur 11 - Windows 10
       
      What is working:
      BCM94360HMB Wifi and Bluetooth AirDrop, Handoff, FaceTime, Messages, App Store, iCloud, etc. Intel HD 530 (QE/CI tested, but now I'm using it in headless) Sleep RX 5700 (QE/CI with 2 1080p monitors connected) Sound (all ports) USB Ports Two Ethernet ports macOS with a light OC (4.12 GHz - 4.5 Ghz, XMP, ASUS optimal) ASUS HyperKit and M.2 with a KINGSTON NVMe SSD - 250 GB Hardware decoding/encoding on both HD 530 and RX 5700 (HD 530 up to HEVC, RX 5700 at the time of writing VP9) iGPU only (with QuickSync) is used in the default config.plist To use dGPU for hw decode/encode and also use Intel QuickSync you need to start with "config_headless.plist" This will use iMac17,2 SMBIOS and shikigva=80 To use dGPU only boot with "config_amd.plist" also disable iGPU completely in BIOS. This will use iMacPro1,1 SMBIOS without iGPU System Integrity Protection is Enabled by default. If you need to boot with SIP disabled you may use "config_debug.plist" or disable it manually in Clover settings. If you want Enabled SIP but with allowing unsigned kexts you may boot with "CsrActiveConfig = 0x01"  
      What is not working:
      -  
       
      Not tested:
      Thunderbolt (no equipment)  
      Issues:
      None  
      BIOS Settings:
      Boot\CSM (Compatibility Support Module): Launch CSM: Disabled Boot\Secure Boot: OS type: Other OS Secure Boot State: Disabled Advanced\System agent (sa) Configuration: VT-d: Enabled Graphics Configuration: (This is for HD 530 in headless) Primary Display: Auto (to use dGPU only this must be PEG) iGPU Multi-monitor: Enabled (to use dGPU only this must be Disabled) RC6(Render Standby): Enabled (to use dGPU only this must be Disabled) DVMT Pre-Allocated: 128M Advanced\PCH Storage Configuration: SATA Mode Selection: AHCI HyperKit: Enable (if you have NVMe SSD with ASUS HyperKit) Advanced\CPU Configuration: Intel Virtualization Technology: Enabled CPU- Power Management Control: CPU- C-States: Enabled Intel SpeedShift: Enabled  
      Getting ready for installation:
      Download the bootpack (Clover v5126): Click here -> Z170-DELUXE_Clover_v5126.zip (Tested: El Capitan 10.11.6 -> macOS Big Sur 11.0.1)  
      Installation:
      Create an installer with any method you know (- Mac: createinstallmedia, gibMacOS - Windows: Transmac, Vmware, Win32diskimager, gibMacOS) Copy my Clover folder to the USB's EFI folder Boot with the Installer USB If you have any problem (kp or freeze) boot with config_debug.plist to see what causes the issue  
      Post Installation:
      Download Clover Configurator and generate a new Serial Number for yourself  
      Some pictures:

       
       



       
      El Capitan 10.11.6
       
      Sierra 10.12.6
       
      High Sierra 10.13.6
       
      Mojave 10.14.6
       
      Catalina 10.15.7
       
      Catalina & Windows 10 Dual-Boot (clean install, on one drive):
       Boot into your Mac installer, Create 2 partitions in GUID table (1 for Win (I used FAT32 but I think it doesn't matter what you choose), 1 for Mac)
       Install Mac, boot with your USB, mount your EFI partition (use terminal or an EFI mounter app), create an EFI folder (if there is no folder), copy the CLOVER folder I attached to the EFI folder, restart
      Boot into your Win installer, Format the partition you created for Win, install. 
      Now, it's automatically booting into Windows. To use Clover open cmd in administrator, type: 
      bcdedit /set {bootmgr} path \EFI\CLOVER\CLOVERX64.efi  
      You're done! It will booting into Clover when you start the system, and you can select Win or Mac (or another OS if installed on a 3rd partition).
       
      IF YOU GETTING ERRORS DURING WINDOWS INSTALLATION (could not be formatted, etc):
      Make sure you have GPT partitions, and GPT (UEFI) installer, also disconnect all external storage drives (except the installer USB)  
      Mounting EFI from Windows:
      Open cmd in administrator mode and type: mountvol b: /s (This will mount your EFI) Open Total Commander or Explorer++ in administrator mode to manage EFI mountvol b: /d (This will unmount your EFI)  
      Useful Applications for Mac:
      EFI Mountain Show -> To easily mount your EFI Clover Configurator -> To easily manage your config.plist https://mackie100projects.altervista.org/download-clover-configurator/ PlistEditPro -> Advanced plist editor https://www.fatcatsoftware.com/plisteditpro/ iStat Menus -> To monitoring your devices https://bjango.com/mac/istatmenus/ Boom 3D -> To significantly increase your audio quality https://www.globaldelight.com/boom/ TextMate -> a basic code editor just like Notepad++ on Windows https://macromates.com Modified Wineskin to run basic Windows 32-bit or 64-bit (or DX9 games) applications on Catalina -> https://www.reddit.com/r/MacOS/comments/fobx5t/i_didnt_want_to_boot_windows_every_time_when_i/ MaciASL -> View/Edit your .aml, .dsl files https://bitbucket.org/RehabMan/os-x-maciasl-patchmatic/downloads/ Hackintool -> All useful info, tools in one place https://github.com/headkaze/Hackintool IORegistryExplorer V2.1 -> To view your IO tables https://github.com/vulgo/IORegistryExplorer/releases/tag/v2.1 App Cleaner -> To delete your apps with caches https://freemacsoft.net/appcleaner/ Intel Power Gadget -> To see your frequencies https://software.intel.com/en-us/articles/intel-power-gadget Carbon Copy Cloner -> Advanced macOS drive backup utility https://bombich.com Commander One ->A Total Commander alternative for macOS https://mac.eltima.com/file-manager.html  
      Useful Applications for Windows:
      Total Commander -> To easily manage EFI https://www.ghisler.com gibMacOS -> A python script for downloading/creating macOS Internet Recovery USB from Windows (working internet is needed when installing) https://github.com/corpnewt/gibMacOS mountvol b: /s -> To mount your system drive EFI
      EasyUEFI -> To manage boot orders and any bootloaders with ease https://www.easyuefi.com/index.html
      MiniTool Partition Wizard -> To mount your USB EFI, and manage other drives https://www.minitool.com/partition-manager/
      Notepad++ -> Basic code editor for all type of files https://notepad-plus-plus.org
       
      Notes:
      According to @albertoacj's comment Sidecar is only working in headless iGPU mode when using an AMD GPU, keep that in mind No need to change anything inside Clover from El Capitan to Big Sur For macOS Mojave and older you might need the full AirPortBrcmFixup.kext for full WiFi support   
      Changelog:
      2020.11.12: Noticed that the CPU is always at 4200 Mhz, created an SSDT for proper CPU stepping. Updated to Big Sur release version, updated bootpack
      2020.11.03: Tested El Capitan, Sierra, High Sierra, Mojave, Catalina, Big Sur
      2020.11.01: Updated bootpack to Clover v5126, ready for macOS 11 Big Sur final release
      2020.04.23: Corrected layout-id to use all audio ports, updated bootpack
      2020.04.22: Deleted unnecessary boot-args, can boot without any custom boot-args (except agdpmod=pikera for RX 5700), updated bootpack
      2020.04.20: Deleted unnecessary lines from config.plist, updated bootpack
      2020.04.17: Replaced FakeSMC with VirtualSMC because FakeSMC is outdated (to see your frequencies use Intel Power Gadget) -> Removed unnecessary kexts, Updated all necessary kexts, updated Clover to v5112, updated bootpack, enabled SIP, deleted bootcamp theme
      2020.03.26: Updated to 10.15.4 -> Updated WhateverGreen, Lilu -> Updated Clover to v5107
      2020.03.23: Removed "EmuVariableUefi.efi" -> deleted, caused false nvram map, now it's native, updated Clover to v5106
      2020.02.11: Updated to 10.15.3 -> No problem when/after installing
      2020.01.19: Added ASUS HyperKit NVMe SSD to the "What is working" list
      2020.01.12: Tested system with OC, added more informations to BIOS settings
      2020.01.11: Added SmallTreeIntel82576.kext for 2nd Ethernet, Tested Ethernet ports
      2020.01.11: First upload
       
    • By kushwavez
      Acer Aspire V15 V5-591G - macOS Sierra 10.12.6 - Big Sur 11
      Running Big Sur 11.0.1!
      (Sierra, High Sierra and Mojave needs "SATA-100-series-unsupported.kext" and unmodified "AirPortBrcmFixup.kext")
       
      (Note: mine is 55TU version, but the bootpack will work fine with another versions of 591G, for example: V5-591G-71K2, -764Z, -59PU, etc.)
      Specifications:
      Motherboard: USOPP_SLS (Skylake-H PCH) BIOS: Insyde Corp. v 1.15 CPU: Intel Core i5-6300HQ 2.3 GHz (Skylake) GPU: NVIDIA GeForce GTX 950M 2 GB (Optimus) & Intel HD Graphics 530 RAM: 16 GB DDR4 (2x 8 GB SAMSUNG 2133 MHz) WiFi + Bluetooth: Qualcomm Atheros QCNFA344A 5 GHz (Later -> Broadcom BRCM94352Z M.2 5 GHz WiFi + 4.0 Bluetooth) Audio: Realtek HD Audio: ALC 255  Ethernet: Realtek RTL8168/8111 Card Reader: Realtek USB 2.0 Card Reader (USB2.0-CRW) Webcam: HD Webcam HDD: TOSHIBA 500 GB HDD SSD: KINGSTON A2000 NVMe PCI-e SSD (if you want Windows dual-boot then you need M.2 SATA SSD since NVMe will not work on Windows due interfering with NVIDIA GTX 950M (bluescreen when loading drivers)) Display: 1366x768 (15.6", Matte) Battery: 6 cell 56Wh / 5040mAh Connectors:  1x SD Card Reader 2x USB 3.0 (1x USB Charging), 1x USB 2.0 1x VGA 1x HDMI 1x 3.5mm microphone/audio combined jack connector 1x Ethernet (Rj-45) Keyboard & Touchpad: Multi-Touch & Multi-gestures ELAN 501 Touchpad, Backlight Keyboard. Working:  
      Wi-Fi (with BCM94352Z) Bluetooth hand-off (With BCM94352Z) Full Graphics Acceleration Display: if default colour profile is corrupted (blue is not actual blue but purplish) Use "Rec. ITU-R BT. 709-5" Color Profile (System Pref. -> Displays -> Color) HDMI & VGA Outputs Audio  Ethernet  App Store, Messages, FaceTime, Siri, iCloud Integrated webcam 3.0 USB Touchpad and Keyboard (with working gestures and Fn+Brightness keys) Battery info Sleep Mode NVMe PCI-e x4 SSD Power Management Hardware decoding/encoding (up to HEVC) Not working:
      Original Wi-Fi (Qualcomm Atheros QCNFA344A):  Only Bluetooth is working, Wifi is unsupported, changed to Broadcom BCM94352Z NVIDIA GeForce GTX 950M: Optimus not supported. Card Reader: Unsupported For Wi-Fi:
      1st method: You can choose an external USB wifi dongle (I used TP-Link Archer T1U (5GHz support), TP-Link has official macOS drivers, you just need to install it 2nd and best method: Replace your M.2 Qualcomm Card with a compatible BCM94352Z card (you will have hand-off Bluetooth too), just install the kexts (enabled with BrcmFirmwareRepo, BrcmPatchRAM3, AirportBrcmFixup kexts they're all in my attached zip). Or buy BCM94360NG for OOB support. You could buy these cards from ebay, aliexpress, or amazon Issues:
      - Sometimes Combo Jack audio is not working after sleep
      Not tested:
      - Hibernation
      - FileVault
      BIOS Settings:
      - BIOS version 1.15 (irrelevant)
      - Secure Boot: Disabled
      - Touchpad: Advanced
      - Boot mode: UEFI
      Getting ready for Installation:
       Download the install zip (bootpack & postinstall):  Click here (v5126) -> Acer_Aspire_V5-591G_Clover_v5126.zip (Tested: Sierra 10.12.6 -> macOS Big Sur 11.0.1)
      Installation:
      - Create an installer with any method you know (- Mac: createinstallmedia, gibMacOS - Windows: Transmac, Vmware, Win32diskimager, gibMacOS)
      - Copy my Clover folder to the USB's EFI folder
      - Boot with the Installer USB
      - If you stuck in boot, reboot and in the Clover bootloader select "config_debug.plist" -> you'll have more informations about the freeze
      - To disable SIP boot with "config_debug.plist"
       
      Please open the README.pdf in my install zip for more informations about the USB Installer & Post installation!
      If you have a single RAM and getting panic at boot, then you need to edit the "config.plist" with these (SMBIOS->after "Version 1.0"):
      ->Edit "Frequency" and "Size" to match your RAM values
      <key>Version</key> <string>1.0</string> <key>Memory</key> <dict> <key>Channels</key> <integer>1</integer> <key>SlotCount</key> <integer>1</integer> <key>Modules</key> <array> <dict> <key>Slot</key> <integer>0</integer> <key>Size</key> <integer>8192</integer> <key>Frequency</key> <integer>2133</integer> <key>Type</key> <string>DDR4</string> </dict> </array> </dict> </dict> Before updating to a new version of macOS please update kexts (and clover if necessary) to newer versions to avoid kernel panics.
      Generate a serial number with Clover Configurator.app (open up your config.plist with CC then -> SMBIOS -> Serial Number -> Generate New)
      Here some pictures:

       
      Running fine on Big Sur 11.0.1 
       

      Finally a fully working touchpad.
       
      Sierra 10.12.6
       
      High Sierra 10.13.6
       
      Mojave 10.14.6
       
      Catalina 10.15.7
      macOS & Windows 10 Dual-Boot:
      Dual-boot clean install (on one drive), UEFI Only:
       
       Boot into your Mac installer, Create 2 partitions in GUID table (1 for Win (I used FAT32 but I think it doesn't matter what you choose), 1 for Mac),   Install Mac, boot with your USB, mount your EFI partition (use terminal or an EFI mounter app), create an EFI folder (if there is no folder), copy the CLOVER folder I attached to the EFI folder, restart,  Boot into your Win installer, Format the partition you created for Win, install.   Now, it's automatically booting into Windows. To use Clover open cmd in administrator, type:  bcdedit /set {bootmgr} path \EFI\CLOVER\CLOVERX64.efi  
            5.  You're done! It will booting into Clover when you start the system, and you can select Win or Mac (or another OS if installed on a 3rd partition).
       
      IF YOU GETTING ERRORS DURING WINDOWS INSTALLATION (could not be formatted, etc):
      Make sure you have GPT partitions, and GPT (UEFI) installer, also disconnect all external storage drives (except the installer USB)  
      IF YOU CAN'T MOUNT YOUR EFI PARTITION (No EFI partition found):
      It's because your EFI is not 200 MB or not an "Apple" original EFI,  but don't worry, try another EFI mounter, or mount from terminal (I used EFI Mountain Show: Getting errors, but you can mount and use without problem) You also could "mount" the EFI from Windows: 1st method: open cmd in administrator mode and type:
      diskpart list vol (Now select the "System" volume,(FAT 32) For example I select 4) sel vol 4 list part (Select System type partition, for example 2) sel part 2 assign letter=b (This will "mount" your EFI partition) Open Explorer++ in administrator mode to manage EFI
      remove letter=b (This will "unmount" your EFI) 2nd method: open cmd in administrator mode and type:
      mountvol b: /s (This will mount your EFI) Open Explorer++ in administrator mode to manage EFI
      mountvol b: /d (This will unmount your EFI) Useful Applications for Mac:
      EFI Mountain Show -> To easily mount your EFI Clover Configurator -> To easily manage your config.plist https://mackie100projects.altervista.org/download-clover-configurator/ PlistEditPro -> Advanced plist editor https://www.fatcatsoftware.com/plisteditpro/ iStat Menus -> To monitoring your devices https://bjango.com/mac/istatmenus/ Boom 3D -> To significantly increase your audio quality https://www.globaldelight.com/boom/ TextMate -> a basic code editor just like Notepad++ on Windows https://macromates.com Modified Wineskin to run basic Windows 32-bit or 64-bit (or DX9 games) applications on Catalina -> https://www.reddit.com/r/MacOS/comments/fobx5t/i_didnt_want_to_boot_windows_every_time_when_i/ CrossOver 20 -> Run DirectX 11 applications on Catalina=< https://www.codeweavers.com/crossover/ MaciASL -> View/Edit your .aml, .dsl files https://bitbucket.org/RehabMan/os-x-maciasl-patchmatic/downloads/ Hackintool -> All useful info, tools in one place https://github.com/headkaze/Hackintool IORegistryExplorer V2.1 -> To view your IO tables https://github.com/vulgo/IORegistryExplorer/releases/tag/v2.1 App Cleaner -> To delete your apps with caches https://freemacsoft.net/appcleaner/ Intel Power Gadget -> To see your frequencies https://software.intel.com/en-us/articles/intel-power-gadget Carbon Copy Cloner -> Advanced macOS drive backup utility https://bombich.com Commander One -> A Total Commander alternative for macOS https://mac.eltima.com/file-manager.html  
      Useful Applications for Windows:
      Total Commander -> To easily manage EFI https://www.ghisler.com mountvol b: /s -> To mount your system drive EFI EasyUEFI -> To manage boot orders and any bootloaders with ease https://www.easyuefi.com/index.html MiniTool Partition Wizard -> To mount your USB EFI, and manage other drives https://www.minitool.com/partition-manager/ Notepad++ -> Basic code editor for all type of files https://notepad-plus-plus.org gibMacOS -> A python script for downloading/creating macOS Internet Recovery USB from Windows (working internet is needed when installing) https://github.com/corpnewt/gibMacOS  
       
      Notes:
      For Sierra, High Sierra, Mojave you need to download and use the full AirPortBrcmFixup.kext for WiFi, and replace CtlnaAHCIPort.kext with SATA-100-series-unsupported.kext for AHCI Sata drives For Sierra only you need to replace SMCBatteryManager.kext with ACPIBatteryManager.kext for working Battery indicator  
      Changelog:
      2020.11.12: Touchpad now fully functional with gestures, Patched Fn+Brightness keys (Fn+Left, Fn+Right), repatched DSDT, changed SMBIOS to MacBookPro13,1 for better support, fixed CPU Stepping, fixed some wrong lines in config.plist, updated to Big Sur release, updated bootpack, updated guide. 2020.11.03: Tested macOS Sierra, High Sierra, Mojave, Catalina, Big Sur, updated guide 2020.11.01: Initial upload
    • By lizdav
      Hi,
       
      I would like to ask for some advice or help even.
       
      I have had some usability issues in the past with my hackintosh so I installed Mojave for the second time but it keeps producing the same exact problem. Most of the time the system stutters and lags after login. The app icons just bounce if I want to open them and even if it does it takes forever. Another thing I picked up on is that it seems like there's no internet access whenever this occurs. The problem ceases after like 2-3 restarts and everything is back to normal. 
       
      What could cause an issue like this? I had the same thing happening with my previous install but I thought that was because of unnecessary kexts I left in the EFI. I only have the bare minimum required this time so I'm kinda lost.
       
      Computer specs:
       
      Mobo: Gigabyte B360M D3H
      Graphics: Radeon Vega 64 8OC
      CPU: Intel i7 8700k
      Ram: 32 Gig
      SSD: Samsung Evo 860 250gb
       
      I also have a separate HDD with Windows 10 installed for gaming purposes. I would greatly appreciate any kind of help, thanks in advance!
       
      –David
       
       
      config.plist
×