Jump to content
angelo_ios

[GUIDE] MacOS 10.14 Mojave on ASUS X555L(J)

17 posts in this topic

Recommended Posts

EDIT: MacOS Mojave 10.14 ONLY I didn’t test 10.14.1! The EFI folder is compatible with High Sierra.

 

Guide to installing 10.14 Mojave on a ASUS X555L

 

What Works:

-WiFi

-Sound

-Graphics (Intel)

 

What doesn't Work:

-Bluetooth

-NVidia Web Drivers

-Battery Indicator

 

Used Kexts:

Picture

 

Clover setup:

Clover plist is downloadable in this topic.

 

Let's start

 

Step one:

First get a USB with 8+ GB of storage and a MacOS Mojave 10.14 installer from the AppStore.

 

Partition the USB in a GUID style and 2 partitions, one partition HFS+ and one partition FAT32.

 

In the FAT32 partition put the EFI Folder there.

 

On the HFS+ partition get the MacOS Mojave .app using this command:

sudo /Applications/Install\ macOS\ Mojave.app/Contents/Resources/createinstallmedia --volume /Volumes/USBNAME --applicationpath /Applications/Install\ macOS\ Mojave.app --nointeraction

Lets install!

 

Put the USB in a 3.0 port on the LEFT side of the Notebook.

 

In the BIOS follow the default Hackintosh settings, do NOT forget to put Memory allocation to 64MB (Otherwise you won't boot)

 

Boot into the Installer and install MacOS Mojave.

 

Boot into MacOS. Now your Graphics are working but your WiFi and Sound are not! for the WiFi follow this video:

https://www.youtube.com/watch?v=OxFsjhc-AuM

Once rebooted WiFi is working! 

 

For sound get the VooDooHDA.kext and place it into /Library/Extensions

 

Reboot once again and your sound is now working flawlessly!

 

My EFI Folder is downloadable

Screenshot 2018-10-25 at 18.33.25.png

config.plist

EFI.zip

Edited by angelo_ios
Forgot the Battery Indicator

Share this post


Link to post
Share on other sites
Advertisement

@ angelo_ios

 

Hello!

 

Your optimus enabled NVDA will never work with OS X, even if there are webdrivers. It would be better to get PM proper working and get rid of nullcpu... and all other rubish kexts in Clover/kexts/other.

 

You should also switch off the NVDA with DSDT/SSDT or if there is an option in Bios.

 

Have fun.

Edited by styrian

Share this post


Link to post
Share on other sites
Thank you !! As I do not understand much of this, what advises me to install: Mojave or High Sierra? With Mojave at this moment everything is activated, wifi, audio and Intel HD Graphics 5500 1536 MB ... problem in starting without USB. It is an Asus X555L I7 Intel 5500 and GeForce Nvidia 920M ... I would appreciate it if you would agree to enter it through TeamViewer and see what could be done. I realize little ... Now that I was interested in hackintosh. Thank you .

Share this post


Link to post
Share on other sites

Hello!

 

I would stay at first at High Sierra and make it at lest nearly perfekt running and on this basis try to instala Mojave.

 

Sorry i don't own a laptop of thiskeind and therefore no Efi(Clover)folder. But you can find here universal config.plist, which perhaps are workin without any modification for the beginning: https://github.com/RehabMan/OS-X-Clover-Laptop-Config

 

For DSDT and SSDT editing you could use these: https://github.com/RehabMan/OS-X-Clover-Laptop-Config/tree/master/hotpatch or rather these: https://github.com/RehabMan/Laptop-DSDT-Patch

 

Have fun.

 

PS: Usually one's hardware is set in the signature - as mentioned in the platform rules.

Share this post


Link to post
Share on other sites
On 11/1/2018 at 3:14 PM, carlos mane said:

Good morning. I did everything as explained, everything works ... but it does not restart without the installation pen drive! How to make ? Thank you .

Make a Partition formates FAT32, then just copy paste your EFI folder in. In the BIOS select (drive name EUFI) as boot priority, reboot and done!

On 11/2/2018 at 12:18 PM, carlos mane said:

One more request: do you have an EFI High Sierra folder for the same Asus ASUS X555L (J)? Give away draw. Thank you.

For me the Mojave EFI folder (provided in the topic) works on High Sierra as well.

On 11/2/2018 at 9:13 AM, carlos mane said:

Thank you !! As I do not understand much of this, what advises me to install: Mojave or High Sierra? With Mojave at this moment everything is activated, wifi, audio and Intel HD Graphics 5500 1536 MB ... problem in starting without USB. It is an Asus X555L I7 Intel 5500 and GeForce Nvidia 920M ... I would appreciate it if you would agree to enter it through TeamViewer and see what could be done. I realize little ... Now that I was interested in hackintosh. Thank you .

I would advice Mojave, but it is up to you. I did not test High Sierra myself but the EFI folder is compatible with HS. As Mojave is newer it will be supported longer and takes away the need to update your MacOS for a long time

Share this post


Link to post
Share on other sites
On 11/2/2018 at 5:19 PM, styrian said:

Hello!

 

I would stay at first at High Sierra and make it at lest nearly perfekt running and on this basis try to instala Mojave.

 

Sorry i don't own a laptop of thiskeind and therefore no Efi(Clover)folder. But you can find here universal config.plist, which perhaps are workin without any modification for the beginning: https://github.com/RehabMan/OS-X-Clover-Laptop-Config

 

For DSDT and SSDT editing you could use these: https://github.com/RehabMan/OS-X-Clover-Laptop-Config/tree/master/hotpatch or rather these: https://github.com/RehabMan/Laptop-DSDT-Patch

 

Have fun.

 

PS: Usually one's hardware is set in the signature - as mentioned in the platform rules.

The Guide for this topic is for the X555LJ, Mojave works flawlessly and (almost) everything works. I didn’t test High Sierra but the EFI folder I provided works with HS as well.

Share this post


Link to post
Share on other sites
Posted (edited)

 

I can not boot, an apple and a download bar appear, then immediately restart. Help please, like I did everything according to the instructions.

WhatsApp Image 2019-03-18 at 14.19.48.jpeg

Edited by zrkyuseo

Share this post


Link to post
Share on other sites

I have dual booted MacOS Mojave 10.14.6 in my Asus X555LJ
Now Ethernet and Intel Graphics HD 5500 are perfectly working.

System Manufacturer: ASUSTeK COMPUTER INC.
System Model: X555LJ
BIOS: X555LJ.204 (type: UEFI)
Processor: Intel(R) Core(TM) i5-5200U CPU @ 2.20GHz (4 CPUs), ~2.2GHz
Memory: 8192MB RAM

Card name: Intel(R) HD Graphics 5500
Current Mode: 1366 x 768 (32 bit) (60Hz)
Card name: NVIDIA GeForce 920M

Sound Device: Speakers (Realtek High Definition Audio)
Sound Capture Device: Microphone (Realtek High Definition Audio)

2x USB 3.0
1x USB 2.0
HDMI and VGA port

Ethernet: Realtek PCIe GBE Family Controller

Wifi & Bluetooth: Broadcom 802.11n Network Adapter

Can you please guide me to get the following things work..?

  1. Wifi
  2. Bluetooth
  3. NVIDIA 920M
  4. Brightness control

Help will be appreciated.

Share this post


Link to post
Share on other sites
On 10/4/2019 at 1:08 AM, styrian said:

Hello,

 

Thanks for the response.

I have followed this guide. Still my wifi and NVIDIA graphics not working.

 

I am using 10.14.6.

Please help.

Share this post


Link to post
Share on other sites

Hello!

 

If the WIFI is an Intel one, it will never work. You need to change it to a suitalble Broadcom one or use an usb wifi adapter, which is working on real Macs.

 

Your NVDA will never work, because it is an Optimus enabled one.

 

Have fun.

Share this post


Link to post
Share on other sites
On 10/10/2019 at 1:41 AM, styrian said:

Hello!

 

If the WIFI is an Intel one, it will never work. You need to change it to a suitalble Broadcom one or use an usb wifi adapter, which is working on real Macs.

 

Your NVDA will never work, because it is an Optimus enabled one.

 

Have fun.

Hi,

 

Wifi is Broadcom 802.11n

No Intel one. Still not working.

 

Please help out.

Share this post


Link to post
Share on other sites
7 hours ago, kankit74 said:

Wifi is Broadcom 802.11n

No Intel one. Still not working.

Hello!

 

Your Wifi adaptoris a Realtek one (Look at the Asus driver page for Win 10). This is also not working with OSX. I do not know the slot standart of the adapter. To resarch this is on your own.

 

Have fun.

Share this post


Link to post
Share on other sites
On 10/12/2019 at 8:13 AM, styrian said:

Hello!

 

Your Wifi adaptoris a Realtek one (Look at the Asus driver page for Win 10). This is also not working with OSX. I do not know the slot standart of the adapter. To resarch this is on your own.

 

Have fun.

Hi,

 

Thanks a lot. I got the thing.

I will use usb wifi adapter insted.

Can you please do one more favour, just battery indication should be working fine..

Please help out.

 

Thanks.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By hungdv
      Hello guys,
      I was try to install MacOS Mojave on my new machine but no luck. Can anyone show me which guide to fit my system, please?please?please?
      + Mobo: GIGABYTE Z390 AORUS ELITE LGA1151v2
      + CPU: Intel Core i5-9600K 3.7GHz
      + iGPU: Sapphire RX 580 Pulse 8GB
      + Drives: SSD Samsung 970 Pro PCIe NVMe V-NAND M.2 2280 512GB
      + Ram: Crucial Ballistix Sport LT 2x8GB Bus 2666 DDR4
      + PSU: Corsair RM650 80 Plus GOLD
      + Case: Corsair 220T White RGB Airflow Tempered Glass
      + Cooler: Cooler Master HYPER 212 BLACK EDTION
      + Dual Band Network Card Broadcom Bcm94360 867Mbps.
    • By Rajan Pandit
      Hai, I have,
      i5 2500k
      GA-z68 AP D3 Rev.1
      Corsair 8 GM Ram
      Gigabyte Radeon RX 560 OC 4G Graphic Card
      500 GB Samsung SSD EVOf
       
      with this configuration I tried to install Mojave but After Apple Logo there was a black screen
      then nothing... please help
      I have create USB with terminal and Install Clover_v2.4k_r4961-Legacy.pkg to activate boot
      then I have recessary kext to EFI/KEXT/OTHER 
      but I am struck at Black Screen after apple logo
    • By Rajan Pandit
      Hai, I have,
      i5 2500k
      GA-z68 AP D3 Rev.1
      Corsair 8 GM Ram
      Gigabyte Radeon RX 560 OC 4G Graphic Card
      500 GB Samsung SSD EVO
      .. I want to install Mojave on this configuration...
      please help. what I need to do... 
      I have downloaded the Installer from APP Store...
      please help
    • By ScoobDoob69
      Hi, everyone so I am currently dual-booting Windows 10 and Linux Mint. I would like to add Mojave and triple boot (without formatting/losing all data from windows and linux).
       
      My Current Specs:
      CPU: Intel Core i7-2600 (not k) Sandy Bridge
      GPU: Aorus Radeon RX570 4GB
      Motherboard: Intel SWQ6710H
      HDD: 4TB Western Digital Blue WD40EZRZ
      Ram: 20GB DDR3 Total (2x 8GB + 2x 2GB)
       
      1. Is it possible to install Mojave on my HDD without wiping Windows 10 or Linux Mint?
      2. What guide is most ideal for my situation? 
       
      If you need any additional information or details, I am more than happy to provide that. I tried multiple guides months ago and could not get the installation to work. 
       
       
×