Jump to content
EduardoMenezes

ACER ASPIRE Intel HD GRAPHICS 5500 WITH MOJAVE - SOLVED - RESOLVIDO

93 posts in this topic

Recommended Posts

Good evening, friends of InsanelyMac.

I have an Acer Aspire E5-571 notebook with Intel processor and Intel Graphics 5500 hd graphics card. When I was using the Sierra, the video card was recognized without problems. Now that I'm using Mojave I can not get the acceleration to work.

I've been researching something about having to use Lilu.kext and whatevergreen.kext but I do not have enough knowledge to solve this problem.

I need the help of someone who can explain to me how to solve this acceleration problem. I'm sure it will be of great value to other users like me.

Thank you very much.

Captura de Tela 2018-10-22 às 21.51.50.png

Edited by EduardoMenezes
Problem Solved

Share this post


Link to post
Share on other sites
Advertisement
Good Morning.

Could anyone help me solve this problem with my video card? I can not get graphic acceleration. Nothing is right.

Does anyone have a step-by-step?

 

Captura de Tela 2018-10-31 às 10.41.51.png

Captura de Tela 2018-10-31 às 10.43.27.png

Captura de Tela 2018-10-31 às 10.43.09.png

Captura de Tela 2018-10-31 às 10.42.55.png

Captura de Tela 2018-10-31 às 10.42.43.png

Share this post


Link to post
Share on other sites
On 10/31/2018 at 8:49 PM, EduardoMenezes said:

Good Morning.

Could anyone help me solve this problem with my video card? I can not get graphic acceleration. Nothing is right.

Does anyone have a step-by-step?

 

Captura de Tela 2018-10-31 às 10.41.51.png

Captura de Tela 2018-10-31 às 10.43.27.png

Captura de Tela 2018-10-31 às 10.43.09.png

Captura de Tela 2018-10-31 às 10.42.55.png

Captura de Tela 2018-10-31 às 10.42.43.png

 

ig-platform-id for IHD 5500 is 0x16260006 not 0x12345678

Share this post


Link to post
Share on other sites
Hello Hervé and Andres Zerocross. I fully agree that you should use ig-platform-id = 0x16260006. The problem is that with Intel Inject = on the notebook resets at boot time. I can only load if I turn off Inject Intel or if I use ig-platform-id = 0x12345678.

This is missing some other configuration.
Edited by EduardoMenezes

Share this post


Link to post
Share on other sites
13 hours ago, EduardoMenezes said:

Hello Hervé and Andres Zerocross. I fully agree that you should use ig-platform-id = 0x16260006. The problem is that with Intel Inject = on the notebook resets at boot time. I can only load if I turn off Inject Intel or if I use ig-platform-id = 0x12345678.

This is missing some other configuration.

 

Then you need to patch min stolen patch, just use latest Lilu.kext and Whatevergreen, and use patch of mem stolen at your config.plist

Share this post


Link to post
Share on other sites
On 11/1/2018 at 5:59 PM, Hervé said:

Try this one.

config.plist

 

Please post your patched tables or, better, your entire Clover EFI folder so that we know what you use...

 

Good evening, Hervé. I'm attaching the zipped EFI folder with whatever you asked for. On the ACPI tab on SSDT I unchecked OEM Droop because the notebook resets during boot. It's not panic. It resets.

Another friend Andres Zerocross commented on Lilu.kext and Whatever.Kext but I'm doubtful how to proceed. I already put it in the S/L/E folder without result.

 

 

 

Captura de Tela 2018-11-04 às 20.04.28.png

CLOVER.zip

Share this post


Link to post
Share on other sites
 
Good evening, Hervé. I'm attaching the zipped EFI folder with whatever you asked for. On the ACPI tab on SSDT I unchecked OEM Droop because the notebook resets during boot. It's not panic. It resets.
Another friend Andres Zerocross commented on Lilu.kext and Whatever.Kext but I'm doubtful how to proceed. I already put it in the S/L/E folder without result.
 
 
 
203441639_CapturadeTela2018-11-04s20_04_28.thumb.png.16b9b0540389cbee8f18b8e9ee9e26d4.png
CLOVER.zip
After use lilu.kext and whatevergreen.kext then you still need to set fb-min stolen patch at your device properties inside config.plist. or whatevergeen won't work.

Sent from my Mi Note 2 using Tapatalk

Share this post


Link to post
Share on other sites
On 11/5/2018 at 2:55 PM, Andres ZeroCross said:

After use lilu.kext and whatevergreen.kext then you still need to set fb-min stolen patch at your device properties inside config.plist. or whatevergeen won't work.

Sent from my Mi Note 2 using Tapatalk
 

 

Friends, I know that something is missing but I do not know how to do it.

Could someone tell me "get it" and put it in the abc folder, then mark it, then uncheck it, then write that in the xpto field ... type a step by step. I'm not a programmer. I'm just a user.

 

I need to know if I need to use lilu and whatevergreem or another kext and where to put these files. In Clover, what should be filled.

 

I say this because I honestly do not know how to solve it.

 

Share this post


Link to post
Share on other sites
 

Friends, I know that something is missing but I do not know how to do it.

Could someone tell me "get it" and put it in the abc folder, then mark it, then uncheck it, then write that in the xpto field ... type a step by step. I'm not a programmer. I'm just a user.

 

I need to know if I need to use lilu and whatevergreem or another kext and where to put these files. In Clover, what should be filled.

 

I say this because I honestly do not know how to solve it.

 

Ok, don't put any kext to System/library/extensions or Library/kext. Just put the kexts at EFI/Clover/kexts/others. After that upload your clover folder here. I will help

Sent from my Mi Note 2 using Tapatalk

Share this post


Link to post
Share on other sites

1. Make sure you remove all 3rd party kext like FakeSMC.kext, Lilu.kext, WhateverGreen.kext and other add on kext from System/Library/Extensions or in Library/Extensions. After that rebuild Kext Cache with Kext Utility I repeat make sure there is no add on kext from S/L/E or L/E. Use this step to avoid duplicate kext and "unpredicted problems".

2. After that,, mount your EFI partition,, then Delete your Entire CLOVER folder inside EFI folder. And replace with mine (i upload the new Clover folder for your).

The configuration include your DSDT and SSDT (brightness fix, minstolen patch fix, usb fix, ehc1 and ehc2 fix and many important patch for your system). I assume your device use RTL8168 Ethernet, so i use RTL8111.kext for your Ethernet. And i don't what is your wifi card (we can face it later).

Try it and give report as soon as possible.

CLOVER.zip

Share this post


Link to post
Share on other sites
2 hours ago, Andres ZeroCross said:

1. Make sure you remove all 3rd party kext like FakeSMC.kext, Lilu.kext, WhateverGreen.kext and other add on kext from System/Library/Extensions or in Library/Extensions. After that rebuild Kext Cache with Kext Utility I repeat make sure there is no add on kext from S/L/E or L/E. Use this step to avoid duplicate kext and "unpredicted problems".

2. After that,, mount your EFI partition,, then Delete your Entire CLOVER folder inside EFI folder. And replace with mine (i upload the new Clover folder for your).

The configuration include your DSDT and SSDT (brightness fix, minstolen patch fix, usb fix, ehc1 and ehc2 fix and many important patch for your system). I assume your device use RTL8168 Ethernet, so i use RTL8111.kext for your Ethernet. And i don't what is your wifi card (we can face it later).

Try it and give report as soon as possible.

CLOVER.zip

 

Good evening.

 

Following his script and replacing my Clover folder with his own, he caused the notebook to restart during boot.

 

I captured an image before resetting.

 

 

So I returned to my Clover folder and I am attaching, as per your previous message.

Screenshot_20181107-200847.png

meu arquivo CLOVER.zip

Share this post


Link to post
Share on other sites

 

Good evening.

 

Following his script and replacing my Clover folder with his own, he caused the notebook to restart during boot.

 

I captured an image before resetting.

 

 

So I returned to my Clover folder and I am attaching, as per your previous message.

Screenshot_20181107-200847.thumb.png.8e897bbc25786584107ff1bef56e12d2.png
meu arquivo CLOVER.zip
Open terminal and type "sudo kextcache -i /" and press enter, then input the pasword and press enter.

Copy the log and paste it here

Sent from my Mi Note 2 using Tapatalk

Share this post


Link to post
Share on other sites

image.png.67048956f6951bb35ddaa707c87678c2.png

 

Are you sure that you only use 3 add on kexts??? No VoodooPS2Controller.kext and another kexts???

 

Now DELETE all of your CLOVER folder,, and and use mine (i attached it), i make mistake before,, forgot to patch minstolen patch at ssdt-0.aml (sorry). Now try it again, and give me report as soon as possible.

CLOVER.zip

Edited by Andres ZeroCross
Make it simple

Share this post


Link to post
Share on other sites
8 hours ago, Andres ZeroCross said:

image.png.67048956f6951bb35ddaa707c87678c2.png

 

Are you sure that you only use 3 add on kexts??? No VoodooPS2Controller.kext and another kexts???

 

Now DELETE all of your CLOVER folder,, and and use mine (i attached it), i make mistake before,, forgot to patch minstolen patch at ssdt-0.aml (sorry). Now try it again, and give me report as soon as possible.

CLOVER.zip

 

Good Morning.

 

I downloaded this last your Clover folder that you attached and I used the command "sudo kextcache -i /" in the terminal.

 

Restart the notebook but it continues to reset during boot.

 

I am attaching the command log "sudo kextcache -i /" to you as per request.

 

I had to go back to my clover folder to use the notebook.

 

If you want you can access the notebook remotely. After all if we can solve this, I can share the solution with other people in Brazil.

 

Captura de Tela 2018-11-08 às 10.57.58.png

Share this post


Link to post
Share on other sites
4 minutes ago, EduardoMenezes said:

 

Good Morning.

 

I downloaded this last your Clover folder that you attached and I used the command "sudo kextcache -i /" in the terminal.

 

Restart the notebook but it continues to reset during boot.

 

I am attaching the command log "sudo kextcache -i /" to you as per request.

 

I had to go back to my clover folder to use the notebook.

 

If you want you can access the notebook remotely. After all if we can solve this, I can share the solution with other people in Brazil.

 

Captura de Tela 2018-11-08 às 10.57.58.png

 

 

As you can see, you did wrong about my instructions. I already tell you "REMOVE ALL 3rd party kext from Library/Extensions and System/Library/Extensions". But as per log i can see FakeSMC. VoodooPS2Controller.kext, VoodooHDA.kext, AppleHDADisabler.kext, ACPIBatteryManager.kext are still at Library/Extensions and System/Library/Extensions. Did you read my comment above????

Edited by Andres ZeroCross

Share this post


Link to post
Share on other sites
2 minutes ago, Andres ZeroCross said:

 

 

As you can see, you did wrong about my instructions. I already tell you "REMOVE ALL 3rd party kext from Library/Extensions and System/Library/Extensions". But as per log i can see FakeSMC. VoodooPS2Controller.kext, VoodooHDA.kext, AppleHDADisabler.kext, ACPIBatteryManager.kext are still at Library/Extensions and System/Library/Extensions. Did you read my comment above????

I understand. I'll redo and return information.

 

Share this post


Link to post
Share on other sites
9 minutes ago, Andres ZeroCross said:

How about it???

Sent from my Mi Note 2 using Tapatalk
 

 

Really those kexts needed to be removed. but during boot the screen dims and the notebook restarts.

 

 

Captura de Tela 2018-11-08 às 12.13.43.png

Share this post


Link to post
Share on other sites
 

Really those kexts needed to be removed. but during boot the screen dims and the notebook restarts.

 

 

543453543_CapturadeTela2018-11-08s12_13_43.png.e3ddfecac69d80acf484f0eaac4ed2e9.png
Correct, remove it. And use my Clover folder. If problem still persist, can you take video?? I need to see the log.

Sent from my Mi Note 2 using Tapatalk

Share this post


Link to post
Share on other sites
1 hour ago, Andres ZeroCross said:

Correct, remove it. And use my Clover folder. If problem still persist, can you take video?? I need to see the log.

Sent from my Mi Note 2 using Tapatalk
 

 

Yes, I'm using your Clover folder. Follow the video link.

 

https://drive.google.com/file/d/1UfXCdAalnHEE4-Xyih4hIbadAdJ60oCf/view?usp=sharing

Captura de Tela 2018-11-08 às 13.40.38.png

Captura de Tela 2018-11-08 às 12.13.43.png

Share this post


Link to post
Share on other sites
6 minutes ago, EduardoMenezes said:
 

Yes, I'm using your Clover folder. Follow the video link.

 

https://drive.google.com/file/d/1UfXCdAalnHEE4-Xyih4hIbadAdJ60oCf/view?usp=sharing
667718445_CapturadeTela2018-11-08s13_40_38.png.4b75e7f185b374b98234bdccc8decf09.png
1546469687_CapturadeTela2018-11-08s12_13_43.png.b57d52e381d1b14ac03cff3ee1028f49.png

It's still related to graphics. Can you fast response?? You take too long to reply

Sent from my Mi Note 2 using Tapatalk
 

Just tell me when you can make fast reply to this forum,, there is too many configurations that i must reply (i joint many forums and group). So it make me no focus if you reply the forum discussion for so long.

Edited by Andres ZeroCross

Share this post


Link to post
Share on other sites
3 minutes ago, Andres ZeroCross said:

It's still related to graphics. Can you fast response?? You take too long to reply

Sent from my Mi Note 2 using Tapatalk
 

I just have to translate some things. I'm learning English now, sorry.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By karthiksh1989
      can somebody walkthrough with the mojave installation guide?
      i have a mac high sierra 13.6 version on my macbook pro and want to install mojave on my desktop
      Exact config is Gigabyte gaming wifi 7 motherboard amy ryzen 7 2nd gen 2700X processor Gigabyte G1 8GB grapgic card VEGA 64
      running 2 nvme Samsung 256gb cards and 1 intel 180gb ssd internal and 1tb WD HDD, with 64 GB 3200Mhz Ram
       
      https://wa.me/919611736534 (whatsapp)
    • By ltooz_audis
      I always want to have a long lasting battery ultrabook to install Mojave on. I was looking at Dell XPS 13 but its design is not very good with the camera and other problems. HP Spectre x360 is a nice design but the wifi module is soldered on board. The Envy 13" is the best one in the bunch for MacOS Mojave. I would not use any other macOS besides Mojave, it's the best one so far. If you can't get it done with macOS Mojave, you don't do it correctly, it's much more refined and given than older macOS's.
      I wanted the 8th generation because of the 4 cores which is almost 1.5 times faster than this 7th generation i7-7500u, but the price is too high. I picked up this one on Craigslist for $400. I've just ordered the 500GB NVME WD Black for $104 and DW1560 for $29. So, the perfect MacBook Pro 14,2 is less than $600 that last 5-6 hours with Mojave and 8-9 hours on Windows 10. The bench mark is the same as the real MacBookPro 14,2. BTW, this is the first try, there will be on going testing and confirming. 250GB hard drive is hardly enough for dual boot Windows and Mac. You need at least 500GB, I don't use Windows at all, so I'll partition 200GB for Windows and 300GB for Mojave.
      All new HP laptops will have kernel panic if using Clover to boot UEFI, at least a fix was found. I'll have more videos and info when I have time to write them. Watch the videos and ask questions if you have any problems.
      1. Clover 4558 - Lilu.kext (1.3.3) - AppleALC.kext (1.3.1) - Whatevergreen.kext (1.2.3) - USBInjectAll.kext (0.6.5) - Fakesmc.kext (6.25-332-gf3a8525c.1758) - ACPIBatteryManager.kext (1.81.4) - AHCIPortInjector.kext - BrcmFirmwareRepo.kext (2.2.7) - BrcmPatchRAM2.kext (2.2.7) - CodecCommander.kext (2.6.2) - FakePCIID_Broadcom_WiFi.kext (1.3.9) - FakePCIID_Intel_HD_Graphics.kext (1.3.9) - FakePCIID.kext (1.3.9) - SSDT-AUIC-ALL.aml - SSDT-USBX.aml - SSDT-PNLF.aml - SSDT-PluginType1.aml - PreLoader.efi.
      2. For the keys F2 & F3 to work with backlight slider - the Fakesmc.kext version is important for some reasons, I'm still trying to find out why.
      The touchscreen actually works without the voodooI2C kexts, just need to patch the clover.
       
      I've been playing with the laptop for over a week now. Ordered the WD 500GB WDS500G2X0C from Amazon for $104, the 256GB is too small for dual booting Windows 10 & Mojave. It's really plug and play.
       
      Hardware - needed to make this a perfect macbook Pro14,2.
      1. DW1560 BCM94352Z - make sure it has 2 notches - Tape the 2 right pins on the 4 pins tab for it to work without a hitch on both Windows 10 and Mojave. You can buy from Ebay cheaper but you have to wait for months.
      2. 500GB NVMe SSD m.2 connector M is a must for dual boot - the cheaper one will be slower - Crucial NVMe 500GB is $25 less than WD.
      3. NOVOO USB-C to HDMI hub that works and inexpensive.
       
      Let's start to get this Kaby Lake working on the HP - I believe HP has the same components for similar configuration on different models. In order to get Mojave to work on Intel Laptop, we need a few important components - Sound is important (look for Realtek - ALC295) - Ethernet if any -Realtek - Trackpad  and TouchScreen (Synaptics or Elan).
       
      REPLACE VNMe SSD HARD DRIVE and DW1560 BCM94352Z
       
      The current BIOS is F22, the newest one is F27 but I don't want to update since it's working well. Since I don't really need the original Windows 10 with Junk software in it, I install the latest Windows 10 using Media Creation USB Boot Drive. The important thing is we have to prepare the SSD correctly or our EFI folder will only be set at 100MB which is not enough to install Clover or any other boot loaders. So instead of letting the Windows installer to create the EFI folder automatically, we can set the size ourselves using "diskpart" command. In order to use diskpart, we need to boot with Windows 10 USB installer (hit F9 then select UEFI USB installer) - select system repair and not installation - then select command prompt, from here we can create EFI folder and MSR for Windows installer to install. The product ID is already in the UEFI bios, so we don't really have to manually activate the Windows 10.

       
       
      diskpart
      select disk 0
      clean
      convert gpt
      create partition efi=300 !!! you can change it from 300MB to any size.
      format quick fs=fat32 label="EFI"
      create partition msr size=16
      exit

      After exit, reboot with the USB installer again in UEFI mode, select the custom. The Windows installer will select the 300MB EFI folder we've just created.
       
       
      How to fix KP on Clover UEFI Boot.
       
       
      This is the macBook Pro 14,2 from HP 13-ad010nr
       
       
       
      Louis
       
    • By yehia2amer
      Problem:
      When I Attempt to wake my Machine from sleep, the screen stays black, although the computer is obviously awake !
      This Machine has a 1300W Power Supply So Sleep is Very Useful.
       
      I Tried:
      1) FIX_WAK and FixShutdown as per Clover Wiki.
      2) Although I am using "SAPPHIRE Radeon PULSE RX 580 8GB GDDR5", which Should be completely Supported by Mojave, I Also changed the Part Number to "113-4E353BU-O4E" as per this Guide: http://www.xlr8yourmac.com/archives/feb18/RadeonRX-580_MacPro.html. The GPU is working GREAT without even Clover Inject
      3) Tried to Run this command: disablehibernate.command.zip
      4) Tried darkwake=0 to 10
      5) Disabled wake on USB & Wake on LAN (BIOS)
       
      Logs:
      sudo pmset -g
      System-wide power settings: Currently in use: hibernatemode 0 disksleep 10 womp 0 networkoversleep 0 sleep 0 Sleep On Power Button 1 ttyskeepawake 1 hibernatefile /var/vm/sleepimage autorestart 0 gpuswitch 2 displaysleep 10 pmset -g assertions
      2019-02-19 18:51:04 +0200 Assertion status system-wide: BackgroundTask 1 ApplePushServiceTask 0 UserIsActive 1 PreventUserIdleDisplaySleep 0 PreventSystemSleep 0 ExternalMedia 1 PreventUserIdleSystemSleep 0 NetworkClientActive 0 Listed by owning process: pid 56(powerd): [0x0000001700088000] 00:13:44 ExternalMedia named: "com.apple.powermanagement.externalmediamounted" pid 100(hidd): [0x00000025000980a7] 00:00:00 UserIsActive named: "com.apple.iohideventsystem.queue.tickle.4294968578.17" Timeout will fire in 600 secs Action=TimeoutActionRelease pid 200(mds_stores): [0x0000034e000b8279] 00:00:00 BackgroundTask named: "com.apple.metadata.mds_stores.power" Kernel Assertions: 0x4=USB id=502 level=255 0x4=USB mod=1/1/70, 2:00 AM description=com.apple.usb.externaldevice.1d130000 owner=USB Keyboard id=503 level=255 0x4=USB mod=1/1/70, 2:00 AM description=com.apple.usb.externaldevice.1d120000 owner=Lenovo Optical Mouse Idle sleep preventers: IODisplayWrangler  
      Specs:
      CPU: 2x Xeon E5-2680 v2 2.8GHz Ten Core Processors
      RAM: 128 GB 1333 MHz DDR3 ECC Memory
      GPU: SAPPHIRE Radeon PULSE RX 580 8GB GDDR5
      Chipset: Intel C602
      Audio: Realtek ALC3220 (ALC280) High Definition Audio
      SAS Drive Controllers (RAID): LSI 2308 SATA/SAS 6Gb/s controller with host based RAID 0, 1, 10 (4  
      Network Controller 1: Intel 82579 Gigabit Ethernet controller with Remote Wake UP, PXE and Jumbo frames support
      Network Controller 2: Intel Ethernet Controller I210 
      NEC USB3.0 xHCI Controller: Renesas Electronics uPD720201 & uPD720202
       
      for more info:
       
      Any Help will be appreciated, Thanks !
       
      Send me Yehias-Mac-Pro.zip
    • By yehia2amer
      Dell Precision T7610 Workstation
      Hackintosh GUIDE (Work in Progress)
       
                        
      Introduction: 
      Hi Everyone,
      This Workstation used to be a Beast with Dual CPUs and tons of RAM, I Know it is now normal to get that much cores in a Desktop but it is still a very decent machine for me (As a Programmer), and I thought it would be a good idea to Install MacOS as the Daily Driver Rather than Linux and It turns out to be a very Great Experience (with Some Challenges ).
       
      Specs:
      CPU: 2x Xeon E5-2680 v2 2.8GHz Ten Core Processors RAM: 128 GB 1333 MHz DDR3 ECC Memory GPU: SAPPHIRE PULSE Radeon RX 580 8GD5 Chipset: Intel C602 Audio: Realtek ALC3220 (ALC280) High Definition Audio SAS Drive Controllers (RAID): LSI 2308 SATA/SAS 6Gb/s controller with host based RAID 0, 1, 10 (4  Network Controller 1: Intel 82579 Gigabit Ethernet controller with Remote Wake UP, PXE and Jumbo frames support
      Network Controller 2: Intel Ethernet Controller I210
      NEC USB3.0 xHCI Controller: Renesas Electronics uPD720201 & uPD720202
       
      Working:
      Both "Xeon E5-2680 v2" and all cores with Power Management and P-States (using VoodooTSCSync & ssdtPRGen.sh) ATI Radeon HD 4870 (Vanilla) Realtek ALC3220 (ALC280)  (using VoodooHDA till Now - it is partially working with AppleALC using layout-id 13) LSI 2308 SAS (using AstekFusion2) Intel 82579 Network Controller (Vanilla) Intel I210 Network Controller (IntelMausiEthernet) USB 2.0  
      Not Working:
      NEC USB3.0 xHCI Controller (Renesas Electronics uPD720201 & uPD720202) Sleep  
      https://github.com/yehia2amer/Dell-Precision-T7610-Workstation-Hackintosh-Guide
    • By wen1
      Work in progress
       
      This is mini guide and config files for installing Mojave on a Dell XPS 13 9370.
       
      I took inspiration from sensibleJoe at on reddit
       
      My laptop's specs
       
      i7-8550U Intel HD 620 Graphics UHD Display 256GB Samsung NVMe SSD PM961 Killer 1435 Wifi  
      Here is what works
       
      Intel HD Graphics  Sleep Sound & Mic USB Wifi (Internal Killer Wifi will not work) Bluetooth Power Management Battery Management Screen Brightness Control  
      What does not work
       
      Internal Wifi Camera SD Card reader  
       
       
      I followed the vanilla guide here to create the Mac OS Mojave install USB. I used Mac OS 10.14.3.
       
      Here are some rough steps
       
      1. Create the USB installer for Mojave. You can use apple's own instructions
      2. Once the installer USB creation is complete, Install the latest version of clover to the USB disk with the following options 
      Install Clover for UEFI booting only
      Install Clover to the ESP
       
      Leave everything else as default (minimal install without a bunch of drivers)
       
      3. Then mount the EFI folder on the USB drive and replace the files in the config folder with the ones from the attached zip file over writing the files already there. This config is specifically for Dell XPS 13 9370.
      4. Go into the UEFI/BIOS on the laptop, Make sure your SATA mode is set to AHCI (And not Raid). Save and Exit
      5. Boot with the USB disk and install Mojave
      6. After the install is complete, Use the USB to boot again but this time boot into the newly installed Mojave partition.
      7. Install Clover on to the SSD with the same options as before.
      8. Then copy the config files to the EFI folder on the SSD overwriting the config folder there.
      9. Acquire the backlight AppleBacklightFixup.kext from here and install to /Library/Extensions (Thanks to Rehabman for the kext)
      10. Reboot.
       
      EDIT: V4 fixes many things, like powermanagement, backlight control etc. you also need to install AppleBacklightFixup.kext to /Library/Extensions
       
       
      CLOVER-v4.zip
×