Jump to content
Sign in to follow this  
Followers 0
Haive_Music

Need some help with DSDT and SSDT with hotplug and weird characters

7 posts in this topic

Recommended Posts

Hey guys,

 

I'm really hoping someone has the experience and ability to help me iron out the last remaining issue on my build.  

 

The motherboard is: Gigabyte Z370 Aorus Gaming 7 and I'm running a Alpine Ridge thunderbolt card (Revision 2).   I've gotten everything working for the most part with the exception of Thunderbolt hotplug.  This is the last piece of the puzzle.  I've tried so many different DSDT/SSDT's, cable plugged in, and unplugged, without any luck at all. 

I've managed to get my Focusrite Clarett 8Pre Thunderbolt working and it's showing up under the PCI section.  It works great, until I shut the device off and turn it back on.  I'd really like to try to get this hotplug issue sorted out, but I've had absolutely no luck so far.

 

I've managed to get the Alpine Ridge NHI and USB controllers showing up in the PCI section too, but for some reason, the USB lists a bunch of ',,,,,,,,' after the name. 

 

 

I'll be the first to admit - I don't really know a whole lot about what I'm doing with this stuff, but I've attached relevant files in hopes someone more experienced and knowledable can help me get this working.  

 

Thanks guys!

config.plist

DSDT.aml

John’s iMac.iojones

Screen Shot 2018-10-09 at 2.39.16 PM copy.png

SSDT-TB3.aml

Edited by Haive_Music

Share this post


Link to post
Share on other sites
Advertisement

Hey Foskvs.  Thanks for the reply.  I do understand that, but I still feel it's at least an indication of the system being configured and working properly.

 

A perfect example of this was the many SSDT's I tried in an attempt to get thunderbolt hotplug to work, and my Focusrite was being detected as an 'unknown multimedia device' and I had an icon in the upper right hand tray that had an 'Eject multimedia card'.  Once I messed around with the SSDT (again, I have no idea what I'm doing with it, just randomly trying things), that tray icon went away, and my Focusrite interface was recognized and behaving correctly.

 

 

In either case, I'm far less concerned about the ',,,,,,,' in the name.  My main goal is to find someone who knows what they're doing when it comes to getting thunderbolt hotplug to work.  I've tried everything I could on my end, and have failed.

Share this post


Link to post
Share on other sites

I’m afraid to tell you that your feeling is wrong...

Look at real Macs. PCI is empty, but the system is configured correctly.

SSDTs don’t inject only PCI properties.

By the way to change those properties, you need to edit _DSM Methods related to the device.

Share this post


Link to post
Share on other sites

Foskvs - The PCI section aside, the behavior of the system changed when I messed around with this SSDT.  I do not get a 'Eject Media Card' tray icon now, where as before I did.  Obviously, since that's literally the only change that has been made, and it changed the behavior of how the device operates and is recognized under OSX then yes - there's more to it than 'your feeling is wrong'.  Again, I completely understand that the PCI section is purely cosmetic - I'm not saying that it isn't, but I'm saying that there's a distinct correlation between the SSDT and how the system is recognizing and interacting with the device.  Perhaps that was simply a side effect of the SSDT having a more appropriate configuration for my device?  I don't know - but again - it changed the behavior of the device under OSX: plain and simple.   Maybe that SSDT changed the _DSM methods then? I don't know?  Again... just as I said multiple times now, I have no idea what I'm doing with them and am trying to learn and gain an understanding of it on my own (which I'm not having much luck doing), and thus here I am inquiring and asking people who have more experience and expertise than myself here for their aid and help.  In either case, cosmetic section aside - I'm truly after getting thunderbolt hotplug to work, and I feel like we're getting hung up on trivial/meaningless/irrelevant tangent here that's completely unrelated to the core of the issue. 

 

 

 

Mald0n - Sorry man.  I appreciate your response, but... I have no idea here how how to put that in to the SSDT.  Is that to help get hotplug working?

 

Edited by Haive_Music

Share this post


Link to post
Share on other sites

Hey there Haive_Music, I have a build where a Presonus Quantum 2 interface is shown as unknown device, I think similarly to your problem. Any idea what you might have fiddled with in the SSDT?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By MaLd0n
      ---INSTALLATION TUTORIAL---
       
      ---Original Post---
      https://olarila.com/forum/viewtopic.php?f=45&t=9172
       
      ---USB---
      https://pikeralpha.wordpress.com/2016/07/13/simple-skylake-usb-fix-no-kexts-required/
       
      ---CLOVER FOLDER---
       
      CLOVER.zip
       
       
      --MOBO
      GigaByte Z390 M Gaming



      --PROCESSOR
      Intel Core i9-9900K


      --COOLER
      CoolerMaster MasterLiquid ML120R RGB


      --MEMORY
      Corsair Dominator Platinum 16GB (2 x 8GB)


      --GPU
      Sapphiretech Radeon RX 590 8 GB GDDR5


       
      --SSD
      Samsung 970 EVO NVMe M2 Flash Drive


      --POWER SUPPLY
      EVGA 750 N1, 750W


      --WIRELESS
      TP-Link Archer T9E


      --BLUETOOTH
      Orico BTA-403


      --CASE
      Thermaltake View 21 Tempered Glass Edition


      --DSDT Patches--
      -FIX ERRORS AND WARNINGS -FIX ACPI ERRORS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA SERIE 10 ID -DMAC -REMOVE 22K LINES, PROBLEMATIC and UNUSED -FIX K.P in REBOOT -NVRAM -REAL TIME CLOCK -SLPB -DARWIN / WINDOWS 2015 -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -REAL TIME CLOCK -ARTC -IRQs -SBUS -MIKEY -BUS1 -MCHC -ALS0 -SHUTDOWN -UAR1 -LAN -FWHD -USBX -PMCR -PPMC -XSPI -GMM -IMEI -EC -PNLF -ARPT -GFX0 -NVME -DTGP -ACQUIRE MUT0 0XFFFF -OPERATION REGION GPIO -MUTEX MUT0 0x00 -EXTERNAL REFERENCES -UNKNOWNOBJ -HDMI / HDAU -FULL RENAMED DEVICES  
      --SCREENSHOTS--





























      --BruceX--
       
      --USB-C-- test with SanDisk Ultra USB-STICK 128gb


       
      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, Sampath007, onemanosx, erroruser, Jenny David, Olarila Facebook Community, Hackintosh Facebook Community and many others!
      We're all here to have fun and learn from each other!
    • By soumaxetuirk
      If you have a working Brightness Slider and you might be using Brightness slider or manual hotkeys to control brightness then this guide may help you to use your Native hotkeys of laptop.
       
      (All the Credits goes to @RehabMan     For OS-X-ACPI-Debug Kext and DSDT Patches.)
       
       
      This step assumes that you are using RehabMan's VoodooPS2Controller or Acidanthera's PS2Controller
      Install the kext: https://github.com/RehabMan/OS-X-ACPI-Debug Open MaciASL and click on patch.(Add rehab man repo) Apply "Add DSDT Debug Methods" and "Instrument EC Queries" that are under Brightness Fix. Save the DSDT and restart Look in Syslog as you press the key corresponding to brightness to determine which _QXX methods handle the keys (UPDATE: From Sierra Apple changed logging process. So you won't find ACPIdebug result using syslog command. Instead use following command )
      log show --last 5 | grep ACPIDebug 6. Then patch DSDT:
      into method label _Q1D replace_content begin // Brightness Down\n Notify(\_SB.PCI0.LPCB.PS2M, 0x0205)\n Notify(\_SB.PCI0.LPCB.PS2M, 0x0285)\n end; into method label _Q1C replace_content begin // Brightness Up\n Notify(\_SB.PCI0.LPCB.PS2M, 0x0206)\n Notify(\_SB.PCI0.LPCB.PS2M, 0x0286)\n end; Change the variable _Q1D/_Q1C as per the log. 

      7. Try compiling and check if it generates errors
      8. If it does, then change the PS2M to PS2X according to the one found in your DSDT
      9. Save and place the compiled DSDT.
      10. Now you should see that you have your corresponding keys to change your brightness 
       
       
       FOR  more detail and Queries,Check Out original Post of @RehabMan Here;
      http://www.insanelym...18#entry1997112
      Get Latest Version of  OS-X-ACPI-Debug kext here:
      https://bitbucket.org/RehabMan/os-x-acpi-debug/downloads
    • By TorqueX86
      Hi guys,

      I'm at my wit's end. I really need a hand here.
      I found only one clover setup for my motherboard, and works absolutely flawlessly for Mojave.

      Today I added an Asus Thunderbolt EX3 card, and that won't even let me boot my Mojave installation.

      My config.plist in attachment. Let's solve at least the Thunderbolt issue for now.
       
      There are also other issues, but let's solve this one first.
       
      Asus WS Z390 PRO + i9 9900K
      32GB 3200
      Nvidia 2080Ti for Windows and AMD RX480 for MacOS.
      Samsung NVME 950PRO
      config.plist
    • By jcrcarmo
      Hello everyone,

      Greetings from Brazil! I'm running macOS Catalina 10.15.2 on my Lenovo Ideapad 300-15ISK laptop. Everything works smoothly, except decent battery management, so I decided to rebuild my DSDT from scratch, so I can patch it properly. It was a bit messy to start with.

      I followed Rehabman's guide (to the letter) posted on tonymacx86. However, I keep getting a compile error, no warnings at all, just 'syntax error, unexpected PARSEOP_ARG1'.  Please refer to attached PNG image and .dsl file.

      I've searched endlessly for a solution, but can't fix it no matter what I try. Any ideas on how to fix this issue? I really appreciate your time and help.

      Best regards and Happy Holidays!

      DSDT.dsl
    • By Musicalchairs
      Hi Guys,
       
      First time poster

      Recently switched to OC from Clover where I had a Mald0n created DSDT in my patched folder
      Bringing Device Objects across via SSDT and after much trial and error had some success with SBUS children by editing this SSDT
      https://raw.githubusercontent.com/acidanthera/OpenCorePkg/master/Docs/AcpiSamples/SSDT-SBUS-MCHC.dsl

      Can anyone let me know what this (MKY0) actually does?

      SSDT-SBUS-MCHC+MKY0.aml
×